{"record":{"id":"8922b9851732c9e6","repo":"langchain-ai/langgraph","slug":"could-not-load-embeddings-from-string-embed","errorCode":null,"errorMessage":"Could not load embeddings from string '{embed}'. {version_info} loading embeddings by provider:identifier string requires langchain>=0.3.9 as well as the provider-specific package. Install LangChain with: pip install 'langchain>=0.3.9' and the provider-specific package (e.g., 'langchain-openai>=0.3.0'). Alternatively, specify 'embed' as a compatible Embeddings object or python function.","messagePattern":"Could not load embeddings from string '(.+?)'\\. (.+?) loading embeddings by provider:identifier string requires langchain>=0\\.3\\.9 as well as the provider-specific package\\. Install LangChain with: pip install 'langchain>=0\\.3\\.9' and the provider-specific package \\(e\\.g\\., 'langchain-openai>=0\\.3\\.0'\\)\\. Alternatively, specify 'embed' as a compatible Embeddings object or python function\\.","errorType":"validation","errorClass":"ValueError","httpStatus":null,"severity":"error","filePath":"libs/checkpoint/langgraph/checkpoint/store/base/embed.py","lineNumber":94,"sourceCode":"    if isinstance(embed, str):\n        init_embeddings = _get_init_embeddings()\n        if init_embeddings is None:\n            from importlib.metadata import PackageNotFoundError, version\n\n            try:\n                lc_version = version(\"langchain\")\n                version_info = f\"Found langchain version {lc_version}, but\"\n            except PackageNotFoundError:\n                version_info = \"langchain is not installed;\"\n\n            raise ValueError(\n                f\"Could not load embeddings from string '{embed}'. {version_info} \"\n                \"loading embeddings by provider:identifier string requires langchain>=0.3.9 \"\n                \"as well as the provider-specific package. \"\n                \"Install LangChain with: pip install 'langchain>=0.3.9' \"\n                \"and the provider-specific package (e.g., 'langchain-openai>=0.3.0'). \"\n                \"Alternatively, specify 'embed' as a compatible Embeddings object or python function.\"\n            )\n        return init_embeddings(embed)","sourceCodeStart":null,"sourceCodeEnd":null,"githubUrl":"https://github.com/langchain-ai/langgraph/blob/38031739e551638e373fb553453256c23feeb41f/libs/checkpoint/langgraph/checkpoint/store/base/embed.py#L94","documentation":"Error \"Could not load embeddings from string '{embed}'. {version_info} loading embeddings by provider:identifier string requires langchain>=0.3.9 as well as the provider-specific package. Install LangChain with: pip install 'langchain>=0.3.9' and the provider-specific package (e.g., 'langchain-openai>=0.3.0'). Alternatively, specify 'embed' as a compatible Embeddings object or python function.\" thrown in langchain-ai/langgraph.","triggerScenarios":"Thrown at libs/checkpoint/langgraph/checkpoint/store/base/embed.py:94 when the library encounters an invalid state.","commonSituations":"See trigger scenarios.","solutions":["Upgrade: pip install 'langchain>=0.3.9' plus the provider package (e.g. 'langchain-openai>=0.3.0')","Pass an Embeddings instance directly: ensure_embeddings(OpenAIEmbeddings())","Pass a plain Python embedding function instead of a provider:identifier string"],"exampleFix":null,"handlingStrategy":"validation","validationCode":null,"typeGuard":null,"tryCatchPattern":null,"preventionTips":[],"tags":[],"backgroundTag":null,"analyzedSha":"38031739e551638e373fb553453256c23feeb41f","analyzedAt":"2026-08-26T18:02:49.312Z","contentChangedAt":"2026-08-26T18:02:49.312Z","schemaVersion":2},"datasetVersion":"2026-09-23T08:17:48.524Z"}