BerriAI/litellm
Documented errors, page 3 of 30. Back to BerriAI/litellm
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Batch record for /v1/responses is missing required `input`… | validation | error | bedrock, batch, responses-api, jsonl, missing-field, litellm |
| LLM Router not initialized. Ensure models added to proxy. | exception | error | litellm, litellm-proxy, managed-files, configuration, router |
| Microsoft Purview DLP: Token-id completion prompts cannot… | http | error | microsoft-purview, guardrails, text-completions, token-ids, fail-closed |
| Unable to health check wildcard model for provider | exception | error | litellm, proxy, health-check, wildcard-model, model-catalog |
| unable to complete request | exception | error | token-limit, reasoning-model, responses-api, configuration |
| Project management is an enterprise feature. You must be a… | http | error | litellm, enterprise-license, http-403, project-management |
| tool call not supported | validation | error | tool-calling, messages, responses-api, validation |
| Error retrieving usage data | exception | error | database, query-failed, error-wrapping, cloudzero, polars |
| Provider ' ' not supported for Focus export configuration | exception | error | litellm, focus, export, provider, factory |
| API key is required | exception | error | watsonx, iam, api-key, authentication, environment-variable, litellm |
| Chat provider: Empty parsed_chunk | exception | error | streaming, sse, responses-api, validation |
| Container API not supported for provider | validation | error | litellm-proxy, containers, unsupported-provider, provider-routing |
| Content blocked: competitor comparison or ranking intent… | http | error | content-filter, guardrail, competitor-intent, moderation, http-400 |
| start_time is required, got= | validation | error | litellm, logging, type-validation, timestamps |
| Failed to parse operation response | exception | error | veo, gemini, video-generation, pydantic, response-parsing |
| Cannot retry A2A localhost URL fix: the client was not… | exception | error | a2a, client, retry, httpx, runtime-error |
| challenge.body if challenge.body is not None else… | http | error | oauth, http-401, upstream-auth, credentials, www-authenticate, mcp |
| Prop ` ` is not a string | exception | error | bytez, messages, content-parts, multimodal, validation |
| Vertex AI batch creation requires the model to be part of… | http | error | |
| Blocked by Gray Swan Guardrail | http | error | grayswan, guardrail, content-moderation, blocked, http-400 |
| dynamic_api_key needs to be a string. dynamic_api_key= | validation | error | litellm, api-key, type-validation, openai-compatible |
| No text content could be extracted from the file for… | validation | error | |
| Content blocked: argument matched a masking rule on a… | http | error | mcp, content-filter, pii-masking, guardrail, http-400 |
| Failed to update key got response = None | exception | error | litellm, prisma, key-management, update, null-response, database |
| Gitlab configuration not found. Please set… | validation | error | gitlab, prompt-management, litellm, configuration |
| No model could be resolved for MCP sampling. Please… | exception | error | mcp, sampling, configuration, model-resolution |
| Trying to use Google Text ModerationYou must be a LiteLLM… | exception | error | litellm, enterprise, license, config, moderation, startup |
| Could not parse timestamp | validation | error | cloudzero, timestamp, iso8601, parsing, usage-export |
| Failed to load prompt | exception | error | bitbucket, prompt-management, litellm-prompts, path-validation |
| Failed to verify request safety with Lasso API | exception | error | network, connection, lasso, guardrails, dependency |
| MCP server is already rejected. | http | warning | litellm, mcp, approval-workflow, idempotency, admin |
| No results found in the response= | validation | error | together-ai, rerank, response-parsing, api-contract, litellm |
| Cloudflare Exception | exception | error | litellm, cloudflare, workers-ai, authentication, api-token |
| DeepEval logging error | exception | error | deepeval, http-status, api-client, authentication, observability |
| requires general_settings. before trusting identity headers… | exception | error | config, trusted-proxy, oauth2-proxy, x-forwarded-for, security |
| {refusal} | exception | error | rubrik, guardrail, content-moderation, prompt-blocking, modify-response-exception |
| callback_name is required in key_logging | validation | error | key-logging, metadata, callbacks, litellm-proxy, validation |
| only accepts identity headers from configured trusted proxy… | exception | error | network, trusted-proxy, ip-allowlist, x-forwarded-for, security |
| Invalid CZRN format | validation | error | cloudzero, czrn, identifier-validation, parsing |
| judge response is not a JSON object | validation | error | llm-judge, evaluation, json-parsing, litellm |
| ReplicateException | exception | error | litellm, replicate, catch-all, api-error, unknown-error |
| Timeout error occurred. | exception | error | vertex-ai, multimodal-embeddings, timeout, async, network |
| Bedrock batch embedding `input` must be a string (or a… | validation | error | bedrock, embeddings, batch, jsonl, input-validation, litellm |
| Exception: Context Window Error | exception | error | litellm, watsonx, context-window, token-limit, prompt-too-long |
| Error in response object format, got None | validation | error | bedrock, image-generation, response-parsing |
| Error rendering template | exception | error | litellm, dotprompt, prompt, jinja2, template-render |
| module has no attribute | exception | error | attributeerror, lazy-import, api-surface, version-upgrade, python |
| unpack_defs: inlined schema exceeded the | validation | error | json-schema, tool-calling, resource-limits, defs |
| Validation fails | exception | error | jwt, signature, audience, issuer, validation, authentication |
| Blocking web crawlers is an enterprise feature. You must be… | exception | error | enterprise, licensing, proxy-config, startup, block-robots |
| Original Response | http | error | streaming, reverse-proxy, upstream-error, error-body |
| Failed to load prompt version | exception | error | arize-phoenix, prompts, wrapper-exception, diagnostics |
| Lasso API timeout | exception | error | network, timeout, lasso, guardrails, httpx |
| response.text | exception | error | together-ai, rerank, http-error, api-response, litellm |
| Team not found for team_id= | http | error | litellm, proxy, teams, key-generation, authorization |
| WXO: No run_id in response | exception | error | watsonx-orchestrate, run-id, api-response, polling, debugging |
| Key not found in team | http | error | not-found, key-management, bulk-update, per-key-failure, litellm-proxy |
| Model needs to be set for bedrock | validation | error | litellm, image-generation, bedrock, aws, missing-argument |
| Utils module lazy import: unknown attribute | exception | error | attributeerror, lazy-import, utils, api-surface, python |
| {error.message} | http | error | dashscope, embeddings, upstream-error, api-key, quota |
| Failed to get repository info | exception | error | bitbucket, http, authentication, repository-config |
| git-subdir 'path' must be a relative path of the form… | http | error | litellm-proxy, claude-code-marketplace, validation, path-traversal, security, http-400 |
| Configuration validation failed | validation | error | prometheus, metrics, config, validation, labels |
| f"Authentication Error | http | error | litellm, error-handling, proxy-exception, user-management |
| Response cannot be casted to CohereChatResult | exception | error | oci, cohere, pydantic, schema-drift, upstream-api |
| sentence-similarity requires 2+ sentences | exception | error | huggingface, embeddings, sentence-similarity, input-validation, litellm |
| You must be a LiteLLM Enterprise user to use SSO for more… | http | error | |
| Access denied to file | exception | error | bitbucket, http-403, permissions, authorization, api |
| Batch record for /v1/completions is missing required… | validation | error | bedrock, batch, text-completion, jsonl, missing-field, litellm |
| Blocked by custom code guardrail | http | error | guardrails, custom-code, http-400, policy-violation, blocked-request, output-filtering |
| Failed to delete file | exception | error | gemini, files-api, delete-file, http-error |
| Mavvrik FOCUS destination: GCS chunk upload failed | exception | error | gcs, resumable-upload, chunked-upload, mavvrik, transient |
| Microsoft Purview: tenant_id is required | validation | error | microsoft-purview, guardrails, configuration, azure-ad, litellm-proxy |
| rpm limit higher than user max. User rpm limit= | http | error | |
| LEVOAI_COLLECTOR_URL environment variable is required for… | validation | error | levo, environment-variables, configuration, opentelemetry, collector-url |
| Max recursion depth reached while reading image bytes for… | validation | error | vertex-ai, imagen, image-edit, recursion, input-validation |
| {error_text} | http | error | bedrock, aws, count-tokens, api-error, anthropic |
| Invalid API key | exception | error | authentication, api-key, lasso, guardrails, http-401 |
| No provider config found for model | validation | error | bedrock, passthrough, model-support, config |
| valkey-semantic does not support cluster-mode-enabled… | validation | error | |
| API key is required for Topaz image variations. Set via… | validation | error | topaz, image-variation, api-key, environment-variables, litellm |
| CREATE eval is not supported for | validation | error | evals, provider-support, validation, openai |
| Database not connected. Connect a database to your proxy -… | exception | error | litellm, cloudzero, prisma, postgres, database, configuration |
| Key not found | http | error | keys, not-found, authorization, litellm-proxy, block |
| res.json().get("error", res.text) | exception | error | deepeval, http-status, api-client, error-body, dead-code |
| url or spec_path is required for HTTP/SSE transport | validation | error | |
| DataDogLLMObs: standard_logging_object is not set | exception | error | datadog, llm-obs, kwargs, internal-api, misuse |
| DD_SITE is not set, set 'DD_SITE=<>', example site =… | exception | error | datadog, llm-obs, env-var, empty-value, region |
| Error loading blocked words file | exception | error | yaml, configuration, validation, content-filter |
| MAVVRIK_FOCUS_FREQUENCY= | validation | error | mavvrik, focus-export, configuration, environment-variables, validation |
| Only admins can create orgs. Your role is = | http | error | |
| skip_pre_call_logic=True requires litellm_logging_obj to be… | exception | error | litellm, proxy, internal, invariant, valueerror |
| Either user_id or user_email must be provided | validation | error | litellm, validation, user-management, missing-param |
| Hosted VLLM does not support max_chunks_per_doc | validation | error | hosted-vllm, rerank, unsupported-parameter, litellm |
internal_server_error An unexpected error occurred | http | error | mcp, http-500, unhandled-exception, debugging |
| Key= has a tpm_limit= which is greater than the team's… | http | error | rate-limit, tpm, key-management, team-limits, litellm-proxy |
| organization_id is required | http | error | |
| Access denied to file | exception | error | gitlab, permissions, http-403, forbidden |
| image variation provider has no known model info config -… | validation | error | litellm, image-variation, provider-config, registry, version-skew |
urn:litellm:error:internal-server-error Failed to list budgets. | http | error | internal-server-error, problem-details, litellm-proxy, budgets, database |