BerriAI/litellm
Documented errors, page 8 of 30. Back to BerriAI/litellm
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| bitbucket_config is required for BitBucket prompt… | validation | error | bitbucket, litellm, prompt-management, missing-config |
| litellm_params.api_base must use http or https scheme | http | error | |
| model parameter is required but was None. Please provide a… | validation | warning | rss, xml-parsing, content-negotiation, litellm, internal |
tool_server_mismatch Tool ' ' belongs to MCP server ' ' but request specified server_id for ' '. | http | error | mcp, routing, http-403, tool-resolution |
| api_base is required for Generic Guardrail API. Set… | validation | critical | generic-guardrail, guardrail, api-base, config, startup |
| Either user id or user email must be provided | validation | error | |
| Error compiling prompt | exception | error | wrapper, prompt-management, error-chaining, async |
guardrail_pipeline_error Content blocked by guardrail pipeline | http | error | |
| Invalid model format. Expected format… | validation | error | bedrock, agentcore, model-string, input-validation, aws |
| Invalid request, No litellm managed file id or… | exception | error | |
| Mavvrik FOCUS destination | validation | error | mavvrik, gcs, allowlist, ssrf, hostname-validation |
| Message `content` must be a string or list of content parts | exception | error | oci, request-validation, messages, content |
| Request must contain content to count tokens | validation | error | bedrock, count-tokens, validation, empty-payload, invoke-model |
| Trying to use Blocked User ListThis uses the enterprise… | exception | error | litellm, enterprise, docker, import-error, config, blocked-users |
| Virtual key is not allowed to call this route. Only allowed… | http | error | |
| DD_API_KEY is not set, set 'DD_API_KEY=<> | exception | error | datadog, environment-variables, credentials, logging, litellm |
| DD_SITE is not set in .env, set 'DD_SITE=<> | exception | error | datadog, environment-variables, configuration, logging, litellm |
| Either prompt_directory or prompt_data must be set before… | validation | error | dotprompt, prompt-management, configuration, lazy-initialization |
| 'instance_id' is required in litellm_params for WXO agents | validation | error | watsonx-orchestrate, instance-id, configuration, required-param |
| Invalid Argilla API Key given. _credentials_api_key=None. | exception | error | argilla, authentication, environment-variable, credentials |
| LiteLLM: provider returned a response with no 'choices'… | http | error | litellm, streaming, response-format, cache, provider-error |
| Unsupported Amazon Nova Canvas taskType | validation | error | bedrock, nova-canvas, image-edit, tasktype, routing, validation |
| Custom code must define an 'apply_guardrail' function… | exception | error | guardrails, custom-code, sandbox, entrypoint, validation |
| Error fetching file | exception | error | bitbucket, network, dns, proxy, tls, connection |
| error_message | http | error | |
| LiteLLM Managed File object with id= | exception | error | litellm, managed-files, race-condition, eventual-consistency |
| No response data in completed operation | exception | error | veo, gemini, video-download, safety-filter, empty-response |
| STABILITY_API_KEY is not set. Please set it via environment… | validation | error | stability-ai, image-edit, api-key, environment-variables, litellm |
| Token exchange response missing fields | exception | error | chatgpt, oauth, token-exchange, schema-mismatch, auth |
| Tool is not allowed for server . Contact proxy admin to… | http | error | |
| api_key is required for Volcengine authentication | exception | error | volcengine, embedding, api-key, authentication, environment-variable, litellm |
| Cannot parse IAM endpoint from URL: missing host or username | exception | error | |
| either key or key_alias must be provided | validation | error | |
| Invalid budget_reset_time | validation | error | litellm-proxy, config, time-format, validation, budget |
| Invalid value passed in for aget_assistants. Only bool or… | validation | error | assistants, openai, type-validation, kwargs, api-misuse |
| No AWS credentials found for Bedrock realtime. Set aws_*… | http | error | bedrock, realtime, authentication, aws-credentials |
| OpenAI client is not initialized. Make sure api_key is… | exception | error | fine-tuning, missing-api-key, client-init, openai, env-var |
| refresh_token is required for refresh_token grant | http | error | |
| xAI OAuth token response was not an object | exception | error | |
| Invalid document type | exception | error | |
| Invalid identifier : contains disallowed characters | exception | error | arize-phoenix, prompts, input-validation, url-sanitization, security |
| max_budget ( ) cannot exceed the caller's own max_budget (… | http | error | litellm-proxy, budget, authorization, virtual-keys, privilege-escalation |
missing_parameter server_id is required in request body | http | error | mcp, http-400, validation, request-body, missing-parameter |
| PHOENIX_API_KEY must be set when using Phoenix Cloud… | exception | error | arize-phoenix, tracing, authentication, environment-variable, otlp |
| User role is required for CLI JWT login | exception | error | litellm, cli, jwt, user-role, login |
| Blocked user check was never set. This call has no… | http | error | litellm, enterprise, importerror, blocked-users, licensing |
| Invalid YAML frontmatter | validation | error | litellm, dotprompt, prompt, yaml, frontmatter, config-parse |
| Prop ` ` is not supported | exception | error | bytez, messages, content-parts, unsupported-feature |
| REDIS_CLUSTER_NODES environment variable is not valid JSON… | exception | error | redis, cluster, environment-variables, json, configuration, cache |
urn:litellm:error:database-not-connected DB not connected. This endpoint needs a database; set DATABASE_URL to a… | http | error | database, configuration, problem-details, litellm-proxy, budgets, management-api |
| Access denied to MCP server | http | error | litellm, mcp, oauth, forbidden, authorization |
| Error transforming response to json | exception | error | watsonx, audio-transcription, json-parse, response-parsing, litellm |
| No models configured on proxy | http | error | litellm, llm-router, model-list, customer-management, validation |
| No response from fallbacks. Got none. Turn on… | exception | error | fallbacks, routing, async, litellm |
| Project= is blocked. Update via `/project/update` if you're… | exception | error | project, blocked, auth, admin-action, litellm-proxy |
| SagemakerException - the value of 'n' must be > 0 and <= 2… | exception | error | sagemaker, parameter-range, best-of, n |
| TogetherAI does not support max_chunks_per_doc | validation | error | together-ai, rerank, parameter-validation, litellm |
| api_base is required for hosted_vllm embeddings | validation | error | hosted-vllm, embeddings, api-base, configuration, litellm |
| API key is required for OpenAI image variations | validation | error | litellm, image-variation, openai, api-key, credentials |
| Azure AD authentication failed for Redis | exception | error | redis, azure, entra-id, authentication, azure-cache, cache |
| Content blocked: pattern detected | http | error | content-moderation, content-filter, regex, http-400, guardrails |
| Invalid : must be an http(s) URL with a host. Local… | http | error | |
| Knowledge Base did not become active in time | exception | error | |
| LiteLLM Managed File object with id= | exception | error | litellm, managed-files, files-api, provider-error, aggregated-errors |
| major_airlines.json not found | http | error | |
| Only premium users can add tags to keys. | exception | error | litellm-proxy, licensing, enterprise, virtual-keys, tags |
| Polling timed out after | exception | error | litellm, black-forest-labs, flux, polling, timeout, async-job, sync |
| Couldn't get Aim api key, either set the `AIM_API_KEY` in… | exception | error | |
| Plugin name must be kebab-case (lowercase letters, numbers… | http | error | litellm-proxy, claude-code-marketplace, validation, naming, http-400, plugin-registration |
| Set either 'max_budget' or 'budget_id', not both. | validation | error | |
| team_member_budget must be a non-negative finite number… | http | error | |
| Unable to parse anthropic tool result for message | exception | error | anthropic, tool-calling, message-conversion |
| Vector store index not found for | exception | error | |
| Authentication failed. Check your GitLab token and… | exception | error | gitlab, auth, http-401, unauthorized, token |
| Failed to get branches | exception | error | bitbucket, http, branches, authentication |
| Internal server error | http | error | |
| max_budget must be a non-negative finite number. Received | http | error | litellm, proxy, validation, budget, key-update |
| OpenAI Moderation API request failed | http | error | openai-moderation, guardrails, upstream, http, rate-limit |
| Client-side 'metadata.tags' not allowed in request… | http | error | metadata, tags, reject-clientside-metadata-tags, bad-request, litellm-proxy |
| 'cp4d_host' is required in litellm_params for WXO agents | validation | error | watsonx-orchestrate, cp4d-host, configuration, required-param |
| CrowdStrike AIDR API base URL is required. Set… | exception | error | crowdstrike, guardrails, base-url, environment-variables, litellm-proxy, startup-config |
| Failed to create OpenSearch index after | exception | error | |
| Failed to import file into RAG corpus | exception | error | vertex-ai, rag, gcs, sdk-error, chained-exception |
| cannot be a dot path segment | exception | error | path-traversal, url-encoding, security, input-validation |
| Only premium users can add tags to projects. You must be a… | http | error | litellm, enterprise, licensing, projects, http-403 |
| {response.read()} | exception | error | langgraph, streaming, http-status, upstream-error |
| Voyage AI API key is required. Set via `api_key` parameter… | exception | error | voyage, rerank, api-key, authentication, environment-variable, litellm |
| Cisco AI Defense API request failed | exception | error | litellm, guardrails, cisco-ai-defense, connection-error, dns, tls, network |
| Error getting file metadata for | exception | error | bitbucket, network, file-metadata, timeout |
| Failed to parse response | exception | error | voyage, rerank, json-parse, response-parsing, litellm |
| HTTPStatusError | exception | error | codestral, mistral, http-status, provider-error, text-completion |
| LLM client cache lazy import: unknown attribute | exception | error | attributeerror, lazy-import, cache, client-cache, python |
| Mavvrik FOCUS destination: response missing 'url' field | exception | error | mavvrik, api-contract, json, response-parsing |
| azure-identity is required for Azure AD Redis… | exception | error | redis, azure, dependency, importerror, active-directory, cache |
| CANCEL eval is not supported for | validation | error | evals, provider-support, validation, openai |
| Cisco AI Defense API returned a non-JSON response | exception | error | litellm, guardrails, cisco-ai-defense, json, response-parsing, proxy |
| max_bytes_per_call must be >= 0 (0 disables the cap… | validation | error | litellm, guardrails, compresr, configuration, validation, numeric-limits |
| mcp_tools_config must be a list of dictionaries | validation | error | mcp, config, yaml, value-error, litellm-proxy, validation |
| No DB Connected. See -… | exception | error | |
| api_base is required for A2A provider. Either provide… | exception | error | a2a, agents, api-base, env-var, litellm |