alibaba/canal
Documented errors, page 3 of 3. Back to alibaba/canal
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| not found tableId | exception | error | mysql, binlog, table-map, tableid, row-event |
| null memoryLogPositionManager | validation | error | canal, log-position-manager, null-check, configuration, constructor |
| Unable to load com.mysql.jdbc.ConnectionImpl | exception | critical | binlog, classpath, driver-compat, mysql, classloading |
| more than 1 default extension name on extension | exception | error | spi, annotation, config, extension-loader |
| RowKey 值为空 | validation | error | hbase-adapter, etl, rowkey, data-quality |
| apply history to db failed caused by | exception | error | tsdb, ddl, database, dao, canal-parse |
| dbMapping.table | exception | error | clickhouse-adapter, canal-adapter, config, validation, null-pointer |
| isn't start , please check | exception | error | lifecycle, double-stop, canal-common, state-management |
| http request failed! | http | warning | rds, openapi, http, status-check, canal-parse |
| No phoenix adapter found for config key | exception | critical | phoenix, config, adapter-init, canal, key-mismatch |
| Query event length is too short. | exception | error | binlog, mysql, query-event, truncation, header-validation |
| apply failed | exception | error | tsdb, ddl, history, rollback, canal-parse |
| Get null field: #io | exception | error | binlog, connection, driver-compat, mysql |
| ERROR ## the bfColumns is null | exception | error | mysql, binlog, update, row-image, internal-error |
| Cannot get field: ' ' @ | validation | error | binlog, reflection, module-system, securitymanager |
| start timestamp : binlog files is empty | exception | error | rds, binlog, openapi, retention, canal-parse |
| apply failed caused by | exception | error | tsdb, snapshot, database, dao, canal-parse |
| canal.adminUser is empty , pls check… | exception | critical | config, spring-boot, startup, canal-admin |
| Extension type == null | validation | error | spi, programming-error, extension-loader |
| Cannot invoke method | validation | error | binlog, reflection, module-system, securitymanager |
| not support for memory | exception | error | tsdb, memory-table-meta, rollback, unsupported-operation, canal-parse |
| apply to memory is failed | exception | error | tsdb, ddl, druid, memory-table-meta, canal-parse |
| stop connect error | exception | warning | rabbitmq, shutdown, canal-connector, lifecycle |
| hbaseMapping.mode | validation | error | hbase-adapter, config, validation, yaml, mode |
| Invoke method failed | validation | error | binlog, reflection, driver-compat, cause-chain |
| binlog: + binlogfilename + is not found | exception | error | parse, binlog, local-binlog, filesystem, position |
| No binlog file header | exception | error | binlog, file, filelogfetcher, validation |
| position timestamp is empty! | exception | critical | rds, binlog, position, data-corruption, canal-parse |
| 集群模式不允许指定server启动 | validation | error | canal-admin, instance-management, cluster-mode, business-rule |
| expect handshake but found other type. | exception | error | network, protocol, handshake, canal-admin |
| Error binlog file header | exception | error | binlog, file, filelogfetcher, magic-bytes, validation |
| unexpected packet type when ack is expected | exception | error | network, auth, protocol, canal-admin |
| unsupported version at this client. | exception | error | network, protocol, version-mismatch, canal-admin, protobuf |
| auth : is failed | http | error | auth, canal-admin, polling, rest-api, credentials |
| hbaseMapping.database | validation | error | hbase-adapter, config, validation, yaml |
| clusterId and serverId are all empty | validation | error | canal-admin, validation, config, request-params |
| something goes wrong when doing authentication | exception | error | auth, credentials, canal-admin, network |
| 当前集群下存在Instance配置,无法删除 | validation | error | canal-admin, cluster, referential-integrity, delete-guard |
| null zooKeeperLogPositionManager | validation | error | canal, log-position-manager, null-check, zookeeper, configuration |
| empty cluster or server id | validation | error | canal-admin, validation, instance-config, request-params |
| end of stream when reading header | exception | error | network, connection-reset, io, canal-admin |
| 当前集群下存在Server, 无法删除 | validation | error | canal-admin, cluster, referential-integrity, delete-guard |
| canal.adminPasswd is empty , pls check… | exception | critical | config, spring-boot, startup, canal-admin, credentials |
| hbaseMapping.table | validation | error | hbase-adapter, config, validation, yaml |
| failed to subscribe with reason | exception | error | canal-admin, server-management, rpc, admin-operation |
| 节点信息已存在 | validation | error | canal-admin, duplicate, node-server, validation |
| hbaseMapping.hbaseTable | validation | error | hbase-adapter, config, validation, yaml |
| something goes wrong when doing authentication: | exception | error | |
| something goes wrong in initRunning method. | exception | error | |
| failed to unSubscribe with reason: | exception | error | |
| failed to subscribe with reason: | exception | error | |
| Read mapping config: error. | exception | error | |
| Read mapping config: error. | exception | error | |
| no alive canal server for | exception | error | |
| at least 1 node required. | exception | error | |
| failed to rollback after | exception | error | |
| unsupported operation | exception | error | |
| failed to ack after | exception | error | |
| should connect first | exception | error |