apache/cassandra
Documented errors, page 10 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| JMX connection server is not enabled for either local or… | console | warning | jmx, configuration, cassandra-yaml, monitoring |
| memtable_flush_writers must be at least 1, but was | validation | error | config, startup, validation |
| MINIMUM_NAME_SIZE_CONFIG_OPTION has to be at least… | validation | error | guardrails, configuration, validation, range |
| Prepared query with ID | exception | error | cql, prepared-statement, cache-miss, restart |
| Provided username and/or password are incorrect | exception | error | authentication, credentials, password-authenticator |
| Received a command with the thrift flag set. This means… | exception | critical | thrift, mixed-version-cluster, upgrade, unsupported-operation |
| Rejecting Protocol Version | exception | error | cql-protocol, version-mismatch, deprecated |
| ' ' not found in keyspace | validation | error | cql, schema, not-found, invalid-request |
| Sequence of kind is in progress for node . Cannot proceed… | exception | error | cluster-metadata, sequence-in-progress, cms, offline-tool |
| Snitch metadata service URL | validation | critical | configuration, url, snitch, startup |
| This cluster is migrating to cluster metadata, can't abort | exception | error | cassandra, cluster-metadata, migration, abort |
| Unknown keyspace . This can occur if the keyspace is being… | exception | warning | sai, virtual-table, race-condition, schema |
| Unknown keyspace/table | validation | error | cli, schema, offline-tools |
| Value for key is only present in the right set | console | warning | logging, cluster-metadata, diagnostics, distributed-consistency |
| Value is of type , not | exception | error | java-driver, cql, type-mismatch |
| ANN ordering by vector requires all restricted column(s) to… | validation | error | cql, ann, vector-index, filtering |
| At least one DataFileDirectory must be specified | validation | critical | configuration, cassandra-yaml, directories |
| Cannot change transactional mode to | validation | error | cassandra, accord, feature-flag, configuration, transactional-mode |
| Column value does not satisfy value constraint for column | validation | error | cassandra, cql, constraint-violation, validation |
| Initiator tokenmap different from ours | console | warning | cluster-metadata, tokens, distributed-consistency, migration |
| Invalid CIDR group(s) | exception | error | |
| Invalid remaining data after end of | validation | error | deserialization, tuple, schema-mismatch |
| No serializer exists for kind | exception | error | accord, serialization, transactions |
| SASI indexes are disabled. Enable in cassandra.yaml to use. | validation | error | cassandra, sasi, index, config |
| The requested position exceeds the index length | validation | error | sstable, index, bounds, corruption |
| Unable to read cassandra-topology.properties | validation | critical | configuration, snitch, properties-file |
| Unknown field ' ' in value of user defined type | validation | error | cql, udt, invalid-request |
| You can not store Async-Profiler results into a data… | exception | error | configuration, filesystem, data-safety |
| An error occurred while scrubbing the partition with key | console | error | cassandra, scrub, counter-table, data-corruption |
| Cannot read from an empty path | exception | error | io, null-path, file |
| CloudstackSnitch cannot handle invalid zone format | validation | error | cloudstack, snitch, format-validation |
| commitlog_disk_access_mode can not be set to direct when… | validation | error | configuration, commitlog, direct-io, filesystem |
| Growth of %.2f%% in token ownership standard deviation… | console | warning | token-allocation, load-balancing, bootstrap |
| Invalid data rate: megabits per second… | validation | error | configuration, range, migration |
| Java source compilation failed:\n | validation | error | udf, java, compilation |
| Numeric literals for DATE must be between 0 and | validation | error | java-driver, date, serialization |
| Too many in flight hints | exception | error | cassandra, hinted-handoff, overload, write-path |
| Unable to find sufficient sources for streaming range " +… | exception | critical | streaming, bootstrap, flow-graph, replication |
| Unable to start because the node is draining. | exception | error | drain, node-lifecycle, operational |
| Unsupported ballot file version | exception | error | io, versioning, paxos |
| You must use conditional updates for serializable writes | validation | error | cassandra, consistency-level, lwt, write |
| Cannot read value of length | exception | error | cql-protocol, truncated-frame, values |
| Configuration must specify either node_proximity and… | validation | error | configuration, snitch, startup, mutually-exclusive |
| FSReadError | exception | critical | io, filesystem, compressed-writer, disk |
| Invalid default spec: | exception | error | cli, configuration, validation |
| Invalid number of values. Expecting | validation | error | cassandra, tuple, arity-mismatch |
| No configured data directory contains enough space to write… | exception | critical | disk-space, storage, fswriteerror, configuration |
| Selected sstable format | validation | error | configuration, sstable, cassandra-yaml |
| Unable to create an instance of the compression service… | exception | error | config, compression, reflection |
| Unable to parse property… | console | warning | configuration, jvm-properties, enum |
| Unable to serialize metadata snapshot triggered by… | console | warning | tcm, snapshot, serialization, metadata |
| A TTL should not be negative | validation | error | validation, data-corruption, ttl, marshal |
| Attempted to serve data request from node in | exception | error | transient-replication, token-ownership, routing, invalid-request |
| Constraints combination of | validation | error | cassandra, cql, constraints, satisfiability |
| Error creating/initializing the SSL Context | exception | critical | ssl, tls, configuration, startup |
| Failed to update the distributed status of view, sleeping 5… | console | warning | materialized-view, system-keyspace, retry, replication |
| Found empty ChronicleQueue file | console | warning | binlog, chronicle-queue, fql, logging, cleanup |
| Ignoring schema push request from | console | warning | schema, mixed-version, upgrade, internal-messaging |
| Invalid operation ( ) for non-numeric and non-text type | validation | error | cql, cassandra, type-mismatch, operator |
| Invalid sstable file | validation | critical | sstable, descriptor, filename-parsing, identifier |
| Keyspace ' ' doesn't exist | validation | error | |
| local_system_data_file_directory must not be the same as… | validation | error | config, startup, directory-conflict |
| Missing port number | exception | error | configuration, builder, missing-port, native-transport |
| Output file name must match pattern | validation | error | validation, regex, filename |
| SSTable ( ) does not intersect repaired ranges , this… | exception | error | repair, anticompaction, invariant |
| Unable to create directory " + dir | exception | critical | filesystem, permissions, startup, directories |
| Unable to serialize password_policy configuration | exception | error | guardrails, json-serialization, password-policy |
| A user type cannot contain non-frozen UDTs | validation | error | |
| Could not assassinate an unresolvable endpoint | exception | error | cassandra, nodetool, dns, assassinate |
| fast_path must be set to 'keyspace' or 'default' or a map… | validation | error | cassandra, accord, configuration, missing-key |
| internode_authenticator.parameters.validator_class_name is… | exception | error | |
| Invalid non-frozen user-defined type | validation | error | cql, udt, primary-key, types |
| replication_factor should not appear as an option at… | validation | error | cql, replication, schema, networktopologystrategy |
| = is invalid | validation | error | zstd, compression-level, configuration, validation |
| Seeking to a partition at | exception | error | sstable, corruption, io |
| There were markers(?) in CQL but bound variables | exception | error | cql, batch, protocol, invalid-request |
| Unable check disk space in | validation | error | filesystem, permissions, startup |
| Unable to determine block size for commit log directory | console | warning | cassandra, configuration, filesystem, commitlog |
| Unable to get an instance of Async-Profiler | exception | error | profiling, initialization, native-library |
| Exception occured while initializing disk error handler of… | exception | error | configuration, disk-error-handler, startup, init |
| Failed marking some sstables compacting in keyspace | exception | error | compaction, sstables, jmx, concurrency |
| Failed to go to the next entry in index | console | error | cassandra, scrub, sstable, corrupt-index |
| Failed to send dictionary update notification to | console | warning | compression, dictionary, internode-messaging, network |
| Failed to transfer all hints to | console | warning | hints, handoff, retry, transfer |
| FSWriteError | exception | critical | io, filesystem, hints, write, fsync |
| Group sync specified, but commitlog_sync_period found. Only… | validation | critical | config, commitlog, startup, conflicting-options |
| Invalid element access syntax for set column | validation | error | cql, set, collection, validation |
| Key may not be empty | validation | error | cassandra, cql, validation, partition-key |
| MBeanServer already initialized | exception | error | jmx, invalid-state, lifecycle |
| No readable value attribute for CQL metric: | exception | error | |
| [# ] Not failing repair due to remote host not supporting… | console | info | repair, gossip, versioning, upgrade |
| Received unexpected response from | exception | error | paxos, internal-invariant, distributed-coordination |
| This ec2-enabled location provider appears to be using the | validation | error | configuration, ec2, snitch, naming-scheme, cluster-consistency |
| Unsupported expression during ANN index query: | exception | error | cassandra, sai, vector-search, ann |
| Cannot re-add previously dropped column | validation | error | cql, schema, alter-table, static-column, dropped-column |
| Could not remove node | exception | error | cms-membership, reconfiguration, internal-invariant, cluster-metadata |
| Hint of bytes is too large - the maximum size is | exception | error | java, hints, limits, memory |
| Invalid value for option | validation | error | cql, schema, config |
| Java UDF validation failed: | validation | error | udf, sandbox, bytecode |
| native_transport_max_message_size must not exceed… | validation | error | config, native-protocol |