apache/cassandra
Documented errors, page 14 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Compression parameters too long, length | exception | error | commitlog, header, limit, compression |
| Corrupted | exception | error | |
| Counters are not supported with Accord for table | validation | error | cassandra, accord, counter-table, transactional-mode, schema |
| Deprecated | exception | error | deprecated, jmx, schema, removed-api |
| Failed to release compression dictionary | console | warning | compression, dictionary-cache, resource-cleanup, logging |
| Invalid parameter list for fixed distribution: | exception | error | cli, argument-validation, distribution |
| Natural log of number zero or less | exception | error | cassandra, arithmetic, math, domain-error |
| already exists | validation | error | auth, identity, duplicate |
| cannot be restricted by more than one relation in an ANN… | validation | error | cql, ann, vector-search, query-validation |
| doesn't exist | validation | error | cql, roles, authorization |
| Unable to load commitlog_archiving.properties | exception | error | cassandra, commitlog, configuration, io |
| Aggregation query used without partition key | console | warning | cassandra, aggregation, performance, client-warning |
| Cannot safely construct descriptor for segment, as name and… | exception | error | cassandra, commitlog, restore, integrity |
| Corrupted file: integrity check | exception | error | io, checksum, corruption, sstable |
| Failed verifying SSTable | exception | error | sstable, import, corruption, verification |
| Invalid data storage | validation | error | configuration, yaml, units |
| Invalid or not supported certificate | exception | error | |
| Invalid specification: | exception | error | cli, topology, argument-parsing |
| Invalid specification | validation | error | configuration, parsing, regex, illegal-argument |
| Last written key >= current key , writing into | exception | error | sstable, writer, sort-order, invariant |
| Mark/Reset not supported | exception | error | io, inputstream, unsupported-operation |
| No local state, state is in silent shutdown, or node hasn't… | console | info | cassandra, gossip, shutdown, node-lifecycle |
| No SSTables available for training in table | exception | error | compression, training, sstable |
| No valid partitions found while scrubbing | console | critical | scrub, data-corruption, data-loss, sstable |
| read_repair must be set to 'NONE' for transiently… | validation | error | cassandra, cql, read-repair, transient-replication, schema |
| can not be equal to . You set and respectively. | validation | error | configuration, guardrails, validation |
| must be a positive number, got | validation | error | configuration, validation, accord |
| '%skeystore_password' must be specified | validation | error | |
| Static column ' ' cannot be part of the PRIMARY KEY | validation | error | cql, static-column, primary-key, schema |
| Still behind after fetching log from CMS | exception | error | tcm, cms, catch-up, replication, epoch |
| Stream Session & SSTable | exception | error | |
| Tokens may not contain the character " +… | validation | error | token, validation, gossip, order-preserving-partitioner |
| Too many markers(?). | validation | error | cql, prepared-statement, limit-exceeded |
| Unable to extract Spiffe from the certificate | exception | error | cassandra, mtls, certificates, spiffe, tls |
| Unable to resolve initial location using cloud metadata… | validation | error | cloud-metadata, network, snitch, startup |
| Unknown listen_address ' | validation | critical | configuration, network, dns, cassandra |
| Unknown property | validation | error | schema, configuration, auto-repair |
| Use of ANN OF in an ORDER BY clause requires a LIMIT that… | validation | error | cassandra, sai, vector, ann, limit |
| Value for column ' ' violated constraint as it is not a… | validation | error | cql, write-path, constraints, json |
| Cannot find configured row cache provider class | exception | critical | cache, configuration, reflection, startup |
| Cannot parse 32-bits float value from | validation | error | parsing, type-codec, string-conversion, float |
| Cannot parse tuple value from | exception | error | parsing, tuple, cql-literal |
| Cannot parse UUID value from | exception | error | |
| Error occured when setting the config for setter | console | error | cli, nodetool, guardrails, setter, reflection |
| Failed to close CompressionDictionaryManager on disabling… | console | warning | compression, schema-change, resource-cleanup, lifecycle |
| is not a CMS member | exception | error | tcm, cms-membership, invalid-state-transition |
| No identity was extracted from the outbound keystore | exception | error | tls, keystore, configuration, internode-authentication |
| SASI only supports Murmur3Partitioner. | validation | error | sasi, configuration, partitioner, index-creation |
| Stop marker is older than start marker | exception | critical | accord, journal, startup, data-corruption, consistency |
| Unknown BufferPool metric name | exception | error | nodetool, cli-argument, jmx, metrics |
| A repair_session_space of | console | warning | cassandra, repair, heap, memory |
| Bad value for system property -D | validation | error | configuration, system-properties, auth |
| Batch with conditions cannot span multiple partitions | validation | error | cql, batch, lwt, multiple-partitions |
| Cannot alter RF while some endpoints are not in normal… | validation | error | configuration, replication, topology, alter-keyspace |
| Cannot replace function | validation | error | cql, udf, type-mismatch, or-replace |
| Could not find NodeId for endpoint | console | warning | cluster-membership, gossip, node-not-found, distributed-consistency |
| Descending ANN ordering is not supported | validation | error | cassandra, cql, ann, vector-search, ordering |
| Expecting URI in variable: [cassandra.config]. Found | validation | critical | configuration, uri, startup |
| 'Failed to read keystore password from the | exception | error | |
| metadata + " does not support filtering by token or… | validation | error | cassandra, virtual-table, token, partition-key |
| Must specify index implementation via USING | validation | error | cassandra, cql, index, configuration |
| Only CUSTOM indexes support multiple columns | validation | error | |
| Set listen_address OR listen_interface, not both | validation | critical | configuration, network, startup, cassandra |
| Unhandled status byte: " + b | exception | error | serialization, accord, enum |
| Unknown client metric | exception | error | invalid-argument, metric-name, client-metrics, nodeprobe |
| Unknown compaction metric | exception | error | invalid-argument, metric-name, nodeprobe, switch-default |
| Base table ' ' doesn't exist | validation | error | |
| Configuration entry inherits non-existing entry . | validation | error | cassandra, configuration, yaml, memtable |
| For field name | validation | error | cql, identifier, utf-8 |
| Invalid integer value | validation | error | cql, integer, property-parsing |
| Invalid negative min_compress_ratio | validation | error | config, compression, validation |
| memtable_cleanup_threshold has been deprecated and should… | console | warning | cassandra, configuration, deprecation, yaml |
| 'nodetool bootstrap resume' is disabled. | validation | warning | nodetool, cli, bootstrap, destructive-operation |
| Not enough bytes to read an UTF8 serialized string preceded… | exception | error | cql-protocol, truncated-frame, framing |
| Unable to parse precision of value | exception | error | cassandra, commitlog, configuration, enum |
| User has no permission on or any of its parents | exception | error | cassandra, authorization, permissions, roles |
| Virtual keyspace ' ' is not user-modifiable | validation | error | cassandra, cql, ddl, virtual-keyspace |
| When specifying the table for a snapshot, you must specify… | exception | error | snapshot, cli, validation |
| Cannot locate . If this is a local file, please confirm… | validation | critical | configuration, file-not-found, startup |
| Cannot mask columns because dynamic data masking is not… | validation | error | cassandra, data-masking, configuration |
| Cannot parse the version of the file: | exception | error | commitlog, filename, parse |
| Cannot TRUNCATE materialized view directly; must truncate… | validation | error | cql, materialized-view, truncate, invalid-request |
| Could not compile function | validation | error | udf, java, compilation, invocation-target |
| Expected an ascii string, but got a | validation | error | cassandra, marshal, json, type-mismatch |
| Failed to close ZstdDictDecompress | console | warning | cassandra, zstd, compression, resource-cleanup, native |
| Invalid compaction strategy: | exception | error | cli, compaction, configuration |
| Invalid configuration. Heap dump is enabled but cannot… | validation | error | cassandra, configuration, heap-dump |
| Invalid operation ( ) for non counter column | validation | error | cql, cassandra, counter, type-mismatch |
| Invalid pair | exception | error | commitlog, replay, configuration, parsing |
| Invalid unset value for tuple field number | validation | error | tuple, unset-value, cql |
| Invalid values for : ' ' do not parse as valid properties | validation | error | config, guardrails, validation, cassandra |
| is corrupt, can't import | exception | critical | sstable, corruption, import |
| Not enough bytes to read an UTF8 serialized string preceded… | exception | error | cql-protocol, truncated-frame, framing |
| Not enough bytes to read %dth field | validation | error | |
| Out of native memory occured, You can avoid it by… | exception | critical | out-of-memory, native-memory, bloom-filter, cassandra |
| Resource doesn't exist | validation | error | cql, permissions, resource |
| Scaling parameter must match | validation | error | cassandra, configuration, compaction, regex, ucs |
| Some records failed verification. See earlier in log for… | exception | error | sstable, transaction-log, startup, corruption |
| SSTable first key > last key | exception | critical | sstable, corruption, validation |
| (TimeType) Unable to coerce | validation | error | cassandra, serialization, time, invalid-date-format |