apache/cassandra
Documented errors, page 26 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Unknown error code | exception | error | protocol, error-code, deserialization |
| unknown target column | validation | error | sasi, index-configuration, configuration-exception, cassandra |
| Cannot parse map value from | exception | error | cql, parsing, map, codec |
| Cannot replace aggregate | validation | error | cql, type-mismatch, schema-evolution |
| Cluster is not running unsafe TCM mode, can't load cluster… | exception | error | tcm, config, unsafe-mode |
| commitlog_segment_size must be at least twice the size of… | validation | error | config, commitlog |
| Invalid byte for ascii: + Byte.toString(b) | validation | error | serialization, ascii, encoding, validation |
| Invalid parameter list for quantized extreme (Weibull)… | exception | error | cassandra, cli, argument-count, distribution |
| More than one restriction was found for the start bound on | validation | error | cql, query-validation, slice-bounds |
| no initialization vector (IV) found in this context | exception | error | encryption, iv, state |
| Non-frozen UDTs with nested non-frozen collections are not… | validation | error | cql, udt, types, schema |
| Static rows are not supported for remote table | validation | error | cassandra, virtual-table, static-columns, unsupported-operation |
| complex columns are not yet supported by SASI | validation | error | sasi, unsupported-type, complex-column, cassandra |
| Expected 8 or 0 byte long for date | validation | error | cassandra, serialization, timestamp, byte-size |
| Ignoring codec because it collides with previously… | console | warning | codec, driver, cache, registration-order |
| Invalid to specify an absolute maximum constant when the… | validation | error | configuration, parsing, conflicting-options |
| Invalid unset value for | validation | error | cql, prepared-statement, unset-value, query-validation |
| JavaScript user-defined functions were removed in… | validation | error | config, udf, removed-feature, upgrade |
| Missing sub-option ' ' for the 'compression' option. | validation | error | cassandra, schema, compression |
| is not currently joining the CMS | exception | warning | tcm, cms, join |
| Snapshot for . already exists. | exception | error | snapshot, duplicate, conflict, idempotency |
| timeout awaiting durability | console | warning | accord, durability, timeout, shutdown |
| unset is not supported inside vectors | validation | error | cassandra, vector-type, unset, validation |
| Aggregate ' ' cannot replace a function | validation | error | cql, namespace-collision, user-defined-function |
| Attempted to read a range containing | exception | error | cassandra, denylist, range-scan, invalid-request |
| Cannot parse UDT value from | exception | error | |
| Cannot parse varint value from | exception | error | |
| Cannot restrict clustering columns when selecting only… | validation | error | cql, invalid-request, static-columns, select |
| Error occurred during repair | exception | error | nodetool, repair, jmx |
| does not match | validation | error | configuration, parsing, regex, illegal-argument |
| Invalid list literal for | validation | error | cql, collections, type-mismatch |
| Invalid null set element | validation | error | |
| Invalid query kind in BATCH messages. Must be 0 or 1 but… | exception | error | batch, protocol, deserialization, native-protocol |
| LIKE value can't be empty. | validation | error | cql, like-operator, validation |
| num_tokens must be >= 1 | validation | critical | cassandra, configuration, bootstrap, tokens |
| of value is less or equal to of value | validation | error | cassandra, guardrails, configuration, validation, ordering |
| . : Keyspace name must not be empty | validation | error | cassandra, schema, builder |
| Unable to use given strategy class: LocalStrategy is… | validation | error | cassandra, cql, keyspace, replication, internal |
| Unknown field in value | exception | error | |
| A NaN cannot be converted into a decimal | validation | error | decimal, arithmetic, nan |
| Column with name ' ' doesn't exist on table | validation | error | cassandra, cql, ddl, column-not-found |
| HintsService is shut down and can't accept new hints | exception | error | lifecycle, shutdown, hints |
| Index is unreadable, scrubbing will continue without index. | console | warning | cassandra, bti, index, iterator |
| Invalid value for progress_barrier_min_consistency_level | validation | error | cassandra, configuration, consistency-level |
| Key may not be unset | validation | error | cql, partition-key, unset-value |
| Missing target column | validation | error | cassandra, sai, invalid-request, missing-argument |
| NANOSECONDS level precision is not supported. | exception | error | cassandra, commitlog, configuration, unsupported |
| Node is still rebuilding. Check nodetool netstats. | exception | error | state, concurrency, streaming, rebuild |
| Only -1 (undefined) and positive values are allowed; given | validation | error | config, validation, integer |
| SAI ANN indexes are not allowed on multiple data directories | validation | error | cassandra, sai, vector, configuration |
| Seed provider returned more than | console | error | |
| SetType takes exactly 1 type parameter | exception | error | cassandra, type-parser, set, configuration |
| Some partition key parts are missing | validation | error | cql, cassandra, partition-key |
| stream_throughput_outbound: is too large; it should be less… | validation | error | configuration, streaming, throughput |
| Unsupported '!=' relation | validation | error | |
| Aborted garbage collection for at least one table, check… | exception | error | compaction, garbagecollect, user-defined, jmx |
| Attempted to reference an already released SharedByteBuffer | exception | error | network, buffer, reference-counting, concurrency |
| Cannot use aliases when defining a materialized view | validation | error | cql, materialized-view, alias |
| Event " + eventType.name() + " not valid for protocol… | exception | error | protocol, events, version-compatibility, cql-native-protocol |
| Host ID not found. | exception | error | removenode, host-id, resource-not-found, operator-error |
| Invalid latency modifier specification | validation | error | cassandra, configuration, timeout, parse-error |
| Invalid null element in list | validation | error | json, list, null, validation |
| Learned about epoch from , but could not fetch log. | console | warning | fetch-log, peer-fetch, network |
| max attempt must be positive; but given | validation | error | configuration, validation, retry |
| Maximum node connections cannot be set without enabling | validation | error | cassandra, sai, vector-index, feature-flag, index-options |
| native_transport_min_backoff_on_queue_overload should be… | validation | error | cassandra, configuration, native-transport |
| No arguments. | console | error | cli, nodetool, guardrails, missing-argument |
| No PRIMARY KEY specifed for view | validation | error | cql, materialized-view, primary-key, schema |
| Node is in state. Only a JOINED node can be set as CMS… | exception | error | node-state, cms-membership, reset, cluster-metadata |
| Only one of , can be specified. | validation | error | configuration, auth, conflicting-options |
| Partition denylist table metadata not found | console | warning | denylist, schema, system-distributed, availability |
| Pull repair can only be performed between two hosts. Please… | validation | error | repair, cli, argument-count |
| is expecting argument values. Getting instead. | console | error | cli, nodetool, guardrails, argument-count |
| Static columns are not supported in COMPACT STORAGE tables | validation | error | cql, schema, compact-storage, static-columns |
| Unknown connection category: + category | exception | error | internode, configuration, illegal-argument, tcp |
| Unknown option id | exception | error | protocol, types, invalid-enum, cql-native-protocol |
| Cannot use transient replication on keyspaces using… | validation | error | configuration, transient-replication, secondary-index, alter-keyspace |
| Corrupt (negative) clustering value length encountered | exception | error | sstable, corruption, deserialization |
| Error during moving node | console | error | nodetool, jmx, ioexception, streaming |
| has shut down | exception | error | concurrency, threadpool, shutdown |
| Invalid Token: | validation | error | cassandra, validation, token, partitioner |
| LIKE value can't contain a % other than at the start and/or… | validation | error | cql, like-operator, wildcard |
| --table option should be passed along with --keyspace option | console | error | cli, validation, permissions |
| Timed out while trying to append item to the log | console | warning | cas, metadata-log, timeout, schema |
| Aggregate ' ' doesn't exist | validation | error | cql, drop-aggregate, not-found, uda |
| Cannot set repair_session_space to < 1 mebibyte | validation | error | configuration, repair, memory |
| Expected a long or a datestring representation of a… | validation | error | cassandra, json, timestamp, type-mismatch |
| Expected a string representation of a time value, but got a | exception | error | cassandra, json, time, type-mismatch |
| Failed to reload SSL certificates. Please check the SSL… | console | error | nodetool, ssl, jmx, certificate-reload |
| History file is not readable.%n | console | error | nodetool, history, permissions, filesystem |
| Invalid + charset + bytes + accessor.toHex(value) | validation | error | serialization, encoding, charset, marshal |
| Invalid custom verb id + id + - we only allow custom ids… | panic | critical | network, enum, verb-id, custom-verb |
| Invalid value for property | validation | error | cassandra, auth, roles, type-error |
| Output file name must not be null or empty. | validation | error | validation, null, async-profiler |
| SPARSE mode doesn't support analyzers. | validation | error | sasi, invalid-config-value, analyzer, sparse-mode, cassandra |
| Threshold value for gc_log*_threshold must be greater than 0 | validation | error | configuration, gc, jvm |
| timeout must be non-negative | validation | error | nodetool, cli-argument, timeout, validation |
| A storage-attached index cannot be created over multiple… | validation | error | cassandra, sai, invalid-request, multi-column |
| Altering column types is no longer supported | validation | error | cassandra, cql, ddl, deprecated |
| Cannot parse map value from | exception | error | cql, parsing, map, codec |