apache/seatunnel
Documented errors, page 17 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| clickhouse local file not exists | exception | error | clickhouse, file-not-found, flush |
| Couldn't get timestamp utils from underlying connection | exception | error | cdc, postgres, jdbc, connection |
| env. .mode=ROUTE requires env. .sink.plugin_name to be… | validation | error | config, missing-required-config, route-mode |
| Error while deserializing binlog event at offset | console | warning | mysql, cdc, binlog, deserialization |
GET_EZS_VERSION_FAILED fail to get easysearch version. | error_code | error | easysearch, cluster-info, connection |
GET_PART_ERROR Cannot get part name from system.parts | error_code | error | clickhouse, system-parts, split-enumeration, query-failed |
| Invalid DuckDB JDBC url: | validation | error | jdbc, duckdb, url, validation |
| Invalid sort JSON: | validation | error | json, config, airtable, validation |
| python.executable does not resolve to an executable file | exception | error | python, filesystem, permissions, configuration |
| restoreSourceJobId must reference a historical terminal… | exception | error | checkpoint-restore, job-submission, invalid-argument-value, zeta-engine |
STAGE_LOAD_FAILED offer data to queue timeout, exceed | error_code | critical | timeout, queue, selectdb |
| must in [ALL, OFF, PART] | validation | error | config, enum, validation |
| Unsupported schemaChangeEvent : | exception | error | elasticsearch, schema-change, cdc, unsupported-event |
| Bedrock Mantle response ended with status | exception | error | python, llm, aws, bedrock, streaming |
| Could not calculate standalone splits | console | warning | mongodb, cdc, command-error, fallback |
| Deserialize message failed, skip this message, message | console | warning | kafka, deserialization, data-loss |
| Failed to decode 'auth.api_key_encoded' as Base64 | console | error | elasticsearch, base64, config-validation |
| Failed to get checkpoint data from master node… | exception | error | zeta-engine, rest-api, rpc, restore |
| Failed to setup RabbitMQ queue | exception | critical | rabbitmq, queue-declare, initialization, sink |
| Failed to truncate collection | exception | error | mongodb, catalog, truncate |
| Invalid BATCH batchId in request | console | warning | protocol, validation, batch-id |
| MQTT source qos must be 0 or 1, got | validation | error | mqtt, qos, validation, config |
| Server property does not contain a usable absolute path | exception | error | python, configuration, security, validation |
| Cannot rename file from | exception | error | hadoop, file-rename, commit |
| close elasticsearch connection error | console | warning | elasticsearch, rest-client, connection-close, cleanup |
| Failed to create table | exception | error | hudi, filesystem, io, write |
| Failed to drop database | exception | error | hive, catalog, metastore |
| Flink job executed failed | exception | error | flink, job-execution, command |
| does not support replacing comments | exception | warning | column, schema, unsupported |
| Skip failed JDBC source table in discovery | console | warning | jdbc, discovery, multi-table |
| 'startup.specific-offset.*' options can only be used when | validation | error | cdc, mysql, config-validation |
| The transform/sink( ) is not configured with ' ' option | validation | error | java, job-config, dag, missing-option |
| Unsupported agent.delivery-guarantee | validation | error | config, enum, validation |
| Unsupported clause merge format: | exception | error | sql, enum, unsupported-value, ddl |
| Unsupported convert to Integer | exception | error | java, type-conversion, unsupported-operation |
| Unsupported convert to Short, typeDefine | exception | error | java, type-conversion, unsupported-operation |
| Unsupported pending split list value type | exception | error | cdc, tidb, checkpoint, state-restore, type-mismatch |
| AzureCosmosDB requires key, primary_key, secondary_key, or… | validation | error | config, azure-cosmosdb, authentication, missing-credentials |
| Cannot drop replication slot | console | warning | cdc, postgresql, replication-slot, connection-in-use |
| Cannot get plugin URL for pluginIdentifier | console | warning | plugin-discovery, url, filesystem |
| Client not connected | exception | error | ftp, network, connection, stream |
| Error queue overflow for stage | exception | error | error-sink, queue-overflow, backpressure, zeta-engine |
| Failed to close edge socket server socket on | console | warning | network, socket, resource-cleanup |
| Failed to close io manager in paimon sink writer. | console | warning | paimon, cleanup, io |
| Log file path is empty, no log file path configured in the… | console | warning | servlet, rest-api, logging, configuration, bad-request |
PARSE_IP_ADDRESS_FAILED PARSE_IP_ADDRESS_FAILED | error_code | error | cassandra, inet, address-parsing |
| ' ' must be configured when ' ' is used | validation | error | rabbitmq, config, validation, schema |
| Unsupported pending split value type | exception | error | cdc, tidb, checkpoint, state-restore, type-mismatch |
| Collector from closed connection before authentication | console | warning | edge-socket, authentication, connection-closed, handshake |
| Convert timestamp to LSN offset error | exception | error | sqlserver, cdc, offset, timestamp |
| Failed to deserialize python source stdout line | exception | error | deserialization, json, python, stdout |
| Failed to start replication stream at | console | warning | cdc, postgresql, replication, retry |
| --limit must be >= 1 | validation | error | cli, validation, limit, argument-validation |
| Object to json exception! | exception | error | jackson, serialization, runtime-exception |
QUERY_COLLECTION_EXISTS_ERROR QUERY_COLLECTION_EXISTS_ERROR.getDescription() | error_code | error | typesense, collection-exists, api-error |
| Stripe option 'created_lt' must not be negative | validation | error | config-validation, timestamp, range-check |
| Table not exist | exception | error | iceberg, catalog, table-not-found |
| table not exist | exception | error | iceberg, catalog, table-not-found, snapshot |
| tableExists error | exception | error | maxcompute, catalog, odps, table-existence |
| tables_configs[ ]: 'start_mode.timestamp' is only valid… | validation | error | kafka, config, validation, conflicting-options |
| tables_configs[ ]: 'start.mode.timestamp' required when… | error_code | error | config, validation, rocketmq |
| The iris database is not supported hash or md5 function… | exception | error | jdbc, iris, config-validation, parallelism |
| Unauthorized to read config.collections or config.chunks | console | warning | mongodb, cdc, authorization, sharding |
| Unexpected error while connecting to MySQL and looking at… | exception | error | mysql, binlog, jdbc, cdc |
AUTH_FAILED HTTP " + status + ": " + body | error_code | critical | http, oauth, salesforce, authentication |
CONFIGURATION_FAILED Google Pub/Sub source supports streaming jobs only | error_code | error | google-pubsub, job-mode, config-validation, java |
| Failed to check if database exists | exception | error | hive, metastore, thrift, database |
| Failed to fetch metadata from Gravitino for metadata | exception | error | network, http, gravitino, metadata |
| Failed to open Hive catalog | exception | critical | hive, catalog, lifecycle, metastore |
| Insert sql must have select statement | exception | error | sql, parser, insert, unsupported-syntax |
| Python source stream closer did not finish within | console | warning | python, fd-leak, shutdown |
| retry.max-attempts must be >= 1. | validation | error | config, retry, validation |
| SeaTunnel job on flink engine deploy mode only support… | validation | error | cli, flink, arguments |
| SFTP connection pool has been closed. | exception | error | sftp, connection-pool, lifecycle |
| Trace file already closed | console | info | io, shutdown, file |
| Unsupported error handler mode | validation | error | config, enum, error-handler |
| Unsupported Int bit width: | exception | error | lance, arrow, integer, bit-width |
ADD_FIELD_FAILED PUT response null | error_code | error | elasticsearch, http, null-response, mapping-update |
| Enumerator thread is interrupted. | exception | info | iceberg, interruption, shutdown |
| Failed to change working directory to | exception | error | ftp, mkdir, cwd, permissions |
| Gravitino metalake is required. Please configure… | validation | error | |
| recordKey values: " " for fields: cannot be entirely null… | exception | error | hudi, data-quality, null-key, sink |
| Skip event with invalid payload for traceId= | console | warning | observability, trace, serialization |
| source position sourceId must not be blank | validation | error | validation, source-position, sqlite, blank-field |
| Stripe option 'rate_limit_max_retries' must not be negative | validation | error | config-validation, retry, range-check |
TABLE_WRITE_RECORD_FAILED This record failed to be written | error_code | error | paimon, sink, write |
| tables_configs[ ]: duplicate 'schema.table' value | validation | error | neo4j, config-validation, duplicate-table |
WRITE_ROW_FAILED Failed to send these rows of data | error_code | error | tablestore, alibaba, batch-write, data-quality |
| Already an MDCStream | exception | error | tracing, mdc, stream, argument-validation |
| Binary chunk size too large (max 100MB), got | exception | error | config-validation, binary, memory |
| Cannot specify both ' ' and root-level ' '. | validation | error | rabbitmq, config, validation, mutually-exclusive |
| fail to get easysearch field | console | warning | elasticsearch-like, mapping, fallback, schema |
| Failed creating table | exception | error | jdbc, postgres, ddl, sql |
FIELD_TYPE_MAPPING_ERROR FIELD_TYPE_MAPPING_ERROR.getDescription() | error_code | error | typesense, field-mapping, schema |
| The configuration of 'overwrite' is deprecated, please use… | console | warning | maxcompute, deprecated, config, sink |
| The scale of time type is larger than | console | warning | jdbc, postgres, time, scale, type-conversion |
| The sink table[ ] is not found | exception | error | sql, parser, insert, unknown-table |
| timeout_ms must be greater than 0 | validation | error | config, firebase, validation, sea-tn |
| transport.endpoint must be non-empty. | validation | error | config, endpoint, validation, empty-string |
| truncate table error | exception | error | maxcompute, catalog, truncate, partition |