apache/seatunnel
Documented errors, page 20 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Invalid LSN format: . Expected format… | exception | error | sqlserver, cdc, lsn, format |
| MySQL-CDC diagnostic: failed to query variable | console | warning | mysql, cdc, diagnostics, sql, variables |
| Not supported for list databases for iris | exception | error | jdbc, iris, unsupported, catalog |
| openai package required for AI_PROVIDER=openai. Install it… | exception | error | python, llm, dependency, openai |
| Please set kerberosKeytabPath | validation | error | hive, kerberos, config |
| The timestamp column | console | warning | jdbc, snowflake, time-scale, type-conversion |
| Unable to create a source for identifier | exception | error | factory, spi, source-plugin, wrapper |
| catalog not implements SupportsNamespaces so can't list… | exception | error | iceberg, catalog, namespaces, unsupported |
| check database exists failed | exception | error | |
| Column not found in table | exception | error | jdbc, yashandb, metadata, sql |
GRAPHQL_SINK_PARAMETER_ERROR GraphQL Sink unsupported operation type | error_code | error | graphql, config, validation, sink, mutation |
| MultiTableSinkFactory only support MultiTableFactoryContext | exception | error | |
| Option 'max_in_flight_messages' must be greater than or… | validation | error | config, validation, azure, source |
PROTOCOL_ERROR For non-subscription mode, URL must start with http:// or https:// | error_code | error | graphql, config, url, protocol |
| SNMP source port must be between 1 and 65535 | validation | error | config, snmp, validation, port |
| Table format cannot be null or empty | validation | error | hive, format, validation, null |
| tables_configs can not be empty. | validation | error | cdc, vitess, empty-list, config-validation |
| The Avro schema is not a nullable type | exception | error | hudi, avro, schema, nullable |
| Unsupported convert to LocalDate | exception | error | java, type-conversion, date, seatunnel-api |
DATABASE_ALREADY_EXISTED Database already exist in Catalog . | error_code | error | jdbc, catalog, duplicate, database |
INVALID_TABLE_PATH table_path is required in tables_configs | error_code | error | config, salesforce, table-path |
| Oracle table name format must be is | validation | error | oracle-cdc, config-validation, table-name-format |
ROUTING_FAILED argument 'routing' is illegal, value is '%routing%'. | error_code | error | doris, address, parsing, config |
| Schema config can not be empty | validation | error | |
| SNMP sink host must not be blank | validation | error | snmp, config, validation |
TABLE_EXISTS_EXCEPTION HbaseConnectorErrorCode.TABLE_EXISTS_EXCEPTION.getErrorMessage() | error_code | error | hbase, table, exists, create |
| Table does not exist in catalog (TableNotExistException) | exception | error | |
| Cannot qualify path for safety check, using raw path… | console | error | |
| Failed to create database | exception | error | hive, catalog, metastore |
| File format 'canal_json' does not support reading. | exception | error | file-connector, file-format, unsupported-read, cdc-json |
| input.multiline.flush-idle-timeout-ms must be > 0 when… | validation | error | config, validation, multiline |
| Invalid YAML configuration | exception | error | yaml, config, parse |
| JsonPath array cannot be null or empty | validation | error | jsonpath, argument-validation, config |
| SNMP source timeout_millis must be greater than 0 | validation | error | config, snmp, timeout |
| The non-primary key field cannot be empty. Please set other… | exception | error | jdbc, xugu, upsert, configuration |
| Agent config is not a readable file | exception | error | config, file-io, yaml, path |
| Cannot convert time: | exception | error | iceberg, type-conversion, time, sink |
| DECIMAL scale exceeds maximum , truncating to | console | warning | jdbc, duckdb, decimal, scale |
| Error to check tables | exception | error | postgres, cdc, database, fetch-task |
| Failed Connection JDBC error | exception | error | |
GRAPHQL_SOURCE_PARAMETER_ERROR GraphQL Sink query is required. | error_code | error | graphql, config, validation, sink |
| Jira source connector not support unbounded operation | exception | error | seatunnel, connector, batch-mode, streaming-unsupported |
| Json parse object exception! | exception | error | jackson, deserialization, runtime-exception |
| list databases failed | exception | error | |
| Can not find catalog table with factoryId | exception | error | catalog, table-not-found, config |
CREATE_BE_READER_FAILED Format of StarRocks BE address | error_code | error | starrocks, address-format, config, be-reader |
| Dropping table exception. | exception | error | hadoop, filesystem, delete, io |
| Failed to connect url | exception | error | |
| Failed to execute custom SQL | exception | error | bigquery, custom-sql, sql-query, catalog |
| The following STREAM_PARAMS value is invalid | console | warning | cdc, postgresql, config-parsing, stream-params |
| TLS certificate verification disabled - not recommended for… | console | warning | tls, security, ssl |
| Unsupported convert to Boolean | exception | error | java, type-conversion, unsupported-operation |
| Vitess CDC requires explicit schema metadata. | validation | error | cdc, vitess, schema-validation |
| Can't create JdbcDialect without compatible mode for Dsql | exception | error | jdbc, dsql, dialect-factory |
| Closing httpClient failed. | exception | warning | doris, io, http-client, resource-cleanup |
| HOCON Config parse from | exception | error | datatype, parsing, hocon |
| Ignore schema change event for unknown table | console | warning | cdc, schema-change, multi-table, data-sync |
| input.on-error must be "skip" or "fail". | validation | error | config, validation, enum |
| ' ' requires ' ' with ' ' when the mode is 'specific'. | validation | error | cdc, mysql, config-validation |
| Sparse vector value must be a Number, but got | validation | error | vector, sparse-vector, type-mismatch, java |
| Cannot resolve insert strategy | validation | error | maxcompute, config, enum, sink |
CREATE_COLLECTION_ERROR CREATE_COLLECTION_ERROR.getDescription() | error_code | error | typesense, create-collection, conflict |
| deploy mode not support | exception | error | configuration, deploy-mode, startup |
| ' ' must be greater than or equal to 0. | validation | error | cdc, mysql, config-validation |
| Retention delete failed: file= | console | error | |
| Unsupported byte value | exception | error | row-kind, deserialization, byte |
| Unsupported syntax | exception | error | sql, parser, unsupported-syntax |
| Elasticsearch Source config warn: when both 'index' and… | console | warning | elasticsearch, config, ambiguity |
| Failed to list offsets for table | exception | error | fluss, offsets, admin-client |
| Map as map key is not supported | exception | error | lance, arrow, map-key, nested-type, sink |
| Please configure `database`, not allow null database in… | validation | error | config-validation, doris, missing-field |
| [ ]: ' ' must be configured | validation | error | rabbitmq, config, validation, schema |
| Stripe option 'rate_limit_backoff_ms' must not be negative | validation | error | config-validation, retry, range-check |
| Unknown AI provider ' '. Available | validation | error | configuration, validation, llm, enum |
| Vitess CDC does not support schema-qualified table paths… | exception | error | cdc, vitess, table-path |
| ARRAY type requires element type | exception | error | hive, type-conversion, array-type |
| Close ErrorHandler for transform stage failed | exception | error | io, error-handling, resource-close, transform |
| Failed to create table | exception | error | hive, catalog, create-table, schema-mapping |
| list tables of database | exception | error | |
| oracle_insert_mode=APPEND_VALUES does not support custom… | validation | error | jdbc, oracle, config-conflict, custom-query |
| Orc does not support NULL type | exception | error | hive, orc, type-conversion, unsupported-type |
| Request failed with empty response. | console | warning | http, starrocks, empty-response |
| SNMP source community must not be blank | validation | error | config, snmp, authentication |
TABLE_CREATE_EXCEPTION HbaseConnectorErrorCode.TABLE_CREATE_EXCEPTION.getErrorMessage() | error_code | error | hbase, table, create, admin |
TABLE_TRUNCATE_FAILED data_save_mode=DROP_DATA is not yet supported by the Bigtable connector. Please… | error_code | error | bigtable, data-save-mode, config, unsupported-feature |
| tables_configs[ ]: 'start.mode.offsets' must not be empty… | error_code | error | config, validation, rocketmq |
| An exception occurred while obtaining the table | exception | error | kudu, catalog, schema |
| must be greater than zero. | validation | error | cli, validation, out-of-range |
| No data converter found for identifier | exception | error | java, spi, service-loader |
| Python source reader has already been closed | exception | error | lifecycle, python, state |
| Unable to create a sink for identifier | exception | error | factory, spi, sink-plugin, wrapper |
| Unsupported convert to Short | exception | error | java, type-conversion, unsupported-operation |
| check table [ ] exists failed | exception | error | |
| DatabaseAlreadyExistException: catalogName, databaseName | error_code | error | database-already-exist, databend, catalog, create-database |
| Failed to truncate table | exception | error | easysearch, catalog, truncate |
| Generate empty file when no data is not supported when… | exception | error | sink, config, partition |
| json to map exception! | exception | error | jackson, deserialization, map |
RedisErrorCode-04 No available nodes in cluster | error_code | error | redis, cluster, topology, connectivity |
| Already an MDCComparator | exception | error | java, mdc, tracing, double-wrap |
BULK_JOB_CREATE_FAILED HTTP " + status + ": " + responseBody | error_code | error | http, salesforce, bulk-api |