apache/seatunnel
Documented errors, page 5 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
READ_COMMITTED_OFFSET_FAILED Could not read PostgreSQL replication slot | error_code | error | postgresql, cdc, replication-slot, offset, checkpoint |
| Schema evolution: partition column [" + col + "] is missing… | validation | critical | file-sink, schema-evolution, partition, cdc |
STREAM_LOAD_FAILED stream load redirect not followed: HTTP/1.1 307 Temporary Redirect, request= | error_code | critical | http, redirect, doris, stream-load, network |
| create new current writer failed, parent path is | exception | error | java, filesystem, wal, imap-storage |
| Failed to get response from Doris | exception | error | http, network, doris, rest |
| JDBC driver does not support savepoints. Row-error handling… | console | warning | jdbc, savepoints, transaction, checkpoint |
| No result returned after running query | exception | error | jdbc, source, chunking, sql |
| Post-sync operation failed and will be retried: action= | console | warning | file-connector, post-sync, retry, filesystem |
| The "before" field of | exception | error | cdc, debezium, postgres, replica-identity, update |
| The "before" field of | exception | error | ogg, cdc, postgres, replica-identity |
| Truncate table interrupted | exception | warning | bigquery, interrupt, truncate, thread-interrupted |
WRITE_FAILED Failed to publish message to Google Pub/Sub | error_code | error | pubsub, google-cloud, sink, write |
| Could not load service provider for event handlers. | exception | error | |
| Failed to write vertices to NebulaGraph tag ' '. The writer… | exception | critical | nebulagraph, write-failed, flush, batch |
| NebulaGraph sink writer is in a failed state. | exception | error | java, sink, lifecycle, nebulagraph |
| No hive tables matched the regex pattern. Please check… | validation | error | hive, regex, metastore, no-match |
| The Factory has not been implemented and the deprecated… | exception | error | factory, sink, deprecated-api, spi |
| Thread interrupted | exception | warning | jdbc, interruption, cancellation, sampling |
| Connector requires binlog file | console | error | mysql, binlog, checkpoint, retention |
| Error while closing Databend source reader | exception | warning | jdbc, databend, resource-cleanup, io |
| Failed to create directory | exception | error | ftp, file-write-failed, io |
| Gitlab source connector not support unbounded operation | exception | error | seatunnel, connector, batch-mode, streaming-unsupported |
| Option 'operation_timeout_ms' must be less than half of… | validation | error | config, validation, azure |
SOURCE_ALREADY_HAS_DATA The target data source already has data | error_code | error | |
| Type mismatch for column | exception | error | bigquery, type-mismatch, schema-validation, save-mode |
| Unable to convert to LocalDate from unexpected value '' of… | exception | error | java, cdc, date-conversion, type-mismatch |
| Unsupported ArrowType | validation | error | lance, arrow, type-dispatch, unsupported-type, sink |
AUTHENTICATE_KERBEROS_FAILED Failed to login user from keytab | error_code | error | kerberos, authentication, hdfs |
CONNECT_FAILED Failed to load Databend JDBC driver | error_code | critical | jdbc, databend, classpath, driver |
| Connector used GTIDs previously, but MySQL does not know of… | console | error | mysql, gtid, binlog, configuration |
| DELETE response status code= , body= for scroll ID | console | warning | elasticsearch, scroll, http-status, cleanup |
| No MetadataProvider found for kind | exception | error | |
SeaTunnelAPIErrorCode.CONFIG_VALIDATION_FAILED Incompatible Markdown Knowledge Sync metadata column | error_code | error | schema, metadata, conflict |
| Snapshot was interrupted before completion | console | warning | cdc, db2, snapshot, interrupted |
| Split file for [ ] failed, cause= | error_code | error | io, file-split, hadoop |
| Expected Array type but got: | exception | error | aerospike, type-mismatch, schema, sink |
| did not infer any source schema. | validation | error | dry-run, schema-inference, source, config-validation |
NAMESPACE_DELETE_EXCEPTION HbaseConnectorErrorCode.NAMESPACE_DELETE_EXCEPTION.getErrorMessage() | error_code | error | hbase, namespace, admin-operation, io-exception |
| Unsupported close starting task | exception | error | zeta-engine, checkpoint, unsupported-operation, task-lifecycle |
| Unsupported SQL type | console | warning | type-conversion, fallback, databend, schema |
| Failed to finish the JDBC source read transaction. Closing… | console | warning | jdbc, connection, transaction, cleanup, close |
FILE_READ_FAILED Read data failed, tableId= | error_code | error | hive, file-read, io, split |
| File does not exist. | exception | error | sftp, filenotfound, ls, permissions |
| Invalid state: currentSplitId is null when emitting… | exception | critical | cdc, state, internal-state, split-reader |
| Job not found | exception | error | seatunnel, zeta-engine, job-not-found, rest-api |
| Post-sync backup: rename-to-staging failed, will retry… | console | warning | hadoop, file-source, rename-failed, io, retryable |
| root-level 'schema' cannot be used with 'tables_configs' | validation | error | neo4j, config-validation, conflicting-options |
| transport.aes-secret-key-base64 is required when… | validation | error | config, encryption, validation, startup |
| Unable to convert to LocalDate from a java.sql.Date value ' | exception | error | java, cdc, time-conversion, type-mismatch |
| Unable to parse unsupported LOB_WRITE SQL | exception | error | oracle, cdc, logminer, lob, redo-sql |
| All candidate sink tables were skipped during job parsing. | validation | error | job-parsing, sink-tables, catalog-discovery, config-validation |
CATALOG_TABLE_SIZE_IS_ERROR The catalogTableFromConfigs size is not correct | error_code | error | file-connector, multi-table, config-mismatch |
| Failed to parse OffsetDateTime value: (class: ) | exception | error | jdbc, datetime, parsing |
| JDBC XA sink requires max_retries equal to 0 when… | validation | error | jdbc, config-validation, exactly-once, xa-transaction |
| KeyStore certificate is not yet valid: | exception | error | ssl, certificate-validity, clock-skew, elasticsearch |
PACKET_AES_KEY_MISSING Missing secret_key when packet encryption is AES_GCM | error_code | error | encryption, config, aes-gcm |
| Failed to drop BigQuery table: | exception | error | bigquery, gcp, drop-table, permissions, api |
| Failed to get file system | exception | critical | hdfs, checkpoint-storage, filesystem |
| Failed to list tables in dataset: | exception | error | bigquery, gcp, metadata, permissions, dataset |
| Ignored malformed cluster health metrics token(s) from… | console | warning | logging, rest-api, cluster-metrics, malformed-input |
| ' ' is set to 'true'. This setting is not recommended and… | console | warning | mysql, cdc, jdbc, timezone, deprecated |
| old: - } and new: - } belongs to the same type family, but… | console | warning | paimon, schema-evolution, type-mismatch |
| Oracle failed to re-construct redo SQL | exception | error | oracle, cdc, logminer, redo-sql, event-processing |
| Post-sync backup promotion target is absent after rename… | console | warning | hadoop, file-source, backup, consistency, retryable |
| The read columns configuration will be filtered by the… | console | warning | file-connector, xml, schema-mismatch, config-validation |
| Cannot read the binlog filename and position via | exception | error | mysql, binlog, replication, cdc |
COMMIT_FAILED <loadResult> | error_code | error | doris, transaction-commit, stream-load |
DELETE_COLLECTION_ERROR DELETE_COLLECTION_ERROR.getDescription() | error_code | error | typesense, http, connector-sink, document-delete |
| Error getting current Lsn/txId | exception | error | postgres, cdc, replication, lsn, wal |
| Field is null, setting to NULL in prepared statement | console | warning | null-values, jdbc, prepared-statement, data-quality |
FILE_READ_STRATEGY_NOT_SUPPORT Cannot found the read strategy for this table | error_code | error | file-source, multi-table, read-strategy, configuration |
| When `use_regex` is enabled, `table_name` must be configured | validation | error | hive, config, regex, missing-option |
COMMON-11 Failed to initialize error sink writer | error_code | error | error-sink, initialization-failure, writer-operation-failed, zeta-engine |
| Failed to close HBase connection. | exception | warning | hbase, resource-cleanup, connection-close, io-exception |
| Failed to export metadata | exception | error | io, file-write, metadata-export, cli |
| get file names error,path is s% | exception | error | java, filesystem, list-files, imap-storage |
NO_SUITABLE_DRIVER No suitable driver found for the configured JDBC URL | error_code | error | jdbc, driver, url, connection |
| should not call here, error | exception | error | cdc, debezium, unsupported-operation, schema-history |
| Timed out waiting for error sink queue to drain. jobId= | exception | error | error-sink, timeout, backpressure, flush, zeta-engine |
| Unable to set innodb_lock_wait_timeout | console | warning | mysql, cdc, snapshot, jdbc |
| Interrupted while connecting to NATS JetStream | exception | error | nats, jetstream, interrupted, connect |
| Not applicable when using read-only flushing strategy | exception | error | oracle, cdc, logminer, read-only, flush-strategy |
| The timestamp column | console | warning | jdbc, yashandb, timestamp, precision |
| array inject error, unsupported data type: " + type | exception | error | unsupported-type, array, data-type, clickhouse, serialization |
| http post response failed. statusCode | console | warning | doris, http, rest-api, network |
| Only printable ASCII strings are supported for string range… | exception | error | jdbc, splitter, ascii, validation |
| Operator requires a compareOption (cross-field comparison)… | validation | error | excel, schema, catalog-table, connector-file |
| set restart.strategy in config | console | warning | flink, config, restart-strategy |
| The decimal column type decimal( , ) is out of range, which… | console | warning | jdbc, saphana, type-conversion, decimal-precision |
| Unsupported schemaChangeEvent | error_code | error | databend, schema-change, cdc, unsupported-event |
| Cannot get maximum archive log SCN as no logs were… | exception | critical | oracle, cdc, logminer, archived-log, scn |
COMMON_UNSUPPORTED_DATA_TYPE (CommonErrorCodeDeprecated.UNSUPPORTED_DATA_TYPE) Unsupported format | error_code | error | kafka, config, serialization, unsupported-format |
| Conditional ' ' not found in options. | validation | error | |
| Invalid YashanDB JDBC URL | validation | error | yashandb, jdbc-url, config-validation |
| NebulaGraph string vertex IDs must not contain unsupported… | exception | error | java, nebulagraph, data-quality |
| Read the binlog offset error | exception | error | postgresql, cdc, jdbc, offset, network |
| Snapshot is using user | console | warning | mysql, cdc, permissions, snapshot |
| `table_name` must not be blank when `use_regex` is enabled | validation | error | hive, config, regex, blank-value |
TABLE_SCHEMA_GET_FAILED Get table schema from Cassandra source failed | error_code | error | cassandra, schema, source, connection |
ACKNOWLEDGE_FAILED Google Pub/Sub returned | error_code | error | google-pubsub, acknowledgement, checkpoint, java |