hashicorp/terraform
Documented errors, page 5 of 8. Back to hashicorp/terraform
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| no non-null, non-empty-string arguments | validation | error | terraform, hcl, collection-functions, coalesce, null-handling |
| hostname for run ( ) does not match the configured cloud… | exception | error | terraform, show, hostname, cloud-plan, config-mismatch |
| No more than one provider_installation block may be… | validation | error | cli-config, provider-installation, validation, duplicate |
| Unexpected HTTP response code | http | error | http, lock, status-code, http-backend, config |
| No instance found for the given address! This command… | console | error | state, state-show, resource-address, instance, terraform-cli |
| unsupported backend state version | exception | error | backend, version-mismatch, compatibility, init |
| cannot hash package at | error_code | error | hash, package-location, installer |
| couldn't read unredacted JSON plan data for cloud run | exception | error | terraform, show, cloud-plan, unredacted, auth, admin, permissions, not-found |
| failed checking for existing remote state | exception | error | terraform, state, remote-state, auth, network, tfe |
| failed to delete tag | exception | error | terraform, cos, tencent-cloud, tag, permissions, state-lock, unlock, remote-state, go |
| Failed to retrieve lock information from OCI Object Storage | error_code | error | oci, state-locking, error-recovery |
| : attribute schema is nil | validation | error | schema-validation, configschema, nil-guard, go |
| unmarshal Ecs sts token response err | error_code | error | oss, ecs, metadata-service, unmarshal, parsing |
| describe oss endpoint using region: %#v got an error: %#v | error_code | error | oss, location-service, network, region, permissions |
| get Ecs sts token err | error_code | error | oss, ecs, metadata-service, network, authentication |
| secret_suffix must not end with | validation | error | kubernetes-backend, validation, secret-suffix, config |
| state not locked | console | error | schema-validation, configschema, nestingset, write-only, provider-schema |
| subdir not found | error_code | error | subdir, module-installation, archive |
| Error creating temporary file for upload | exception | error | terraform, ssh, scp, upload, tempfile, filesystem, provisioner |
| failed to unlock S3 | exception | error | locking, s3, remote-state, unlock, partial-failure, iam |
| file exceeds maximum part count | error_code | error | oci, multipart-upload, state-file, validation |
| found invalid type within path | panic | critical | terraform-internal, jsonformat, panic, attribute-path, bug |
| the secret name is invalid, This is a requirement for… | validation | error | schema-validation, configschema, nestingmode, enum, provider-schema |
| workspace not found For security, returns '404 Not Found'… | exception | error | tfe, hcp, cloud-backend, workspace, not-found, permissions |
| can not read intermediate certificate from | exception | error | oci, authentication, filesystem, certificates, instance-principal, terraform-backend |
| Failed to load the backend state file when preparing to… | exception | error | terraform, state-migration, local-state, json, filesystem |
| Failed to set new workspace | exception | error | backend, migration, workspace, filesystem, permissions, init |
| Import blocks are not supported in this version of the HCP… | exception | error | terraform, import, hcp-terraform-agent, version-check, remote-execution |
| lock id mismatch, != | exception | error | cos, tencent-cloud, state-locking, backend |
| request was canceled | exception | warning | cancellation, context, plugin-download, terraform |
| unsupported hash format (this may require a newer version… | validation | error | hash, lock-file, version-mismatch, forward-compat |
| A managed resource address is required. Importing into a… | validation | error | terraform, cli, import, resource-mode, argument-validation |
| Can't ask approval for state migration when interactive… | console | error | backend-migration, cloud, multi-state, input-disabled, interactive, state, terraform-cli |
| Error unlocking Alibaba Cloud OSS state file: Lock ID | exception | error | alibaba-cloud, tablestore, ots, terraform, state-lock, force-unlock, cleanup |
| the state is already locked by another terraform client | console | error | schema-validation, configschema, nestingmap, computed, minitems, dead-code, provider-schema |
| unrecognized type | validation | error | flatmap, hcl2shim, paths, dynamic-type, go |
| Additionally, unlocking the state file on Google Cloud… | exception | error | gcs, backend, state-locking, recovery, initialization |
| failed to lock inmem state | exception | error | inmem-backend, locking, concurrency, init |
| input is disabled | console | error | input-disabled, interactive, confirm, terraform-cli, ci |
| invalid provider matching pattern | validation | error | provider-config, pattern, wildcard, namespace, validation, multi-source |
| ${protoResp.Error} | exception | error | terraform, provisioner, grpc, plugin-v5, shutdown |
| tag elements must be strings | validation | error | terraform, cloud-backend, tags, validation, config, types |
| attempted to encode a malformed backend state file; data is… | validation | error | backend, state-store, validate, encode, malformed |
| Error loading statefile | exception | error | terraform, show, state, io, filesystem |
| Error parsing URL | validation | error | module-address, url-parsing, subdir |
| expected type of to be int | validation | error | oss, validation, type-check, session-expiration |
| failed to create stacks plugin stored path file | exception | error | terraform, stacks, plugin, filesystem, data-dir, permissions |
| Failed to select a workspace | exception | error | state-store, workspace, provider, init, authentication |
| host for provisioner cannot be empty | validation | error | terraform, connection, ssh, validation, config, provisioner |
| State store provider | exception | error | init, provider, state-store, interactive-prompt, approval |
| The remote state does not match the expected hash | exception | error | consul, backend, state-corruption, integrity, md5 |
| Unknown or unexpected policy state | exception | error | backend, remote-backend, policy, version-skew, unknown-state, go |
| building Storage Accounts client: %+v | exception | error | azure, backend, sdk, configuration, environment, arm |
| cannot search an empty list | validation | error | terraform, hcl, collection-functions, index, empty-collection |
| Error connecting to proxy | exception | error | terraform, ssh, proxy, http-proxy, bastion, connection, provisioner |
| error creating workspace | exception | error | tfe, hcp, cloud-backend, workspace, permissions |
| must be eight hexadecimal digits | validation | error | addrs, deposed-key, validation, terraform |
| refresh Ecs sts token err, json.Unmarshal fail | error_code | error | oss, ecs, metadata-service, json, parsing, authentication |
| does not support the operation. | exception | error | tfe, hcp, cloud-backend, operation, unsupported |
| state file locked, but could not unmarshal lock info | console | error | state, locking, json, parse-error, local-backend |
| unsupported protocol version | panic | critical | terraform, provider-plugin, protocol-version, panic, version-mismatch |
| failed to access object | exception | error | oci, object-storage, encryption, iam, network |
| failed to replace with temporary file | console | error | credentials, filesystem, rename, atomic-write, locking |
| HTTP remote state already locked: ID= | http | error | lock, concurrency, http-backend, lock-error, state |
| invalid syntax: no format version number | exception | error | backend, version-field, schema, init |
| this working directory uses legacy remote state and so must… | exception | error | backend, legacy-migration, version, init |
errPolicyOverrideNeedsUIConfirmation Cannot override soft failed policy checks when -input=false. Please open the… | console | error | terraform, cloud, policy, sentinel, input-mode, ci-cd, override |
| Error creating new client connection via proxy | exception | error | terraform, ssh, proxy, bastion, handshake, authentication, provisioner |
| error loading state | exception | error | tfe, hcp, cloud-backend, state, init |
| Error selecting workspace | exception | error | terraform, workspace, output, cli, state |
| : attribute schema is nil | validation | error | schema, validation, provider-development, nil-pointer, attributes, internal |
| can't use local directory | validation | error | module-address, registry, validation |
| client_certificate_pem is set but client_private_key_pem is… | validation | error | config, tls, mtls, http-backend, validation |
| invalid tfvars content | validation | error | terraform, hcl, decode-tfvars, content-shape |
| lock ID ' ' does not match the existing lock ID | exception | error | locking, s3, remote-state, lock-id, safety-guard, concurrency, unlock |
| Provider installation was canceled by an interrupt signal. | exception | warning | terraform, state-migration, provider, interrupt, context, signal |
| Error: unsupported data source | exception | error | terraform, go, provider, data-source, invariant |
| expected to receive state in | exception | error | terraform, grpc, streaming, state, truncation, data-integrity |
| failed to encode version index | panic | critical | terraform-cli, json-marshal, panic, providers-mirror, invariant |
| Failed to read file | console | warning | fmt, cli, filesystem, permissions, race |
| length of keys and values should be equal | validation | error | terraform, hcl, collection-functions, matchkeys, length-mismatch |
| Unable to access object | exception | error | s3, aws, head-object, sse-c, permissions, kms |
| error loading config with snapshot | exception | error | tfe, hcp, cloud-backend, config, hcl, validation |
| HTTP remote state endpoint requires auth | http | error | auth, http, lock, http-backend, credentials |
| provider mirror does not have archive index for… | http | error | network, mirror, consistency, registry |
| state blob is already locked | exception | error | azure, state-locking, lease, concurrency, force-unlock |
| either a string or an integer is required | validation | error | addrs, instance-key, type-error, terraform |
| error parsing BitBucket URL | validation | error | bitbucket, url-parsing, encoding |
| Error reading as a statefile | exception | error | terraform, show, state, parsing, decode |
| No more than one credentials_helper block may be specified | validation | error | cli-config, credentials-helper, validation, duplicate |
| state locked | console | error | schema-validation, configschema, nestingset, cty, dynamic-type, provider-schema |
| Error retrieving state | exception | error | terraform, remote-backend, tfe, state, permissions, network |
| Failed to refresh module manifest | exception | error | terraform, module, init, registry, network |
| Failed to retrieve workspace | exception | error | backend, remote-backend, workspace, api-error, network, permissions, go |
| lock ID does not match existing lock ( ) | exception | error | locking, dynamodb, remote-state, lock-id, safety-guard, concurrency, unlock |
| unable to retrieve file from S3 bucket | exception | error | locking, s3, remote-state, unlock, getobject, iam, encryption |
| Option -write cannot be used when reading from stdin | validation | warning | fmt, cli, stdin, flags, user-error |
| state store is not valid: provider version data is missing… | validation | error | backend, state-store, provider-version, supply-mode, validate |
| timeout - last error | exception | error | terraform, connection, timeout, retry, ssh, provisioner |
| unable to initialize the location client: %#v | error_code | error | oss, location-service, authentication, sts, network |