kubernetes/kops

Documented errors, page 16 of 33. Back to kubernetes/kops

Code / MessageTypeSeverityTags
cannot apply changes to Disk
exception error gcp, gce, disk, reconciliation
did not find floatingsubnet for LB
exception error openstack, neutron, loadbalancer, subnet, config
error creating output directory
exception error filesystem, terraform, kops, permissions
error creating ResourceRecordSets
error_code error aws, route53, dns, kops, resource-record-set
error deleting route53 record
exception error aws, route53, dns, deletion
error deleting warm pool
exception error aws, autoscaling, warm-pool
Error getting endpoint
http error http, internal-server-error, storage, read
error listing servers
exception error openstack, nova, compute, loadbalancer
error rendering failures table
console error kops, cli, table-rendering, output
failed to find lifecycle hook
exception error aws, autoscaling, lifecycle-hook, iam
failed to get shield instance identity
exception error gce, shielded-vm, tpm, api-error
invalid image source URL
exception error nodeup, images, url, config-validation
listing ELB LoadBalancers
exception error aws, elbv2, api-error, list
parsing AWS STS url
exception error aws, sts, url-parsing, endpoint
unable to find task , referenced from
exception error
applying object to cluster
exception error crd, server-side-apply, kubernetes, rbac
arn doesn't start with "arn
validation error
building vfs path
exception error kops, vfs, path, nodeup
Could not find ' ' tag from route table
exception error aws, ec2, tags, routetable, natgateway
error applying annotation to namespace
exception error kubernetes, patch, rbac, annotations
error listing AutoScaling LaunchTemplates
exception error aws, ec2, launch-template, api-pagination
error writing terraform data to output file
exception error filesystem, terraform, kops, write-failed
failed to delete volume
exception error digitalocean, volume, api-error
found EIP Addresses for 1 NATGateway, expected 1
exception error aws, ec2, nat-gateway, elastic-ip
invalid hash - not hex
exception error hashing, hex, validation
reading Cilium IPSec config
console error file-io, cli, cilium
reading existing keyset
console error keystore, state-store, io
unable to parse sha
exception error go, sha, parsing, asset-copy
cannot parse field path
exception error reflection, path-parsing, validation
duplicate InstanceGroup Name found
exception error kops, instance-group, validation, duplicate
error building (Designate) DNS provider
exception error openstack, dns, designate, provider
error creating instanceGroup
error_code error kops, instancegroup, create, state-store
error initializing hetzner cloud
exception error
error listing InstanceTemplates
exception error gce, api-error, instance-template, list
error parsing network name from cluster spec
exception error
error updating IAMRole
exception error aws, iam, go, policy
expected at most one zone for disk
validation error
failed to create bpf mount unit
exception error nodeup, cilium, bpf, systemd, mount
failed to delete warm pool instance
exception error rolling-update, warm-pool, cloud-api, instance-deletion
failed to load aws config
console error aws, aws-sdk-go-v2, configuration, imds
field not found in
exception error go, reflection, field-not-found
listing role assignments
exception error azure, rbac, role-assignments, pagination
method metal.Cloud::DNS not implemented
exception error
no instance types found in instance groups in cluster
exception error kops, cluster-api, instance-types, instance-groups
providerID not recognized
exception error azure, provider-id, parsing, kops
unable to write secret
exception error vfs, secrets, write-failed, replace
addon source is not configured for
exception error addons, bootstrap-channel, validation
BuildFlags of value type not handled: %T
exception error reflection, flagbuilder, unsupported-type, maps
cannot create request
exception error
cannot load kubecfg settings
exception error
cannot parse flag spec
exception error reflection, struct-tags, flagbuilder, configuration
ConfigLocation is required
validation error nodeup, configuration, missing-argument
could not determine the zone of subnet
exception error subnet, zones, aws, cluster-provisioning
creating file
exception error filesystem, permissions, kops, dump
DNS not implemented on azureCloud
error_code error azure, dns, not-implemented, cloud-provider
Error creating router. Could not list external networks…
exception error openstack, neutron, router, gateway
error describing addresses
exception error aws, ec2, elastic-ip, api-error
error from callback challenge
exception error grpc, rpc, mtls, challenge
error listing Instances
exception error gce, instance, api-error
error writing cluster yaml to stdout
exception error cli, dry-run, yaml-output
failed to convert server ID
exception error hetzner, authentication, token
failed to extract recordsets pages for zone
exception error openstack, designate, dns, recordsets, api-error
keypair/ task not found
exception error keypair, ca, nodeup, tasks
modifying NLB target group health check
exception error aws, elbv2, health-check, target-group
parsing STS request URL
exception error aws, sts, url-parsing, bootstrap
reading file
exception error file-io, state-store, cluster-config
unable to resolve image
exception error aws, ami, image-not-found, launch-template
unsupported output type
console error cli, flags, validation
cannot specify additional objects when multiple clusters…
exception error kops, cli, addons, ambiguity
classic networking not supported
validation error networking, cluster-spec, validation
ConfigStore.Base path is not cluster readable
exception error vfs, storage-permissions, state-store
different sha for same file
exception error assets, files, integrity
error during Disk creation
exception error gcp, gce, disk, cloud-api
error identifying node
exception error kubernetes, node-controller, cloud-provider, aws
error listing Subnets
exception error
error parsing actual RolePolicyDocument for IAMRole
exception error aws, iam, json, drift, policy
error waiting for IP Address
exception error
failed to convert private networks to object
exception error hetzner, yaml, metadata-service, deserialization
failed to get hostname
exception error ssh, hostname
failed to update pool membership
exception error openstack, octavia, pool-member, conflict, retry
getting cluster servers for load-balancer's back-end
exception error scaleway, instances, api-error, load-balancer
listing IPs for server
exception error scaleway, ipam, network, api-error
no cluster found
exception error cli, state-store, cluster-lookup
removing file
exception error azure, blob-storage, deletion, permissions
unable to parse assets as assetBuilder is not defined
exception error go, nil-pointer, assets, validation
unable to write template
exception error cli, filesystem, file-io
Unauthorized
http error http, auth, mtls, client-certificate
could not find any non-overlapping CIDRs in parent…
validation error network, cidr, capacity, kops
determining IP configurations for
exception error azure, network, nic, ip
error closing target
exception error terraform, dryrun, filesystem
error creating loadbalancer
exception error openstack, octavia, loadbalancer, api-error, quota
error getting cloud instance group
exception error
error listing routers
exception error gce, router, listing, cloud-api
error parsing addons
exception error yaml, schema, parsing, addons
error rendering Instance metadata
exception error
error rendering RolePolicyAttachment
exception error terraform, render, kops-update
error setting file mode for
exception error
failed to convert ssh key ID
exception error digitalocean, ssh, type-conversion, data-integrity
failed to parse apiVersion
validation error api-version, manifest, validation, kubernetes
failed to retrieve server ID
exception error hetzner, metadata, authentication