kubernetes/kops
Documented errors, page 24 of 33. Back to kubernetes/kops
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| --region is required (when --external) | console | error | cli, aws, validation, missing-flag |
| unable to parse CIDR for | exception | error | network, cidr, parsing, subnet |
| unhandled field | validation | error | kops, cli-input, argument-parsing |
| unknown mode for Network | validation | error | |
| cannot apply changes to IP Address | exception | error | |
| cannot apply changes to Subnet | exception | error | |
| cannot determine role for instance group | exception | error | instancegroup, role, nodeup |
| could not list server groups | exception | error | openstack, nova, server-groups, api-list |
| error excluding node from load balancer | exception | error | kubernetes, load-balancer, labels, rolling-update |
| error hashing manifest location | exception | info | hashing, defensive, unreachable |
| error listing objects | exception | error | list, dynamic-client, rbac, kubernetes |
| error marshaling object | exception | error | vfs, serialization, marshaling, codec |
| error modifying target group attributes for NLB | exception | error | aws, elbv2, target-group-attributes |
| error powering on instance | exception | error | |
| error replacing instanceGroup | error_code | error | kops, instancegroup, update, conflict |
| expected acl to be S3Acl, was %T | exception | error | vfs, memfs, acl, type-assertion |
| failed to get server | exception | error | scaleway, api, server-lookup |
| failed to list lbs | exception | error | digitalocean, load-balancer, api-error |
| Failed to update member | exception | error | openstack, octavia, loadbalancer, pool-member, update |
| found multiple instance groups matching | exception | error | |
| found SSH key in Akamai (Linode), but public key data did… | exception | error | linode, akamai, sshkey, drift, mismatch |
| insufficient (big) CIDRs remaining for automatic CIDR… | validation | error | network, cidr, capacity, kops |
| karpenter requires --discovery-store | validation | error | karpenter, discovery-store, prerequisite |
| key name not enabled | exception | error | certificates, configuration, bootstrap, allowlist |
| no ipv6 address found on interface | exception | error | |
| no subnets found in cluster | exception | error | kops, cluster-api, subnets, cluster-spec |
| PublicKey not set, and cannot be determined from %T | exception | error | |
| cannot apply changes to Instance | exception | error | |
| Didn't find k8s-instancegroup for tag | error_code | error | |
| error creating IAMInstanceProfileRole | exception | error | aws, iam, kops, instance-profile |
| error listing Akamai (Linode) VPC subnets for VPC | exception | error | linode, akamai, vpc, subnet, api-error |
| error querying for route53 zones | exception | error | aws, route53, dns, listing |
| error reading state store | exception | error | go, vfs, storage, state-store |
| found VMSS without network interface config properties | exception | error | azure, vmss, network-interface |
| invalid subnet CIDR | validation | error | network, cidr, validation, kops |
| must specify label with cluster name to create SSHCredential | exception | error | kops, cli, ssh, missing-label |
| parsing key | exception | error | |
| providerID not set for node | exception | error | azure, node, providerid, configuration |
| server-side client does not support ListKeysets | exception | error | keystore, read-only, unsupported-operation, kops-controller |
| unexpected subnet type: for InstanceGroup | validation | error | azure, subnet, vmss, configuration |
| updating front-end for load-balancer | exception | error | scaleway, load-balancer, api-error, frontend |
| building compute API client | exception | error | |
| cannot add secondary item when no existing primary item | validation | error | go, ca, keyset, ordering |
| cannot apply changes to Network | exception | error | |
| clusterName is required | validation | error | go, vfs, validation |
| couldn't determine hostname | exception | error | |
| creating load-balancer | exception | error | |
| error building bootstrap script for | exception | error | |
| error building lb client | exception | error | openstack, octavia, gophercloud, loadbalancer |
| error creating record | exception | error | |
| error describing oidc provider | exception | error | aws, iam, oidc, kops |
| error listing namespaces | exception | error | |
| error querying for route53 records for zone | exception | error | |
| error querying for valid AZs in | exception | error | aws, ec2, credentials, availability-zones |
| error reading droplet metadata | error_code | error | |
| fetching instance metadata | exception | error | |
| found VMSS without OS profile | exception | error | azure, vmss, os-profile |
| invalid Azure Blob scheme | validation | error | azure, azureblob, url-scheme, vfs |
| missing required --azure-resource-group-name when… | validation | error | |
| parsing providerID | exception | error | |
| unexpected format for server id | exception | error | scaleway, node-identity, id-format |
| unknown secret type | validation | error | cli, kops, invalid-flag-value, validation |
| unknown subnet type | validation | error | aws, spotinst, subnets, cluster-config |
| error finding associated RouteTable to NatGateway | exception | error | aws, ec2, routetable, api-error |
| error listing objects in namespace | exception | error | list, namespace, dynamic-client, kubernetes |
| error parsing etcd cluster label | error_code | error | |
| error reading created Disk | exception | error | gcp, gce, disk, api-read |
| error reading file | exception | error | filesystem, cli, io |
| error untagging IAMOIDCProvider | exception | error | aws, iam, oidc, tagging, kops |
| insufficient (little) CIDRs remaining for automatic CIDR… | validation | error | network, cidr, capacity, kops |
| invalid instance type | exception | error | |
| loadbalancer failed to go into ACTIVE provisioning status… | exception | error | |
| node name is required | validation | error | |
| reading user-data for instance group | exception | error | hetzner, user-data, io |
| subnet not set | exception | error | aws, routetableassociation, validation, bug |
| VMScaleSet is missing ID or Name | exception | error | |
| CAPI Machine is missing cluster.x-k8s.io/deployment-name… | exception | error | go, capi, kubernetes, labels, bootstrap |
| could not get spec.version from ClusterPackage | validation | error | |
| error applying update after prune | exception | error | |
| error building cloud tags | exception | error | aws, tags, instance-group, launch-template |
| error creating server | exception | error | |
| error downloading content from | exception | error | vfs, cloud-storage, network |
| error generating Akamai (Linode) instance label for group | exception | error | linode, random, entropy |
| error resolving channel | exception | error | |
| error Zone is not a recognized AZ | exception | error | aws, ec2, availability-zones, validation |
| no sources specified | exception | error | nodeup, loadimage, containerd |
| spotinst: failed to create elastigroup | exception | error | spotinst, aws, api, create |
| ssm image parameter is required | validation | error | karpenter, aws, ssm, validation |
| error encoding RSA private key | exception | warning | pki, rsa, pem-encoding |
| error listing all versions of file | exception | error | aws, s3, versioning, iam, pagination |
| error loading config file | exception | error | openstack, ini, config, file |
| error parsing cloudformation policy document from JSON | exception | error | iam, json, policy-document |
| EtcdMembers found with same name | validation | error | etcd, cluster-spec, duplicate |
| failed to connect to SSH agent with SSH_AUTH_SOCK | exception | error | ssh, ssh-agent, unix-socket |
| failed to create pool association | exception | error | openstack, octavia, create-member, pool-association |
| failed to extract members | exception | error | openstack, octavia, json, unmarshal |
| found more than one port for instance | exception | error | |
| invalid Hetzner object storage path | validation | error | vfs, hetzner, url-scheme |
| invalid remote address | exception | error | |
| listening on | exception | error |