prestodb/presto
Documented errors, page 9 of 13. Back to prestodb/presto
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Iceberg column type is not supported | exception | error | |
| Illegal char '%c' in label | validation | error | lark-sheets, parsing, input-validation |
| Invalid property tpch.splits-per-node | validation | error | configuration, tpch, connector |
MEMORY_LIMIT_EXCEEDED Memory limit [ ] for memory connector exceeded | error_code | error | presto, memory-connector, memory-limit, resource-exhaustion |
PINOT_UNABLE_TO_FIND_BROKER Cannot parse in the broker instance | error_code | error | pinot, broker-discovery, format-mismatch, version-compatibility |
| Subfield column [ | exception | error | |
| The chunkLength ( ) must not be negative or greater than… | error_code | error | orc, corruption, compression, chunk-header |
THRIFT_SERVICE_INVALID_RESPONSE Requested and actual table names are different | error_code | error | thrift-connector, invalid-response, metadata, protocol |
| Timestamp exceeds maximum supported value, value | exception | error | orc, timestamp, overflow, presto |
| Unable to query ranger service | exception | critical | ranger, hive, startup, network, configuration |
| Error reading response from server | exception | error | network, http, okhttp, read-failure, spark |
| expecting SpecialFormExpression(DEREFERENCE), but got: | exception | error | |
| Node ttl fetcher factory | exception | error | duplicate-registration, ttl, plugin, presto |
| path is empty | exception | error | presto, subfield, illegal-state, empty-path |
| Property for should have value of type , not | error_code | error | presto, properties, type-mismatch, metadata |
| TIMESTAMP precision must be in range | validation | error | presto, type-system, illegal-argument, timestamp-precision |
| createStruct | exception | error | jdbc, presto, unsupported-operation, struct |
DIVISION_BY_ZERO interval_day_to_second division by zero | error_code | error | presto, interval-day-to-second, division-by-zero |
INVALID_PRIVILEGE Unknown privilege | error_code | error | sql, permissions, invalid-privilege, semantic-error |
| Invalid URI: | exception | error | serialization, uri, storage-handle, presto |
REST_SERVER_NOT_FOUND Resource not found on REST server. Request: | error_code | error | |
| Table does not have column | validation | error | metadata, tpch, column-not-found |
| Connection property ' ' is both in the URL and an argument | validation | error | |
| Error decoding values in encoding: | exception | error | |
| "Expected entry size to be exactly " + INT128_BYTES + "… | exception | error | presto, block-builder, int128, incomplete-entry |
HIVE_TABLE_BUCKETING_IS_IGNORED Table bucketing is ignored. The virtual "$bucket" column cannot be referenced. | error_code | error | hive, bucketing, virtual-column |
| id is empty | validation | error | presto, spi, memory, illegal-argument, validation |
INVALID_LIMIT_CLAUSE Invalid limit | error_code | error | presto, planner, sql-syntax, limit |
| Job has been interrupted | error_code | error | |
| Map key is null at position: " + position | validation | error | presto, block, map-block, null-key, illegal-state |
SHEETS_TABLE_LOAD_ERROR Error loading data for table: | error_code | error | google-sheets, connector, api, network |
| Stream size of one of the streams for column is larger than… | exception | error | |
| Unsupported EXPLAIN type: | exception | error | sql-parser, explain, illegal-argument |
| Constraint not found | exception | error | hive, metastore, constraint, ddl |
INVALID_WINDOW_FRAME Window frame start cannot be UNBOUNDED FOLLOWING | error_code | error | |
| isLast | exception | error | jdbc, presto, unsupported-operation, cursor-position |
| min-file-size-bytes must be a valid long, got | validation | error | iceberg, validation, number-format, argument-parsing |
PINOT_QUERY_GENERATOR_FAILURE Limit not supported: Limit is not being pushed down | error_code | error | pinot, pushdown, limit, argument-validation |
PINOT_REQUEST_GENERATOR_FAILURE Unable to Jsonify request | error_code | error | pinot, json-serialization, jackson, request-building |
READ_ONLY_VIOLATION Cannot execute write in a read-only transaction | error_code | error | transaction, read-only, presto |
| Schema is not setup: | validation | error | thrift, testing, configuration, tpch |
| Timed out waiting for query preprocessor after | exception | error | cli, timeout, query-preprocessing, subprocess |
| Column does not have same position count | exception | error | presto, page, position-count-mismatch, illegal-argument |
| Error creating an instance of | exception | error | s3, credentials, reflection, configuration |
| Hive Connector does not support GRANTED BY statement | exception | error | hive, access-control, authorization, sql |
| Invalid PBKDF2 password | validation | error | |
| afterLast | exception | error | jdbc, unsupported-operation, forward-only-resultset |
| Cannot grant privilege | exception | error | security, authorization, grants, privileges |
| Codec not supported in Parquet: | exception | error | parquet, codec, compression, not-supported |
HIVE_RANGER_SERVER_ERROR Unable to fetch policy information from ranger | error_code | critical | ranger, hive, authorization, network, presto-exception |
| Inserting into an unpartitioned table that were added… | exception | error | hive, transaction, insert, unsupported-operation |
| Only one of 'case-insensitive-name-matching=true' or… | validation | error | configuration, jdbc, catalog, mutually-exclusive |
| pattern may be specified only if location is a directory | validation | error | configuration, validation, localfile |
| unsupported column type | validation | error | statistics, type-mapping, tpcds |
| Directory is not empty | exception | error | s3, filesystem, delete, directory |
| Function call spec is not in a valid format. | validation | error | sql-parser, parsing, validation, verifier |
HIVE_PATH_ALREADY_EXISTS Unable to create directory | error_code | error | |
INVALID_ORDINAL GROUP BY position is not in select list | error_code | error | sql, presto, group-by, ordinal |
| isBeforeFirst | exception | error | jdbc, presto, unsupported-operation, cursor-position |
PINOT_UNAUTHENTICATED_EXCEPTION Query authentication failed. | error_code | error | pinot, authentication, access-denied, token |
| Cannot call procedure | exception | error | security, procedures, access-control, authorization |
| Encrypted data size exceeds limit of 2^23 | exception | error | orc, dwrf, encryption, buffer-limit |
| escape not implemented | validation | error | rcfile, text-encoding, escape, writer |
ICEBERG_INCOMPATIBLE_COLUMN_TYPE Failed to set column type: | error_code | error | iceberg, schema-evolution, column-type, incompatible-type |
| Invalid header | exception | error | http-header, url-encoding, prepared-statement |
| Missing row group column statistics for stripe at offset | exception | error | |
| offset must be 0 or 8 | exception | error | presto, block, illegal-argument, int128 |
PROMETHEUS_OUTPUT_ERROR Unable to handle Prometheus result: | error_code | error | |
STANDALONE_LAMBDA Lambda expression should always be used inside a function | error_code | error | |
| : failureInfo.toException() (decoded failure rethrown with… | error_code | error | sql, presto, error-propagation, error-code |
| Value exceeds MAX_INT | exception | error | presto, integer, overflow, block-builder |
| Values in column " " are too large to process for Presto… | exception | error | |
BIGQUERY_UNSUPPORTED_TYPE_FOR_BLOCK Unhandled type for Block: | error_code | error | bigquery, nested-types, block |
| Cannot grant roles to | exception | error | security, roles, access-control, authorization |
| getNCharacterStream | exception | error | jdbc, unsupported-feature, presto |
| Invalid day-time interval: | exception | error | parsing, presto-client, illegal-argument, interval |
| Invalid postscript length | exception | error | orc, corrupt-file, postscript |
| Not a Hive table: | exception | error | hive, iceberg, delta-lake, table-format, wrong-connector |
| Session property configuration manager | validation | error | presto, session-properties, plugin-registration, illegal-argument |
| SparkConf is already initialized | exception | error | java, spark, configuration, initialization |
| stream type not implemented yet | exception | error | |
| Unexpected varchar value in numeric enum signature | validation | error | presto, type-signature, enum, parsing |
| Value exceeds MAX_SHORT | exception | error | range-check, overflow, smallint |
| Value is not null but data stream is missing | exception | error | orc, corruption, direct-encoding, missing-stream |
| Cannot create view | exception | error | security, authorization, access-denied, views |
| invalid evaluation state | exception | error | orc, illegal-state, internal-bug, filter |
| Invalid ORC metadata | exception | error | orc, dwrf, stripe-cache, corrupt-file |
| No alter routine characteristics specified | exception | error | sql-parser, alter-function, empty-input |
| No host specified: | validation | error | |
| Table not found: . | exception | error | hive, metastore, table-not-found, statistics |
| Cannot select from columns | exception | error | security, authorization, column-level-security, select |
| Expected at most one parameter for CHAR | validation | error | presto, type-system, char, ddl |
| getRef | exception | error | jdbc, presto, unsupported-feature, sql-ref, sqlfeaturenotsupported |
MATERIALIZED_VIEW_ALREADY_EXISTS Destination materialized view | error_code | error | presto, materialized-view, already-exists, ddl |
| Parameter 'limit' for getAllQueryInfo must be positive. Got | http | error | |
| PBKDF2 password input is malformed | validation | error | |
| Reading RLE byte got EOF | exception | error | orc, corruption, rle, eof, truncated-file |
| SQL is not an update statement: | exception | error | |
| Cannot alter function in hive function namespace | exception | error | functions, sql-udf, hive, not-supported |
| Cannot create function in hive function namespace | exception | error | functions, sql-udf, hive, not-supported |