redis/redis-py
Documented errors, page 2 of 4. Back to redis/redis-py
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Cannot extend a lock that's no longer owned | exception | error | lock, distributed-lock, ownership-lost, ttl-expiry |
| Cannot use FIELDNAME alias with no field | validation | error | search, aggregation, reducer, valueerror, redisearch |
| Maintenance notifications are not supported for connection… | exception | error | maintenance-notifications, connection-class, config, validation, async, pool, subclassing |
| Prefix can only be used with bcast | exception | error | client-side-caching, validation, dataerror, tracking |
| Requested token is expired | exception | error | auth, token-renewal, clock-skew, sync |
| Timeout reading from socket | exception | error | timeout, network, sync, hiredis, blocking-commands |
| Wrong command or module name | validation | error | cluster, policies, internal, valueerror, routing |
| Too many connections | exception | error | connection-pool, resource-limits, configuration |
| Maintenance notifications are not supported for connections… | exception | error | maintenance-notifications, host, config, validation, async, pool |
| failed to fetch issuer certificate | exception | error | ocsp, ssl, tls, security, network, issuer-certificate, http, certificate, connection |
| no matching issuer cert found in certificate chain | exception | error | ocsp, ssl, tls, security, certificate-chain, certificate, connection |
| Timeout reading from | exception | error | network, timeout, read, socket-timeout, async, blocking-command, host-error |
| Cache must implement CacheInterface | exception | error | client-side-caching, validation, configuration |
| Invalid SSL Certificate Requirements Flag | exception | error | ssl, configuration, validation |
| No way to dispatch this command to Redis Cluster. Missing… | exception | error | cluster-routing, keyless-command, target-nodes |
| Too many targets for command | exception | error | cluster, pipeline, routing, cross-slot |
| CLIENT LIST _type must be one of | exception | error | client-management, validation, dataerror, redis-version-compat |
| 'username' and 'password' cannot be passed along with… | validation | error | authentication, configuration, credential-provider, validation |
| XRANGE count must be a positive integer | validation | error | streams, xrange, argument-validation, dataerror |
| Cannot release a lock that's not owned or is already… | exception | error | lock, distributed-lock, lifecycle, double-release |
| Unsupported client type | validation | error | multidb, health-check, typeerror, config, validation |
| "max_connections" must be a positive integer | exception | error | configuration, connection-pool, validation |
| MEMORY DOCTOR is intentionally not implemented in the… | exception | error | memory, notimplemented, intentional |
| Cannot extend an unlocked lock | exception | error | lock, distributed-lock, precondition, thread-local |
| Initial health check failed. Initial health check policy | exception | critical | multidb, health-check, initialization, config, circuit-breaker |
| no certificates found for the responder | exception | error | ocsp, ssl, tls, security, responder, delegation, certificate, connection |
| All keys involved in a cluster transaction must map to the… | exception | error | cluster, pipeline, transaction, multi, cross-slot |
| Health check event loop failed to start within | exception | error | background, event-loop, threading, resource-limits |
| CLIENT KILL type must be one of | exception | error | client, validation, client-kill, input-validation, enum |
| Either an OCSP staple or pure OCSP connection must be… | exception | error | ssl, ocsp, configuration |
| LATENCY DOCTOR is intentionally not implemented in the… | exception | error | latency, notimplemented, intentional |
| Database health check url is not set. Please check… | validation | error | multidb, health-check, redis-enterprise, configuration |
| Wrong number of response items from pipeline execution | exception | error | pipeline, transaction, protocol, response, corruption |
| Invalid args in command | exception | error | eval, lua-scripting, cluster, arguments |
| startup_nodes could not agree on a valid slots cache | exception | critical | topology, split-brain, slot-conflict, cluster-health |
| Client caching is only supported with RESP version 3 | exception | error | configuration, client-side-caching, resp3, protocol |
| px must be datetime.timedelta or int | exception | error | set, expiry, data-error, validation |
| Python wasn't built with SSL support | exception | critical | ssl, environment, configuration, dependency |
| cryptography is not installed. | exception | error | ssl, ocsp, dependency, configuration |
| driver_info must be a DriverInfo instance or None | exception | error | driver-info, type-check, validation, client-config |
| Timed out closing connection after | exception | warning | network, timeout, disconnect, async, shutdown, socket-connect-timeout |
| Unhealthy database | exception | warning | multidb, health-check, circuit-breaker, network, async |
| COMMAND INFO is intentionally not implemented in the client. | exception | error | command-introspection, notimplemented, intentional |
| SLAVEOF is not supported in cluster mode | exception | error | cluster, replication, api-misuse, unsupported-command |
| The 'retry' argument cannot be used in kwargs when running… | exception | error | cluster, config, retry, api-misuse |
| AGGREGATION requires exactly one aggregation spec per key | validation | error | redistimeseries, nrange, aggregation, argument-validation |
| method watch() is not supported outside of transactional… | exception | error | cluster, pipeline, transaction, optimistic-locking, api-misuse |
| SHUTDOWN save and nosave cannot both be set | validation | error | admin, validation, dataerror, shutdown |
| Timeout writing to socket | exception | error | timeout, network, write, performance |
| Error while writing to socket. . | exception | error | network, oserror, write, broken-pipe, connection-reset, async, retry |
| Error setting client name | exception | error | client-name, configuration, connection, validation |
| FAILOVER is intentionally not implemented in the client. | exception | error | replication, notimplemented, intentional, failover |
| Error while reading from | exception | error | network, read, connection-reset, oserror |
| ``nx``, ``xx``, ``ifeq``, ``ifne``, ``ifdeq``, ``ifdne``… | validation | error | set, conditional-flags, mutual-exclusivity, validation |
| Maintenance notifications are only supported with hiredis… | exception | error | async, connection, resp3, maintenance-notifications, parser |
| Watched variable changed. | exception | warning | cluster, pipeline, transaction, watch, optimistic-locking |
| method multi() is not supported outside of transactional… | exception | error | cluster, pipeline, transaction, api-misuse |
| Unable to acquire lock within the time specified | exception | error | lock, timeout, distributed-lock, async |
| genpass optionally accepts a bits argument, between 0 and… | exception | error | acl, validation, acl-genpass, input-validation, range-check |
| Invalid ssl verify flag | exception | error | ssl, configuration, url-parsing, validation |
| Realtime vector indexing supporting 3 Indexing… | validation | error | search, vectorfield, dataerror, redisearch, vss, typo-in-message |
| CLIENT KILL ... ... must specify at least one filter | exception | error | client-management, validation, dataerror |
| Buffer is closed. | exception | error | async, hiredis, lifecycle, oserror, buffer-closed |
| HIMPORT fieldset must have at least one field | validation | error | himport, validation, data-error, fields |
| nx and xx are mutually exclusive: use one, the other or… | validation | error | json, jsonset, argument-validation, mutually-exclusive, exception |
| HOTKEYS commands are not supported in cluster mode. Please… | exception | error | redis-cluster, not-implemented, hotkeys, intentional-stub |
| Cannot set active database, database is unhealthy | exception | warning | multidb, active-active, circuit-breaker, health-check, failover |
| Cannot set 'nopass' and supply 'passwords' or… | exception | error | acl, validation, acl-setuser, input-validation, mutually-exclusive |
| Cluster client has no nodes - cannot create health check… | validation | error | multidb, health-check, cluster, config, validation |
| Hiredis is not available. | exception | error | hiredis, dependency, config, async, init |
| Password must be prefixed with a "+" to add or a "-" to… | exception | error | acl, validation, acl-setuser, passwords, input-validation, prefix |
| Command " " must be prefixed with "+" or | exception | error | acl, validation, acl-setuser, commands, input-validation, prefix |
| Commands without an initial WATCH have already been issued | exception | error | pipeline, transaction, api-misuse |
| socket.getaddrinfo returned an empty list | exception | critical | dns, network, connection, configuration |
| Driver name must not be None | exception | error | driver-info, validation, null-check, upstream-driver |
| Error while reading from | exception | error | network, read, connection-reset, pubsub |
| Cannot reacquire a lock that's no longer owned | exception | error | lock, distributed-lock, ownership-lost, ttl-expiry |
| {e} | exception | error | auth, token-renewal, callback, sync |
| health_check_probes must be greater than 0 | validation | error | multidb, health-check, validation, config |
| Cannot reacquire an unlocked lock | exception | error | lock, distributed-lock, precondition, thread-local |
| prefix must be provided | validation | error | redisearch, index-definition, argument-validation |
| Subcommand not found in command | exception | error | cluster, commands, policies, internal |
| Provide either json_body or data, not both. | validation | error | http, validation, request-body, mutual-exclusion |
| XAUTOCLAIM min_idle_time must be a nonnegative integer | validation | error | stream, xautoclaim, validation |
| if XPENDING is provided with idle time or consumername, it… | validation | error | stream, xpending, validation, argument-combination |
| ocsp certificate was issued in the future | exception | warning | ocsp, ssl, tls, security, clock-skew, ntp, certificate, connection |
| Redis URL must specify one of the following schemes… | exception | error | url, config, validation, scheme, async |
| CLIENT REPLY must be one of | exception | error | client-management, validation, dataerror, case-sensitivity |
| LATENCY GRAPH is intentionally not implemented in the… | exception | error | latency, notimplemented, intentional |
| RedisCluster requires at least one node to discover the… | exception | error | cluster, configuration, init, discovery |
| Cannot extend a lock with no timeout | exception | error | lock, distributed-lock, ttl, precondition |
| RedisCluster requires at least one node to discover the… | exception | error | cluster, config, api-misuse, startup |
| Invalid input of type: 'bool'. Convert to a bytes, string… | exception | error | encoding, data-types, user-error, serializer |
| Cannot issue a WATCH after a MULTI | exception | error | cluster, pipeline, transaction, optimistic-locking, api-misuse |
| idletimemust be an integer | validation | error | restore, arguments, validation, dataerror, typo |
| To configure maintenance notifications, a parser must be… | exception | error | async, connection, maintenance-notifications, internal |
| deleting multiple keys is not implemented in pipeline… | exception | error | cluster, pipeline, cross-slot, delete |
| Invalid Database | exception | error | database-index, configuration, connection, validation |
| Invalid input of type | exception | error | encoding, data-types, user-error, serializer |
| For "stable" state please use cluster_setslot_stable | exception | error | cluster, slot-management, api-misuse, validation |