temporalio/temporal
Documented errors, page 2 of 4. Back to temporalio/temporal
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| failed to load decoded CA Cert as PEM | validation | error | cassandra, tls, x509, pem |
| unable to load decoded CA Cert as PEM | validation | error | tls, pem, certificates, edge-case |
| unknown workflow state sync result | exception | error | go, history-service, internal-invariant, enum |
| reader with ID already exists | panic | error | go, history-service, task-queue, duplicate-id, panic |
| upload stream unknown status | panic | error | go, replication, streaming, unhandled-enum-case |
| invalid filter name | validation | error | go, archiver, s3, query-parsing, sqlparser |
| lcaItem is nil | panic | error | persistence, panic, version-history, nil-pointer |
| schedule spec next-time search exceeded the compute… | exception | error | go, scheduler, compute-limit, iteration |
| unable to resolve AWS region for obtaining AWS Elastic… | exception | error | go, aws, elasticsearch, configuration, missing-env-var, visibility-store |
| Unknown cluster name | panic | error | go, panic, cluster-metadata, invariant |
| Unknown repication task type | panic | critical | go, replication, dlq, version-skew, unhandled-type |
| : state transition count < ref transition count: < | exception | error | go, replication, transition-count, versioning |
| could not decode next time cache as proto or json | panic | critical | panic, workflow-replay, payload-decoding, scheduler |
| ExecutableTaskTracker encountered unknown task state | panic | error | go, replication, task-state, unhandled-enum-case |
| failed to parse visibility filename | validation | error | go, archiver, filestore, visibility |
| Found key with non-zero pending task count but has no… | panic | error | go, panic, invariant-violation, history-service |
| version history not initialized | panic | error | persistence, panic, version-history, empty-state |
| %w: %v | exception | error | go, search-attributes, parse, invalid-type |
| second value out of range | validation | warning | nexus, timestamp, validation, http-header |
| unknown workflow close status | validation | error | go, archiver, visibility, query-parser |
| error loading nexus endpoints cache | exception | error | go, nexus, matching-service, persistence, cache |
| unknown workflow update abort reason | panic | critical | go, panic, workflow-updates, invariant-violation |
| Cache encountered dirty mutable state transaction | panic | critical | workflow-cache, mutable-state, panic, invariant-violation, concurrency |
| bucket not found | validation | error | network, membership, http, address-parsing |
| %v, %w | exception | info | errors, error-aggregation, tls |
ErrStaleState %w: %w | error_code | warning | go, chasm, hsm, replication, stale-state |
| serializer error | exception | error | nexus, serialization, payload |
| invalid filter | validation | error | go, query-validation, matching-service, list-filter, task-queue |
| missing RespondWorkflowTaskCompletedRequest return | console | error | testing, taskpoller, nil-argument |
| CronString does not have interval after @every | validation | error | go, scheduler, validation, cron |
| Found overlapping incoming slices, left slice range | panic | error | go, history-service, task-queue, slice-ordering, panic |
| unable to get namespace details | exception | error | go, namespace, persistence, lookup-failed |
| ClusterMetadata encountered local namesapce with failover… | panic | error | go, panic, namespace, failover-version |
| ${failure.Message} | exception | error | go, worker-deployment, versioning, error-translation |
| GetWorkflowExecutionHistory failed | error_code | error | batch, history, rpc, go |
| component has Field[*Visibility] but no businessID alias… | validation | error | chasm, registry, visibility, missing-option |
| unable to create AWS HTTP client for Elasticsearch | console | critical | elasticsearch, aws, config, startup, go |
| value is not a string value | validation | error | go, sql-query, visibility, query-syntax |
| version history cannot be null | panic | error | persistence, panic, version-history, nil |
| : cannot deserialize into | validation | error | nexus, serialization, type-mismatch, temporal-payload |
| error initializing cluster metadata manager | console | error | persistence, cluster-metadata, startup, database |
| unknown timer task | panic | error | timer-task, panic, type-switch, history-service, version-skew |
| unable to find archiver config for the given scheme | validation | error | archival, provider, configuration, missing-config |
| component type must be and interface or struct that… | exception | error | chasm, registry, type-mismatch, task-registration |
| current cluster is missing from cluster metadata | exception | error | go, multi-cluster, cluster-metadata, configuration |
| requested bucket does not exist | validation | error | archival, s3, aws, bucket |
| where expression is nil | validation | error | archival, gcloud, query-parsing, visibility |
| failed to process config file | validation | error | config, template, yaml |
| HistoryEventIterator Next() called without checking… | panic | error | go, panic, iterator, pagination, api-misuse |
ErrInvalidOperationToken : length exceeds allowed limit ( / ) | exception | error | nexus, nexusoperation, token, validation |
| unable to upsert workflow execution | exception | error | mysql, visibility, upsert, schema |
| : zombie workflow cannot be updated | error_code | error | go, history-service, chasm, stale-reference |
| Can't deep copy value of type | panic | error | go, panic, reflection, dynamicconfig, deep-copy |
| membershipExpiry duration should be atleast 1 second | validation | error | persistence, cluster-membership, validation |
| unable to encode single payload | panic | error | go, payloads, encoding, panic |
| rows were affected instead of 1 | exception | error | go, persistence, sql, task-queue |
| root task queue partition has no parent | console | warning | tqid, task-queue, partitioning, sentinel-error |
| unable to create Elasticsearch client | console | error | elasticsearch, startup, config, persistence |
| Empty cluster information | panic | critical | cluster, config, panic, startup, replication |
| field NamespaceId is empty | validation | error | go, archival, request-validation |
| Queue slice encountered task doesn't belong to either… | panic | error | go, history-service, task-queue, split-invariant |
| internal error, reference-id | exception | error | nexus, callback, internal-error, logging |
| not supported batch type | validation | error | go, batch, validation, unsupported-operation |
| unknown admin batch type: %T | exception | error | go, batch, type-switch, unsupported-operation |
| : %T (expected string) | exception | error | mysql, search-attributes, data-corruption, type-mismatch, keyword-list |
| ConvertGradualChange can only be used with scalar types for… | panic | error | go, panic, generics, dynamicconfig |
| unknown filter name | validation | error | go, archiver, gcloud, query-parsing, visibility |
| WorkflowId or WorkflowType is required in query | validation | error | go, archival, query-validation, s3store |
| BatchSize too large | validation | error | dlq, validation, go, batch-size |
| client auth required, but no certificate provided | exception | error | tls, mtls, client-certificate, authentication |
ErrDuplicateRegistration : command handler for | exception | error | chasm, workflow, registry, registration |
| registrable component validation error: search attribute… | panic | error | chasm, search-attributes, registration, duplicate, panic |
| invalid subsecond value | validation | warning | nexus, timestamp, validation, http-header |
| no nexus context set on context | console | error | nexus, context, handler, temporal-server |
| only operation = is support for | validation | error | go, archiver, s3store, query-parser, visibility |
| unknown archetypeID | exception | error | go, temporal, chasm, registry, version-skew |
| unknown number type | panic | error | go, panic, type-switch, invariant |
| Unknown task category type | panic | error | go, persistence, tasks, enum, panic |
ErrCancellationAlreadyRequested with request ID | exception | warning | nexus, nexusoperation, cancellation, idempotency |
| invalid config type: %T for… | validation | error | dynamicconfig, nexus, configuration, template |
| membership upserts require all fields | validation | error | persistence, cluster-membership, validation |
| not implemented | panic | error | go, panic, metrics, unimplemented |
ErrUnableToExecuteActivity : AddESMappingFieldActivity | error_code | error | go, elasticsearch, search-attributes, activity-failure, system-workflow |
| invalid service in service list | validation | error | config, validation, startup, services |
| task queue user data replication failed | exception | error | go, temporal, workflow, replication, task-queue |
| conflicting timezone names | validation | error | scheduler, timezone, validation, go |
| Key encountered positive overflow | panic | error | task-key, panic, integer-overflow, history-service |
| Task key Sub encountered underflow: self | panic | error | task-key, panic, integer-overflow, history-service |
| unable to decode cassandra serial consistency | panic | critical | go, panic, config, cassandra, persistence |
| invalid value | validation | error | go, archiver, s3, query-parsing, sqlparser |
| worker deployment version deleted | exception | warning | worker-deployments, query, deleted-version, temporal |
| Cannot use Put API in Pin mode. Use Delete and… | panic | error | cache, lru, pin-mode, panic, misuse-guard |
| invalid task schema version | panic | critical | go, cassandra, persistence, schema-version, panic |
| only one of keyData or keyFile properties should be… | validation | error | cassandra, tls, configuration |
| URI is invalid | validation | error | tls, config-validation, mutually-exclusive-fields |
| HistoryEventIterator Next() should return either a history… | panic | error | go, panic, iterator, pagination, concurrency |
| Key encountered negative underflow | panic | error | task-key, panic, integer-overflow, history-service |
| panic(err) | panic | error | testing, test-data, panic, initialization |
| can't decode TweakablePolicies: | panic | critical | panic, workflow-replay, side-effect, decoding |
| UpdateTaskQueue encountered ExpiryTime not set for sticky… | panic | error | persistence, panic, task-queue, sticky, expiry |