ErrLookup › TechnitiumSoftware/DnsServer
TechnitiumSoftware/DnsServer
Technitium DNS Server · C# · 206 source files
Analyzed at d0484b6c1e on 2026-08-13. 410 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| The Query Access option is invalid for | validation | error | dns, forwarder-zone, query-access, argumentexception, acl |
| The DNS web service is already running. | http | error | dns-server, technitium, lifecycle, double-start, csharp |
| Cannot add DNSSEC record. | exception | error | dns, primary-zone, subdomain, dnssec, invalidoperationexception |
| Old and new record types do not match. | exception | error | dns, forwarder-zone, record-update, invalidoperationexception |
| Cannot set SOA record on sub domain. | exception | error | dns, primary-zone, subdomain, soa-record, invalidoperationexception |
| Cannot update record: use SetRecords() for | exception | error | dns, forwarder-zone, soa-record, invalidoperationexception |
| Cannot set records: disabling records in a signed zones is… | exception | error | dns, primary-zone, subdomain, dnssec, disabled-record, dnsserverexception |
| DNS Server config version not supported. | exception | error | dns-server, technitium, config, migration, version-mismatch, csharp |
| The Notify option is invalid for | validation | error | dns, forwarder-zone, notify, argumentexception |
| Cannot set DNSSEC records. | exception | error | dns, primary-zone, subdomain, dnssec, invalidoperationexception |
| Cannot update record: the record does not exists to be… | exception | error | dns, forwarder-zone, record-update, concurrency, dnsserverexception |
| Failed to generate unique label for the given domain name | exception | warning | dns, catalog-zone, rfc-9432, random, collision, retry |
| The Dynamic Updates option is invalid for | validation | error | dns, forwarder-zone, dynamic-update, argumentexception, acl |
| The record type is not supported by DNSSEC signed primary… | exception | error | dns, primary-zone, subdomain, dnssec, aname, dnsserverexception |
| Cluster node URL length must be less than 255 bytes. | validation | error | cluster, validation, constructor, serialization, url-length |
| Failed to initialize Cluster: a SSO user cannot initialize… | exception | error | cluster, auth, sso, initialization, permissions, technitium-dns-server |
| Current SOA serial does not match with the IXFR difference… | exception | error | dns, ixfr, zone-transfer, soa, secondary-zone |
| Failed to sign record set | exception | error | dnssec, rrsig, signing, rrset, validation |
| No API token was found for the Cluster domain. | exception | error | cluster, auth, api-token, configuration, invalid-operation |
| Cannot add record: record already exists for the same name. | exception | error | dns, cname, dname, exclusive-record, auth-zone |
| Cannot set records. Please try again. | exception | error | dns, primary-zone, subdomain, concurrency, retry, dnsserverexception |
| Cannot update record: TTL cannot be greater than SOA EXPIRE. | exception | error | dns, forwarder-zone, ttl, soa-expire, dnsserverexception |
| Failed to promote to Primary node: the Cluster Primary zone… | exception | critical | cluster, dns-zone, promote, inconsistent-state, conversion, technitium |
| The Zone Transfer option is invalid for | validation | error | dns, forwarder-zone, zone-transfer, argumentexception, acl |
| DNS Server auth config file format is invalid. | exception | critical | config, startup, binary-format, auth |
| Zone was not found for domain | exception | error | dns, csharp, zone-management, api-misuse, technitium |
| AuthZoneInfo format version not supported. | exception | critical | dns, serialization, version-mismatch, data-corruption, auth-zone-info |
| Cannot set records: TTL cannot be greater than SOA EXPIRE. | exception | error | dns, primary-zone, subdomain, ttl, soa-expire, dnsserverexception |
| Failed to initialize Cluster: failed to create the Cluster… | exception | error | cluster, dns-zone, initialization, validation, technitium-dns-server |
| Zone cannot have sub domains. | exception | error | dns, zone-management, stub-zone, type-mismatch |
| AddressFamily not supported. | exception | error | dns-server, technitium, ipv6, reverse-zone, input-validation, csharp |
| Failed to update self node URL: the node's domain name… | exception | error | cluster, configuration, duplicate-name, dns-server |
| Unable to load daily stats. | exception | error | stats, cache, race-condition, concurrency, daily-stats |
| Cannot add record: a CNAME record cannot exists with other… | exception | error | dns, cname, rfc-1034, record-conflict, auth-zone |
| Access was denied. | exception | error | groups, auth, reserved-names, access-control |
| Cannot add record: use SetRecords() for | exception | error | dns, record-management, singleton-record, auth-zone, api-misuse |
| DNSSEC algorithm is not supported | exception | error | dns, dnssec, crypto, algorithm, not-supported |
| The record type is not supported by primary zones. | exception | error | dns, primary-zone, subdomain, fwd-record, dnsserverexception |
| Cannot add record: TTL cannot be greater than SOA EXPIRE. | exception | error | csharp, dns, ttl, soa, validation, technitium-dns |
| Cannot update DNSKEY TTL value: one or more private keys… | exception | warning | dns, dnssec, dnskey, ttl, key-rollover, validation |
| Valid range is from 1 to 1000. | exception | error | dns, quic, streams, configuration, argumentoutofrange, source-inconsistency |
| Cannot update record: disabling records in a signed zones… | exception | error | csharp, dns, dnssec, zone-management, validation, technitium-dns |
| Zone Signing Key (ZSK) automatic rollover cannot be set due… | exception | error | dnssec, zsk, rollover, lifecycle, state-machine |
| Display name length cannot exceed 255 characters. | validation | error | auth, validation, length-limit, serialization, technitium-dns-server |
| Invalid SOA record. | exception | error | dns, catalog-zone, soa, rfc-9432, validation |
| AuthRecordInfo format version not supported. | exception | critical | serialization, auth-record, zone, version, deserialization |
| The 'connectionString' parameter must not define… | exception | error | mysql, config, connection-string, querylogs-app |
| Failed to initialize Cluster: the zone | exception | error | cluster, dns-zone, initialization, primary-zone, zone-conflict |
| Invalid domain name [ ]: invalid character [ ] was found. | validation | error | dns, csharp, validation, idna, domain-name, encoding |
| Max limit of attempts exceeded. Access blocked for seconds. | exception | error | auth, login, rate-limiting, network |
| Cannot update record: the old record does not exists. | exception | error | dns-records, zone-management, validation, record-update, stale-data |
| DNS-over-HTTP Real IP header name cannot exceed 255… | exception | error | dns, configuration, validation, doh, http-header |
| Unix Domain Sockets (UDS) are supported only on Linux… | exception | error | dns, uds, platform, dnsoverhttp, configuration, argumentexception |
| Failed to read 'Zones' permissions: auth.config file is… | exception | critical | dns-server, technitium, auth, configuration, config-corruption, permissions, csharp |
| Cannot add record in Catalog zone. | exception | error | dns, catalog-zone, rfc-9432, read-only, api-misuse |
| Unexpected URL format | exception | error | csharp, config, json, schema, technitium, advanced-blocking-app |
| Cannot set records in Catalog zone. | exception | error | dns, catalog-zone, rfc-9432, read-only, api-misuse |
| Cannot update DNS zone | exception | error | dhcp, dns, zone-type, configuration |
| The domain name ' ' does not have an A/AAAA record… | exception | error | cluster, dns-resolution, update-primary, network, technitium |
| Failed to delete Secondary node: please try again. | exception | warning | cluster, concurrency, optimistic-locking, retry, dns-server |
| Resource record comment text cannot exceed 255 characters. | validation | error | validation, generic-record, comments, argument-range, serialization |
| Address family not supported | exception | error | config, nxdomain-override, ip-address, address-family, notsupported |
| Invalid IXFR/AXFR response was received. | exception | error | zone-transfer, ixfr, axfr, zone-management, validation, network |
| StatCounter version not supported. | exception | warning | stats, stat-counter, version, serialization, deserialization |
| Invalid time-based one-time password (TOTP) was attempted… | exception | error | auth, totp, mfa, validation, clock-skew, technitium-dns-server |
| Cannot clone the zone: source zone must be a Primary or… | exception | error | dns, zone-management, clone, unsupported-type |
| Invalid data or version not supported. | exception | critical | auth, session, serialization, version, corruption, technitium-dns-server |
| Failed to update Primary node: the Primary node domain name | exception | error | cluster, dns-resolution, update-primary, network, wrapped-exception, technitium |
| Invalid JSON response was received. | exception | error | http-api, client, json, protocol |
| Cannot delete DNSSEC records. | exception | error | csharp, dns, dnssec, zone-management, validation, technitium-dns |
| Cluster node cannot have more than 10 IP addresses. | validation | error | cluster, validation, constructor, ip-addresses |
| Time-based one-time password (TOTP) is already enabled for… | exception | warning | auth, totp, mfa, state, technitium-dns-server |
| DNS record type is not supported | exception | error | config, drop-requests, enum-parse, dns-record-type |
| Zone Signing Key (ZSK) automatic rollover cannot be set… | exception | error | dnssec, zsk, rollover, lifecycle, state-machine |
| Valid RSA ( ) private key size range is between 1024-4096… | exception | error | dns, dnssec, crypto, rsa, validation, key-size |
| Token name length cannot exceed 255 characters. | validation | error | auth, session, token, validation, length-limit, technitium-dns-server |
| Time-based one-time password (TOTP) feature is not… | exception | warning | auth, sso, totp, mfa, technitium-dns-server |
| Failed to leave Cluster: only Secondary nodes can leave the… | exception | error | cluster, role-guard, secondary-node, leave, technitium |
| Cannot change username when using old password hash scheme… | exception | error | auth, user-management, password-hash, migration |
| Failed to find ' ' member zone entry in ' ' Catalog zone… | exception | error | dns, catalog-zone, rfc-9432, member-zone, lookup |
| Invalid domain name [ ]: length cannot exceed 255 bytes. | validation | error | dns, csharp, validation, rfc-1035, domain-name |
| Failed to initialize Cluster: the Cluster is already… | exception | error | cluster, state, initialization, technitium-dns-server |
| Local end point group map contains an invalid end point | exception | error | csharp, config, json, endpoint, technitium, advanced-blocking-app |
| {httpResponse.StatusCode} {httpResponse.ReasonPhrase} | exception | warning | csharp, http, network, blocklist, retry, technitium, advanced-blocking-app |
| Cannot delete records in Catalog zone. | exception | error | dns, catalog-zone, rfc-9432, read-only, api-misuse |
| Failed to initialize Cluster: failed to create the Cluster… | exception | error | cluster, dns-zone, catalog, retry, transient |
| Failed to update web server config. Please try again. | exception | error | csharp, config, json, duplicate, web-server, technitium, block-page-app |
| DNSBL block list type is not supported | exception | error | config, dnsbl, enum-switch, notsupported |
| Failed to add Secondary node: please try again. | exception | error | cluster, concurrency, retry, optimistic-locking, race-condition |
| Failed to leave Cluster: a Primary self node cannot leave… | exception | error | cluster, role-guard, primary-node, leave, technitium |
| External to internal translation entries must have same… | exception | error | splithorizon, config, networking, nat, validation |
| Zone Signing Key (ZSK) automatic rollover days valid range… | exception | error | dnssec, zsk, rollover, validation, argument-range |
| Failed to update DNSKEY TTL. Please try again. | exception | warning | dns, dnssec, dnskey, ttl, transient, retry, concurrency |
| No 'healthCheck' was configured for | exception | error | config, failover, health-check, format-exception |
| The ' ' is an invalid Settings parameter. | validation | error | validation, argument, settings, dnsserver, reserved-keys |
| Cannot add record: disabling records in a signed zones is… | exception | error | dns, primary-zone, subdomain, dnssec, disabled-record, dnsserverexception |
| Cannot delete record in Catalog zone. | exception | error | dns, catalog-zone, rfc-9432, read-only, api-misuse |
| HistoryRecordInfo format version not supported. | exception | warning | serialization, history-record, version, deserialization, zone |
| Cannot update record in Catalog zone. | exception | error | dns, catalog-zone, rfc-9432, read-only, api-misuse |
| Failed to leave Cluster: the Cluster is not initialized. | exception | error | cluster, precondition, leave, technitium, state-guard |