TechnitiumSoftware/DnsServer

Documented errors, page 2 of 5. Back to TechnitiumSoftware/DnsServer

Code / MessageTypeSeverityTags
The SSO Scope name length cannot be more than 255 chars.
validation warning sso, config, validation, length-limit, oidc-scopes
Cannot change password for SSO users.
exception warning auth, sso, password, technitium-dns-server, invalidoperation
DNS zone type not supported.
exception error dns, csharp, zone-management, enum, technitium
Zone must be a primary, secondary, or forwarder zone.
exception error zone-transfer, axfr, zone-management, soa, validation
Address family not supported.
validation error dhcp, validation, constructor, ipv4, address-family
Failed to add header
exception error config, log-exporter, http, headers, format-exception
CacheZoneManager format is invalid.
exception error dns, cache, config-file, serialization, startup
DNS Server Cluster config file format is invalid.
exception critical cluster, config, serialization, corruption, file-format, technitium-dns-server
Invalid username or password for user
exception error auth, login, credentials
Please specify a valid connection string in…
exception critical config, query-logs, mysql, connection-string, startup
Session timeout value must be between 0-604800 seconds.
validation error auth, session, validation, range, technitium-dns-server
SOARecordInfo format version not supported.
exception critical serialization, soa-record, version, deserialization, zone
DNS Server Cluster config version not supported.
exception critical cluster, config, serialization, version, technitium-dns-server
Failed to find 'Administrators' group: auth.config file is…
exception critical dns-server, technitium, auth, configuration, config-corruption, permissions, csharp
CacheRecordInfo format version not supported.
exception warning serialization, cache-record, version, deserialization, cache
Failed to set DNSSEC records. Please try again.
exception error dnssec, nsec, concurrency, retry, internal
Cannot convert the zone '<currentZoneInfo.DisplayName>'…
exception error dns, zone-management, convert, dnssec, data-loss-prevention
GenericRecordInfo format version not supported.
exception critical serialization, generic-record, zone, version, deserialization
Invalid AdGuard Upstreams config file format: missing ']'…
exception error csharp, config, adguard, format, technitium, advanced-forwarding-app
Zone was not found
exception error zone-transfer, axfr, zone-management, validation
DnsServer allowed zone file format is invalid.
exception error dns, csharp, config, binary-format, technitium, data-corruption
Port number valid range is from 0 to 65535.
exception error dns, network, port, proxy, configuration, argumentoutofrange
Cannot convert to NSEC3: the zone must be signed with NSEC…
exception error dnssec, nsec3, state-precondition, validation, csharp
The 'connectionString' parameter must not define 'Initial…
exception error sqlserver, config, connection-string, querylogs-app
Failed to update Primary node: the specified node is the…
exception error cluster, role-guard, update-primary, self-node, technitium
Time-based one-time password (TOTP) was not initialized for…
exception error auth, totp, mfa, state, workflow, technitium-dns-server
Cannot set record: TTL cannot be greater than SOA EXPIRE.
exception error dns, record, soa, ttl, expire, validation
Failed to clone the zone: zone already exists.
exception error dns, zone-management, clone, duplicate, conflict
The Query Access option is invalid for Secondary…
exception error dns, secondary-forwarder-zone, query-access, config, enum, zone-type
Error while creating session. Please try again.
exception error auth, session, concurrency, transient
Network group map contains an invalid network address
exception error splithorizon, config, networking, cidr, validation
Cannot set record: SOA REFRESH cannot be greater than SOA…
exception error dns, record, soa, refresh, expire, validation
Cannot set records in
exception error dns, secondary-subdomain-zone, read-only, immutable, zone-type
Ending address must be greater than starting address.
validation error dhcp, ipv4, validation, scope, argument
The SSO Authority URL length cannot be more than 255 chars.
validation warning sso, config, validation, length-limit
SVCBRecordInfo format version not supported.
exception critical serialization, svcb-record, https-record, version, deserialization
Cannot update record: use SetRecords() for
exception error csharp, dns, soa, zone-management, validation, technitium-dns
No authoritative zone was found
exception error zone-transfer, ixfr, zone-management, soa, validation
Cannot update record: use SetRecords() for updating SOA…
exception error dns-records, zone-management, soa, validation, record-update
The private key must be a Key Signing Key.
validation error csharp, dns, dnssec, validation, technitium-dns
MaxMind database not initialized.
exception error geo, maxmind, config, invalid-operation, runtime-state
Zone must be a primary or forwarder type
exception error dns, zone-import, zone-management, validation
Failed to delete Secondary node: the specified node is the…
exception error cluster, primary-node, validation, dns-server
Failed to delete Cluster: please remove all Secondary nodes…
exception error cluster, delete, secondary-nodes, safety-guard, drain
Zone transfer TSIG key names cannot have more than 255…
validation error dns, tsig, zone-transfer, validation, security
DNS-over-HTTP Real IP header name cannot contain invalid…
exception error dns, configuration, validation, doh, http-header
The domain name ' ' does not belong to the zone
exception error dns, csharp, zone-management, validation, api-misuse, technitium
The SSO Authority URL scheme can be 'http' or 'https' only.
validation warning sso, config, validation, uri-scheme
Failed to load DNS zone file: the zone file does not…
exception error dns, csharp, zone-file, validation, technitium, data-corruption
HourlyStats format is invalid.
exception warning stats, hourly-stats, serialization, deserialization, corruption
Invalid token or session expired.
http error dns-server, technitium, auth, session, cluster, token-expiry, csharp
No such user exists
exception error auth, session, login, user-management
Cannot update DNSSEC records.
exception error csharp, dns, dnssec, zone-management, validation, technitium-dns
Network Access Control List cannot have more than 255…
exception error dns, network, acl, reverse-proxy, configuration, argumentoutofrange
Invalid AXFR response was received.
exception error zone-transfer, axfr, zone-management, validation, network
Syslog protocol is not supported
exception error config, log-exporter, syslog, enum-switch, notsupported
HourlyStats version not supported.
exception warning stats, hourly-stats, version, serialization, deserialization
MaxMind City file is missing!
exception critical geo, maxmind, city, distance, file-not-found, startup
Value cannot be less than 1.
exception error dns, resolver, concurrency, configuration, argumentoutofrange
Cannot publish DNSKEY: the key is already published.
exception error dnssec, private-key, dnskey, validation, duplicate, csharp
Client hardware address cannot exceed 16 bytes.
validation error dhcp, validation, constructor, rfc2131, mac-address
Cannot update record: zone
exception error dns-records, zone-management, validation, record-update
Failed to initialize Cluster: the zone
exception error cluster, dns-zone, catalog, initialization, zone-conflict
Secondary Catalog name server addresses cannot have more…
validation error dns, notify, catalog-zone, zone-transfer, validation
External to internal translation entries must have same…
exception error splithorizon, config, networking, nat, validation
TSIG keys cannot have more than 255 entries.
exception error dns, configuration, validation, tsig, limits
Block list URL (or comment line) length cannot exceed 255…
validation error dns, blocklist, validation, configuration
Cannot sign zone: the zone is already signed.
exception error csharp, dns, dnssec, zone-management, concurrency, technitium-dns
NSRecordInfo format version not supported.
exception critical serialization, ns-record, glue-records, version, deserialization
Zone was not found for domain
exception error dns, csharp, zone-management, api-misuse, technitium
Already logged in. Please create a new object to use a…
exception error http-api, client, session, auth, state
Failed to refresh configuration: only Secondary nodes can…
exception warning cluster, role-guard, config-refresh, primary-node, technitium
Automatic rollover is not supported for Key Signing Keys…
exception error dnssec, ksk, rollover, validation
Cannot add user to group: user can be member of max 255…
exception error auth, groups, limit, serialization, technitium-dns-server
DNSSEC private key version not supported
exception error dns, dnssec, crypto, serialization, version, format
Invalid domain name [ ]: label length cannot be 0 byte.
validation error dns, csharp, validation, rfc-1035, domain-name
Cannot set record at zone apex.
exception error dns, record, cname, ds, apex, invalidoperation, validation
No SOA record was found for IXFR.
exception error zone-transfer, ixfr, zone-management, soa, validation
DNS application already exists
exception error dns-app, install, duplicate, state-conflict
DnsServer zone file format is invalid.
exception error dns, csharp, zone-file, binary-format, technitium, data-corruption
No such zone was found
exception error zone-transfer, ixfr, zone-management, race-condition, validation
Health check type 'ping' is not supported over proxy.
exception error failover, health-check, ping, proxy, notsupported
No such node exists in the Cluster by name
http error dns-server, technitium, cluster, node-routing, input-validation, csharp
Boot file name cannot exceed 127 bytes.
validation error dhcp, validation, constructor, rfc2131, boot-file
Cannot update reverse DNS zone
exception error dhcp, dns, zone-type, reverse-dns, configuration
DNS Server auth config version not supported.
exception critical config, startup, versioning, auth
StatCounter format is invalid.
exception warning stats, stat-counter, serialization, deserialization, corruption
Failed to ask Secondary node to leave: the specified node…
exception error cluster, leave, primary-node, wrong-target
Failed to promote to Primary node: the Cluster Secondary…
exception error cluster, dns-zone, promote, missing-state, technitium
MaxStatFileDays must be greater than or equal to 0.
validation error stats, validation, argument-range, retention, config
Server host name cannot exceed 63 bytes.
validation error dhcp, validation, constructor, rfc2131, hostname
Valid range is from 8 KB to 65536 KB.
exception error dns, udp, buffer, socket, configuration, argumentoutofrange
Invalid application configuration.
exception error config, log-exporter, deserialization, startup
The private keys must contain at least one Key Signing Key.
validation error csharp, dns, dnssec, validation, technitium-dns
Unknown status value was received
exception error http-api, client, json, version-skew
Failed to find 'DNS Administrators' group: auth.config file…
exception critical dns-server, technitium, auth, configuration, config-corruption, permissions, csharp
No such primary zone was found
exception error dns, dnssec, signing, primary-zone, not-found
Cannot convert to NSEC: the zone must be signed with NSEC3…
exception error csharp, dns, dnssec, nsec3, zone-management, technitium-dns
MaxMind Country file is missing!
exception critical geo, maxmind, file-not-found, startup, config
Cannot set DS record at zone apex.
exception error dns, dnssec, record, ds, apex, invalidoperation, validation