TechnitiumSoftware/DnsServer

Documented errors, page 4 of 5. Back to TechnitiumSoftware/DnsServer

Code / MessageTypeSeverityTags
An IPv6 network address is expected for 'excludedIpv6'…
exception error csharp, config, ipv6, dns64, network, technitium
DHCP Server requires static IP address to work correctly…
exception error dhcp, networking, ipv4, static-ip, configuration
Port 53 cannot be used for DNS-over-HTTP service. Please…
exception error dns, network, port, dnsoverhttp, reserved-port, configuration, argumentoutofrange
Invalid AdGuard Upstreams config file format: missing…
exception error csharp, config, adguard, format, technitium, advanced-forwarding-app
Zone does not contain SOA record.
exception error dns, csharp, zone-file, soa, validation, technitium
DNS Zone file version not supported.
exception error dns, csharp, zone-file, version-mismatch, technitium
Failed to delete Cluster: the Cluster is not initialized.
exception error cluster, lifecycle, delete, validation, not-initialized
Cannot update record: new record must be of same type.
exception error dns-records, zone-management, validation, record-update
Proxy server was not defined
exception error csharp, config, json, proxy, reference, technitium, advanced-forwarding-app
Seconds elapsed must be 2 bytes.
validation error dhcp, validation, constructor, rfc2131, seconds
The ECDSA ( ) private key must have key size of 384 bits.
exception error dns, dnssec, crypto, ecdsa, pem, key-size
Web server ' ' TLS certificate file does not exists
exception error csharp, tls, certificate, config, filesystem, technitium, block-page-app
Invalid domain name [ ]: IP address cannot be used for DNS…
exception error server-domain, config, validation, ip-misuse
Starting address cannot be same as the network address.
validation error dhcp, ipv4, validation, scope, subnet
Web server ' ' TLS certificate file must be PKCS #12…
exception error csharp, tls, certificate, pkcs12, config, technitium, block-page-app
Username length cannot exceed 255 characters.
validation error auth, user-management, validation, length-limit
Valid range is from 10 to 30.
exception error dns, configuration, validation, resolver, limits
Cannot create more than 255 users.
exception error auth, user-management, limits
Cannot add record in
exception error dns, secondary-subdomain-zone, read-only, immutable, zone-type
No active session exist to logout.
exception error http-api, client, session, state
The primary zone must be signed.
exception error dnssec, private-key, state-precondition, validation, csharp
EDNS Client Subnet IPv6 prefix length cannot be greater…
exception error dns, edns, ecs, ipv6, configuration
Reserved address must be in scope range.
validation error dhcp, validation, scope, ipv4, reservation, argument
Web service TLS certificate password length cannot exceed…
validation error dns-server, technitium, tls, certificate, input-validation, configuration, csharp
DNS Server config file format is invalid.
exception error config, file-format, import, corruption
Exclusion starting address must be in scope range.
validation error dhcp, validation, scope, ipv4, exclusion, argument
Percentage value valid range is between 0 and 100.
exception error dns, qpm, rate-limiting, udp, configuration
No dynamic lease was found for client identifier
exception warning dhcp, lease, runtime-state, scope, reservation, client-id
The application name is invalid
exception error security, path-traversal, input-validation, dns-app
Failed to resync configuration: the Cluster is not…
exception warning cluster, precondition, config-resync, technitium, state-guard
No lease was found for client identifier
exception warning dhcp, lease, runtime-state, scope, client-id
Ending address cannot be same as the broadcast address.
validation error dhcp, ipv4, validation, scope, subnet
Failed to add private key: key tag collision. Please…
exception error dnssec, private-key, key-tag, validation, csharp
requires IPv6 support on the system to work.
exception error quic, ipv6, doq, doh3, environment
Groups array was not defined.
exception error csharp, config, json, schema, technitium, advanced-forwarding-app
Scope data format version not supported.
exception error dhcp, scope, serialization, versioning, corruption
DNS optional protocols TLS certificate password length…
validation warning tls, certificate, password, length
QPM limit IPv4 prefix valid range is between 0 and 32.
exception error dns, qpm, rate-limiting, ipv4, validation
Invalid domain name [ ]: label length cannot exceed 63…
validation error dns, csharp, validation, rfc-1035, domain-name
No such zone was found: <zoneName or ".">
exception error dns, zone-management, convert, not-found, input-validation
EDNS Client Subnet IPv4 prefix length cannot be greater…
exception error dns, edns, ecs, ipv4, configuration
Web Service TLS certificate file must be PKCS #12 formatted…
validation error dns-server, technitium, tls, certificate, pkcs12, configuration, csharp
Failed to add Secondary node: A node with the same DNS…
exception error cluster, join, duplicate, naming, uniqueness
Port 53 cannot be used for DNS-over-TLS service. Please use…
exception error dns, network, port, dnsovertls, reserved-port, configuration, argumentoutofrange
No reserved lease was found for client identifier
exception warning dhcp, lease, runtime-state, scope, reservation, client-id
NSEC3 salt length valid range is 0-32
validation error csharp, dns, dnssec, nsec3, validation, technitium-dns
DNS Server is already running.
exception error lifecycle, start, state-machine, concurrency
Failed to join Cluster: the zone
exception error cluster, zones, lifecycle, join, validation, dns-server
The EdDSA ( ) private key must be for Ed448 curve.
exception error dns, dnssec, crypto, eddsa, ed448, pem
Cannot delete records in
exception error dns, secondary-subdomain-zone, read-only, immutable, zone-type, delete
Exclusion ending address must be greater than or equal to…
validation error dhcp, exclusion, ipv4, validation
Cannot delete record in
exception error dns, secondary-subdomain-zone, read-only, immutable, zone-type, delete
The zone '<memberZoneInfo.DisplayName>' is not a member of…
exception error dns, catalog-zone, membership, state-violation, input-validation
Valid range is from 1000 to 10000.
exception error dns, timeout, client, configuration
Failed to delete Secondary node: the specified node does…
exception error cluster, delete-secondary, not-found, stale-reference
DNS Server TLS certificate file must be PKCS #12 formatted…
validation error tls, certificate, pkcs12, format
Exclusion ending address must be in scope range.
validation error dhcp, validation, scope, ipv4, exclusion, argument
Failed to update Secondary node: A node with the same DNS…
exception error cluster, uniqueness, dns-names, validation, dns-server
Failed to update Secondary node: only a Primary node can…
exception error cluster, primary-node, authorization, validation, dns-server
QPM Prefix Limits for IPv6 cannot have more than 255…
exception error dns, qpm, rate-limiting, ipv6, configuration
Cannot create more than 255 groups.
exception error auth, group-management, limits
Group name cannot be null or empty.
validation error groups, validation, auth
No reserved lease was found for hardware address
exception warning dhcp, lease, runtime-state, scope, reservation
QPM limit IPv6 prefix valid range is between 0 and 128.
exception error dns, qpm, rate-limiting, ipv6, validation
Transaction ID must be 4 bytes.
validation error dhcp, validation, constructor, rfc2131, transaction-id
No dynamic lease was found for hardware address
exception warning dhcp, lease, runtime-state, scope, reservation
Failed to transfer configuration: the Cluster is not…
exception error cluster, lifecycle, config-transfer, validation, dns-server
Failed to update Secondary node: the Cluster is not…
exception error cluster, lifecycle, validation, dns-server
Failed to delete Secondary node: only a Primary node can…
exception error cluster, authorization, primary-node, delete-secondary, rbac
DNS optional protocols TLS certificate path length cannot…
validation warning tls, certificate, path-length, config
Failed to ask Secondary node to leave: the specified node…
exception error cluster, leave, not-found, stale-reference
DNS application does not exists
exception warning dns, application, runtime-state, state
DNS Server TLS certificate file does not exists
validation error tls, certificate, filesystem, dot-doh-doq
The address must be an IPv4 address
validation error dhcp, ipv4, validation, networking
DNS optional protocols TLS certificate path cannot be null…
validation error tls, certificate, argument, config
Value must be between 1 hour and 168 hours (7 days) or 0 to…
validation error dns, blocklist, validation, configuration
Failed to join Cluster: the domain name
exception error cluster, network, dns-resolution, join, dns-server
Lease data format version not supported.
exception error dhcp, lease, serialization, versioning
Web Service TLS certificate file does not exists
validation error dns-server, technitium, tls, certificate, configuration, filesystem, csharp
Web service TLS certificate path cannot be null or empty.
validation error dns-server, technitium, tls, certificate, input-validation, configuration, csharp
The scope name contains an invalid character
validation error dhcp, scope, validation, filesystem, sanitization
DHCP Server is already running.
exception error dhcp, lifecycle, startup, concurrency
DhcpServer scope file format is invalid.
exception error dhcp, scope, file-format, serialization, corruption
Invalid cache maximum entries value. Valid range is 0 and…
validation error dns, cache, validation, configuration
Lease time in days must be between 0 to 999.
validation error dhcp, validation, scope, lease-time, argument
Valid range is between 1 and 60 minutes.
exception error dns, qpm, rate-limiting, configuration
Failed to join Cluster: the Primary node does not have a…
exception error cluster, lifecycle, join, validation, dns-server
Failed to update Secondary node: the specified node to…
exception error cluster, primary-node, validation, dns-server
Group name length cannot exceed 255 characters.
validation error groups, validation, length-limit, auth
Valid range is from 1000 to 90000.
exception error dns, timeout, tcp, configuration
Failed to join Cluster: the Primary node domain name
exception error cluster, network, dns-resolution, join, dns-server
Scope with name ' ' already exists.
exception error dhcp, scope, validation, duplicate
Port 53 cannot be used for DNS-over-QUIC service. Please…
exception error dns, network, port, dnsoverquic, reserved-port, configuration, argumentoutofrange
Port 53 cannot be used for DNS-over-HTTPS service. Please…
exception error dns, network, port, dnsoverhttps, reserved-port, configuration, argumentoutofrange
QPM limit value cannot be less than 0.
exception error dns, qpm, rate-limiting, validation
Failed to join Cluster: the Cluster is already initialized.
exception error cluster, lifecycle, validation, dns-server
Failed to ask Secondary node to leave: the Cluster is not…
exception error cluster, leave, validation, not-initialized
The zone must be signed.
exception error dnssec, private-key, state-precondition, validation, csharp
Failed to update Cluster options: the Cluster is not…
exception error cluster, lifecycle, configuration, validation, dns-server
Failed to transfer configuration: only the Primary node can…
exception error cluster, primary-node, config-transfer, authorization, dns-server