apache/hadoop
Documented errors, page 25 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| PrivilegedActionException with no underlying cause. UGI ["… | exception | warning | hadoop, ugi, doas, privileged-action |
| Rec# : Failed to skip past value of length | exception | error | hadoop, mapreduce, shuffle, merge, data-corruption, ifile |
| Received unimplemented DNA_SHUTDOWN | exception | error | hdfs, datanode, datanodeprotocol, unsupported-command, shutdown |
| srcIIP.getPath() + " can't be moved from encryption zone "… | exception | error | hdfs, encryption-zone, rename, key-management, distcp |
| This API: cannot be supported without default cluster(that… | exception | error | hdfs, viewfs, mount-table, link-fallback, config |
| : slot is already in use. | exception | warning | hdfs, short-circuit-read, shared-memory, slots, duplicate-request, datanode |
| Thread interrupted during retry | exception | warning | bos, thread-interruption, task-cancellation, hadoop |
| Destination path already exist, cannot rename! | exception | error | sftp, rename, destination-exists, hadoop, filesystem |
| Directory " + f.toString() + " is not empty | exception | error | hadoop, local-filesystem, delete, directory-not-empty, cleanup |
| {err} | exception | error | dynamometer, cli, usage, arguments |
| Incompatible clusterID for journal | exception | error | qjm, journalnode, cluster-id-mismatch, format, configuration |
| Invalid arguments list! | exception | error | hadoop, rumen, anonymizer, cli-args, argument-parsing |
| No other node is currently active. | exception | error | hadoop, high-availability, graceful-failover, zookeeper, election |
| is missing. | exception | error | createsnapshot, missing-argument, argument-validation, snapshot, hadoop-shell |
| Target path for atomic-commit already exists | exception | error | distcp, atomic-commit, target-path, input-validation |
| Unexpected mount table link entry | validation | error | hadoop, viewfs, mount-table, configuration, root-mount |
| attributes cannot have a NULL key | validation | error | java, hadoop, key-provider, validation, null-key |
| Cannot rollback. None of the storage directories contain… | exception | error | hdfs, namenode, rollback, upgrade |
| dfs.namenode.lazypersist.file.scrub.interval.sec must be… | validation | error | hadoop, hdfs, namenode, configuration, lazy-persist, numeric-range |
| Failed to for on because this file lease is currently owned… | exception | error | hdfs, lease, single-writer, already-being-created, concurrency |
| Hadoop bin directory is not a directory. | exception | error | hadoop, shell, bin-directory, filesystem, filenotfound |
| Incompatible namespaceIDs in | exception | critical | hadoop, hdfs, datanode, storage, namespaceid, mismatch, pre-federation |
| jobId cannot be null | validation | error | |
| No DFS available in child file systems. | exception | error | hdfs, viewfs, centralized-caching, unsupported |
| Redundant -getlevel command | validation | error | hadoop, logging, cli, loglevel, duplicate-flag |
| removeAcl is only supported by storage accounts with the… | exception | error | azure-abfs, acl, hierarchical-namespace, unsupported-operation |
| rename cannot overwrite non empty destination directory | exception | error | hadoop, filesystem, rename, directory-not-empty |
| setShuffleFinishTime() not supported for MapTask | exception | error | hadoop, mapreduce, taskstatus, unsupported-operation, api-misuse |
| The option dfs.namenode.support.allow.format is set to… | exception | error | hdfs, namenode, format, configuration, ha, safety-guard |
| Unable to determine current user | exception | error | |
| Cannot truncate a directory (=" + f + ") | exception | error | hadoop, local-filesystem, truncate, directory, ioexception |
| contained no entry. | exception | error | hdfs, oiv, fsimage, reversexml, snapshot-diff, missing-field |
| Failed to delete the mapped file | exception | warning | hdfs, datanode, file-delete, race-condition, checksum |
| Failed to read fields from SetAclOp | exception | error | hdfs, edit-log, protobuf, acl, corruption, truncation |
| file conflicts | exception | error | hadoop, obs, posix, name-conflict, getfilestatus |
| has incompatible storage Id. | exception | error | hadoop, hdfs, datanode, storage, storage-id, mismatch |
| hsync not supported by | exception | error | hadoop, io, output-stream, syncable, statistics, unsupported-operation |
| Illegal option -t | exception | error | movefromlocal, invalid-option, command-line, hadoop-shell, unsupported-flag |
| "Invalid argument: " + cmd | validation | error | hdfs, rbf, federation, safe-mode, cli, argument-validation |
| Invalid UID, could not determine effective user | exception | error | hadoop, ugi, login, unix, uid, container |
| Malformed xml formation queue name not specified | exception | error | hadoop, mapreduce, queues, xml, missing-field, configuration |
| Non existing file: . Create option is not specified in | exception | error | hadoop, filesystem, file-not-found, create-flag, append |
| Only HDFS is supported as underlyingFileSystem, fs scheme | exception | error | nfs-gateway, hdfs, filesystem-scheme, exports, configuration |
| already exists | exception | error | s3a, create, file-already-exists, overwrite |
| Path without scheme with non-null authority | validation | error | hadoop, uri, path, scheme, validation |
| Replica is not in expected state | exception | error | hdfs, datanode, block-check, replica-state, lease-recovery |
| Stream closed or unbuffer is called | exception | warning | s3a, hadoop-aws, vectored-read, interruptedioexception, unbuffer, stream-lifecycle |
| wildcard_expandPath: on readdir | console | warning | hdfs, libhdfs, classpath, readdir, wildcard-expansion |
| Block length mismatch, len= | exception | error | hdfs, datanode, replica-files, length-mismatch, consistency |
| DN shut down before block pool registered | exception | warning | hdfs, datanode, shutdown, registration, lifecycle |
| File conflicts during rename | exception | error | hadoop, obs, posix, rename, conflict |
| file not open for writing. | exception | error | hdfs, oiv-legacy, io, visitor-lifecycle |
| getErasureCodingPolicy is not supported for HttpFs on | exception | error | httpfs, webhdfs, erasure-coding, unsupported-operation, fs-defaultfs |
| Illegal minload factor | exception | error | validation, constructor, illegal-argument, hash-table |
| Missing a valid replica to recover from | exception | error | hdfs, datanode, replica, builder, block-recovery, required-parameter |
| Not allow to add an inner node | exception | error | hadoop-common, network-topology, invalid-argument, java |
| Proxy error: fs.oss.proxy.username or fs.oss.proxy.password… | validation | error | aliyun-oss, configuration, proxy, paired-config, hadoop-connector |
| Unknown Task | exception | error | mapreduce, am-client, task-id, rpc |
| Unsupported HTTP authentication scheme | exception | error | |
| ViewFs: Non absolute mount name in config | validation | error | hadoop, viewfs, mount-table, configuration, path-validation |
| Already started | exception | error | kerberos, minikdc, lifecycle, test-infrastructure |
| Append on EC file without new block is not supported. Use… | exception | error | hdfs, append, erasure-coding, create-flag |
| Can't find the queue by the given name | exception | error | hadoop-sls, capacity-scheduler, queue-config, yarn, configuration |
| Failed to create uri for | exception | error | hadoop, stringutils, uri, rfc-2396, configuration |
| contained no entry. | exception | error | hdfs, oiv, fsimage, reversexml, snapshot-diff, missing-field |
| HTTP stream closed before all bytes were read. Expected %,d… | exception | error | s3a, hadoop-aws, vectored-read, eofexception, truncated-response, network |
| Mark not set | exception | error | hadoop, java, io, mark-reset, stream-wrapper |
| Storage directory is in use. | exception | warning | hadoop, hdfs, datanode, storage, hot-swap, reconfig |
| The ownership on the staging directory | exception | error | |
| "User " + pc.getUser() + " is not a super user (non-super… | exception | error | hdfs, permissions, chown, access-control |
| Wrong FS: and port= , expected: with port= | validation | error | hadoop, filesystem, port, uri, mismatch |
| A valid path needs to be specified for " +… | exception | error | provided-storage, aliasmap, leveldb, configuration, missing-config |
| Failed to find user in name " + subject | exception | error | hadoop, jaas, login, kerberos, ugi |
| Image uploading failed, status | exception | error | hdfs, namenode, transferfsimage, http, image-upload, kerberos, checkpoint |
| No edits file for range | exception | error | qjm, journalnode, missing-file, edit-log, finalized-segment |
| Not implemented by the | exception | error | hadoop, filesystem, api-misuse, unsupported-operation |
S06 Could not load file [ ] | error_code | critical | httpfs, server-startup, xml-config, configuration, file-permissions |
| Can't read partitions file | exception | error | mapreduce, partitioning, total-order-sort, file-io, configuration |
| Client (= ) is not the lease owner (= : (inode ) | exception | error | hdfs, namenode, lease, single-writer, concurrency |
| Failed to parse generation stamp: blockFile= | exception | error | hdfs, datanode, file-naming, generation-stamp, metadata |
| Invalid cipher suite name | validation | error | crypto, configuration, hadoop |
| Metrics are read-only. | exception | error | jmx, metrics2, hadoop, read-only, unsupported-operation |
| non-array value of class | exception | error | hadoop, serialization, writable, type-validation, array |
| The user name '" + userName + "' is not found. " +… | exception | error | unix, group-mapping, user-not-found |
| Bad status: | exception | error | hdfs, block-report, protobuf, enum, serialization |
| Buffer has no data left. | exception | error | hadoop-common, network, nio, bytebuffer, java |
| encoded array length is negative | exception | error | hadoop, serialization, deserialization, data-corruption, stream-validation |
ENOTSUP ERROR: cannot open an hdfs file in O_RDWR mode
| console | error | c, libhdfs, hdfs, file-open, enotsup, posix-portability |
| Failed to rename to , file already exists! | exception | error | aliyun-oss, rename, destination-exists, hadoop-connector |
| "File/Directory does not exist: " + iip.getPath() | exception | error | hdfs, storage-policy, file-not-found |
| File for given inode path does not exist | exception | error | |
| File " + url + " computed digest " + computedDigest + "… | exception | error | hdfs, fsimage, md5, checksum, data-corruption, transfer |
| GoogleHadoopFileSystem has been closed or not initialized. | exception | error | lifecycle, gcs, hadoop, filesystem, initialization |
| invalid negative number of blocks | exception | critical | hdfs, namenode, edit-log, corruption, blocks, data-format |
| Invalid options " + opts.getClass() | exception | error | provided-storage, aliasmap, leveldb, options, illegal-argument |
| Invalid storage type (null) | validation | error | webhdfs, null-argument, storage-type, quota |
| No data at path | exception | warning | registry, zookeeper, serialization, empty-data |
| already exists as a directory | exception | error | hdfs, create, path-conflict, directory |
| is not a directory. | exception | error | cli, generic-options-parser, libjars, wildcard, not-a-directory |
| ProvidedReplica does not support renaming metadata | exception | error | hdfs, datanode, provided-storage, read-only, rename |