apache/hadoop
Documented errors, page 23 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| taskId cannot be null | validation | error | |
| "Unexpected argument " + args[nextArgIndex] | validation | error | hadoop, logging, cli, loglevel, usage, arguments |
| Unknown server chain certificate | exception | error | ssl, tls, truststore, certificate, handshake, hadoop, client |
| Failed to for on because is already the current lease… | exception | error | hdfs, lease, already-being-created, single-writer, concurrency |
| getBytesOnDisk() < getVisibleLength(), rip= | exception | error | hdfs, datanode, block-recovery, truncated-block, visible-length |
| getTrashRoots is not supported for HttpFs on | exception | error | hdfs, httpfs, webhdfs, trash, fs-defaultfs, configuration, unsupported-operation |
| No section found at the top of the fsimage XML. This XML… | exception | error | hdfs, oiv, fsimage, reversexml, version, legacy-format |
| Not an AP-REQ token | exception | error | kerberos, spnego, gss-api, token-parsing |
| closed | exception | error | erasure-coding, native, isal, resource-lifecycle, ioexception |
| Unable to parse relative time value of | exception | error | hdfs, cli, parsing, duration, ttl, time-unit |
UNKNOWN Unknown error | exception | error | native-io, windows, chmod, unknown-error, win32 |
| Unknown or duplicate section found for | exception | error | hdfs, offline-image-viewer, xml, fsimage |
| you must put at the top of the XML file! Got tag instead | validation | error | hadoop, hdfs, offline-edits-viewer, xml, parsing |
| Can't combine -recover with other startup options. | exception | error | hdfs, namenode, cli, arguments, recovery, startup-options |
| Can't parse " + mapName + " list entry:" + line | exception | error | unix, user-mapping, nfs, shell, parsing |
| Cannot mutate read-only channel | exception | error | gcs, read-only, unsupported-operation, byte-channel, write |
| does not support enhanced byte buffer access. | exception | error | crypto, hdfs, stream, bytebuffer, zero-copy, hadoop |
| Could not launch job | exception | error | |
| Datanode state: LV = | exception | critical | hdfs, datanode, storage, ctime, rollback-mismatch |
| Failed to start active services | exception | critical | hdfs, namenode, ha, state-transition, service-failed, failover |
| still not leave safemode | exception | error | hdfs, namenode, ha, safemode, state-transition, failover |
| Invalid HTTP DELETE operation | exception | error | httpfs, webhdfs, rest-api, http-delete, operation-dispatch, bad-request |
| mkdirs path arg is null | validation | error | hadoop, local-filesystem, mkdirs, null-argument, illegalargumentexception, configuration |
| No arguments specified | validation | error | hadoop, logging, cli, loglevel, arguments |
| No type in deserialized FileStatus | validation | error | hadoop, java-serialization, filestatus, invalid-object |
| oidName: is not supported. | exception | warning | kerberos, gss-api, deprecated, hadoop-auth |
| shutdownHook cannot be NULL | exception | error | hadoop, shutdown-hook, null-argument, lifecycle |
| : invalid slot index | exception | warning | hdfs, short-circuit-read, shared-memory, slots, version-skew, datanode |
| BlockReader: error in packet header | exception | error | hdfs, data-transfer, packet, corruption, network |
| Cannot rename because path does not exist | exception | error | rename, gcs, hadoop, directories, filesystem |
| Cannot search in unsorted TFile | exception | error | tfile, hadoop-common, unsorted, binary-search, precondition |
| Destination ' ' exists but cannot be deleted | exception | error | hdfs, file-copy, delete, permissions, file-locking |
| DFS client does not support blockId | validation | error | azure, abfs, dfs, block, unsupported-operation, misuse |
H02 Kerberos initialization failed | error_code | critical | httpfs, kerberos, authentication, kdc, keytab |
| HADOOP_CONF_DIR not configured | exception | error | hadoop-compat-bench, environment-variables, hadoop-conf-dir, shell-tests |
| Invalid seek offset: position value | exception | error | gcs, seek, negative-offset, validation, read-channel |
| Invalid VECSUM_TYPE environment variable. Valid values are… | console | error | environment-variable, configuration, input-validation, vecsum |
| : mapreduce.reduce.input.buffer.percent must be a float… | exception | error | hadoop, mapreduce, shuffle, config, memory, reduce, validation |
| Only 'KILLED' is allowed as a target state. | http | error | mapreduce, rest, http-400, state-transition, task-attempt |
| Bandwidth specified is invalid | exception | error | distcp, cli, bandwidth, number-format, invalid-arguments |
| Cannot close proxy since it is null | exception | error | rpc, lifecycle, null-check, cleanup, client |
| CreateChecksumType option is set multiple times | validation | error | hadoop, file-create, options, checksum, varargs |
| dfs.datanode.parallel.volumes.load.threads.num = | exception | error | hadoop, hdfs, datanode, configuration, validation, upgrade |
| Failed to delete objects, detail | exception | error | hadoop-tos, object-storage, batch-delete, iam-permissions, cleanup |
| File " + f + " does not exist | exception | error | hadoop, local-filesystem, liststatus, file-not-found, filenotfoundexception |
| invalid args | validation | error | hadoop, hdfs, jmxget, cli, arguments |
| Invalid buffer found, not allowing null | exception | error | erasure-coding, buffer-validation, null-check |
| Invalid UTF-8 representation. | exception | error | hadoop-record, utf-8, deserialization, deprecated, data-corruption |
| Range extends beyond the file length | validation | error | vectored-io, file-range, eof, truncation |
| Read invalid opcode | exception | error | hdfs, edit-log, corruption, opcode, downgrade |
| The source cluster must be specified. | validation | error | fedbalance, federation-balance, uri-validation, path, cluster-addressing |
| Unexpected stat output: " + line | exception | error | hadoop, stat, parsing, locale |
| Unsupported add(value) for metric | exception | error | metrics2, hadoop, metric-name-collision, type-mismatch |
| Wrong scheme: , in path: , expected scheme | exception | error | path, gcs, hadoop, scheme, validation |
| Cannot start trash emptier with negative interval. Set… | exception | error | hdfs, namenode, configuration, trash, startup |
| Directory is in an inconsistent state: previous fs state… | exception | error | hdfs, namenode, upgrade, finalize, rollback |
| Failed to add : You cannot have a rack and a non-rack node… | exception | error | hadoop-common, network-topology, configuration, hdfs, invalid-topology |
| File deletion is not supported in pseudo local file system. | exception | error | hadoop, gridmix, pseudo-local-fs, unsupported-operation, delete |
| Identifier cannot be null | exception | error | refresh, registry, null-check, admin, plugin |
| Inconsistent checkpoint fields.\nLV = layoutVersion… | exception | error | |
| Invalid buffer not of length | exception | error | erasure-coding, buffer-validation, hadoop-common |
| Invalid registration, no rpc address specified | validation | error | hdfs, router-based-federation, state-store, membership, record-validation |
| Length not matched: length= | exception | error | java, hadoop, webhdfs, checksum, response-validation |
| Native-Task doesn't support sort class | exception | error | nativetask, sorting, job-configuration, pluggable-framework |
| = numBytes < visible = , temp= | exception | error | hdfs, datanode, block-write, length-mismatch, temporary-replica |
| -protocol needs one parameter | validation | error | hadoop, logging, cli, loglevel, missing-arguments, protocol |
| ProvidedReplica does not support pinning | exception | error | hdfs, datanode, provided-storage, pinning, read-only |
| Shared edits storage is not enabled for this namenode. | validation | error | hdfs, namenode, bootstrap-standby, ha, shared-edits, missing-configuration |
| Task memory allocation may not be < 0 | validation | error | |
| Content changed | exception | error | hdfs, path-handle, staleness, mtime |
| Directory is not executable | exception | error | disk, permissions, filesystem, diskchecker, traverse |
| Failed to for on because the file is under construction but… | exception | error | hdfs, lease, orphaned-lease, namenode-failover, under-construction |
| Invalid inputs are found, all being null | exception | error | erasure-coding, null-check, validation |
| Invalid operation. | exception | error | rpc, schedulable, call-queue, unsupported-operation |
| JNI_GetCreatedJavaVMs failed with error | console | critical | hdfs, libhdfs, jni, jvm, initialization |
| ProvidedReplica does not yet support copy metadata | exception | error | hdfs, datanode, provided-storage, block-replication, metadata |
| The SSL encryption is enabled for the component's ZooKeeper… | exception | error | hadoop, zookeeper, ssl, tls, keystore, configuration, java |
| threadJoin: WaitForSingleObject failed with error | console | error | libhdfs, windows, waitforsingleobject, thread-join, win32 |
| A valid name and value must be specified. | validation | error | azure-abfs, setxattr, xattr, illegal-argument |
DATANODE_STATUS_NOT_REGULAR Datanode is in special state, e.g. Upgrade/Rollback etc. Disk balancing not… | exception | error | hadoop, hdfs, datanode, diskbalancer, startup-options, upgrade |
| GetAclStatus operation is only supported on HNS enabled… | exception | error | azure, abfs, unsupported-operation, hns, acl |
| hadoop.security.authorizationis configured to true but… | validation | error | hadoop, high-availability, zkfc, security, authorization |
| Id exists but maps to and not | exception | error | hadoop, serialization, writable, mapwritable, ipc |
| Invalid attribute value for hadoop.security.authentication… | exception | error | configuration, authentication, startup |
| Mark not supported | exception | error | hadoop, java, io, mark-reset, stream-wrapper |
| MD5 file at references file named but we expected it to… | exception | error | md5, checksum, file-naming, fsimage, sidecar |
| Operation [ ], invalid path [ ], must be '/ | exception | error | httpfs, webhdfs, rest-api, request-path, validation |
| Path: should start with /webhdfs/v1 | http | error | hdfs, offline-image-viewer, webhdfs, http, url-path |
| Symlinks not supported - please remove symlink before… | exception | error | hdfs, namenode, symlink, upgrade, edit-log, op-symlink |
| The GenericWritable has NOT been set correctly. type= | exception | error | hadoop, serialization, writable, uninitialized-state, validation |
| Unable to parse permission string | exception | error | hdfs, oiv, fsimage, reversexml, permission, validation |
| unlinkTmpFile= does not end with .unlinked | exception | error | hdfs, datanode, file-naming, unlink, argument-validation |
| Bad option value found for | exception | error | erasure-coding, schema, validation, invalid-value |
| Cannot rename source | exception | error | ftp, hadoop, rename, unsupported-operation |
| doesn't support setStoragePolicy | exception | error | hadoop, filesystem, storage-policy, hdfs, unsupportedoperationexception |
ENOENT No such file or directory | exception | error | native-io, windows, chmod, enoent |
| GCS path must include non-empty object name | exception | error | gcs, object-name, uri, validation |
| Invalid empty argument | validation | error | hadoop, fs-shell, find, permissions, argument-validation |
| Key already exists in | exception | error | java, hadoop, key-provider, duplicate, credentials, user-provider |
| Mismatch in length of source | exception | error | distcp, hadoop, verification, length-mismatch, data-integrity |