apache/hadoop
Documented errors, page 22 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Unexpected configuration parameters: dfs.replication.max = | validation | error | hdfs, namenode, configuration, replication, range-check, startup-check |
| Unknown algorithm | exception | error | java, hadoop, webhdfs, checksum, compatibility |
| unknown scheme for endpoint | exception | error | hadoop, http-server, jetty, uri, configuration |
| : Stream is closed! | exception | error | s3a, hadoop-aws, stream-lifecycle, ioexception, close, concurrency |
| Value length unknown. | exception | error | tfile, hadoop-common, precondition, value-length, runtime-exception |
| XAttrs not supported for file system | exception | error | distcp, hadoop, xattr, preserve, filesystem-capability |
| All specified directories have failed to load. | exception | critical | hadoop, hdfs, datanode, storage, startup, fatal |
| Can not create a Path from an empty string | exception | error | hadoop, hdfs, path, empty-string, illegalargumentexception, configuration |
| Can't get alias " + alias + " from " + getPathAsString() | exception | error | hadoop, credential-provider, keystore, aliases, jceks |
| "Cannot append to lazy persist file " + path | exception | error | hdfs, append, storage-policy, lazy-persist |
| failed to append to non-existent file | exception | error | hdfs, append, file-not-found, createflag, writer-sink |
| file modifier options not compatible with stream | exception | error | hadoop, sequence-file, api-misuse, invalid-argument |
| : FileSystem is closed! | exception | error | sftp, filesystem-closed, lifecycle, hadoop, filesystem-cache |
| Hadoop home directory | exception | error | hadoop, shell, hadoop-home, filenotfound, configuration |
| Key/value class provided does not match the file | exception | error | hadoop, sequence-file, append, schema-mismatch |
| Killing tasks in LocalJobRunner is not supported | exception | error | hadoop, mapreduce, local-mode, task-kill, unsupported-operation |
| Multipart upload failed | exception | critical | bos, multipart-upload, upload-aborted, data-loss, hadoop |
| No version in key path | exception | error | java, hadoop, key-provider, parsing, key-name |
| Param op must be specified. | http | error | hdfs, offline-image-viewer, webhdfs, http, query-parameter |
| Property not found within | exception | error | dynamometer, jmx, metrics, configuration |
| Replica is not readable, block= | exception | error | hdfs, datanode, read-path, replica-state, rbw |
| "Requested data length " + dataLength + " is longer than… | exception | error | rpc, message-size, configuration, hadoop-ipc |
| Too many spill files got created, control it with… | exception | error | hadoop, mapreduce, spill, io-sort-buffer, configuration, limits |
| Cannot mlock a non-direct ByteBuffer | exception | error | native-io, mlock, bytebuffer, memory |
| Failed to serialize object to JSON | exception | error | json, serialization, hadoop-common |
H11 Could not load Hadoop config files | error_code | critical | httpfs, hadoop-conf, xml, configuration, parsing |
| Hybrid metrics: registry required. | exception | error | metrics2, hadoop, annotation, builder, hybrid-source |
| Invalid MD5 file : the content " " does not match the… | exception | error | md5, regex, file-format, validation, checksum |
| Invalid payload length | exception | critical | hdfs, data-transfer, corruption, wire-protocol, packet |
| KeyProvider was found but it is a transient provider. | exception | error | kms, encryption, security, hadoop-common, configuration |
| does not exist, r= | exception | error | hdfs, datanode, replica-files, checksum-meta, file-not-found |
| null argument passed in equal(). | exception | error | hadoop, serialization, writable, equals-contract, null-check |
| Storage not yet initialized for | exception | error | hadoop, hdfs, datanode, rpc, startup, initialization |
| too many failures downloading events | exception | error | mapreduce, shuffle, rpc, resourcemanager, retry, app-master |
| Unauthorized connection for super-user | exception | error | authorization, proxy-user, ip-allowlist, security, hadoop, core-site |
| Undefined scheme for " + u | exception | error | hdfs, configuration, uri, storage |
| WebImageViewer does not support secure mode. To start in… | exception | error | hdfs, offline-image-viewer, webhdfs, kerberos, security |
| Bad EC policy configuration file: top-level element not | validation | error | hdfs, erasure-coding, ec-policy, xml, schema-validation, configuration |
| Bootstrap's JavaScript requires jQuery | exception | error | javascript, bootstrap, jquery, script-order, hdfs-web-ui |
| Can't store credential " + alias + " in " + this | exception | error | hadoop, credential-provider, keystore, jceks, store-type, write-failure |
| detachCurrentThreadFromJvm: GetJavaVM failed with error | console | warning | libhdfs, windows, jni, thread-detach, dll |
| Input array can not be null | exception | error | null-safety, toarray, null-pointer, set |
| Invalid Path element | exception | error | registry, dns, path, naming, validation |
| Invalid value in server response: name= | exception | error | java, hadoop, webhdfs, json, datanode, compatibility |
| No queues defined | exception | error | hadoop, mapreduce, queues, xml, empty-configuration |
| Not an OOB status | exception | error | hadoop, hdfs, datanode, oob, status, validation |
| read past end of stream reading | exception | error | hadoop, mapreduce, shuffle, network, truncated-response, fetcher |
S13 Missing system property | exception | critical | httpfs, system-property, startup, network, configuration |
| security validation of TT Map output failed | exception | error | hadoop, mapreduce, shuffle, security, hmac, job-token |
| The source and destination are the same | exception | error | hadoop, rename, file-already-exists, filesystem, validation |
| You must set the VECSUM_TYPE environment variable to… | console | error | environment-variable, configuration, vecsum, startup-validation |
| adding an additional class would exceed the maximum number… | exception | error | hadoop, serialization, writable, mapwritable, limits |
| "append: lastBlock=" + lastBlock + " of src=" + path + " is… | exception | error | hdfs, append, replication, retry, datanode |
| Can't handle old inotify server response. | exception | error | hdfs, inotify, version-skew, backward-compatibility |
| createNonRecursive unsupported for this filesystem | exception | error | hadoop, filesystem, create, unsupported-operation |
| Interrupted while choosing DataNode for read. | exception | error | hdfs, interrupt, datanode, backoff |
| Invalid value for "mapreduce.task.spill.files.count.limit"… | exception | error | |
| Mkdirs is not supported in pseudo local file system. | exception | error | hadoop, gridmix, pseudo-local-fs, unsupported-operation, mkdirs |
| Proxy error: fs.s3a.proxy.port set without fs.s3a.proxy.host | exception | error | s3a, proxy, configuration |
| task not found with id | http | warning | hadoop, mapreduce, jobhistory, rest, http-404, task-id, not-found |
| threadCreate: pthread_create failed with error | console | error | libhdfs, pthread, thread-creation, resource-limits, posix |
| Unable to become active. Service became unhealthy while… | exception | error | hadoop, high-availability, graceful-failover, health-check |
| doesn't support unsetStoragePolicy | exception | error | hadoop, filesystem, storage-policy, hdfs, unsupportedoperationexception |
| FileMetadata not match key:" + key | exception | error | bos, metadata-mismatch, invariant, internal-api, hadoop |
| Illegal load factor: " + loadFactor | exception | error | hadoop, java, gset, load-factor, constructor |
| Invalid HTTP POST operation | exception | error | httpfs, webhdfs, rest-api, http-post, operation-dispatch, bad-request |
| Invalid type of acl in | validation | error | hadoop, acl, validation, parsing, enum |
| next value iterator failed | exception | error | mapreduce, reducer, iterator, backup-store, local-disk |
| No Path in deserialized FileStatus | validation | error | hadoop, java-serialization, filestatus, invalid-object |
| (null) entry in command string | exception | error | hadoop, shell, process, null-argument, command-execution |
| Too many matches | exception | error | hadoop, hdfs, glob, ambiguous-match, copy, shell |
| Unable to failover to | exception | critical | hadoop, high-availability, failover, name-node, qjm |
| Unable to stat path: " + original | exception | error | hadoop, stat, shell-command, empty-output |
| Wrong number of partitions in keyset | exception | error | mapreduce, partitioning, total-order-sort, sampling, configuration |
| Can't create keystore | exception | critical | hadoop, credential-provider, keystore, jvm, fips, jceks |
| Code is not implemented | exception | error | registry, not-implemented, unsupported-api, filesystem-backend, hadoop-registry |
| Concat is not supported by ChecksumFileSystem | exception | error | hadoop, filesystem, concat, local-filesystem, checksum-fs, unsupported-operation |
| Could not complete transfer, Reply Code | exception | error | ftp, transfer-aborted, stor, quota |
| detachBlock:Block not found. | exception | error | block, hardlink, volume, hdfs, datanode |
| File exists | exception | error | movefromlocal, file-exists, destination-conflict, hadoop-shell |
| Folder already exists! Delete manually or provide another… | exception | error | hdfs, offline-image-viewer, leveldb, temp-dir |
| Interrupted waiting for lockSharedStorage() response | exception | error | qjm, rollback, interrupt, shutdown, misleading-message |
| Interrupted waiting " + timeoutMs + "ms for a quorum of… | exception | error | hdfs, qjm, journal-node, ha, interrupted, edit-log |
| Invalid state for recovering from replica with blk id | exception | error | hdfs, datanode, replica, builder, block-recovery, conflicting-arguments |
| Proposed epoch <= last promise ; journal id | exception | error | qjm, epoch, fencing, split-brain, ha-failover |
| The EnumSet argument is null, or is an empty set but with… | exception | error | hadoop, serialization, writable, enumset, null-check |
| wildcard_expandPath: on closedir | console | warning | hdfs, libhdfs, classpath, closedir, wildcard-expansion |
| block pool is not found | exception | error | hdfs, datanode, block-pool, registration, race-condition |
| doesn't support satisfyStoragePolicy | exception | error | hadoop, filesystem, storage-policy, hdfs, unsupportedoperationexception |
| Expected quoted string | exception | error | hadoop, mapreduce, join, parser, quoting |
| Factory is not in SERVER mode. Actual mode is | validation | error | ssl, tls, illegal-state, mode-mismatch, hadoop |
| File does not exist: (inode ) | exception | error | hdfs, lease, file-deleted, filenotfound, concurrent-write |
| File " + original + " does not exist | exception | error | hadoop, stat, file-not-found |
| file VERSION has " + name + " missing. | exception | critical | hdfs, version-file, corruption, storage, startup |
| Must specify either -getlevel or -setlevel | validation | error | hadoop, logging, cli, loglevel, usage |
| cannot be empty | validation | error | httpfs, empty-string, argument-validation, input-validation |
| No matching attributes found for remove operation | exception | error | hdfs, xattr, remove, not-found, idempotency |
| Offset: exceeds file length | exception | error | hdfs, offset, validation, read |
| Op has size , but the minimum op size is | exception | error | hdfs, edit-log, corruption, truncation, limits |
| ${resource} | exception | error | json, classpath, packaging, hadoop-common |