apache/hadoop
Documented errors, page 20 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Bootstrap's JavaScript requires jQuery version 1.9.1 or… | exception | error | javascript, bootstrap, jquery, version-mismatch, hdfs-web-ui |
| checkpoint directory does not exist or is not accessible. | exception | error | hdfs, secondary-namenode, checkpoint, missing-directory, storage, startup |
| Could not find configured fencing method | exception | error | hadoop, configuration, fencing, classpath, class-not-found |
| EOF while reading header from the metadata file. The meta… | exception | error | hdfs, datanode, block-metadata, corruption, disk |
| exception in compare | exception | error | |
| Failed to disconnect | exception | warning | ftp, hadoop, connection-cleanup, masked-exception |
| filters cannot be or-ed | exception | error | bloom-filter, incompatible-parameters, merge, hadoop-common |
| getLinkTarget on path | exception | error | viewfs, hadoop, symlink, mount-table, configuration |
| Incompatible namespaceID for journal | exception | error | qjm, journalnode, namespace-mismatch, format, configuration |
| Invalid stream type: \"" + s + "\" | validation | error | hadoop-aws, configuration, input-stream, hadoop-3-4-upgrade, illegal-argument |
| map= is negative. Please check | exception | error | hdfs, router, federation, rename, configuration, misconfiguration |
| Operation not supported | exception | error | hadoop, hdfs, symlink, unsupported-operation, copy, shell |
| The new recovery id: must be greater than the current one | exception | error | hdfs, datanode, block-recovery, generation-stamp, replica, illegal-argument |
| threadLocalStorageGet: pthread_key_create failed with error | console | error | libhdfs, pthread, tls, thread-local-storage, resource-limits |
| Can't cast key for in keystore to a KeyMetadata. Key may… | exception | error | keystore, kms, crypto, metadata, keytool, type-mismatch |
| Cannot mark as corrupt because datanode ( ) does not exist | exception | warning | hdfs, corrupt-replica, datanode-registration, incremental-block-report, namenode |
| "Concat operation doesn't support " +… | exception | error | hdfs, concat, reserved-path, encryption-zone |
| Couldn't find listing-file at | exception | error | distcp, hadoop, listing, sequencefile, corruption |
| error in shuffle in | exception | critical | hadoop, mapreduce, shuffle, task-failure, concurrency |
| Fail to rename tmp file | exception | error | distcp, hadoop, rename, concat, blocksperchunk |
| is not currently healthy. Cannot be failover target | exception | error | hadoop, high-availability, graceful-failover, health-check |
| limit value must be greater then 0 | validation | warning | mapreduce, job-history-server, rest, query-params, validation |
| Multipart uploads are disabled for the FileSystem, the… | exception | error | aws, s3a, committer, multipart-upload, configuration |
| Popover requires tooltip.js | exception | error | javascript, bootstrap, popover, tooltip, script-order |
| Router Federation Rename is interrupted while checking… | exception | warning | hdfs, router, federation, rename, interrupted, shutdown |
| source map cannot be null | exception | error | hadoop, serialization, writable, null-check, mapwritable |
| Stream closed. | exception | error | aliyun-oss, stream-lifecycle, write-after-close, hadoop-connector |
| The NameNode is configured to report UNHEALTHY to ZKFC in… | exception | error | hdfs, namenode, ha, safemode, health-check, zookeeper-failover |
| Too many chunks created with splitRatio | exception | error | distcp, hadoop, dynamic, configuration, capacity |
| User is null while setting up jobhistory eventwriter | exception | error | mapreduce, job-history, ugi, kerberos, user-identity |
| Attempt to create an encryption zone for a file. | exception | error | hdfs, encryption-zone, path-type, provisioning |
| Can't replace . Target is , Source is | exception | error | distcp, hadoop, path-conflict, type-mismatch, filesystem |
| Failed to replace a bad datanode on the existing pipeline… | exception | error | |
| Incomplete map output received for | exception | error | hadoop, mapreduce, shuffle, truncated-response, validation |
| Invalid Path | exception | error | registry, zookeeper, path, validation |
| listXAttrs on path ` ' is not within a mount point | exception | error | viewfs, mount-table, xattr, hadoop-common, java |
| Missing entry | exception | error | cli, setfacl, acl, empty-spec, hadoop |
| cannot be null | validation | error | httpfs, null-check, argument-validation, programming-error |
| numLevels must be at least 1 | exception | critical | hadoop, ipc, configuration, callqueue, validation, server-startup |
| Reducer has been already set | exception | error | hadoop, mapreduce, chain, duplicate-setup, illegalstate |
| Unexpected metrics type | exception | error | metrics2, hadoop, metric-name-collision, type-mismatch |
| Cannot seek to a negative offset " + targetPos | exception | error | bos, input-stream, seek, negative-offset, hadoop |
| "Content-Length header is not provided by the server when… | exception | error | hdfs, edit-log, http, content-length, proxy, chunked-encoding |
| expected </DATA> | validation | error | hdfs, offline-edits-viewer, oev, edit-log, xml, nesting |
| Failed to find in INodeSection. | exception | error | hdfs, reversexml, fsimage, required-field, inodesection |
| Failed to instantiate class | exception | error | s3a, hadoop-aws, auditing, reflection, configuration, class-loading |
| File not found in | exception | error | hadoop, har-filesystem, file-not-found, liststatus, archive-index |
| hdfsThreadDestructor: Unable to detach thread | console | warning | libhdfs, jni, detachcurrentthread, thread-exit, tls-destructor |
| Input Iterator not markable | validation | error | |
| interrupt exception | exception | error | |
| Move destination must be different from source for | exception | error | gcs, hadoop-gcp, rename, no-op, argument-validation |
| Property not specified | exception | error | hadoop, ssl, tls, keystore, configuration, http-server |
| Unexepcted blockpoolID " + bpid + " . Expected " +… | exception | critical | hdfs, namenode, storage, blockpool, clusterid |
| cannot access checkpoint directory. | exception | error | hdfs, secondary-namenode, checkpoint, permissions, security-manager, startup |
| catch exception when allocating BosBlockBuffer: | exception | error | bos, out-of-memory, buffer-allocation, output-stream, hadoop |
| Don't support Quota for storage type | exception | error | hdfs, quota, storage-type, ram-disk, unsupported-operation |
| Event schema string not parsed since its null | exception | error | hadoop, mapreduce, jobhistory, truncated-file, empty-file, ioexception |
| expected a tag | validation | error | hadoop, hdfs, offline-edits-viewer, xml, parsing |
| Got an IO exception | exception | error | hadoop, high-availability, failover, rpc, network |
| Illegal parameters to TransferFsImage | exception | error | hdfs, http, request-validation, query-params |
| Invalid number format | validation | warning | mapreduce, job-history-server, rest, query-params, validation |
| Malformed gss token | exception | error | kerberos, spnego, gss-api, token-parsing |
| Problem in starting http server. Server handlers failed | exception | error | hadoop, http-server, jetty, startup, filter |
| ProvidedReplica does not yet support copy data | exception | error | hdfs, datanode, provided-storage, block-replication, read-only |
| secretProvider cannot be NULL | exception | error | hadoop-auth, signing, null-check, constructor |
| Specified path does not exist | exception | error | hadoop, datanode, storage-dir, disk, path-not-found, configuration |
| There is no primary group for UGI " + this | exception | error | hadoop, ugi, group-mapping, permissions |
| Unknown BlockChecksumType: " + groupChecksumType | exception | error | hdfs, datanode, erasure-coding, block-checksum, enum-switch |
| Unknown Job | exception | error | mapreduce, am-client, job-id, rpc |
| Block cannot be null | validation | error | hdfs, provided-storage, alias-map, null-check, rpc-client |
| Certificate exception storing keystore | exception | error | hadoop, credential-provider, keystore, certificate, flush, jceks |
| Incompatible shuffle response version | exception | error | hadoop, mapreduce, shuffle, protocol, version-mismatch, http-headers |
| Index entry size out of range | exception | error | tfile, hadoop-common, index, data-corruption, io |
| Invalid rule | exception | error | kerberos, configuration, auth-to-local, startup |
| Namenode metrics is not initialized | exception | error | hdfs, router-based-federation, metrics, startup-race, jmx |
| Premature EOF from inputStream | exception | error | io, eof, truncated-file, hadoop-common |
| setErasureCodingPolicy is not supported for HttpFs on | exception | error | httpfs, webhdfs, erasure-coding, unsupported-operation, fs-defaultfs |
| tlsCallback: TlsFree failed with error | console | info | libhdfs, windows, tls, tlsfree, dll-unload |
| -uri is not specified. | validation | error | hadoop-compat-bench, cli, command-line-arguments, uri |
| A file cannot be created in root. | exception | error | gcs, rename, root-path, path-validation |
| Edits file is not found in | exception | critical | hadoop, hdfs, namenode, edits, storage-dir, legacy-format |
| Error validating LDAP user | exception | error | |
| Incorrect data format. ConcatDeleteOp can have at most | exception | error | hdfs, edit-log, corruption, concat, limits |
| authentication is not enabled. Available | exception | critical | rpc, sasl, security, authentication, configuration, mismatch |
| No more elements | exception | error | iterator, no-such-element-exception, concat, programming-error |
| Path is not a file | exception | error | hdfs, namenode, path-type, file-not-found, namespace |
| Running in secure mode, but config doesn't have a keytab… | exception | error | kerberos, keytab, configuration, startup |
| SAX error | exception | error | hdfs, offline-edits-viewer, xml, sax, output-stream |
| Unknown OpenFileType | validation | error | hdfs, namenode, client-protocol, enum, illegal-argument, open-files |
| Wrong length | validation | error | md5, checksum, validation, hadoop-common |
| "Access denied for user " + pc.getUser() + ". Superuser or… | exception | error | hdfs, quota, permissions, access-control |
| Access denied: User does not have permission to view job | http | error | mapreduce, web-ui, http-403, acl, authorization, applicationmaster |
| closed | exception | error | bzip2, compression, write-after-close, lifecycle, hadoop |
| diff= is negative. Please check | exception | error | hdfs, router, federation, rename, configuration, diff |
| HADOOP_CONF_DIR is not valid: " + srcDir | exception | error | hadoop-compat-bench, environment-variables, hadoop-conf-dir, invalid-path |
| Illegal initial capacity: " + initCapacity | exception | error | hadoop, java, gset, constructor, argument-validation |
| no SharedFileDescriptorFactory paths were configured. | exception | error | short-circuit-reads, shared-memory, configuration, hdfs |
| Replica cannot be moved from storageType | exception | warning | hadoop, hdfs, datanode, fsdataset, lazy-persist, ram-disk, mover |
| is not appendable. | exception | error | hadoop-tos, volcengine-tos, append, fns, object-semantics |
| Unexpected EOF while trying to read response from server | exception | error | hdfs, eof, network, inotify, protobuf-framing |