apache/hadoop
Documented errors, page 18 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Cannot create a file whose name looks like a directory | exception | error | gcs, create, path-validation, trailing-slash |
| Compression option provided does not match the file | exception | error | hadoop, sequence-file, append, compression, codec-mismatch |
| Could not create directory | exception | error | hdfs, secondary-namenode, checkpoint, mkdir-failed, disk-full, storage |
| Error parsing archives argument. Argument must be a valid… | exception | error | distributed-cache, uri, archives-option, job-submission, mapreduce |
| Error reading md5 file at | exception | error | filesystem, md5, io-error, permissions, checksum |
| Improper queue name | exception | error | hadoop, mapreduce, queues, queue-name, configuration, validation |
| Invalid mode | validation | error | hadoop, fs-shell, find, permissions, symbolic-mode, argument-validation |
| Must start privileged NFS server with… | exception | critical | nfs-gateway, hadoop, configuration, privileged-port, startup, jsvc, daemon |
| No more entries | exception | error | hdfs, remote-iterator, no-such-element-exception, iterator-misuse, distributed-filesystem |
| No valid image files found | exception | critical | hadoop, hdfs, namenode, fsimage, storage-dir, startup |
| is not a valid runState. | exception | error | hadoop, mapred, job-status, tos, enum-mapping |
| serial id > | exception | critical | hdfs, fsimage, serial-number, data-corruption, image-load, illegal-state |
| setAcl is only supported by storage accounts with the… | exception | error | azure-abfs, acl, hierarchical-namespace, unsupported-operation, setacl |
| The flush interval property must be at least 1 minute… | exception | error | metrics2, rolling-file-sink, configuration, range, validation |
| Unexpected block size | exception | error | hdfs, serialization, data-corruption, wire-protocol |
| Can not read resource file | exception | error | classpath, resources, packaging, hadoop-common |
| Configuration file not found at | exception | critical | hadoop, mapreduce, queues, configuration, missing-file, startup |
| Could not initialize target File System for URI | exception | error | hadoop, viewfs, mount-table, filesystem, lazy-init, uri |
| Could not locate Hadoop executable | exception | error | hadoop, windows, winutils, executable, filenotfound |
| createSymlink is not supported in ViewHDFS | exception | error | hdfs, viewfs, symlink, unsupported |
| Entries are not comparable for unsorted TFiles | exception | error | hadoop, tfile, unsorted, comparator, reader |
| Error loading token state from | exception | error | mapreduce, job-history-server, leveldb, state-store, data-corruption |
| Failed to since is set to false. | exception | error | hdfs, storage-policy, configuration, namenode |
| getAclStatus is only supported by storage account with the… | exception | error | azure-abfs, acl, hierarchical-namespace, unsupported-operation, getaclstatus |
| Host is not authorized for protocol | exception | error | authorization, acl, host-acl, rpc, hadoop-policy, hadoop, security |
| Negative Position | exception | error | hdfs, webhdfs, io, seek, offset-validation |
NO_SUCH_PLAN No such plan. | exception | error | hdfs, diskbalancer, cancel-plan, plan-id, dfsadmin |
| doesn't exist | exception | error | distcp, path-not-found, input-validation, file-listing |
S14 Could not initialize server | exception | critical | httpfs, dns, startup, network, hostname-resolution |
| unsetErasureCodingPolicy is not supported for HttpFs on | exception | error | httpfs, webhdfs, erasure-coding, unsupported-operation, fs-defaultfs |
| wrong key class: is not | exception | error | hadoop, sequence-file, type-mismatch, append |
| {blockURI} | exception | critical | hdfs, datanode, block-check, file-not-found, data-loss, disk-failure |
| FileSystem ' 'is not a ViewFileSystem. | exception | error | viewfs, type-mismatch, fs-status, hadoop-common, java |
| getFileChecksum(Path, long) is not supported by | exception | error | hdfs, checksum, symlink, cross-filesystem, unsupported-filesystem, distributed-filesystem |
INVALID_MOVE Disk Balancer - Source and destination volumes are same | exception | error | disk-balancer, invalid-move, plan-validation, hdfs |
| is not a number | exception | error | javascript, json, numeric, validation, hdfs-web-ui |
| It is not allowed to rename a parent directory | exception | error | cosn, hadoop, rename, subdirectory, cycle-prevention |
| millis timeout while waiting for channel to be ready for … | exception | error | hadoop-common, network, timeout, nio, java |
| NameNode format aborted as reformat is disabled for this… | exception | error | hdfs, namenode, format, configuration, safety-guard |
| Path part from URI is not a valid filename. | validation | error | hadoop, path, filename, validation, hdfs |
| Properties not found for storage directory " + sd | exception | critical | hdfs, namenode, storage, version-file, startup |
| Response is null. | exception | error | hadoop, ipc, rpc-client, network, eof, connection-drop |
| SetWorkingDirectory is not supported in pseudo local file… | exception | error | hadoop, gridmix, pseudo-local-fs, unsupported-operation, working-directory |
| Timed out waiting for lockSharedStorage() response | exception | error | qjm, rollback, timeout, journalnode, misleading-message |
| Unsupported gauge type | exception | error | metrics2, hadoop, annotation, type-mismatch, reflection |
| Address type of does not match required type of | exception | error | registry, endpoint, address-type, validation |
| Append on block returned a replica of state ; expected RBW | exception | error | hdfs, datanode, append, invariant, custom-fsdataset |
| args = | validation | error | hdfs, balancer, cli, argument-validation |
| Cannot compare keys for unsorted TFiles. | exception | error | hadoop, tfile, unsorted, comparator, reader |
| Cannot finalize with no NameNode active | exception | error | hdfs, dfsadmin, ha, namenode, finalize-upgrade, high-availability |
| Did not expect argument | validation | error | hadoop, hdfs, getconf, cli, arguments |
| End of stream reached draining data between ranges… | exception | error | s3a, hadoop-aws, vectored-read, eofexception, network, connection-reset |
| getSnapshottableDirListing is not supported for HttpFs on | exception | error | httpfs, webhdfs, snapshot, unsupported-operation, fs-defaultfs |
| Incompatible clusterIDs in | exception | critical | hadoop, hdfs, datanode, storage, clusterid, mismatch, reformat |
| Invalid job run state | exception | error | hadoop, mapreduce, outputcommitter, job-lifecycle, invalid-state |
| Invalid "mapreduce.task.io.sort.mb | exception | error | |
| key + ": Stream is closed!" | exception | error | bos, input-stream, stream-closed, lifecycle, hadoop |
| NameNode directory " + sd.getRoot() + " is not formatted. | exception | critical | hdfs, namenode, format, storage, version-file |
| offs( ) + len( ) > buf.length( ). | exception | error | bzip2, compression, invalid-argument, bounds, off-by-one, hadoop |
OLD_PLAN_SUBMITTED Plan was generated more than | exception | error | disk-balancer, plan-expiry, configuration, hdfs, datanode |
| "Source file " + src + " and target file " +… | exception | error | hdfs, concat, erasure-coding, policy-mismatch, precondition |
| The stream is null. | exception | error | java, hadoop, webhdfs, http, json, response-body |
| Thread aborted | exception | error | distcp, hadoop, bandwidth, throttling, interruption |
| Unable to create aliasmap snapshot directory | exception | error | hdfs, provided-storage, aliasmap, snapshot, leveldb |
| *********** Upgrade is not supported from this older… | exception | critical | hdfs, upgrade, layout-version, namenode, storage |
| Can't re-install the signal handlers. | exception | error | hadoop, unix-signals, initialization, illegalstate, singleton |
| Error generating shuffle secret key | exception | error | |
| Failed to obtain current username | exception | error | java, hadoop, webhdfs, kerberos, authentication, usergroupinformation |
| File " + p + " does not exist | exception | error | hadoop, local-filesystem, set-times, file-not-found, filenotfoundexception, metadata |
| Illegal escaped string | exception | error | hadoop, stringutils, escaping, configuration, illegalargument |
| Input file does not contain valid topology data. | exception | error | hadoop, rumen, json-parsing, topology, empty-file |
| Invalid packet: data length in packet header exceeds data… | exception | critical | hdfs, data-transfer, packet, corruption, checksum |
| Invalid permission ' ' in permission string | exception | error | zookeeper, acl, configuration, validation, hadoop-common |
| No compressed file found in the input directory | exception | error | |
| Object doesn't exit | exception | error | hadoop-tos, volcengine-tos, object-not-found, zero-length-read |
| The value does not map to a valid checksum Type | exception | critical | hdfs, checksum, type-mapping, version-skew, corruption |
| There is already an existing lease operation | exception | error | azure-blob, abfs, lease, concurrency, async |
| Unsupported path please check mount table | exception | error | hadoop, rbf, mount-table, path-resolution, malformed-record |
| User: is not allowed to impersonate | exception | error | authorization, proxy-user, impersonation, security, hadoop, core-site |
| Capacity ratio config is not with correct format | exception | error | hdfs, datanode, storage, config, capacity, tiering, illegal-argument |
| does not support seek. | exception | error | crypto, hdfs, stream, seek, hadoop |
| Client already attempted negotiation | exception | critical | rpc, sasl, security, state-machine, retry |
| delay= is negative. Please check | exception | error | hdfs, router, federation, rename, configuration, delay |
| Destination ' ' directory cannot be created | exception | error | hadoop, hdfs, datanode, fsdataset, checksum, mkdir, permissions |
| doesn't exist in mount table. | exception | error | hdfs, rbf, federation, quota, mount-table, not-found |
| Expected classpath expansion length to be %zu but instead… | console | error | hdfs, libhdfs, classpath, race-condition, wildcard-expansion |
| file VERSION has no block pool Id. | exception | critical | hdfs, namenode, storage, blockpool, version-file |
| GCS path supports only | exception | error | uri, gcs, hadoop, scheme, validation |
| getSnapshotDiff is not supported for HttpFs on | exception | error | httpfs, webhdfs, snapshot-diff, unsupported-operation, fs-defaultfs |
| Initialization of all the collectors failed. Error in last… | exception | error | |
| modification=" + modification + " != iterModification = " +… | exception | error | collections, iterator, concurrency, hadoop-common |
| No class configured for | exception | error | hdfs, namenode, edit-log, journal-manager, configuration, missing-config |
| no entry found for | exception | error | xml, fsimage, offline-image-viewer, hdfs, parsing |
| : No such file or directory! | exception | error | aliyun-oss, file-not-found, path-resolution, hadoop-connector |
| Premature EOF from inputStream after skipping | exception | error | io, eof, seek, truncated-file, hadoop-common |
| Results differed for getJournalCTime | exception | error | qjm, upgrade, ctime, state-divergence, consensus-check |
| The LAZY_PERSIST storage policy has been disabled by the… | exception | error | hdfs, storage-policy, lazy-persist, create-flag, namenode-config |
| Trying to remove more than one block from file | exception | error | hdfs, namenode, edit-log, replay, blocks, abandon-block, corruption |
| unknown DiffEntry type | exception | error | hdfs, offline-image-viewer, protobuf, snapshot, version-mismatch |
| Virtual IP for failover not found,misconfigured | validation | error | hdfs, observer-name-node, ip-failover, configuration |