apache/hadoop

Documented errors, page 16 of 39. Back to apache/hadoop

Code / MessageTypeSeverityTags
E_WRONG_FS
Output path is not on an S3A Filesystem
exception error s3a, filesystem-scheme, committer, hadoop
Failed to multipart upload to oss, abort it.
exception critical aliyun-oss, multipart-upload, interrupt, hadoop-connector
Har: startLocalOutput not allowed
exception error hadoop, har-filesystem, read-only, local-output, fileutil-copy
Job failed!
exception error
Keys are not added in sorted order
exception error hadoop, tfile, sorted-order, comparator, writer
Not implemented
exception warning hdfs, router-based-federation, batched-listing, unsupported-operation, version-compat
Parent directory doesn't exist
exception error hadoop, filesystem, create, missing-directory, local-filesystem, file-not-found
Replica does not exist
exception error hdfs, datanode, block-write, replica-not-found, temporary-replica
setMapFinishTime() not supported for ReduceTask
exception error hadoop, mapreduce, task-status, unsupported-operation, reduce
The layout version supports inodeId but gave bogus inodeId
exception error hdfs, namenode, edit-log, inode-id, layout-version, corruption, replay
Unable to write to output stream.
exception error io, print-stream, broken-pipe, hadoop-common
Unexpected data node
exception error hadoop-common, network-topology, nodegroup, invalid-topology
Value of is null
validation error hdfs, erasure-coding, ec-policy, xml, configuration
Attempted to seek or read past the end of the file " + pos
exception error hadoop-aws, prefetch, seek, eof, cache-corruption
blockSize( ) < 1
exception error bzip2, compression, invalid-argument, constructor, hadoop
Cannot get the remote user name
exception error hdfs, router, federation, access-control, superuser, rpc-context
Cannot lock storage . The directory is already locked
exception critical hdfs, storage-directory, file-lock, startup, namenode, datanode
Cannot recover task
exception error hadoop, mapreduce, manifest-committer, job-recovery, am-restart
does not exist.
exception error filesystem, md5, precondition, file-not-found, checkpoint
File copy failed: -->
exception error distcp, hadoop, copy, io, retry
getMapFinishTime() not supported for ReduceTask
exception error hadoop, mapreduce, task-status, unsupported-operation, reduce
Illegal configuration value for…
exception error hdfs, configuration, fail-fast, client-startup
Illegal Unicode Codepoint
exception error hadoop-record, unicode, utf-8, serialization, deprecated
modification= != startModification =
exception error iteration, fail-fast, concurrent-modification, linked-set
Named output name cannot be 'part'
validation error hadoop, mapreduce, multiple-outputs, reserved-name, naming
Negative length of the file
exception critical hadoop, hdfs, namenode, fsimage, truncated-file, disk-full
Operating system not supported by this class
exception error hadoop-streaming, platform-support, environment-variables, os-detection
parts length mismatched
exception error hadoop, tos, filestore, multipart-upload, data-integrity
Session credentials in Hadoop configuration: No AWS…
exception error s3a, hadoop-aws, credentials, session-token, sts, authentication
Signer class [ ] not found for signer [ ]
exception error aws, s3a, signer, classpath, class-not-found
The modification time for the record cannot be negative.
validation error hdfs, router-based-federation, state-store, record-validation, timestamps
unknown flags set in ModifyCacheDirectiveInfoOp
exception error hadoop, hdfs, namenode, cache-directive, edits, serialization, version-mismatch
Already have a finalized segment
exception critical qjm, edit-log, segment-conflict, corruption, split-brain, fencing
Bad policy is found in EC policy configuration file
validation error hdfs, erasure-coding, ec-policy, xml, schema-validation
Bucket not found
exception error gcs, hadoop-gcp, copy, bucket-not-found, validation
CheckAccess operation is only supported on HNS enabled…
exception error azure, abfs, unsupported-operation, hns, access-check
input array component type
exception error hadoop, serialization, writable, type-validation, primitive-array
new destination is an existed directory
exception error hadoop, obs, rename, destination-exists, directory
No DFS found in child fs. This API can't be supported in…
exception error hdfs, viewfs, centralized-caching, unsupported, remote-iterator
No more corrupt file blocks
exception warning hdfs, iterator, corrupt-files, api-misuse
Not a hex character
exception error md5, hex, validation, hadoop-common
output stream is out of sync, pos=
exception critical nfs-gateway, hdfs, write-path, data-integrity, invariant, nfs3
S03
Could not load file from classpath
error_code critical httpfs, server-startup, classpath, log4j, deployment-corruption
Unexpected BlockPoolId
exception error hdfs, federation, block-pool, misconfiguration, ha
Algorithm not matched. Expected
exception error java, hadoop, webhdfs, checksum, response-validation
BlockId is not valid.
exception error hadoop, hdfs, datanode, fsdataset, replica, block-not-found
Cannot delete/rename subdirectory under protected…
exception error hdfs, namenode, protected-directories, delete, rename, permissions, policy
Cannot start datanode because the configured max locked…
exception critical hadoop, hdfs, datanode, ulimit, memlock, centralized-cache, os-limits
Couldn't open queue configuration at " + xmlInUrl
exception critical hadoop, mapreduce, configuration, classpath, file-io, startup
Expected ','
exception error hadoop, mapreduce, join, parser, expression, syntax
Got unxpected characters while looking for
exception error hdfs, reversexml, xml-text-content, fsimage
Invalid
validation error hadoop, acl, validation, parsing
Invalid blacklistDisablePercent
validation error mapreduce, configuration, blacklisting, validation, am-init
modification= != expectedModification =
exception error iteration, fail-fast, concurrent-modification, set
Namenode is in startup mode
exception warning hdfs, namenode, startup, retry, rpc
new destination is an existed file
exception error hadoop, obs, rename, destination-exists, overwrite
No key-value to read
exception error hadoop, tfile, scanner, eof, iteration
No KeyProviderFactory for
exception error java, hadoop, key-provider, configuration, uri-scheme, classpath
Output directory not set.
validation error hadoop, mapreduce, job-configuration, output-path, job-submission
Reset called without a previous mark
exception error mapreduce, reducer, iterator, mark-reset, state-machine
tasktype must be either m or r
http warning hadoop, mapreduce, jobhistory, rest, http-400, enum-value, task-type
ViewFs: Cannot initialize: Invalid entry in Mount table in…
validation error hadoop, viewfs, mount-table, configuration, typo
doesn't support deleteSnapshot
exception error hadoop, filesystem, hdfs, snapshot, unsupportedoperationexception, retention
Error sending data
exception error hadoop, metrics2, kafka, interrupt, send
Failed to get home directory
exception error ftp, hadoop, connection, configuration
Failed to remove
exception error hadoop, hdfs, datanode, storage, file-lock, startup
hadoopReadZero failed with error code
console error hdfs, libhdfs, zero-copy, short-circuit, domain-socket, errno, vecsum
InMemoryAliasMap enabled with null location
exception error hdfs, namenode, bootstrap-standby, provided-storage, aliasmap, missing-configuration
Multi-part upload with id
exception critical aliyun-oss, multipart-upload, upload-failure, hadoop-connector
TaskAttemptId string
validation error
too much write to local file system. current value is " +…
exception error hadoop, mapreduce, task-limits, local-disk, configuration, resource-limit
Unsupported layout version
exception critical hadoop, hdfs, namenode, fsimage, layout-version, downgrade
url cannot be NULL
exception error authentication, null-argument, url, hadoop-auth, precondition
Could not parse line
exception error hadoop, disk, df, parsing, fuse, missing-field
Dest filesystem ' ' doesn't support concat.
exception error hadoop, filesystem, concat, unsupported-operation, hdfs, shell
File not found
exception error hadoop, tos, filestore, object-storage, file-not-found
Image file is not found in
exception critical hadoop, hdfs, namenode, fsimage, storage-dir, legacy-format
Invalid -k argument. Must be of the form -k pos1,[pos2]…
validation error mapreduce, sorting, streaming, argument-validation, configuration
Invalid value configured for…
validation critical hadoop, hdfs, datanode, configuration, volume-management, startup
Path already exists as link
validation error hadoop, viewfs, mount-table, configuration, conflict
The dst path= already exists. The admin should delete it…
validation error fedbalance, federation-balance, destination-exists, job-recovery, distcp
threadJoin: WaitForSingleObject unexpected error
console warning libhdfs, windows, waitforsingleobject, thread-join, win32
Undefined for " + x
exception error hadoop, java, sorting, off-by-one, argument-validation
value cannot be blank
validation error configuration, validation, parsing, storage, hadoop
Can't get credential " + alias + " from " +…
exception error hadoop, credential-provider, keystore, jceks, io
Cannot overwrite an existing file
exception error rename, gcs, hadoop, filesystem, google-cloud-storage
Cannot recover append/close to a replica that's not…
exception error hdfs, datanode, block-recovery, replica-state, datanode-restart
Could not create DataChecksum from the byte array of length
exception critical hdfs, checksum, data-integrity, corruption, bytes-per-checksum
Error setting field annotated with
exception error metrics2, hadoop, annotation, reflection, field-injection
FATAL_DESERIALIZING_REQUEST
"IPC server unable to read call parameters: " + t.getMessage()
exception error rpc, deserialization, protobuf, version-mismatch, hadoop-ipc
File system image contains an old layout version
exception critical hdfs, namenode, upgrade, layout-version, startup
key can not be null
exception error bloom-filter, counting-bloom-filter, null-check, precondition, hadoop-common
MR AM not authorized to renew delegation token
exception error mapreduce, delegation-token, renewal, security
The volume has already closed.
exception warning hdfs, datanode, volume, shutdown, race-condition
" + this + " login authentication is not supported
exception error hadoop, ugi, authentication-method, jaas
Unknown committer
exception error s3a, committer, configuration, factory
Cannot finalize block
exception error hdfs, datanode, finalize, thread-interrupt, shutdown
First key length out of range
exception error tfile, hadoop-common, index, key-length, data-corruption
does not specify any options
exception error hadoop, filesystem, create-flag, validation, argument-error
map cannot be copied
exception error hadoop, serialization, writable, mapwritable, copy