apache/hadoop
Documented errors, page 14 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Unable to get log information for task | exception | error | hadoop, mapreduce, yarn, logs, task-attempt, null-field |
| Unexpected not positive size | validation | error | hdfs, name-node, rpc, balancer, getblocks, argument-validation |
| Unknown status: , message | exception | error | hdfs, protobuf, version-skew, data-transfer-protocol |
| bad framework group name | validation | error | hadoop, mapreduce, counters, illegalargument, name-lookup |
| Credentials requested after provider list was closed | exception | error | cosn, hadoop-cos, lifecycle, use-after-close, credentials |
| doesn't support getAclStatus | exception | error | acl, unsupported-feature, object-store, audit, hadoop-fs |
| Failed to rename to ; source is a directory and dest is a… | exception | error | s3a, rename, file-already-exists, type-mismatch |
| getErasureCodingPolicies is not supported for HttpFs on | exception | error | httpfs, webhdfs, erasure-coding, unsupported-operation, fs-defaultfs |
| getUsed on path `/' is not within a mount point | exception | error | viewfs, hadoop, mount-table, linkmergeslash, capacity |
| NameNode initialization not yet complete. FSImage has not… | http | warning | hdfs, namenode, startup, checkpoint, http-403, image-transfer |
| No store location directory configured in… | exception | error | mapreduce, job-history-server, leveldb, recovery, configuration |
| Problem starting http server | exception | error | hadoop, http-server, jetty, startup, configuration |
| Request looked like a retry to allocate block | exception | error | hdfs, addblock, retry, client-state, data-integrity |
| -setlevel needs three parameters | validation | error | hadoop, logging, cli, loglevel, missing-arguments |
| symlinks not supported | exception | error | fs2img, symlink, unsupported-file-type, fsimage, treewalk |
| Type mismatch in key from map: expected | exception | error | hadoop, mapreduce, mapper, serialization, type-mismatch, configuration |
| Unable to rename to : couldn't create parent directory | exception | error | hadoop, mapreduce, spill, rename, local-dirs, disk-full |
| unexpected event type | exception | error | hadoop, mapreduce, jobhistory, enum, runtimeexception, version-skew |
| Exception while processing StorageDirectory " + sd.getRoot() | exception | error | hdfs, configuration, path, storage |
| Expression is null | exception | error | hadoop, mapreduce, join, configuration, missing-property |
| Illegal argument for connect() | exception | error | socket, connect, argument-validation, hadoop-common |
| Invalid URI ' ' has a malformed authority, expected… | exception | error | azure-abfs, uri, authority, container-name, configuration |
| Invalid value: bytesPerChecksum = | validation | error | hdfs, hdfs-client, config, checksum, validation |
| Key length out of range | exception | error | tfile, hadoop-common, data-corruption, io, key-length |
| Negative length | exception | error | hadoop-aws, multipart-uploader, part-handle, corrupt-data, validation |
| Number too large to be represented as Integer | exception | error | tfile, hadoop-common, utils, varint, overflow, data-corruption |
| Permission denied while accessing mount table | exception | error | hdfs, router, federation, mount-table, permission-denied, access-control, admin-api |
| Submit job failed. | exception | error | fedbalance, federation-balance, distcp, job-submission, yarn |
| There is no reducer, no need to use native output collector | exception | error | nativetask, mapreduce, job-configuration, map-only |
| Unknown task symbol | exception | error | hadoop, mapreduce, rest-api, web-ui, query-param, task-type |
| Can't create root path | exception | error | s3a, path, root, create, invalid-argument |
| Can't store keystore " + this | exception | error | hadoop, credential-provider, keystore, flush, persist, jceks |
| "Concat: the source file " + src + " is referred by some… | exception | error | hdfs, concat, snapshot, inode-reference, rename |
| Could not obtain block | exception | critical | hdfs, block-missing, data-loss, read |
| File had invalid length | exception | error | filesystem, corruption, storage, journalnode, metadata |
| Got incremental block report from unregistered or dead node | exception | warning | hdfs, incremental-block-report, datanode-registration, namenode, failover |
| hasPathCapability on path | exception | error | viewfs, hadoop, capability, mount-table, configuration |
| Incorrect state to start a new value | exception | error | hadoop, tfile, state-machine, writer |
| Must specify a key name when creating an encryption zone | exception | error | hdfs, encryption-zone, invalid-argument, key-name |
| Native output collector doesn't support compression codec | exception | error | nativetask, compression, codec, job-configuration |
| No COS Credential Providers | exception | critical | cosn, hadoop-cos, authentication, credentials, configuration |
| no permission supplied | validation | error | hadoop, file-create, permissions, options, validation |
| This feature is disabled. Please refer to… | exception | error | hdfs, write-pipeline, datanode-replacement, configuration |
| Timed out waiting " + timeoutMs + "ms for a quorum of nodes… | exception | critical | hdfs, qjm, journal-node, timeout, quorum, edit-log |
| Unrecognized FSImage | exception | error | hdfs, offline-image-viewer, fsimage, file-format |
| Unresolved topology mapping for host | exception | critical | hdfs, network-topology, datanode-registration, dns, rack-awareness, configuration |
| User cannot perform operation on | exception | error | mapreduce, acl, authorization, access-control |
| address is null. | exception | error | hadoop, java, acl, null-check, host-filter |
| Buffer interrupted while waiting for the writer | exception | error | hadoop, mapreduce, spill, io-sort-buffer, threading, interrupted |
| ConcatDeleteOp can only have | exception | error | hdfs, concat, edit-log, validation, limits |
| Could not instantiate KeyProvider for uri | exception | error | kms, encryption, security, hadoop-common, configuration |
| Couldn't obtain an instance of RawLocalFileSystem. | exception | critical | hadoop, filesystem, static-initializer, configuration |
| Error connecting to file system | exception | error | metrics2, rolling-file-sink, hdfs, network, configuration |
| failed to get group id list for user '" + userName + "' | exception | error | unix, group-mapping, shell, exit-code |
| File is deleted: (inode ) | exception | error | hdfs, namenode, lease, file-not-found, deleted-file |
| got EOF while trying to transfer the file descriptor for… | exception | warning | hdfs, short-circuit-reads, unix-domain-socket, shared-memory |
| Got unexpected tag end event for | exception | error | hdfs, offline-image-viewer, xml, stax, fsimage |
| InMemoryAliasMap location is null | validation | error | hdfs, provided-storage, aliasmap, configuration, leveldb |
| Invalid id:password | validation | error | registry, digest, credentials, validation, hadoop-registry |
| Invalid value for webhdfs parameter "op" | http | error | hdfs, offline-image-viewer, webhdfs, http, query-parameter, unsupported-operation |
| Not a local path: | exception | error | not-a-local-path, local-filesystem, illegal-argument, pathdata |
| ReRegistration of rpcKind | exception | error | rpc, server, registration, initialization, rpc-kind |
| SignVersion is V4 but region is empty | validation | critical | aliyun-oss, configuration, v4-signing, missing-region, hadoop-connector |
| Uri without authority | validation | error | hadoop, uri, authority, filesystem, configuration |
| Block pool is not found | exception | error | hdfs, block-token, security, block-pool, data-node |
| Cannot recover task output for first attempt... | exception | error | hadoop, mapreduce, file-output-committer, task-recovery, app-attempt, api-misuse |
| Checkpoint cannot be an absolute path | exception | error | |
| Credentials should not be null. | validation | error | aliyun-oss, credentials, null-argument, hadoop-connector |
| Failed move to trash. | exception | error | fedbalance, federation-balance, hdfs-trash, cleanup, source-deletion |
| Generation Stamp should be monotonically increased bpid | exception | error | hdfs, datanode, finalize, generation-stamp, lease-recovery |
| "Illegal value for nsQuota or ssQuota : " + nsQuota + " and… | exception | error | hdfs, quota, validation, illegal-argument |
| Passed URI's scheme is not for Hdfs | exception | error | hdfs, uri, configuration, filecontext, hadoop |
| pathName + " can't be moved because encryption zone " +… | exception | error | hdfs, encryption-zone, reencryption, rename, key-rotation |
| rur.getRecoveryID() != recoveryId = | exception | error | hdfs, datanode, block-recovery, generation-stamp, lease-recovery |
| Unable to fence | exception | critical | hadoop, high-availability, zkfc, fencing, split-brain, graceful-failover |
| Unexpected file in store | exception | error | mapreduce, job-history-server, state-store, filesystem, initialization |
| bytes array length error. Actual length is | exception | error | hdfs, offline-image-viewer, leveldb, data-corruption |
| Cannot rename to , is a file | exception | error | cosn, hadoop, rename, enotdir, parent-is-file |
| Child value classes fail to agree | exception | error | hadoop, mapreduce, join, classcast, value-type, type-mismatch |
| Class already registered but maps to and not | exception | error | hadoop, serialization, writable, mapwritable, ipc |
| doesn't support getXAttr | exception | error | xattr, extended-attributes, unsupported-feature, object-store, hadoop-fs |
| doesn't support removeAcl | exception | error | acl, unsupported-feature, object-store, permissions, hadoop-fs |
| error: (no exception) | console | warning | c, libhdfs, jni, jvm, oom, error-handling |
| finishedTimeBegin must be greater than 0 | validation | warning | hadoop, mapreduce, jobhistory, rest, http-400, query-param, time-range |
| Interrupted while copying objects (copy) | exception | error | hadoop, obs, rename, interrupt, concurrency |
| Required edits directory | exception | error | hadoop, hdfs, namenode, configuration, edits-dir, startup |
| responseTimeThreshold millis must be >= 0 | validation | error | hadoop, ipc, decay-scheduler, backoff, thresholds, config |
| is invalid. | exception | error | azure, abfs, metadata, x-ms-properties, base64, parsing |
| Seeking in unsorted TFile | exception | error | hadoop, tfile, unsorted, seek, reader |
| SetPermission operation is only supported on HNS enabled… | exception | error | azure, abfs, unsupported-operation, hns, permissions |
| Unexpect end of stream, expected length | exception | error | hadoop, tos, filestore, stream-length, object-storage |
| Unknown client chain certificate | exception | error | ssl, tls, truststore, certificate, handshake, hadoop |
| ACL ' ' not of expected form scheme:id | validation | error | registry, acl, format, configuration, hadoop-registry |
| Buffer not enough to store the key | exception | error | tfile, hadoop-common, index-out-of-bounds, buffer, key |
| Cannot obtain block length for | exception | error | hdfs, block-replica, under-construction, read |
| Cannot parse string | validation | error | hdfs, balancer, cli, argument-validation, enum-value |
| fetchBlockByteRange(). Got a checksum exception for | exception | error | hdfs, checksum, corruption, datanode |
| Input quota value should be a positive number. | validation | error | hdfs, rbf, federation, quota, validation, cli |
| Invalid format (Expected name, name:SignerClass… | exception | error | aws, s3a, signer, configuration, validation |
| Invalid registration, no block pool specified | validation | error | hdfs, router-based-federation, state-store, membership, record-validation, block-pool |