apache/hadoop
Documented errors, page 15 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Item: parent's path is null. This can happen if mkdir is… | exception | error | hadoop, mkdir, shell, root-path, path-not-found, argument-validation |
| Native output collector doesn't support customized java… | exception | error | nativetask, comparator, sorting, job-configuration |
| Overflow: for n = , the least power of two (the least… | exception | error | hdfs, util, integer-overflow, byte-buffer, power-of-two |
| Permission denied rename | exception | error | hdfs, router, federation, rename, permission-denied, access-control, kerberos-proxy |
| Replica of type does not support createInfo | exception | error | replica, finalized, recovery, unsupported-operation, hdfs, datanode |
| tokenStr cannot be null | exception | error | authentication, token, null-argument, hadoop-auth, precondition |
| Tried to exit non-existent enclosing element in FSImage file | exception | error | hdfs, oiv-legacy, xml, visitor-lifecycle |
| We encountered an error reading | exception | error | |
53 Wrong filesystem for URI " + fs.getUri() + " : " + fs.getClass().getName() | exception | error | hadoop-aws, s3guard, cli, filesystem-scheme, exit-code-53 |
| Can not create a Path from a null string | exception | error | hadoop, hdfs, path, null-argument, illegalargumentexception, configuration |
| Cannot allocate block in | exception | error | hdfs, addblock, stale-state, lease-recovery, ha-failover |
| Could not find a free port in | exception | error | rpc, server, bind, port, network, configuration |
| Expecting arguments size of at most two, getting | exception | error | hadoop, configuration, fencing, shell, argument-validation |
| Failed to initialize | exception | critical | hadoop-kms, configuration, audit, startup-failure, initialization |
| File deletion failed! | exception | error | hadoop, yarn, disk-check, temp-file, cleanup |
| Invalid read parameters: buf.length= | exception | error | bos, input-stream, index-out-of-bounds, argument-validation, hadoop |
| Offset= out of the range | exception | error | hadoop, hdfs, rbf, webhdfs, offset, range-validation, open |
| Cannot truncate to a larger file size. Current size: " +… | validation | error | hadoop, local-filesystem, truncate, file-size, illegalargumentexception |
| Corrupted replica with a length of expected length is | exception | error | hadoop, hdfs, datanode, fsdataset, mover, corruption, block-length |
| File: already exists | exception | error | cosn, hadoop, rename, destination-exists, file-already-exists |
INVALID_VOLUME Disk Balancer - Unable to find source volume | exception | error | disk-balancer, volume, storage-id, hdfs, datanode |
| Path is a file | exception | error | obs, huaweicloud, mkdirs, file-conflict, file-already-exists |
| Storage policy name is empty. | validation | error | webhdfs, hdfs, storage-policy, rest-api, missing-parameter, query-parameter |
| The BlockReader is null. The BlockReader creation failed or… | exception | error | hdfs, erasure-coding, block-reader, datanode, io |
| The object key is a invalid key, detail | exception | error | invalid-object-key, path-under-file, filenotfoundexception, tos |
| The type of instance is: " + instance.getClass() + ", which… | exception | error | hadoop, serialization, writable, type-registration, generic-writable |
| Append is not supported in pseudo local file system. | exception | error | hadoop, gridmix, pseudo-local-fs, unsupported-operation, append |
| Can't set metadata key | exception | error | java, hadoop, keystore, key-provider, flush |
| Failed to copy metadata to | exception | error | hadoop, hdfs, datanode, fsdataset, lazy-persist, ram-disk, copy, metadata-file |
| getedit failed. | http | error | qjm, journalnode, http-servlet, edit-log, streaming |
| Hadoop bin directory does not exist | exception | error | hadoop, shell, bin-directory, winutils, filenotfound |
| has no enough internal blocks(current: ), unable to start… | exception | critical | hdfs, erasure-coding, datanode, block-recovery, data-loss |
MALFORMED_PLAN Parsing plan failed. | exception | error | disk-balancer, json, plan-validation, hdfs, datanode |
| No CredentialProviderFactory for | exception | error | hadoop, credential-provider, uri, scheme, configuration, classpath |
| Provided name ' ' has components instead of the expected 3. | exception | error | hdfs, sasl, encryption, datatransfer, handshake, auth-token |
| Replica already exists on storage | exception | warning | hadoop, hdfs, datanode, fsdataset, mover, idempotency, storage-policy |
| Resource not found during scripts prepare: " + res | exception | error | hadoop-compat-bench, classpath, resources, packaging, shell-tests |
| : slot is not marked as valid. | exception | warning | hdfs, short-circuit-read, shared-memory, slots, race-condition, memory-visibility |
| Can't make directory for path | exception | error | cosn, hadoop, mkdirs, race-condition, ancestor-is-file |
| Cannot seek in compressed stream | exception | error | |
| "Directory " + srcIIP.getPath() + " is already an… | exception | error | hdfs, encryption-zone, already-exists, key-management |
| File not found. | exception | error | hadoop, hdfs, rbf, webhdfs, file-not-found, open, append |
| Listing file doesn't exist at | exception | error | distcp, hadoop, listing, inputformat, missing-file |
| Listing ' ' failed | exception | error | gcs, hadoop-gcp, listing, permissions, retry |
| Mkdirs failed to create directory | exception | error | mapfile, mkdirs, permissions, hdfs, hadoop-common |
| Multipart IO request | exception | error | s3a, hadoop-aws, multipart-upload, auditing, configuration, committer |
| NULL reporter has no input | exception | error | hadoop, mapreduce, reporter, null-object, unsupported-operation |
| offset < 0 || offset >= getFileLength(), offset= | exception | error | hdfs, offset, validation, read |
| : Path is not a directory; its status is | exception | error | hadoop, manifest-committer, path-conflict, filesystem, output-committer |
| is a directory | exception | error | s3a, create, file-already-exists, directory |
| Requested replication factor of | exception | error | hdfs, replication, configuration, file-create, validation |
| Security is enabled but block access tokens (via… | exception | critical | hadoop, hdfs, datanode, kerberos, security, configuration, startup |
| stdin (-) must be the sole input argument when present | exception | error | hadoop, appendtofile, shell, stdin, argument-validation |
| too many schemes? when process scheme | validation | error | hadoop, mapreduce, counters, filesystem-counter, limit, illegalargument |
| username == null && groupname == null | validation | error | invalid-argument, null-check, set-owner, posix, fileutil |
| Attempted to use QJM output buffer capacity (" + size + ")… | exception | error | hdfs, qjm, ipc, configuration, edit-log, message-size |
| cannot locate OfferService thread for bp= | exception | error | hadoop, hdfs, datanode, block-pool, federation, startup-race |
| Cannot Rename within internal dirs of mount table: src= | exception | error | viewfs, mount-table, rename, access-control, hadoop-common |
| Expecting additional output after line | exception | error | hadoop, disk, df, parsing, lvm, nfs, long-device-name |
| Failed to copy to due to failure in… | exception | error | hdfs, file-copy, native-io, disk-full, io-error |
| Failed to run job | exception | error | hadoop, mapreduce, yarn, job-submission, application-failed, diagnostics |
| File " + f + " not found | exception | error | hadoop, local-filesystem, truncate, file-not-found, filenotfoundexception |
| Found unknown XML keys in | exception | error | hdfs, reversexml, xml-schema, fsimage |
| Har: completeLocalOutput not allowed | exception | error | hadoop, har-filesystem, read-only, local-output, fileutil-copy |
| Invalid GCS bucket name | exception | error | gcs, bucket, validation, uri |
| min sleep time must be positive number and max sleep time… | exception | error | bos, retry-policy, invalid-config, illegal-argument, hadoop |
| namespaceID is incompatible with others. | exception | critical | hdfs, namespace-id, storage, configuration, startup |
| {path} | http | error | hdfs, offline-image-viewer, webhdfs, path-resolution, file-not-found |
| Replica of type does not support getOriginalReplica | exception | error | replica, finalized, recovery, unsupported-operation, hdfs, datanode |
| doesn't support putObjectTagging. | exception | error | hadoop-tos, object-storage, object-tagging, unsupported-operation, spi |
| SignerInitializer class | exception | error | aws, s3a, signer, classpath, class-not-found |
| Unsupported file version | exception | critical | hadoop, hdfs, namenode, fsimage, protobuf, version-mismatch |
| Work path " + workDir + " and target path " + targetPath +… | validation | error | distcp, atomic-commit, filesystem-mismatch, tmp-directory |
| Access denied: dfs.http.policy is HTTPS_ONLY. | exception | critical | java, hadoop, webhdfs, security, kerberos, https, configuration |
| bad fs counter name | validation | error | hadoop, mapreduce, counters, filesystem-counter, naming, illegalargument |
| cluster Id is incompatible with others. | exception | critical | hdfs, cluster-id, storage, configuration, startup |
| destination parent [ ] is not a directory | exception | error | hadoop, obs, rename, parent-directory, path-hierarchy |
| Failed to delete temporary files while closing stream | exception | error | gcs, hadoop, output-stream, close, cleanup, interrupt |
| Fetch of url failed with status code… | exception | error | hdfs, edit-log, http, kerberos, standby-nn |
| is not boolean value | validation | error | hdfs, name-node, reconfig, metrics, lock, dfsadmin, boolean-value |
| Job Priority cannot be null. | exception | error | job-status, null-check, constructor, argument-validation, mapreduce |
| No AWS credential providers created by Delegation Token… | exception | error | aws, s3a, delegation-token, credentials, configuration |
| This operation is not supported across two different… | exception | error | gcs, hadoop-gcp, rename, cross-bucket, unsupported-operation |
| Unrecognized status | exception | error | hadoop, mapreduce, yarn, completion-event, enum-conversion, version-mismatch |
| User not in HttpFSServer admin group | exception | error | httpfs, authorization, access-control, instrumentation, configuration, http-403 |
| Capacity ratio is not between 0 to 1 | exception | error | hdfs, datanode, storage, config, capacity, tiering, illegal-argument |
| data was too long to write! Expected less than or equal to | exception | error | text, size-limit, serialization, writable, hadoop |
| Disk mount already has volume, when trying to add . Please… | exception | error | hadoop, hdfs, datanode, volume-management, mount, disk-tiering |
| Mismatched checkpoint type | validation | error | |
| NativeIO was not loaded | exception | error | native-io, jni, java-library-path, hadoop-common |
| No committer defined in… | validation | error | hadoop, mapreduce, output-committer, missing-configuration |
| No DFS available in child filesystems | exception | error | hdfs, viewfs, erasure-coding, topology-check, mount-table |
| Server asks us to fall back to SIMPLE auth, but this client… | exception | error | hadoop, ipc, kerberos, authentication, sasl, security, configuration |
| Source path does not exist | exception | error | sftp, rename, path-not-found, hadoop, filesystem |
| Unknown FSImage section | exception | error | hdfs, offline-image-viewer, internal-invariant |
| is not in expected format.Expected format is . e.g. 1000MB | validation | error | configuration, validation, parsing, storage, hadoop |
| Bad value buffer offset-length combination. | exception | error | hadoop, tfile, bounds-check, index-out-of-bounds |
| Can't scan a pre-transactional edit log. | exception | error | hdfs, edit-log, version-compatibility, recovery, java |
| Could not create DataChecksum of type | exception | critical | hdfs, checksum, data-integrity, stream, datachecksum |
| disallowSnapshot is not supported for HttpFs on | exception | error | httpfs, webhdfs, snapshot, unsupported-operation, fs-defaultfs |