apache/hadoop
Documented errors, page 12 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Got error, status= , status message | exception | error | hdfs, datanode, lazy-persist, ram-disk, memory |
| Illegal principal name " + name + ": " + ioe.toString() | exception | error | hadoop, kerberos, principal, auth-to-local, ugi |
| IllegalArgumentException Wrong eek_op value, it must be… | validation | error | hadoop-kms, rest-api, http-400, invalid-parameter, key-management |
| Input files cannot be merged as they have different Key… | validation | error | mapfile, merge, comparator, type-mismatch, hadoop-common |
| Invalid or extra Arguments | validation | error | hadoop, hdfs, diskbalancer, cli, arguments |
| Invalid URI - account name is not fully qualified. | exception | critical | azure, abfs, sharedkey, account-name, authentication, configuration |
| job, , is not found | http | warning | mapreduce, rest, am-web-services, http-404, job-id |
| Parallel access to the create path detected. Failing… | exception | error | azure, abfs, concurrency, etag, precondition-failed, blob-endpoint |
| shouldn't enable snapshot. | validation | error | fedbalance, federation-balance, hdfs-snapshot, precheck, distcp |
| THIS IS NOT SUPPOSED TO HAPPEN… | exception | error | hdfs, datanode, block-recovery, generation-stamp, invariant, name-node |
| unterminated code point escape: string broke off in the… | exception | error | xml, parsing, escape-sequences, hdfs, fsimage |
| zero-copy reads were not available, and the ByteBufferPool… | exception | error | hadoop, filesystem, zero-copy, bytebuffer, memory-pool |
| Aliasmap archive ( ) does not exist | exception | error | hdfs, provided-storage, aliasmap, bootstrap, file-transfer |
| Call cos sdk failed, call method | exception | error | cosn, hadoop-cos, sdk-client-error, catch-all, ioexception |
| Cannot find source file | exception | error | hadoop, hdfs, rbf, concat, file-not-found, async-rpc |
| Cannot parse ssQuota | validation | error | hdfs, rbf, federation, quota, cli, number-format |
| Content-Type " " is incompatible with "application/json"… | exception | error | webhdfs, httpfs, content-type, json, proxy |
| Error while reading compressed data | exception | error | io, compression, native-library, hadoop-common |
| Failed to convert \" \" to RollingUpgradeStartupOption | exception | error | hdfs, rolling-upgrade, namenode, cli, invalid-argument |
| failures downloading | exception | critical | hadoop, mapreduce, shuffle, fetcher, retry-exhausted, node-failure |
| / is not a file. The directory / already exist at… | exception | error | viewfs, hadoop, create, file-already-exists, mount-table |
| Malformed varint | exception | error | hadoop, java, rpc, protobuf, varint, wire-protocol |
| ns + "." + IPC_CALLQUEUE_WRRMUX_WEIGHTS_KEY + " must… | exception | error | hadoop, ipc, call-queue, faircallqueue, configuration, weights |
| : path already exists and has status | exception | error | hadoop, manifest-committer, file-already-exists, idempotency, job-retry |
| Port specified in URI but host ' ' is a logical (HA)… | exception | error | hdfs, high-availability, uri, configuration, ha |
| ' ' did not respond with JSON to the ' ' delegation token… | exception | error | client, content-type, delegation-token, http, proxy |
| Symlinks not supported | exception | error | hadoop, local-filesystem, symlink, unsupported-operation |
| Unable to load OAuth2 connection factory. | exception | error | java, hadoop, webhdfs, oauth2, configuration, initialization |
| "Concat: the source file " + src + " is in snapshot" | exception | error | hdfs, concat, snapshot, snapshot-conflict |
| Fail to get block MD5 for | exception | error | hdfs, checksum, replica-unavailable, datanode, block-health |
| Final DistCp failed. Failure | exception | error | fedbalance, federation-balance, distcp, mapreduce, final-copy |
| Illegal field separator | exception | error | hadoop, ipc, audit, caller-context, configuration, validation |
| Interrupted while waiting for IO on channel | exception | warning | hadoop-common, network, interruption, concurrency, nio |
| previous and finalized.tmpcannot exist together. | exception | error | hdfs, storage, finalize, upgrade, inconsistent-state, recovery |
| Retry " + retry + " times to read still exception: " +… | exception | error | bos, read-failure, retry-exhausted, network, hadoop |
| Unable to determine the name service ID. This is an HA… | exception | error | hadoop, hdfs, ha, federation, haadmin, nameservice-id |
| Unable to instantiate " + copyListingClassName | exception | error | distcp, reflection, copy-listing, classloading, configuration |
| Unable to locate storage class, check… | exception | critical | mapreduce, job-history-server, recovery, configuration, startup |
| absolutePath + ": No such file or directory." | exception | error | hadoop, typedbytes, serialization, unsupported-type |
| Datanode not found. | exception | warning | hdfs, balancer, datanode-registration, namenode, rpc |
| Enabling or disabling storage policy satisfier service on | exception | error | hdfs, name-node, reconfig, storage-policy-satisfier, sps, ha, standby |
| failed to create tmp file | exception | error | hadoop, tos, filestore, temp-file, local-storage |
| Internal error: default blockSize is not a multiple of… | exception | error | hadoop, file-create, blocksize, checksum, configuration |
| Invalid UTF-8 byte at offset in length of | exception | error | hadoop-record, utf-8, deserialization, deprecated, data-corruption |
| "Key " + keyName + " doesn't exist." | exception | error | hdfs, encryption-zone, kms, key-not-found, tde |
| Unable to initialize History Viewer | exception | error | hadoop, mapreduce, jobhistory, filename-validation, ioexception |
| Wrong header string: \"" + header + "\" | exception | error | hadoop-aws, multipart-uploader, part-handle, serialization, data-corruption |
| A flag must be specified. | validation | error | xattr, extended-attributes, invalid-argument |
| Cannot initialize the class | exception | error | hadoop, serialization, deserialization, reflection, classpath, constructor |
| Cannot move " " to the trash, as it contains the trash | exception | error | hadoop, trash, delete, path-conflict |
| Cannot remove current directory | exception | error | hdfs, storage, format, io, permissions, file-lock |
| Checksum verification failed for the block | exception | error | hdfs, datanode, pmem, centralized-cache, checksum, corruption |
| concat: at least two of the source files are the same | exception | error | hdfs, concat, duplicate-source, precondition |
| Corrupted VLong encoding | exception | error | tfile, hadoop-common, utils, varint, encoding, data-corruption |
| Delegation Token can be renewed only with kerberos or web… | exception | error | hdfs, router-based-federation, security, delegation-token, kerberos, authentication |
| Failed to get files with active leases | exception | error | hdfs, leases, concurrency, executor, open-files |
| Filesystem not supported by this committer | exception | error | aws, s3a, committer, filesystem, scheme, configuration |
| No such file or directory | exception | error | s3a, file-not-found, status, probe |
| Null IO stream | exception | error | cosn, hadoop, input-stream, read-ahead, interrupted, concurrency |
| Period millis must be >= 0 | validation | error | hadoop, ipc, decay-scheduler, config, validation, startup |
| PipeMapRed.waitOutputThreads(): subprocess failed with code | exception | error | hadoop-streaming, subprocess, exit-code, scripting, mapreduce |
| replication must be >= 1 | exception | error | setrep, replication-factor, invalid-argument, argument-validation |
| there is no shared memory segment registered with shmId | exception | error | hdfs, datanode, short-circuit, shared-memory, domain-socket, client |
| Too many or few parameters for request. Method | validation | error | hadoop, ipc, rpc, protobuf, proxy, reflection |
| Unknown processor (valid processors: xml, binary, stats) | validation | error | hadoop, hdfs, offline-edits-viewer, cli, arguments |
| A record version mismatch occurred. Expecting v | exception | error | hadoop, sequence-file, append, version-mismatch |
| A valid owner or group must be specified. | validation | error | azure-abfs, setowner, illegal-argument, hns, acl |
| Bad EC policy configuration file: no | validation | error | hdfs, erasure-coding, ec-policy, xml, schema-validation, missing-element |
| Error accessing Bucket | exception | error | gcs, hadoop-gcp, bucket-metadata, permissions, storageexception |
| Failed to load image from | exception | critical | hdfs, namenode, fsimage, reserved-path, startup |
| filters cannot be xor-ed | exception | error | bloom-filter, incompatible-parameters, merge, hadoop-common |
| -getlevel needs two parameters | validation | error | hadoop, logging, cli, loglevel, missing-arguments |
| Is not a directory | exception | error | path-is-not-directory, type-mismatch, pathdata, hadoop-shell |
| Offset and length don't match block ( blockLen ) | exception | error | hdfs, datanode, read-path, offset, validation |
| Parse error | exception | error | hadoop, mapreduce, join, parser, composite-input-format |
PathNotFound openFileForWrite must be used with files and not directories | exception | error | azure, abfs, create, append, path-conflict, is-a-directory |
| Unexpected XML event | exception | error | hdfs, reversexml, xml-attributes, fsimage |
| value can not be null | validation | error | hadoop, bloom-filter, java, null-check, constructor |
| BUG: The stored LV = | exception | critical | hadoop, hdfs, datanode, storage, layout-version, downgrade, version-mismatch |
| Couldn't run retriable-command | exception | error | distcp, hadoop, retry, io |
| Failed to create temporary file for | exception | error | hdfs, datanode, race-condition, temp-file, block-write, lease-recovery |
| Failed to load FSImage file, see error(s) above for more… | exception | critical | hdfs, namenode, fsimage, corruption, startup |
| Failed update mount table " + mount | exception | error | hadoop, rbf, fedbalance, mount-table, state-store, update-failed |
| FS: , Namenode ID collision for path: nnid: uri being… | exception | critical | nfs-gateway, hdfs, exports, dfsclientcache, startup, configuration |
| Got EOF but currentPos = | exception | error | hdfs, webhdfs, http, truncated-response, network |
| Invalid file name: in | exception | error | hadoop, har-filesystem, path-resolution, namespace |
| Operation " " is not supported | exception | warning | hdfs, router-based-federation, upgrade, unsupported-operation, admin |
| Repetitive schemas in EC policy configuration file | validation | error | hdfs, erasure-coding, ec-policy, xml, duplicate-entry |
| Router is in startup mode | exception | warning | hadoop, hdfs, rbf, webhdfs, startup, retriable |
| Too many bytes before delimiter: " + bytesConsumed | exception | error | hadoop, java, io, text-parsing, record-delimiter |
| Unable to stop existing writer for block | exception | error | hdfs, datanode, writer-stop, timeout, disk-io |
| Unexpected end of stream: buffer | exception | error | hadoop-aws, prefetch, eof, network-truncation, cache-corruption, s3 |
| can't understand DelegationTokenIdentifier KIND | exception | error | hdfs, offline-edits-viewer, xml, delegation-token, java |
| Cannot load data from ZooKeeper; itwas written with a newer… | exception | error | hadoop-auth, zookeeper, version-mismatch, rolling-upgrade |
| DIR* NameSystem.internalReleaseLease: attempt to release a… | exception | error | hdfs, namenode, lease-recovery, block-state, invariant |
| Directory is in an inconsistent state: Message digest… | exception | critical | hdfs, namenode, fsimage, checksum, version-file, migration |
| DN shut down before block pool connected | exception | warning | hdfs, datanode, shutdown, namenode-connection, lifecycle |
| Failed to create root dir. | exception | error | hadoop, tos, filestore, local-storage, configuration |
| File check failed | exception | error | ftp, hadoop, filesystem, io, wrapped-exception |
| getServerDefaults is not supported for HttpFs on | exception | error | httpfs, webhdfs, server-defaults, unsupported-operation, fs-defaultfs |