apache/hadoop
Documented errors, page 3 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Invalid AuthenticationToken type | exception | error | authentication, token-type, hadoop-auth, auth-cookie, composite-handler |
| LZO codec class not specified. Did you forget to set… | exception | error | hadoop, tfile, lzo, compression, codec-unavailable |
| Proxy error: fs.s3a.proxy.username or fs.s3a.proxy.password… | exception | error | s3a, proxy, configuration, credentials |
| Rename of to is not allowed, no eligible destination in the… | exception | error | hdfs, router, federation, rename, mount-table, cross-namespace, configuration |
| Unknown operation | exception | warning | webhdfs, internal-api, defensive-check, block-locations |
| Unsupported Address type | exception | error | ganglia, metrics2, socket-address, configuration, hadoop-common |
| Checksum error: at exp: got | exception | critical | hadoop, filesystem, checksum, local-filesystem, data-corruption |
| Could not obtain the last block locations. | exception | error | hdfs, open, under-construction, block-report, cluster-restart |
| getJNIEnv: getGlobalJNIEnv failed | console | error | libhdfs, jni, jvm-bootstrap, umbrella-error, thread-local-storage |
| Received invalid http response | exception | error | oauth2, webhdfs, http-status, client-credentials |
| All negative block group IDs are used, growing into… | exception | critical | hdfs, erasure-coding, block-id, namenode, id-exhaustion, illegal-state |
| Cannot serialize field | exception | error | hdfs, router-based-federation, jmx, serialization, reflection, state-store |
| File does not exist in pseudo local file system | exception | error | hadoop, gridmix, pseudo-local-fs, file-not-found, path-validation |
| From option | exception | error | obs, huaweicloud, credentials, class-loading, config |
| host file read operation timed out | exception | error | hdfs, namenode, hosts-file, timeout, nfs, configuration |
| Invalid path: : directory does not exist | exception | error | hadoop, hdfs, datanode, volume-management, filesystem, path-validation |
| No such file or directory | exception | error | hadoop, hdfs, glob, path-not-found, copy, shell |
| This should not happen | exception | error | client, delegation-token, token-cancel, http, ioexception |
| Unable to update the boundaries/Range of contentChannel | exception | error | gcs, read, seek, range-request, ioexception |
| Bailing out since native library couldn't be loaded | exception | error | native-library, jni, netgroups, group-mapping, hadoop |
| non-posix bucket. Append is not supported by OBSFileSystem | exception | error | append, unsupported-operation, bucket-capability, hadoop-obs |
| Null IO stream from reopen of | exception | error | network, sdk-anomaly, read, hadoop-obs |
| Parameter [ ], cannot be NULL | validation | error | webhdfs, kerberos, user-param, authentication, hdfs |
| Unknown authentication type | exception | error | authentication, gcs, hadoop, configuration, enum |
| {uri} | exception | error | azure-abfs, uri, configuration, illegal-argument, fs-defaultfs |
| write (b[ ], , ) | validation | error | obs, huaweicloud, index-out-of-bounds, buffer-math, api-misuse |
| Failed to create a URI (URISyntaxException) for the remote… | exception | error | distributed-cache, uri, fragment, files-option, mapreduce |
| Invalid SPNEGO sequence, 'WWW-Authenticate' header incorrect | exception | error | kerberos, spnego, negotiate, www-authenticate, hadoop-auth, authentication |
| Invalid value: " " does not belong to the domain | validation | error | webhdfs, query-param, regex-validation, usernames, httpfs |
| Unable to bind on specified info port in secure context… | exception | critical | hdfs, datanode, security, kerberos, jsvc, port-binding, http-server, startup |
| Authentication type must be specified: simple|kerberos| | exception | critical | configuration, servlet-filter, hadoop-auth, deployment, authentication-type |
| byte[] arrays are not supported for DirectDecompressor | exception | error | snappy, compression, unsupported-operation, direct-buffer, hadoop |
| Byte-per-checksum not matched: bpc= | exception | error | hdfs, checksum, file-integrity, configuration, distcp |
| Can't re-compute encryption key for nonce, since the… | exception | error | hdfs, block-token, security, encryption, key-expiry, data-node |
| Failed to create | exception | error | hadoop, mapreduce, output-committer, reflection, configuration |
| Failed to rename to due to failure in native rename. | exception | error | hdfs, storage, rename, native-io, filesystem |
| Highest txn ID available in the journal is | exception | critical | hdfs, qjournal, journal-lag, ha, tail-edits, data-loss |
| Inconsistent split cardinality from child | exception | error | hadoop, mapreduce, join, inputsplit, partitioning, map-side-join |
| lz4-java library is not available: Lz4Compressor has not… | exception | error | lz4, compression, classpath, missing-dependency, hadoop, native-library |
| Unable to rename " + src + " to " + target | exception | error | rename-failed, windows-file-lock, cross-filesystem, file-lock, fileutil |
| Unexpected version of storage directory | exception | critical | hdfs, layout-version, downgrade, version-mismatch, storage |
| "Can't create an encryption zone for " + src + " since no… | exception | error | hdfs, encryption-zone, kms, key-provider, configuration |
| Could not get the namenode ID of this node. You may run… | exception | error | hadoop, hdfs, high-availability, zkfc, nameservice-id |
| Fail to get block checksum for | exception | error | hdfs, erasure-coding, checksum, block-group, datanode |
| FileSystem is not an HDFS file system. The fs class is | validation | error | hdfs, dfsadmin, filesystem, configuration, fs-defaultfs, viewfs |
| Append is not supported by BaiduBosFileSystem | exception | error | hadoop, streaming, classpath, classloader, illegal-argument |
| Can not read resource file | exception | error | classloader, classpath, threading, resources, hadoop-common |
| No KeyProvider has been defined | exception | critical | hadoop-kms, configuration, startup-failure, key-provider, missing-config |
| No log file to finalize at transaction ID | exception | critical | hdfs, qjournal, edit-log, ha, journal-out-of-sync, data-loss |
| Security enabled but user not authenticated by filter | exception | error | hdfs, web-ui, kerberos, spnego, authentication, security |
| Task set failed with an uncaught throwable | exception | error | hadoop, tos, concurrency, error-handling, iceberg-tasks |
| Unable to construct journal | exception | error | hdfs, namenode, edit-log, journal-manager, reflection, constructor, api-mismatch |
| Failed to write manifest data for task | exception | error | hadoop, manifest-committer, local-disk, disk-full, job-commit, queue |
| : [ ] | exception | error | metrics2, rolling-file-sink, hdfs, io, append |
| Unsupported callback: | exception | error | sasl, authentication, callback, digest-md5, hadoop |
| User: not allowed to do ' ' on | exception | error | hadoop-kms, authorization, http-403, acl, security, key-management |
| Could not update Stored Token ZKDTSMDelegationToken_ | exception | error | zookeeper, delegation-token, token-renew, ha |
| free ports could not be acquired. | exception | error | port, ephemeral-port, resource-exhaustion, testing, hadoop-common |
| is not supported | http | error | webhdfs, hdfs, rest-api, http-method, unsupported-operation, put |
| The authorization provider does not implement the… | exception | error | hdfs, authorization, provider-plugin, upgrade, default-method, rbf |
| The ingress service type must be configured as DFS | validation | error | azure-blob, abfs, configuration, hns, dfs, ingress, hadoop |
| File name can't be empty string | exception | error | cli, generic-options-parser, libjars, files-option, validation |
| Not a directory | exception | error | create, parent-directory, file-vs-directory, hadoop-obs |
| Record Writer not set for FilterRecordWriter | exception | error | hadoop, mapreduce, record-writer, filter-output-format, delegate, null-delegate |
| Stream data required | validation | error | hadoop, pathhandle, deserialization, corruption |
| Unable to close file because dfsclient was unable to… | exception | error | hdfs, hdfs-client, close, namenode, connectivity, lease, failover |
| Unknown option | exception | error | fs2img, cli, option-parsing, usage-error |
| User [ ] is not authorized to create key !! | exception | error | hadoop-kms, authorization, http-403, key-acl, security, key-management |
| WASB Driver using wasb(s) schema is no longer supported… | exception | error | azure, wasb, abfs, adls-gen2, removed-feature, hadoop-azure |
| Could not rename to | exception | error | mapreduce, job-history-server, state-store, filesystem, rename |
| End of file reached before reading fully. | exception | error | eof, read, readfully, hadoop-obs |
| Failed to load EC policy file | exception | error | hdfs, erasure-coding, ec-policy, xml, hdfs-ec-cli, configuration |
| File already exists | exception | error | hadoop, file-io, race-condition, security |
| Trying to construct a provided replica on | exception | error | hdfs, datanode, provided-storage, replica, builder, illegal-argument |
| (unable to get root cause for ) | console | warning | c, libhdfs, jni, classpath, version-mismatch, diagnostics |
| Cannot complete block: block has not been COMMITTED by the… | exception | error | hdfs, namenode, block, block-state, file-close, lease-recovery |
| Error skipping over blocks | exception | error | hdfs, fsimage, truncated-file, skipblocks, offline-image-viewer |
| Mkdirs failed to create " + parent.getAbsolutePath() | exception | error | mkdir-failed, unzip, permissions, disk-full, archive-extraction |
| Only Namenode, Secondary Namenode, and administrators may… | http | error | hdfs, security, kerberos, authorization, checkpoint |
| The proxies specified for | exception | error | hadoop, ipc, rpc, proxy, reflection, wiring |
| DataChecksum.Type.MIXED is not supported for COMPOSITE_CRC | exception | error | hdfs, checksum, erasure-coding-unrelated, configuration, crc32c |
| getServerDefaults on empty path is invalid | exception | error | viewfs, hadoop, mount-table, configuration, server-defaults |
| Missing configuration properties | exception | error | minikdc, kerberos, testing, configuration, missing-config |
| Bucket does not exist | exception | critical | obs, huaweicloud, bucket-not-found, endpoint, initialization |
| Failed to hardLink block file to | exception | error | hadoop, hdfs, datanode, fsdataset, hardlink, same-disk-tiering, io |
| Unrecognized priority | exception | error | hadoop, mapreduce, job-priority, enum-conversion, version-mismatch |
| Interrupted multi-part upload with id | exception | error | obs, huaweicloud, interrupted, multipart-upload, concurrency |
PathConflict The specified path, or an element of the path, exists and its resource type is… | http | error | azure, abfs, conflict, http-409, create, blob-endpoint |
| This namenode has storage info " + myStorageInfoString + "… | http | error | hdfs, checkpoint, clusterid, storage-info, configuration |
| Use Token.renew instead | exception | info | hadoop, mapreduce, yarn, delegation-token, unsupported-operation, api-migration |
| class name " + suiteClassName + " must be an implementation… | validation | error | hadoop-compat-bench, reflection, classloading, plugin, suite-registration |
| Exception while refreshing access token | exception | error | oauth2, webhdfs, response-parsing, refresh-token |
| expecting </EDITS> | validation | error | hadoop, hdfs, offline-edits-viewer, xml, parsing |
| No namenodes to invoke | exception | error | hdfs, router-based-federation, async-rpc, namenode-resolution, state-store |
| Resilient commit not supported | exception | error | hadoop, manifest-committer, unsupported-operation, subclassing, api-contract |
| Undefined named output | validation | error | hadoop, mapreduce, multiple-outputs, undefined-channel, ordering, illegalargument |
| closed has error. bs : pre write obs | exception | error | obs, huaweicloud, close, multipart-upload, data-integrity |
| Expected the file renamed from | exception | error | hadoop, manifest-committer, etag, data-integrity, output-validation |
| Failed to create [source= , allow-append= , , ] | exception | error | metrics2, rolling-file-sink, hdfs, permissions, configuration |
| Inconsistent storage detected, image and edits checkpoint… | exception | critical | hadoop, hdfs, namenode, checkpoint, storage-consistency, legacy-format |