apache/hadoop
Documented errors, page 5 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| RPC response has invalid length of | exception | error | hadoop, ipc, rpc, protocol-mismatch, wire-format, corruption |
| : slot does not exist. | exception | warning | hdfs, short-circuit-read, shared-memory, slots, datanode, stale-state |
| Zero blocklocations for | exception | warning | hdfs, safe-mode, block-locations, read-path, retryable, namenode |
| Cannot complete block: block does not satisfy minimal… | exception | error | hdfs, namenode, block, replication, min-replication, file-close |
| Failed to convert " " to RollingUpgradeAction | validation | error | hdfs, dfsadmin, rolling-upgrade, cli, argument-parsing, enum-value |
| Mkdirs failed to create | exception | error | hadoop, runjar, mkdirs, filesystem, permissions, temp-dir |
| Unable to load user-bound SAS token provider class | exception | error | azure, abfs, sas-token, classpath, extensions, classloading |
| Unexpected blockChecksumType | exception | error | hdfs, checksum, rolling-upgrade, version-mismatch, datanode |
| Parsing | exception | error | registry, zookeeper, acl, configuration, format, hadoop-registry |
| Recovery block where it is not under construction. | exception | error | hdfs, lease-recovery, block-state, namenode, race-condition, internal-error |
| Content-Length header is not provided by the namenode when… | exception | error | hdfs, fsimage, checkpoint, http-header, namenode, transfer |
| Could not increment shared counter !! | exception | error | zookeeper, delegation-token, shared-count, token-issue, ha |
| Permission denied: user= | exception | error | hadoop, hdfs, filesystem, permissions, posix, accesscontrolexception, authorization |
| responseTimeThresholds must match with the number of… | validation | error | hadoop, ipc, decay-scheduler, backoff, thresholds, config |
| System property 'kms.config.dir' must be an absolute path | exception | critical | hadoop-kms, configuration, startup-failure, path-error |
| This operation is not supported across two different… | exception | error | gcs, hadoop-gcp, copy, cross-region, unsupported-operation, bucket-metadata |
| Unable to determine the name service ID. | exception | error | hadoop, hdfs, ha, haadmin, nameservice-id, configuration |
| Unexpected FS state: for storage directory | exception | error | hdfs, storage, recovery, internal-error, version-mismatch, state-machine |
| Can't make directory for path | exception | error | obs, huaweicloud, mkdirs, ancestors, file-already-exists |
| Configuration hadoop.user.group.static.mapping.overrides is… | exception | error | configuration, group-mapping, core-site, hadoop |
| iip.getPath() + " is non empty" | exception | error | hdfs, delete, directory-not-empty, precondition |
| Processing RPC request caught | exception | error | rpc, observer-namenode, state-alignment, hdfs, router |
| ProvidedReplica does not support deleting metadata | exception | error | hdfs, datanode, provided-storage, read-only, metadata |
| Target address cannot be null. | exception | error | configuration, socket-address, hadoop-common, validation |
| We expect to read , but we actually read | exception | critical | nativetask, data-corruption, serialization, buffer-management |
| Cannnot build location | exception | error | hadoop, rbf, mount-table, resolver, multi-destination, configuration |
| Error checking directory | exception | critical | disk, health-check, datanode, nodemanager, io-error, diskchecker |
| Unexpected: " + type | exception | error | hadoop, mapreduce, join, lexer, parser, expression |
| Upload failed for ' '. reason= | exception | critical | gcs, upload, write-channel, resumable-upload, commit-failed |
E_NO_MAGIC_PATH_ELEMENT No __magic_job- element in path | exception | error | s3a, magic-committer, path-validation, illegal-argument |
| Failed to invoke | exception | error | sasl, reflection, callback, ioexception, hadoop |
| Failed to read node list from file | validation | error | hdfs, balancer, cli, file-io, node-filter |
| File not found in downstream nameservices | exception | error | hdfs, router-based-federation, mount-table, admin, validation |
| Invalid reservationId | exception | error | yarn, reservations, job-submission, configuration, mapreduce |
| Invalid resource name | exception | error | yarn, locality, scheduling, configuration, job-submission |
| "Requested queues (" + aNumQueues + ") must be greater than… | exception | error | hadoop, ipc, call-queue, faircallqueue, configuration, startup |
| Unexpected format of JMX JSON response for | exception | error | dynamometer, jmx, json, http, startup-check |
| Cannot find locations for | exception | error | hdfs, router-based-federation, content-summary, mount-table, resolution, no-location |
| FsDatasetSpi has not been initialized | exception | error | hadoop, hdfs, datanode, reconfiguration, initialization, race-condition |
| No more entry in " + f | exception | error | hadoop, streaming, configuration, missing-property, xml-record-reader |
| Secure IO is not possible without native code extensions. | exception | critical | hadoop, kerberos, native-library, static-initializer, security |
| The journal edits cache is not enabled, which is a… | exception | error | hdfs, qjournal, configuration, ha, tail-edits, name-node |
| AWS Authentication chain is no longer supplying session… | exception | error | aws, s3a, delegation-token, session-credentials, sts |
| Cannot initialize expiryPeriod to | exception | error | hdfs, configuration, socket-cache, dfsclient, invalid-config |
| Checksum failed at for replica | exception | error | hdfs, datanode, read-path, checksum, data-corruption |
| Entry " " not found; JAAS config = | exception | error | registry, jaas, sasl, kerberos, zookeeper, configuration, hadoop-registry |
| Expected a file renamed from | exception | error | hadoop, manifest-committer, output-validation, job-commit, path-conflict |
| Expected to read bytes from offset but read bytes. | exception | error | hdfs, datanode, checksum, truncation, corruption |
| Malformed xml formation queue tag and acls tags or state… | exception | error | hadoop, mapreduce, queue-configuration, xml, config |
| TaskId string : is not properly formed | exception | error | |
| Expecting , but got XMLStreamException | exception | error | hdfs, reversexml, malformed-xml, fsimage, offline-image-viewer |
| Failed to move block file for | exception | error | hadoop, hdfs, datanode, fsdataset, mover, rename, block-file, io |
| Invalid path URI: - cannot contain both a URI fragment and… | exception | error | hadoop, mapreduce, distributed-cache, wildcard, uri, fragment |
| zero-copy reads were not available, and you did not provide… | exception | error | hadoop, filesystem, zero-copy, bytebuffer, unsupportedoperationexception |
| blocksperchunk is not supported since the target file… | exception | error | distcp, blocksperchunk, concat, object-store, filesystem-support |
| Cannot remove user, group or other entry from access ACL. | validation | error | azure, abfs, acl, posix-acl, hadoop, validation |
| Cannot rename symlink | exception | error | rename, symlink, filealreadyexists, filecontext, hadoop-fs |
| Compression codec was not found. | validation | error | hadoop, mapreduce, compression, codec, classpath, classnotfound, configuration |
| currentKey hasn't been initialized. | exception | error | hdfs, block-token, security, initialization, lifecycle |
| Illagal value: = < MIN = | validation | error | hdfs, namenode, bit-packing, internal-api, illegal-argument |
| JSON parser error | exception | error | webhdfs, xattr, json-parse, client-server-skew |
| Not a primitive | validation | error | serialization, object-writable, reflection, hadoop-common |
| Not enough capacity ratio left on mount | exception | error | hdfs, datanode, same-disk-tiering, configuration, capacity-ratio |
| The creation time for the record cannot be negative. | validation | error | hdfs, router-based-federation, state-store, record-validation, timestamps |
| Timed out waiting for doFinalize() response | exception | error | qjm, journalnode, timeout, upgrade-finalize, rpc |
| Unable to retrieve InMemoryAliasMap for block pool id " +… | exception | error | provided-storage, aliasmap, inmemory-leveldb, block-pool, rpc |
| Unexpected EOS from the reader | exception | error | hdfs, erasure-coding, premature-eof, datanode, network |
| Usernames not matched: expecting null but name= | exception | error | hdfs, webhdfs, datanode, delegation-token, ugi, username-mismatch |
| Cannot rollback to storage version | exception | error | hdfs, namenode, upgrade, rollback, layout-version, storage |
| Disallowed RPC access from | exception | error | hadoop, hdfs, access-control, acl, zkfc, permissions |
| Failed to create directory | exception | error | hdfs, mkdir, race-condition, concurrency |
| "Failed to set quota by storage type because either" +… | exception | error | hdfs, quota, storage-type, config |
| Invalid size prefix ' ' in ' '. Allowed prefixes are k, m… | exception | error | string-parsing, binary-prefix, size-units, configuration, hadoop-common |
| Mailformed URL while finding the web resource dir | exception | error | hadoop, http-server, url, dev-environment |
| No attribute for | exception | error | hadoop, hdfs, cli, option-value, copy, java |
| Proxy error: or set without the other. | exception | error | obs, huaweicloud, proxy, config, initialization |
| replaceFile interrupted. | exception | error | rename, windows-file-lock, interrupted, concurrency, fileutil |
| Subject does not contain a valid User | exception | error | hadoop, security, ugi, jaas-subject |
| This method is deprecated: use the other addResponseTime | exception | error | rpc, scheduler, deprecated, metrics, upgrade |
| Client sent unsupported state | exception | error | sasl, authentication, rpc, protocol-mismatch, hadoop-ipc |
| Could not set handler for signal | exception | error | jvm, signals, service-launcher, shutdown, xrs |
| This method is not supposed to be called at runtime. Use… | exception | error | mapreduce, deprecated-api, binary-compatibility, hadoop, task-log-url |
| truncated return from reader.read(): excpected | exception | error | hdfs, truncated-read, replica-corruption, datanode |
| Duration of a task shouldn't be less or equal to 0! | exception | error | hadoop-sls, yarn, workload-simulation, input-validation, configuration |
| Encoded type converted to valid component type but no… | exception | error | hadoop, serialization, invariant-violation, defensive-check, deserialization |
| Failed to parse " " as a radix- integer. | validation | error | webhdfs, query-param, number-parsing, integer, hdfs |
| Path must be absolute: " + path | exception | error | hadoop, streaming, validation, illegal-argument, key-value |
| Append is not supported by ChecksumFileSystem | exception | error | hadoop, filesystem, append, local-filesystem, checksum-fs, unsupported-operation |
| Cannot find target file | exception | error | hdfs, router-based-federation, concat, file-not-found, mount-table |
| doesn't support removeXAttr | exception | error | hadoop, filesystem, xattr, filecontext, unsupportedoperationexception |
| expanding " + entry.getName() + " would create file outside… | exception | error | zip-slip, path-traversal, security, archive-extraction, unzip |
| expanding would create file outside of | exception | critical | hadoop, java, security, zip-slip, path-traversal, jar |
| Failed to parse " " as a radix- short integer. | validation | error | webhdfs, query-param, number-parsing, permissions, hdfs |
| PathHandle only available for files | validation | error | hadoop, local-filesystem, pathhandle, invalid-argument |
| Unable to determine service address for namenode | exception | error | hadoop, hdfs, ha, haadmin, rpc-address, configuration |
| Cannot seek to a negative offset | exception | error | cosn, hadoop, input-stream, seek, negative-offset |
| failed to put file since rename fail. | exception | error | hadoop, tos, filestore, rename, local-storage |
| Filesystem does not support symlinks! | exception | error | hadoop, filesystem, symlink, unsupportedoperationexception, hdfs, object-store |
| is not an encryption zone. | exception | error | hdfs, encryption-zone, kms, hdfs-crypto, re-encryption |
| Not implemented for Windows | exception | error | windows, unsupported-operation, shell-path, platform-limitation, fileutil |