apache/hadoop
Documented errors, page 8 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Need to set transport! | exception | error | kerberos, minikdc, configuration, null-config |
| OutputFormat not set for FilterOutputFormat | exception | error | hadoop, mapreduce, output-format, filter-output-format, delegate, null-delegate |
| ' ' did not handle the ' ' delegation token operation | exception | error | client, json, delegation-token, http, proxy |
| Client IDs not matched: local ID= | exception | error | hadoop, ipc, rpc-client, protocol, connection-state, debugging |
| does not support method msync | exception | error | hadoop, filesystem, hdfs, msync, unsupportedoperationexception, metadata-consistency, ha |
| Failed to add a datanode. Response status | exception | error | hdfs, write, pipeline-recovery, datanode, block-transfer |
| FSImage XML ended prematurely, without including section(s) | exception | error | hdfs, offline-image-viewer, fsimage, xml, reversexml |
| hadoop.security.dns.nameserver requires… | exception | error | configuration, dns, kerberos, startup |
| More than one value found for | exception | error | xml, fsimage, offline-image-viewer, hdfs, parsing |
| not found | exception | error | jmx, metrics2, hadoop, monitoring, attribute-not-found |
| Quota by storage type : type on path : pathName is… | exception | error | hdfs, quota, storage-type, storage-policy, tiering |
| is not appendable because append non-existed object with… | exception | error | hadoop-tos, volcengine-tos, append, hns, directory-bucket |
| Address should be : , but it is | exception | error | host-port, string-parsing, validation, hadoop-common |
| Expected numtype | exception | error | hadoop, mapreduce, join, parser, token, extension |
| FileSystem does not support Erasure Coding | exception | error | hadoop, ls, erasure-coding, unsupported-operation, shell, hdfs |
| interrupted | exception | error | |
| Truncate is not supported by ChecksumFileSystem | exception | error | hadoop, filesystem, truncate, local-filesystem, checksum-fs, unsupported-operation |
| Unable to create the Decommission monitor from | exception | critical | hdfs, namenode-startup, decommission, configuration, reflection, classpath |
| Uninitialized InputSplit | exception | error | hadoop, mapreduce, join, input-split, initialization |
| can't use DfsClientShm because we failed to load… | exception | error | hdfs, short-circuit-read, sun-misc-unsafe, jdk-compatibility, reflection, jlink |
| Datanode is restarting | exception | error | hdfs, write, datanode-restart, rolling-upgrade, pipeline |
| Generation stamps mismatched: block | exception | error | hdfs, erasure-coding, striped-blocks, generation-stamp, write-path |
| invalid number of blocks | exception | error | hdfs, edit-log, namenode, corruption, blocks |
| Invalid value configured for dfs.datanode.disk.check.timeout | exception | error | hdfs, datanode, disk-check, config, startup, dead-code, validation |
| is in observer state. Cannot be failover target | exception | error | hadoop, hdfs, ha, failover, observer, zkfc |
| Lease desired but no lease threads configured, set… | validation | error | azure-blob, abfs, lease, configuration, thread-pool, hadoop |
| Named output ' ' already alreadyDefined | validation | error | hadoop, mapreduce, multiple-outputs, duplicate, configuration |
S04 Service [ ] does not implement declared interface [ ] | error_code | critical | httpfs, server-startup, service-loading, custom-service, class-identity |
| Unable to bind on specified streaming port in secure… | exception | critical | hdfs, datanode, security, kerberos, jsvc, port-binding, startup |
| Attempted to read past end of file | exception | error | hdfs, hdfs-client, erasure-coding, striped, eof, read |
| Could not complete transfer, Reply Code - | exception | error | ftp, hadoop, transfer, data-connection, close |
| Could not locate MapReduce framework name | exception | error | hadoop, mapreduce, classpath, framework-path, configuration |
| Failed to read block | exception | error | hdfs, datanode, failover, read |
| part etag mismatched | exception | error | hadoop, tos, filestore, multipart-upload, checksum, data-integrity |
| Serverside implements | exception | error | hadoop, rpc, protocol, version-mismatch, ha |
| Unable to create symlink to non-local file system: " +… | exception | error | hadoop, local-filesystem, symlink, invalid-argument |
| Could not determine OS | exception | error | platform-support, operating-system, factory, hadoop-common |
| dst.toString() | exception | error | path-is-directory, copy, destination-check, hdfs, fileutil |
| Expected the file renamed from | exception | error | hadoop, manifest-committer, file-size, data-integrity, output-validation |
| Failed to TRUNCATE_FILE | exception | error | hdfs, truncate, concurrency, lease-recovery, namenode |
| Got invalid response code | exception | error | hadoop, mapreduce, shuffle, fetcher, http, network |
| Router quota manager is not initialized. | exception | error | hdfs, router, federation, quota, initialization, startup, internal-invariant |
| startedTimeEnd must be greater than startTimeBegin | validation | warning | hadoop, mapreduce, jobhistory, rest, http-400, query-param, time-range |
| The property must be non-negative. Value was | exception | error | metrics2, rolling-file-sink, configuration, range |
| Total heap the can be used is | exception | error | hadoop, gridmix, heap-emulation, resource-emulation, capacity |
| Unsupported compression algorithm name: | exception | error | hadoop, tfile, compression, input-validation |
| can not copy a directory to a subdirectory of self | exception | error | cosn, hadoop, rename, copy-directory, subdirectory |
| Datanode denied communication with namenode because… | exception | error | hdfs, datanode-registration, dns, configuration, namenode |
| does not fit in a Long | exception | error | numeric-overflow, string-parsing, size-units, hadoop-common |
| f.toString() | exception | error | hadoop, typedbytes, writable, type-mismatch, serialization |
| getDefaultBlockSize on path | exception | error | viewfs, hadoop, mount-table, block-size, configuration |
| Interrupted waiting for the proxy | exception | error | rpc, ipc, interrupt, threading, client, retry |
| Invalid state of the job for cleanup. State found " +… | exception | error | hadoop, mapreduce, job-cleanup, output-committer, state-machine |
| "Mkdirs failed to create " + reduceIn.getParent().toString() | exception | error | mapreduce, yarn, uber-mode, local-filesystem, mkdir, disk-full |
| Multipart upload incomplete: expected | exception | critical | bos, multipart-upload, incomplete-upload, race-condition, data-loss, hadoop |
| Not a valid manifest file; file status = | exception | error | hadoop, manifest-committer, data-corruption, job-commit, validation |
| "Source file " + src + " is not in the same directory with… | exception | error | hdfs, concat, same-directory, precondition |
| Task attempt has a self-generated job UUID | exception | error | aws, s3a, committer, spark, uuid, configuration |
| Unrecognized flush interval | exception | error | metrics2, rolling-file-sink, configuration, numberformat-exception, integer-overflow |
| Cannot close TFile in the middle of key-value insertion. | exception | error | hadoop, tfile, state-machine, resource-leak, writer |
| Cannot process fslayout version | exception | error | hdfs, fsimage, layout-version, version-mismatch, offline-image-viewer |
| Copy of file size into file resulted in a size of | exception | error | block, hardlink, io, disk-corruption, hdfs, datanode |
| Decoding S3A token | exception | error | aws, s3a, delegation-token, classpath, class-not-found, deserialization |
| iip.getPath() + " is not a file or directory" | exception | error | hdfs, storage-policy, symlink, namenode |
| "Mkdirs failed to create " + workDir.toString() | exception | error | mapreduce, yarn, node-manager, local-dirs, mkdir, disk-full, permissions |
| Non-alphanumeric data found in input, aborting. | exception | error | hadoop, profiling, async-profiler, input-validation, xss |
| Scheduler's refresh-queues failed with the exception : " +… | exception | error | hadoop, mapreduce, capacity-scheduler, refresh, queues, config |
| srcIIP.getPath() + " can't be moved from an encryption… | exception | error | hdfs, encryption-zone, rename, security |
| tos: request interrupted. | exception | warning | hadoop-tos, volcengine-tos, retry, thread-interrupt, cancellation |
| Bucket does not exist | exception | critical | s3a, s3, bucket, unknown-store, cache-invalidation |
| Can't load keystore | exception | error | hadoop, credential-provider, keystore, corrupt-file, load, jceks |
| Can't retrieve username from tokenIdentifier. | exception | critical | rpc, security, delegation-token, authentication, sasl |
| could not find method | console | critical | hdfs, libhdfs, jni, classpath, version-mismatch, nosuchmethoderror |
| Error closing connection to Graphite. | exception | warning | graphite, metrics2, network, socket, flush |
| Exception while initializing metric credentials | exception | error | azure-blob, abfs, metrics, credentials, configuration, base64, hadoop |
| Failed to report bad block | exception | warning | hdfs, datanode, namenode, rpc, bad-block, retry-queue |
| got unexpected exception | exception | error | hdfs, edit-log, corruption, recovery, unexpected-exception |
| listing object ' ' failed. | exception | error | gcs, listing, storageexception, permissions, ioexception |
| Missing value for configuration option | exception | error | registry, configuration, missing-config, authentication, hadoop-registry |
| Name cannot be have a | validation | error | hadoop, mapreduce, multiple-outputs, validation, naming |
| startedTimeEnd must be greater than 0 | validation | warning | hadoop, mapreduce, jobhistory, rest, http-400, query-param, time-range |
| The destination cluster must be specified. | exception | error | hadoop, rbf, fedbalance, cli, uri-validation, client-side |
| Token should be in bucket , found in bucket | exception | error | mapreduce, job-history-server, state-store, data-corruption, startup |
| Unable to serialize empty EnumSet with no element type… | exception | error | hadoop, serialization, writable, enumset, empty-collection |
| Bad key buffer offset-length combination. | exception | error | hadoop, tfile, bounds-check, index-out-of-bounds |
| Error creating Producer | exception | error | hadoop, metrics2, kafka, producer, initialization |
| File " + lastFileStatus.getPath() + " and " +… | exception | error | distcp, duplicate-paths, input-validation, file-listing |
| Invalid split type | exception | error | hadoop, mapreduce, join, inputsplit, type-mismatch |
| No namespace availaible. | exception | error | hadoop, hdfs, rbf, erasure-coding, state-store, membership, async-rpc |
| problem advancing post rec#"+ctr | exception | error | hadoop, mapreduce, reduce, merge, io, disk-failure, runtime-exception |
| rur.getRecoveryID() >= recoveryId = | exception | warning | hdfs, datanode, block-recovery, recovery-in-progress, concurrency |
| Unable to parse arguments. | exception | error | distcp, cli, commons-cli, argument-parsing, invalid-arguments |
| Unable to support FSFileBlockLocationsLegacy because the… | exception | error | httpfs, webhdfs, block-locations, legacy-client, unsupported-operation, fs-defaultfs |
| Wait failed for get( ) | exception | error | hadoop, prefetch, retry-exhausted, object-store, illegal-state |
| ACL ' ' not of expected form scheme:id:perm | exception | error | zookeeper, acl, configuration, validation, hadoop-common |
| Did not find requested id | exception | warning | hdfs, caching, pagination, compatibility |
| FS modified | exception | error | fs2img, treewalk, concurrent-modification, fsimage, file-mutation-race |
| No more items in iterator. | exception | error | iterator, no-such-element-exception, programming-error, collections |
| Null IO stream from reopen of (" + reason + ") " + key | exception | error | bos, stream-reopen, read-failure, recovery, hadoop |
| Ouput format not set for LazyOutputFormat | exception | error | hadoop, mapreduce, lazyoutputformat, outputformat, configuration |