hashicorp/nomad
Documented errors, page 10 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| failed to retrieve namespaces from consul | console | error | consul, nomad, namespaces, acl |
| Failed to signal container | exception | error | docker-driver, kill, signal, docker-api |
| Prefix matched multiple jobs\n\n | exception | error | nomad-cli, ambiguity, prefix-lookup, user-input |
| Task not found | exception | error | nomad, client, signal, task-not-found |
| taskConfig with ID ' ' already started | exception | error | qemu, nomad, duplicate-task, lifecycle |
| unsupported primitive type | panic | error | hcl, cty, panic, type-conversion |
| volume already exists but is incompatible with these… | error_code | error | csi, grpc, storage, conflict |
| Couldn't create destination directory | exception | error | filesystem, chroot, permissions |
| error opening fifo parent directory | exception | error | go, linux, fifo, directory-not-found |
| Error querying job | exception | error | nomad, cli, api-client, job-status |
| failed to create stdout logfile for | exception | error | logging, logmon, filesystem, configuration |
| host volume updates already batched | exception | warning | nomad-client, fingerprinting, one-shot, state-machine |
| invalid address_mode | validation | error | nomad, service-check, address-mode, config-validation |
| Invalid HealthCheck | validation | error | nomad, go, validation, migrate-strategy, enum |
| job summary insert failed | exception | error | state-store, job-summary, raft |
| Missing task resources | validation | error | nomad, job-spec, validation, resources |
| node is not feasible for volume | validation | error | nomad, host-volumes, constraints, placement |
| panic(r) | panic | critical | raft, fsm, repanic, data-corruption |
| recovery failed to make temp FSM | exception | error | raft, recovery, fsm, internal |
| unexpectedly did not forward CSIVolume.List to region | exception | error | nomad, rpc-forwarding, csi, multi-region |
| unsupported minimum common raft protocol version | http | error | nomad, raft, consensus, versioning, leader-election |
| Couldn't create symlink | exception | error | filesystem, symlink, chroot, permissions |
| CSI.ControllerCreateSnapshot: plugin did not return error… | exception | error | csi, snapshot, plugin, nil-check |
| csi_plugin lookup failed | exception | error | nomad, state-store, csi, plugin-lookup |
| ExternalVolumeID is required | validation | error | csi, validation, volume-expand |
| failed to clean task directories after failed migration | error_code | error | nomad, allocdir, migration, filesystem |
| failed to computed node class | exception | error | nomad, node-registration, computed-class |
| failed to decompress snapshot | exception | error | gzip, snapshot, corruption, io |
| failed to resolve ACL token | http | error | acl, token-resolution, rpc, nomad |
| failed to retrieve OIDC provider metadata | exception | error | nomad, acl, oidc, sso, metadata |
| Invalid variable path | validation | error | nomad, acl, variables, path-format |
| MaxEntries cannot be negative | validation | error | csi, validation, pagination, storage |
| mount --rbind failed | exception | error | linux, network-namespace, mount, bind-mount |
| node identity claims missing node pool | exception | error | nomad, node-identity, jwt, node-pool, acl |
| StopAfterClientDisconnect is deprecated and ignored favor… | validation | error | nomad, job-spec, deprecation, validation |
| unable to parse public key for JWT auth | exception | error | jwt, auth, pem, key-parsing |
| unknown OIDC KeySource | exception | error | oidc, client-assertion, config, validation |
| can not update mount options while volume is in use | validation | error | csi, nomad, volume, mount-options, in-use |
| cannot generate configuration path | exception | error | windows, configuration, path |
| failed to create reserve cpuset partition | error_code | critical | linux, cgroups, cgroup-v1, cpuset, mkdir |
| failed to generate command UI | exception | error | go, cli, ui |
| failed to read filter expression | validation | error | nomad, filter-expression, bexpr, input-validation |
| Label encoding failed | validation | error | hcl, config-validation, plugin |
| No Keyloader object to perform LoadKeyPair | exception | error | tls, configuration, nil-pointer, dependency-injection |
| process failed to exit after 15 seconds | exception | warning | signals, timeout, shutdown, process-lifecycle |
| volume lookup failed | exception | error | state-store, memdb, csi, plugin, nomad |
| cmd is required, but was empty | validation | error | docker, exec, validation |
ErrMultipleNamespaces multiple Vault namespaces requires Nomad Enterprise | validation | error | nomad, vault, enterprise, job-registration |
| failed to decode log endpoint response as JSON | exception | error | streaming, json, nomad-api |
| failed to extract claims from token | exception | error | jwt, nomad-client, claims, json-parsing |
| failed to initialize Consul client | exception | error | consul, client-init, configuration |
| invalid constraint | console | error | hcl, nomad, constraint, validation |
| on_update must be , , or ; got | validation | error | nomad, service-check, config-validation, deployment |
| client stopped and may not longer create config entries | exception | warning | nomad, consul, config-entry, shutdown |
| [✘] Could not write namespace | exception | error | consul, acl, enterprise, setup |
| error deleting unexpected key | error_code | error | bolt, upgrade, state-store, disk |
| failed to recover vault token from | exception | error | vault, filesystem, permissions, tokens, nomad-client |
| failed to update status | exception | critical | nomad-client, heartbeat, rpc |
| file not found under path | exception | error | executor, path-lookup, task-dir |
| missing | validation | error | nomad, volumes, config, host-volume |
| monitorPath not set | exception | error | qemu, shutdown, monitor-socket, nomad-driver |
| no one-time token returned | exception | error | consul, acl, empty-response, one-time-token |
| Port label already in use by | validation | error | nomad, network, ports, job-validation |
| volume in use | exception | warning | csi, nomad, volume-in-use, claims |
| all servers must be running version | validation | error | nomad, node-pools, versioning, rolling-upgrade |
| all servers should be running version | exception | error | nomad, acl, oidc, version-skew, federation |
| Exec | exception | error | cgroups, exec, subcommand, nomad-executor |
| failed to create WAL directory | exception | error | filesystem, permissions, migration, raft-wal |
| failed to decode data into passed object | exception | error | serialization, msgpack, decoding, schema-mismatch |
| Failed to load cert/key pair | exception | error | tls, certificate, private-key, configuration |
| Failed to parse any valid certificates in CA file | exception | error | tls, certificate, pem, configuration |
| failed to parse security_opt configuration | validation | error | docker, nomad-driver, security-opt, config-validation |
| mismatched request namespace in request | validation | error | nomad, namespace, job-registration, validation |
| missing VolumeCapabilities | validation | error | csi, storage, volume-capability, validation |
| pre-run hook failed | exception | critical | nomad, client, hooks, lifecycle, prerun |
| recovery failed | exception | critical | raft, recovery, cluster, data-loss |
| Task group service validation failed | validation | error | nomad, job-validation, services, consul |
| Unable to determine Nomad version | error_code | error | rpc, nomad, versioning |
| Unable to find nobody user | exception | error | permissions, users, linux, nomad |
| cannot apply allowed_modes configuration | validation | error | config, docker, validation, pid-mode |
| could not delete | exception | error | csi, rpc, snapshot, controller |
| CSI.ControllerListSnapshots | exception | warning | csi, snapshot, plugin, retry |
| failed to collect stats | exception | warning | docker, stats, telemetry |
| failed to convert to a log index | exception | error | nomad, client, logs, parsing, filesystem |
| failed to open raft logs | exception | error | raft, boltdb, corruption, go |
| Invalid host volume capability | validation | error | nomad, acl, capability-validation, host-volume |
| Invalid task environment given | validation | error | config, validation, nomad-client, template |
| Missing affinity operand | validation | error | nomad, affinity, validation |
| 'port_map' cannot map group network ports, use 'ports'… | validation | error | docker, nomad-driver, ports, port-map, legacy |
| Prefix matched multiple CSI volumes | console | warning | nomad-cli, csi, prefix-match, ux |
| task not started yet. | http | warning | nomad, exec, race-condition, timing |
| wait aborted | exception | warning | docker, context-cancellation, image-pull |
| Couldn't resolve symlink for | exception | error | filesystem, symlink, chroot, linux |
| CSI.ControllerValidateVolume: VolumeID is required | validation | error | csi, validation, volume, request |
| deleting job versions failed | exception | error | nomad, state-store, job-versions, pruning |
| dynamic_user_min must be set | validation | error | nomad, agent-config, validation |
| failed to read after | exception | error | network, io, snapshot, stream |
| failed to write bootstrap environment | exception | error | envoy, consul-connect, filesystem |
| Invalid cron spec | validation | error | nomad, validation, cron, job-spec |
| invalid PemKeyFile | validation | error | nomad, oidc, client-assertion, file-path |