hashicorp/nomad

Documented errors, page 12 of 29. Back to hashicorp/nomad

Code / MessageTypeSeverityTags
Node does not support RPC; requires 0.8 or later
error_code error rpc, nomad, versioning, compatibility
task network resources have been deprecated as of Nomad…
validation warning nomad, deprecation, networking, warnings
Token does not match for Evaluation ID
exception error go, nomad, scheduler, broker, concurrency
unable to convert userid to uint32
exception error unix, uid, strconv, nomad-executor
volume lookup failed
exception error state-store, memdb, csi, node, nomad
volume is in nonexistent namespace
validation error nomad, csi, namespace, volume
WARNING! The "nomad " command is deprecated. Please use…
console info cli, deprecation, warning
all servers must be running version
validation error nomad, node-pools, versioning, rolling-upgrade
cgroupslib: unable to update share cpuset with
error_code error linux, cgroups, cpuset, filesystem-permissions
Connect configuration empty for service
validation error consul, connect, configuration, nomad
could not read path from keystore
console critical nomad, keystore, filesystem, permissions, encryption
could not resolve user
exception error nomad, authentication, acl, rpc
failed to generate key wrapper key
exception error cryptography, entropy, key-wrapping
failed to get job node pool
exception error nomad, scheduler, sysbatch, node-pool, state-store
failed to load CNI config list file
exception error cni, networking, file-parse
failed to query node pool
exception error nomad, node-pool, state-store, internal-error
file missing for
exception error integrity, missing-file, snapshot
Group has warnings
validation warning nomad, warnings, task-group, job-validation
http_read_timeout must be > 0
validation error nomad, config, validation, duration-parsing
Invalid lifecycle hooks given
validation error
missing SnapshotID
validation error csi, validation, missing-field, snapshot, storage
node secret ID does not match. Not registering node.
validation error nomad, node-registration, security, secret-mismatch
one of LimitBytes or RequiredBytes must be set
validation error csi, validation, missing-field, storage, volume-expansion
run_for not a valid duration
validation error nomad, mock-driver, duration-parsing, config-validation
Task group volume validation for
validation error nomad, job-validation, volumes, csi
unknown plugin with name
exception error plugin-loader, unknown-plugin, plugin-discovery, nomad
wait config min is greater than max
validation error config, validation, wait, go
can't unblock running deployment
error_code warning nomad, deployment, state-conflict
Could not find job version
console error multiregion, deployment, not-found
CSIPluginConfig must have a non-empty PluginID
validation error nomad, csi, validation, jobspec
evals field must not be set
validation error nomad, rpc, validation, client-server
failed to construct ACL
exception error nomad, acl, policy, construction
Failed to mount secrets dir
exception error filesystem, mount, secrets
failed to reset heartbeat since server is not leader
error_code warning nomad, raft, leader-election, heartbeat
failed to validate API versions
exception error go, plugin-loader, api-version-negotiation, nomad
invalid security_opt
validation error docker, security, config-parsing
IOPS has been deprecated as of Nomad 0.9.0. Please remove…
validation warning nomad, deprecation, resources, warnings
Job type does not allow migrate block
validation error nomad, job-validation, migrate-block, hcl
orphaned processes have not been removed from cgroups pid…
exception error linux, cgroups, process-lifecycle, executor
SecretsMB value ( ) cannot be larger than MemoryMB value ( )
validation error nomad, resources, validation, memory
Server at address failed ping
exception error network, ping, rpc, server-discovery
template render subprocess failed
exception error
cannot change attachment mode of claimed volume
validation error nomad, csi, volume, claim, storage
Consul Connect service name
validation error nomad, consul-connect, naming, job-validation
ErrInvalidBound
range bound not valid
error_code error validation, uid-gid, ranges, nomad
ErrVolumeNameExists
volume name already exists on this node
error_code warning go, host-volumes, concurrency
failed to parse bytes
exception error pem, x509, certificate, oidc
failed to write vault token
exception error nomad, vault, filesystem, permissions
GCE machine-type format invalid
exception warning gce, metadata, validation
internal plugin doesn't meet base plugin interface
exception error go, plugins, type-assertion, interface
invalid status for node
validation error nomad, node-registration, validation
missing certificate information
exception error tls, mtls, authentication, rpc
rcp.accept_backlog interval must be greater than zero
validation error config, validation, nomad-agent, rpc
service registration not found
exception warning nomad, service-registration, delete-not-found, state-store
subscription closed by server, client should resubscribe
exception warning nomad, streaming, event-broker, subscription
unable to parse address template
validation error config, consul, template, address
Unknown node
exception error filesystem, streaming, nomad, unknown-node
volume max claims reached
error_code error csi, storage, nomad, claim-limit
cgroupslib: unable to update reserve cpuset with
error_code error linux, cgroups, cpuset, filesystem-permissions
change_signal must be specified when using change_mode=
validation error nomad, workload-identity, validation, config
Client RPC advertise address is not a TCP Address
exception critical network, advertise, startup, address
decompression_size_limit must not be nil
validation error nomad, config-validation, missing-field, decompression
error generating CA certificate
exception error tls, x509, certificate-generation
ErrPluginDisabled
device is not enabled
error_code info devices, fingerprinting, plugin, configuration
Failed to start serf
exception critical nomad, go, serf, gossip, startup
job not found in namespace
http error nomad, exec, job-not-found, namespace
missing attributes for client registration
validation error nomad, rpc, validation, fingerprint
missing namespace
validation error nomad, variables, validation, namespaces
node ID cannot be updated
validation error nomad, host-volume, immutability, update-validation
one of SnapshotID or CloneID must be set if ContentSource…
validation error csi, validation, content-source, storage
Prefix matched multiple nodes\n\n
exception error cli, nomad, node, ambiguity
process did not exit after 15 seconds
exception warning shutdown, timeout, process-lifecycle
rcp.connection_write_timeout must be greater than zero
validation error config, validation, nomad-agent, rpc, timeout
rcp.stream_open_timeout must be greater than zero
validation error config, validation, nomad-agent, rpc, timeout
telemetry in-memory collection interval must be greater…
validation error config-validation, telemetry, metrics, duration
timed out while opening database, is another Nomad process…
exception error nomad, boltdb, file-lock, client-startup
unexpectedly did not forward Alloc.List to region
exception error nomad, rpc-forwarding, multi-region
ACL binding rule not found
error_code error nomad, acl, sso, delete-not-found
ACL binding rules lookup failed
exception error nomad, state-store, acl, lookup
client_introduction.default_identity_ttl must be greater one
validation error config-validation, ttl, client-introduction
CSI.ControllerCreateSnapshot
exception error csi, snapshot, request-validation
default namespace can not be deleted
validation error nomad, state-store, namespace
empty region value
exception warning fingerprint, digitalocean, metadata-service, network
error opening env template
exception error
failed to convert username to UTF-16
exception error windows, utf-16, encoding, logonuser
Failed to mount alloc dir
exception error filesystem, mount, nomad-client
Failed to parse as octal
validation error
gcs_timeout must be > 0
validation error config, validation, duration, nomad
incompatible state version. expected
error_code critical state-store, upgrade, version-mismatch, nomad
invalid address
validation error configuration, url, nomad-api
missing redirect URI
validation error nomad, acl, oidc, validation, redirect-uri
missing target region
http error nomad, rpc, log-monitoring, region, streaming
retry config backoff
validation error config, validation, retry, backoff, go
ACL role with name already exists
validation error nomad, acl, uniqueness, name-conflict
Connect proxy task must not have a service block
validation error nomad, connect, consul, service-mesh, validation
could not verify host path for
error_code error host-volumes, filesystem, path-validation
csi_plugin lookup error
exception error nomad, csi, state-store, memdb
ErrCNICheckFailed
%w: %w
error_code error nomad, cni, netns-check, sentinel-error
failed to configure network
error_code error
failed to create parent directories of
exception error filesystem, permissions, directory, debug