hashicorp/nomad
Documented errors, page 14 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| bitmap must be byte aligned | validation | error | nomad, bitmap, validation, alignment |
| error moving task local dir | exception | error | filesystem, rename, allocation-migration |
| error parsing address | validation | error | parsing, address, ipv6 |
| failed to connect to docker daemon | exception | critical | docker, network, daemon-connection |
| failed to fingerprint plugins | exception | error | go, plugins, fingerprinting, exec |
| failed to get the current netns | exception | error | linux, network-namespace, procfs |
| failed to retrieve capabilities for driver | error_code | error | nomad, driver, capabilities, plugin-rpc |
| Identity is invalid | validation | error | nomad, workload-identity, validation |
| invalid digest format | validation | error | go, checksum, input-validation, http |
| invalid interface name | validation | error | config, network, interface |
| missing lock ID | validation | error | nomad, variables, locking, validation |
| node plugin returned an error | exception | error | csi, storage, grpc, plugin |
| only one server.keyring can be active in Nomad Community… | exception | error | go, nomad, configuration, licensing, keyring |
| self-drain exceeded deadline | exception | error | drain, deadline, node-lifecycle |
| Static port already reserved by | validation | error | nomad, network, ports, host-network |
| unexpected ExpirationLeeway type | validation | error | json, unmarshal, acl, consul-api |
| volume validation failed: no such namespace | validation | error | nomad, host-volumes, namespace, validation |
| can't fail terminal deployment | error_code | error | deployment, state, rpc, nomad |
| cluster ID not ready yet | error_code | warning | nomad, raft, cluster-metadata, timing |
| command cannot be empty | validation | error | nomad, validation, jobspec, actions |
| devices updates already batched | exception | warning | nomad-client, devices, fingerprinting, one-shot |
| error creating task dir | exception | error | filesystem, mkdir, allocation-migration, permissions |
| error writing to file | exception | error | filesystem, io, alloc-migration |
| failed to convert " " to UTF16 | exception | error | windows, encoding, utf16, fingerprinting |
| Failed to encode request | exception | error | nomad, raft, encoding, messagepack, internal-api |
| failed to load CNI config | error_code | error | nomad, cni, config-load, bridge-network |
| failed to parse mac_address | validation | error | docker, nomad, mac-address, config-validation |
| failed to send signal | exception | error | nomad, vault, signal, driver |
| failed to write bootstrap command line | exception | error | envoy, consul-connect, filesystem |
| Invalid agent policy: %#v | validation | error | nomad, acl, policy-validation, agent |
| minimum DiskMB value is 10; got | validation | error | nomad, ephemeral-disk, resources, job-spec, validation |
| node doesn't have a drain strategy set | console | error | nomad, node-drain, state-inconsistency |
| node does not exist | validation | error | nomad, host-volumes, node, not-found |
| Nomad can't restart the TaskGroup | validation | error | nomad, validation, duration, restart-policy |
| task group volume claim does not exist | exception | error | nomad, volumes, not-found, claims |
| Template has same destination as | validation | error | nomad, job-validation, template, duplicate |
| unable to create KMS wrapper for provider | console | error | kms, wrapper, configuration, credentials, go |
| update hook failed | exception | error | nomad, client, hooks, update, lifecycle |
| VerifyIncoming set, and no CA certificate provided! | exception | error | tls, mtls, configuration |
| allocation directory is inaccessible | exception | error | restore, filesystem, agent-restart, alloc-dir |
| container stopped | exception | info | docker, stats, lifecycle, container-stopped |
| Docker privileged mode is disabled on this Nomad agent | validation | error | docker, nomad-driver, privileged, security |
errMissingACLAuthMethodName missing ACL auth-method name | error_code | error | consul, acl, auth-method, validation, sentinel-error |
| error deleting invalid allocation state | error_code | critical | bolt, upgrade, corruption, disk |
| expiration time cannot be more than | validation | error | acl, token, validation, ttl, expiration |
| failed to copy stable store | exception | error | migration, raft, stable-store, io |
| failed to create stderr logfile for | exception | error | logging, logmon, filesystem, configuration |
| failed to encode bootstrap command line | exception | error | envoy, consul-connect, io |
| failed to query Consul namespaces | console | error | consul, namespaces, acl, sync, nomad |
| failed to update job stability | exception | error | nomad, state-store, deployment, job-stability |
| failed to validate volume | exception | error | nomad-client, host-volumes, configuration |
| http_max_size must be set | validation | error | nomad, config, validation, missing-field |
| Missing Log Config | validation | error | nomad, job-spec, validation, logging |
| No servers found | exception | warning | nomad, raft, autopilot, consensus |
| no such key | exception | error | keyring, key-not-found, timeout |
| Task group must have at least one main task | validation | error | nomad, job-validation, lifecycle-hooks |
| unable to stop existing service | exception | error | windows, service-control-manager, installation |
| volume mount has an invalid SELinux label | validation | error | nomad, volumes, selinux, validation |
| cannot specify Accessor ID | validation | error | nomad, csi, unknown-node, state-store |
| could not read -jwks-certfile | exception | error | consul, file-io, tls, setup |
| could not validate task driver capabilities | error_code | error | csi, drivers, nomad, plugin |
| drain for task group | console | error | nomad, node-drain, task-group, wrapped-error |
| error parsing port from check | validation | error | consul, nomad, port, strconv |
| failed to determine relative path base= | exception | error | path-resolution, executor, task-dir |
| Failed to initialize Vault client for | exception | error | vault, client, configuration |
| Failed to open file | console | error | cli, filesystem, permissions, fmt |
| Failed to parse ACL Policy | validation | error | acl, policy, hcl, parsing |
| failed to parse raft_logstore verification interval | validation | error | nomad, config-validation, raft, duration-parsing |
| failed to receive initial message | exception | error | grpc, streaming, exec, plugin |
| JobByID lookup failed | exception | error | nomad, raft, fsm, state-store |
| Malformed ulimit specification | validation | error | docker, ulimit, config-validation |
| root key material is required | validation | error | nomad, keyring, validation, root-key |
| Service name must be valid per RFC 1123 and can contain… | validation | error | nomad, naming, rfc1123, validation |
| snapshot has a pending operation | error_code | warning | csi, snapshot, grpc, concurrency, nomad |
| all servers should be running version | exception | error | versioning, cluster, acl, jwt, compatibility |
| archive contains symlink that escapes alloc dir | exception | critical | nomad, security, symlink, path-traversal |
| Bind address resolution failed | validation | error | config, network, bind-address, validation |
| CSI.ControllerAttachVolume: ClientCSINodeID is required | validation | error | csi, validation, nomad, storage |
| description longer than | validation | error | acl, validation, limits |
| Error listing CSI volumes | console | error | nomad-api, csi, network, acl |
| Error while detecting network interface | exception | error | network, fingerprinting, configuration |
| failed to decode key | validation | error | hcl, keyring, type-error, config-parsing |
| failed to get allocs for job | exception | error | nomad, scheduler, sysbatch, allocations, state-store |
| format must be key=value | validation | error | cli, argument-parsing, key-value |
| invalid address mode | validation | error | nomad, service-registration, invalid-enum, invariant |
| missing accessor ID | validation | error | nomad, csi, fingerprinting, node-plugin |
| missing job ID for marking job as stable | validation | error | nomad, job-stable, validation, missing-argument |
| %s: %s | validation | error | hcl, diagnostics, parsing, go |
| set mode | exception | error | rpc, yamux, streaming, nomad |
| Spread target value already defined | validation | error | nomad, spread, job-spec, validation |
| topology: no node distance | panic | error | numa, topology, panic, invariant-violation |
| cni not initialized | error_code | error | nomad, cni, initialization, network-setup |
| controller delete volume | exception | error | nomad, csi, storage, deletion, plugin |
| could not get existing service | exception | error | go, windows, service-control-manager, permissions |
| could not remove eventlog configuration | exception | warning | go, windows, registry, eventlog |
errMissingACLRoleID missing ACL role ID | error_code | error | consul, acl, validation, missing-argument, sentinel-error |
| error parsing address | validation | error | parsing, address, validation |
| failed to generate logging UI | exception | error | ui, logging, cli, initialization |
| invalid KeySource | validation | error | nomad, acl, oidc, enum-value, validation |
| KVM accelerator is unsupported on the current platform | exception | error | qemu, kvm, windows, macos, virtualization |