hashicorp/nomad
Documented errors, page 15 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| leadership transfer not supported with Raft version lower… | exception | error | nomad, raft, leadership, version-compatibility |
| must provide a valid alloc id | validation | warning | api, validation, filesystem |
| Spread block must have a positive weight from 0 to 100 | validation | error | nomad, spread, scheduling, validation, range-check |
| TargetPath is required | validation | error | csi, validation, volume-expand |
| user name must contain domain | validation | error | windows, user-impersonation, executor, nomad |
| could not configure Windows job object for executor | exception | error | windows, job-object, process-management, kernel |
| could not create default configuration file | exception | error | windows, configuration-file, permissions |
| could not parse transparent proxy excluded outbound CIDR as… | validation | error | validation, connect, cidr, networking |
| disable_filesystem_isolation must be set | validation | error | config, validation, nomad-agent |
| failed to create secrets/envoy_bootstrap.json for envoy | exception | error | go, filesystem, nomad, envoy, file-create |
| failed to open docker client | exception | error | docker, logging, connection, driver-setup |
| Failed to parse Consul Auth config | exception | error | |
| failed to parse 'image_delay' duration | validation | error | docker, duration, config, nomad |
| failed to remove pause container | exception | error | docker, network, cleanup, container-remove |
| failed to retrieve signed workload identity | exception | error | nomad, vault, workload-identity, rpc |
| failed to start plugin | exception | error | plugin, devicemanager, go-plugin |
| invalid node pool configuration | validation | error | nomad, validation, node-pool |
| Invalid policy | validation | error | acl, policy, validation |
| must update at least one allocation | validation | error | nomad, rpc, validation, allocations |
| -node or -node-pool options can only be used when no ID is… | validation | error | nomad, cli, flag-conflict, usage |
| PreventRescheduleOnLost is deprecated and ignored in favor… | validation | error | nomad, job-spec, deprecation, validation |
| received an error from stderr log stream | console | error | nomad, streaming, logs, stderr, network |
| s3_timeout must be set | validation | error | nomad, config-validation, missing-field, s3 |
| Task missing name | validation | error | nomad, job-validation, task-definition |
| Unsupported isolation mode | validation | error | docker, windows, isolation, config |
| validator | exception | error | user-lookup, uid, validation, os-users |
| volume validation failed | validation | error | nomad, host-volumes, validation, schema |
| Couldn't read directory | exception | error | filesystem, chroot, read-dir |
| Couldn't read the file information | exception | error | filesystem, chroot, race-condition |
| error parsing server's last_log_term value | exception | error | nomad, raft, parsing, rpc |
| Failed to copy snapshot to temporary file | exception | error | raft, snapshot, io, enospc, go |
| failed to decode 0.8 driver state | exception | error | nomad, state-upgrade, json-decode, migration |
| failed to encrypt root key | exception | error | kms, encryption, network |
| failed to generate ACL token name | exception | error | template, hil, acl, nomad |
| failed to retrieve config schema for internal plugin | exception | error | go, plugin-loader, config-schema, nomad |
| Invalid operator policy: %#v | validation | error | nomad, acl, policy-validation, operator |
| invalid port : port label not found or is not numeric | validation | error | nomad, service-registration, port-label, configuration |
| missing policy name | validation | error | validation, sentinel, input-validation, api |
| Must provide the NodeID | validation | error | nomad, rpc, validation, node |
| namespace contains at least one variable. All variables in… | validation | error | nomad, state-store, namespace, variables |
| no Vault cluster named | exception | error | nomad-client, vault, lookup |
| node pool does not exist | validation | error | nomad, host-volumes, node-pool, not-found |
| volume lookup failed for | exception | error | state-store, memdb, csi, read-txn, nomad |
| computed bind name for bind target is invalid | exception | error | auth, acl-binding-rule, name-validation |
| Consul Connect must be exclusively native, make use of a… | validation | error | nomad, consul-connect, validation, config |
| decompression_size_limit is not a valid size | validation | error | nomad, config-validation, size-parse, decompression |
| error reading file | exception | error | cli, file-io, argument-parsing |
| failed to open state database | exception | critical | client-init, boltdb, state-database, filesystem |
| job summary lookup failed | exception | error | nomad, state-store, evals, job-summary |
| missing volume definition | validation | error | nomad, host-volumes, request-validation |
| Multi-Cluster Consul is unlicensed. | validation | error | nomad, licensing, enterprise, consul |
| service ( ) failed validation | validation | error | service, validation, consul, naming |
| stderr_repeat_duration | validation | error | nomad, mock-driver, duration-parsing, config-validation |
| task does not support networking mode | validation | error | nomad, network-mode, driver-capabilities, bridge |
| unable to write to custom cgroup | exception | error | cgroups, cgroup-v1, configuration |
| cannot specify ACL role ID | validation | error | consul, acl, create-vs-update, validation |
| check cannot use address_mode="alloc_ipv6", only checks… | validation | error | nomad, health-check, ipv6, address-mode |
| claiming volumes | error_code | error | csi, storage, volumes, nomad |
| Error parsing advertise address | validation | error | config, consul, address-parsing, advertise-address |
| ExternalID is required | validation | error | go, csi, validation |
| failed to convert parsed config to map | exception | error | plugin-loader, cty, type-conversion, nomad |
| failed to decode snapshot | exception | error | codec, snapshot, decoding, nomad |
| Failed to resolve Server RPC advertise address | exception | error | network, dns, configuration, nomad |
| failed to stream snapshot | http | error | network, io, snapshot, rpc |
| failed to unmount NS: at | exception | error | linux, network-namespace, unmount, cleanup |
| MinHealthyTime is and must be >= 0 | validation | error | nomad, go, validation, migrate-strategy, duration |
| Must specify a source path or have an embedded template | validation | error | nomad, template, job-spec-validation |
| namespace must be set to set job ID | validation | error | acl, validation, job-acl, namespace |
| secret provider cannot be empty | validation | error | nomad, secrets, validation, provider |
| should be an object | validation | error | hcl, vault, config-parsing |
| Spread target percentage for value | validation | error | nomad, spread, percent, job-spec, validation |
| ACL binding rule insert failed: ACL auth method not found | validation | error | nomad, acl, binding-rule, auth-method, raft |
| default_pid_mode must be | validation | error | java-driver, config-validation, nomad |
| Deployment ID couldn't be updated as it does not exist | validation | error | nomad, state-store, deployment, not-found |
| driver does not support exec | exception | error | plugin, driver, exec, capability |
| failed to read dynamic plugin registry state | exception | error | bolt, state-store, deserialization, csi, nomad |
| failed to restart task | exception | error | restart, task-runner, driver, concurrency |
| failed to snapshot state | exception | critical | nomad, state-store, internal, snapshot |
| max_identity_ttl must be greater than or equal to… | validation | error | nomad, config, validation, ttl |
| misconfigured connection | http | error | events, configuration, agent |
| path escapes the alloc directory | exception | error | security, path-traversal, filesystem |
| path was not a regular file | exception | error | filesystem, path-lookup, executor |
| rcp.stream_close_timeout must be greater than zero | validation | error | config, validation, nomad-agent, rpc, timeout |
| Region not found | exception | error | multiregion, deployment, cli, nil-region |
| scaling policy delete failed | exception | error | nomad, state-store, scaling-policy, transaction |
| Vault validation failed | validation | error | nomad, validation, vault, job-spec |
| could not add key file | console | critical | keyring, cipher, key-rotation, go |
| driver updates already batched | exception | warning | nomad-client, drivers, fingerprinting, one-shot |
| error creating fifo | exception | error | go, linux, fifo, syscall |
| Error querying CSI external volumes for plugin | console | warning | csi, api, pagination, multierror |
| failed to decode input | exception | error | decode, streaming, msgpack, rpc |
| failed to fetch signed identities | exception | critical | workload-identity, startup, rpc, nomad |
| failed to find instances of controller plugin | exception | error | csi, nomad, plugin-registration, controller |
| Failed to query list of containers | error_code | error | docker, nomad, daemon-unreachable, timeout |
| must not be nil | validation | error | nomad, workload-identity, validation, nil-pointer |
| recovery failed to delete peers.json, please delete… | exception | error | raft, recovery, filesystem, permissions |
| rpc error: lead thread didn't get connection | exception | error | rpc, connection-pool, race |
| unable to update volume | exception | error | csi, validation, conflict |
| Version affinity is invalid | validation | error | nomad, affinity, version-parsing, job-validation |
| cannot detect current nomad path | exception | error | windows, executable, os |