hashicorp/nomad
Documented errors, page 17 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| must be a int64; got a (%T) %[2]v | console | error | hcl, nomad, type-mismatch, validation |
| unable to update job submission | exception | error | nomad, state-store, job-submission |
| unsupported capacity_range for volume | error_code | error | csi, grpc, storage, capacity-range |
| CSI.ControllerDetachVolume | exception | error | csi, plugin, retryable, detach |
| CSI.ControllerValidateVolume | exception | error | csi, validation, request-conversion |
ErrLockConflict conflicting operation over lock | error_code | error | go, nomad, lock, conflict, http-409 |
| error marshaling ECDSA private key | exception | error | tls, cryptography, x509 |
| Error reading | exception | error | cli, file-io, var-put |
| failed to create state database | exception | critical | nomad, boltdb, state-database, filesystem |
| failed to encode driver config | exception | error | |
| failed to parse 'infra_image_pull_timeout' duration | validation | error | docker, duration, config, nomad |
| failed to sync temp snapshot | exception | error | filesystem, fsync, io, disk |
| Failed to write data to file | exception | error | filesystem, disk-full, io, debug |
| job does not have allocation | http | error | nomad, exec, mismatch, validation |
| Missing constraint operand | validation | error | nomad, constraint, validation |
| Missing job ID | validation | error | nomad, go, validation, job-spec |
| missing target namespace | validation | error | nomad, scaling-policy, target, validation |
| no such node | validation | error | nomad, host-volumes, node-not-found, placement |
| no such volume | validation | error | nomad, host-volumes, not-found, delete |
| not a valid task schedule state | validation | error | nomad, task-scheduling, enum, validation |
| session open | exception | error | rpc, yamux, networking, nomad |
| unable to parse var file | validation | error | hcl, parsing, jobspec, variables |
| unsupported attribute | validation | error | nomad, constraint, validation, attributes |
| validate called on nil host volume capability | validation | error | nomad, host-volume, nil-pointer, validation |
| wait config is empty | validation | error | nomad, config, consul-template, conversion |
| cannot write nomad binary for install | exception | error | go, windows, filesystem, io |
| error parsing env template | exception | error | |
| error parsing port from service | validation | error | consul, service-registration, port, parsing, nomad |
| error | exception | error | versioning, parsing, nomad |
| failed to decode Docker response | exception | warning | docker, stats, json-decode |
| Failed to start RPC layer | exception | critical | nomad, go, rpc, port-conflict, startup |
| gcs_timeout must be set | validation | error | config, validation, nomad, gcs |
| Invalid namespace | validation | error | nomad, namespace, validation, schema |
| Invalid variable policy: no variable paths in namespace | validation | error | nomad, acl, variables, policy-validation |
| namespace does not allow volumes to use node pool | validation | error | nomad, host-volumes, node-pool, namespace-governance, acl |
| origin must be start or end | validation | warning | api, validation, logs, streaming |
| s3_timeout not a valid duration | validation | error | nomad, config-validation, duration-parse, s3 |
| Scaling policy invalid | validation | error | nomad, scaling-policy, job-validation |
| task driver does not support exec | exception | error | exec, drivers, streaming |
| unable to stop service | exception | error | go, windows, service-control-manager, service-stop |
| Artifact validation failed | validation | error | nomad, validation, artifacts, job-spec |
| Could not find task runner for task | exception | error | api, task-runner, name-mismatch, alloc-runner |
| error streaming previous alloc | exception | error | nomad, alloc-migration, tar-stream, remote-error |
| exec timed out | exception | error | grpc, timeout, exec, context-canceled |
| failed to decode driver task state | exception | error | state-decode, task-recovery, json-unmarshal, nomad-driver |
| Failed to find docker auth for repo | exception | error | docker, auth, registry |
| Failed to parse RPC advertise address | validation | error | config, network, advertise-address |
| failed to query Consul checks | console | error | consul, checks, acl, sync, multierror, nomad |
| Failed to stop container | exception | error | docker-driver, kill, container-stop |
| job in namespace doesn't exist to be deregistered | exception | error | nomad, raft, fsm, job-not-found |
| must have at least client or server mode enabled | validation | error | nomad, config, startup |
| must specify plugin type to deregister | validation | error | validation, plugin-registry, nomad |
| no storage node plugins found | exception | error | csi, nomad, plugin-manager, storage, node-plugins |
| unable to find token for workload | exception | error | workload-identity, cache-miss, nomad |
| unable to process ACLToken | exception | error | nomad, consul, acl-token, base64, state-corruption |
| validator | exception | error | user-lookup, gid, os-groups, validation |
| Volume Mount ( ) references undefined volume | validation | error | nomad, volume, csi, job-validation |
| all servers must be running version | exception | error | nomad, rpc, version-compatibility, cluster-upgrade |
| allocation not found | http | error | nomad, allocation, filesystem, api |
| controller detach volume | exception | error | nomad, csi, storage, detach, plugin |
| destroy hook failed | exception | error | |
| error generating ECDSA private key | exception | error | tls, cryptography, entropy |
| failed to add job | exception | error | nomad, scheduler, periodic-jobs, duplicate-entry |
| failed to get current user | exception | error | user-lookup, validation, unix, nomad, rawexec |
| failed to parse version | exception | error | go, plugin-loader, version-parsing, nomad |
| failed to start command | exception | error | process-start, exec, tty, nomad-executor |
| invalid key type: %T | exception | error | tls, x509, key-type |
| invalid token locality | validation | error | acl, validation, nomad |
| minimum CPU value is | validation | error | nomad, resources, validation, cpu |
| nil logger passed | validation | error | go, configuration, logging, validation |
| no identities requested | validation | error | nomad, rpc, validation, workload-identity |
| one of LimitBytes or RequiredBytes must be set if… | validation | error | csi, validation, go, storage, capacity |
| Periodic can only be used with | validation | error | nomad, periodic-job, scheduler, job-validation |
| plugin config passed without binary name | validation | error | go, configuration, validation, plugins |
| plugin instance is not healthy | exception | error | csi, nomad, plugin-health, heartbeat |
| plugin doesn't implement base plugin interface | exception | error | plugin-loader, type-assertion, plugin-interface, nomad |
| Required and optional meta keys should be disjoint… | validation | error | nomad, validation, dispatch, configuration |
| Service identity must provide at least one target aud value | validation | error | nomad, workload-identity, jwt, validation |
| service cannot have "connect" block, only services defined… | validation | error | nomad, consul-connect, service-validation, service-mesh |
| task group does not exist in job | error_code | error | nomad, allocrunner, task-group, state |
| can't copy nil Bitmap | validation | error | nomad, bitmap, nil-pointer, copy |
| deprecated config field 'RaftBoltNoFreelistSync' is set… | validation | error | nomad, go, deprecated-config, startup |
| disable_artifact_inspection must be set | validation | error | nomad, config-validation, missing-field, security |
| Error formatting the data | console | error | cli, templating, go-templates |
| failed to find java binary | exception | error | nomad, java-driver, environment, missing-binary |
| failed to make pkce verifier | exception | error | pkce, oidc, crypto, nomad |
| Failed to parse Serf advertise address | validation | error | config, network, advertise-address, serf |
| Failed to parse signal | validation | error | config, signals, nomad, template, validation |
| invalid bridge_network_subnet | validation | error | nomad, config-validation, network, cidr |
| Invalid client config given | validation | error | |
| invalid starting token | error_code | error | csi, grpc, pagination, list-volumes |
| missing alloc bucket | exception | error | |
| missing StagingTargetPath | validation | error | csi, validation, go, storage |
| node lookup failed | exception | error | nomad, state-store, storage, node-events |
| node not found | error_code | error | nomad, state-store, node-status, missing-entity |
| not : format | validation | error | docker, volumes, windows, parsing |
| Parameter for choose must be in form | error_code | error | validation, rpc, filtering, nomad |
| Restart policy with attempts is ambiguous | validation | error | nomad, validation, job-spec, restart-policy |
| singleton plugin exited | exception | warning | plugin-loader, singleton, retry |
| stop_after cannot be a negative duration | validation | error | nomad, job-spec, validation, disconnect |