hashicorp/nomad

Documented errors, page 19 of 29. Back to hashicorp/nomad

Code / MessageTypeSeverityTags
job submissions lookup failed
exception error nomad, state-store, job-submissions
must call StopTask for the given task before Destroy or set…
error_code error docker, nomad, lifecycle, destroy-task
Parameterized job can only be used with
validation error nomad, parameterized-job, dispatch, job-validation
unable to open raft logs that are in use
exception error raft, boltdb, file-lock
Allocation is running the following tasks: * Please specify…
exception error cli, logs, task-selection, argument-required
command empty
validation error docker, nomad, validation, empty-argument
could not open existing file
exception error filesystem, permissions, io
error setting up exec subcommand
exception error cgroups, executor, configuration
failed to load CNI config file
exception error cni, networking, file-parse
file ' ' cannot be mapped. Only directories can be mapped…
validation error docker, volumes, windows, filesystem
nil response from plugin.NodeExpandVolume
exception error go, csi, grpc, volume-expansion
plan exceeds max allocation
validation error nomad, scheduler, capacity, plan
unable to parse var content
validation error hcl, parsing, jobspec, variables
unsupported bind type
validation error nomad, acl, binding-rule, enum-value, validation
value is not known
exception error hcl, cty, jobspec, unknown-value
Could not find Nomad executable
exception error discovery, working-directory, testing, filesystem
failed to create file
exception error filesystem, permissions, file-create, debug
failed to inspect container state
error_code error docker, nomad, container-inspect, daemon-unreachable
failed to set subtree control on cpuset share partition
error_code error linux, cgroups, cgroupv2, subtree-control
invalid config
validation error acl, validation, oidc, jwt, nomad
invalid port: : not a valid port mapping or numeric port
validation error
'io.Reader' being decoded is nil
exception error cli, json, nil-reader
job ID in payload did not match URL
validation error
Last contact duration is out of range
exception error http-header, overflow, parsing
missing Name
validation error csi, validation, go, storage
no node events given for node
validation error nomad, rpc, events, validation
No node pool with prefix
exception error cli, nomad, node-pool, not-found
pids_limit cannot be greater than nomad plugin config…
validation error docker, pids-limit, config, nomad
SecretsMB value ( ) cannot be negative
validation error nomad, resources, validation
Sum of spread target percentages must not be greater than…
validation error nomad, spread, percent, job-spec, validation
ttl for default identity not yet supported
validation error nomad, workload-identity, validation, ttl
unable to convert groupid to uint32
exception error unix, gid, strconv, nomad-executor
upserting token failed
exception error nomad, state-store, acl, raft
cannot apply allowed_modes configuration
validation error config, docker, validation, uts-mode
cannot submit plan without job info
validation error nomad, rpc, plan, internal-api
cron is deprecated and may be removed in a future release…
validation warning nomad, deprecation, periodic-job, cron
CSIPluginConfig StagePublishBaseDir must not be a…
validation error nomad, csi, validation, filesystem
error chowning directory
exception error nomad, filesystem, permissions, chown
Failed to open auth config file
exception error docker, auth, config-file, permissions
Failed to parse as bool
validation error
failed to read driver manager plugin state
exception error bolt, state-store, deserialization, nomad
first message should always be setup
exception error grpc, streaming, protocol
missing metadata
exception error encryption, keyring, missing-metadata
missing volume ID to delete
validation error nomad, host-volumes, missing-argument, input-validation
Server RPC advertise address is not a TCP Address
exception error network, type-assertion, configuration, nomad
tasks and want to initiate networking but only one driver…
validation error nomad, network-initiator, task-group, conflict
telemetry in-memory retention period must be greater than…
validation error config-validation, telemetry, metrics, duration
x5t assertion headers use SHA-1, which is forbidden in…
exception error oidc, fips, sha1, jwt
Action defined multiple times
validation error nomad, job-validation, action, duplicate
Action validation failed
validation error nomad, job-validation, action, hcl
Both json and template formatting are not allowed
validation error cli, json, template, flag-parsing
can't cancel terminal deployment
error_code error deployment, state, rpc, nomad
cannot reload agent with nil configuration
validation error nomad, reload, tls, configuration
controller create volume
exception error nomad, csi, storage, provisioning, plugin
controller expand volume
exception error nomad, csi, storage, expansion, plugin
Error querying CSI volume
console error nomad-api, csi, acl, network
failed joining
exception error http, api, cluster-join, consul-agent
failed parsing cron expression
validation error nomad, cron, validation, scheduler
failed to compress snapshot file
exception error gzip, compression, io, snapshot
Failed to convert RTarget
validation error nomad, constraint, distinct-property, parsing
Invalid max template event rate given
validation error config, validation, nomad-client, rate-limit
invalid mount type, must be "bind", "volume", "tmpfs
validation error docker, mount, validation, nomad
Job ID contains a null character
validation error nomad, go, validation, control-characters
parsing plugin configurations failed
exception error go, configuration, hcl, plugins
pid_mode must be or , got
validation error nomad, exec-driver, task-config, validation
prefix ; unsupported type
panic error reflection, flatmap, panic, unsupported-type
running as uid is disallowed
validation error security, uid, policy, validation
unable to lookup user's group membership
exception error unix, groups, nss, nomad-executor
volume delete failed
exception error go, state-store, csi, nomad, delete
attempted to resize a non-tty session
exception error tty, pty, unix, resize
cannot generate binary install path
exception error windows, path, install-dir
duplicate CNI arg
validation error
either ID or Address must be set
validation error nomad, raft, operator-api, validation
ErrInvalidRange
lower bound cannot be greater than upper bound
error_code error validation, uid-gid, ranges, nomad
error creating fifo
error_code error linux, fifo, filesystem, logging
Error fetching job
console error api, network, nomad-jobs
eval broker is enabled; eval broker must be paused to…
exception error nomad, eval, scheduler, operator
evaluation not blocked
exception warning nomad, rpc, scheduler, state-check
failed to create allocation directory for volume
exception error csi, nomad, filesystem, mkdir, volume-publish
failed to lookup job deployments
exception error nomad, scheduler, deployment, state-store
file not found under path
exception error executor, path-lookup, task-dir
Invalid answer
validation error cli, interactive, parsing, duration
invalid bridge_network_subnet: not an IPv4 address
validation error nomad, config-validation, ipv4, ipv6
Invalid key value pair for topic, topic
http error events, parsing, validation
missing logs [ , ]
exception error raft, compaction, log-gap, go
Only .nomad and .hcl files can be processed using nomad fmt
validation warning cli, fmt, file-extension, validation
%s %q
exception error
ScalingPoliciesByJob lookup failed
exception error nomad, state-store, scaling-policies
server config setup failed
exception critical nomad, server, config-setup, startup
Specified job is stopped
validation error nomad, api, stopped-job, state
Task not running
exception error
Unsupported drive_interface
validation error qemu, config-validation, disk, nomad
updating job summary failed
exception error nomad, state-store, memdb, job-summary
volume mount references an empty volume
validation error nomad, volumes, validation, missing-field
check has invalid numeric port
validation error nomad, health-check, port, validation
[✘] Could not create Vault auth method
exception error vault, jwt, config, network
ErrConnectRequireOneNetwork
must have exactly one network for Consul Connect
validation error nomad, consul-connect, job-validation, network
error parsing https_handshake_timeout
validation error configuration, duration-parsing, hcl, nomad
evaluation ID or filter flag required
validation error cli, flags, evals, argument-validation
failed deleting variable entry
exception error nomad, state-store, memdb, variables, delete