hashicorp/nomad
Documented errors, page 21 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Task has an identity called but no vault block | validation | warning | nomad, workload-identity, vault, job-spec |
| version tag not found for job | exception | error | lookup-miss, jobs, versioning |
| alloc does not have a job | exception | error | |
| checksum must be given as "type:value"; got | validation | error | nomad, checksum, format, artifact |
| decompression_file_count_limit must be >= 0 but found | validation | error | nomad, config-validation, integer-range, decompression |
| driver does not implement network management RPCs | error_code | error | nomad, driver, interface-assertion, driver-network-manager |
| error chmoding file | exception | error | nomad, filesystem, chmod, permissions |
| failed to load SI token for native task | exception | error | |
| failed to parse HCL file | validation | error | config, consul, hcl, syntax, parsing |
| failed to read random bytes | panic | critical | uuid, randomness, crypto, panic |
| failed to resolve alloc directory | exception | error | filesystem, symlink, path-resolution |
| failed to set command tty | exception | error | tty, termios, exec, container, nomad |
| first PEM-block should be CERTIFICATE type | validation | error | tls, pem, certificate-parsing, wrong-input |
| Lifecycle validation failed | validation | error | nomad, job-validation, lifecycle |
| No LTarget provided but is required | validation | error | nomad, affinity, job-spec, validation |
| : map key is not string | panic | error | reflection, flatmap, panic, type-error |
| server_join and start_join cannot both be defined; prefer… | validation | error | config, nomad, consul, startup |
| service registration check failed | exception | error | windows, service-control-manager, permissions |
| tag not found on job | validation | warning | nomad, state-store, job-versions, not-found |
| timeout exceeded waiting for process | exception | error | windows, timeout, process, service |
| unable to query job | exception | error | nomad, state-store, alloc, gc |
| All templates should have same Once value | validation | error | config, validation, nomad, template, consul-template |
| device name must be given as one of the following: type… | validation | error | nomad, devices, gpu, job-validation |
| error parsing offset | http | error | filesystem, parsing, http-api |
| error parsing topics | http | error | events, parsing, http-api |
| failed querying self endpoint | exception | error | http, api, network, consul-agent |
| failed to download artifact | exception | error | |
| failed to parse ipv4_address | validation | error | docker, nomad-driver, ip-address, network, config-validation |
| fingerprinting failed | exception | error | client, fingerprinting, initialization |
| unable to upsert job into job_version table | exception | error | nomad, state-store, job-version |
| Unsupported platform | exception | error | platform, filesystem, unsupported-os |
| Affinity weight cannot be zero | validation | error | nomad, affinity, weight, job-spec, validation |
| auth method is missing | validation | error | nomad, acl, binding-rule, config-validation |
| Connect proxy task must not have leader set | validation | error | nomad, connect, consul, leader, validation |
| deployment references unknown job | console | error | nomad, deployment, job, state-store |
| failed to get active nomad key | exception | error | keyring, encryption, oidc, nomad, enterprise |
| failed to get conn | exception | error | rpc, network, connection-refused |
| failed to start command path= | exception | error | process-start, exec, network-isolation, nomad-executor |
| invalid port : port label not found | validation | error | |
| invalid signature | validation | error | jwt, signature, jose, key-rotation, go |
| Missing allocation ID | error_code | error | rpc, nomad, request-validation |
| missing Audience | validation | error | nomad, oidc, jwt, validation |
| missing state | validation | error | nomad, acl, oidc, validation, csrf-state |
| non-default Consul cluster requires Nomad Enterprise | validation | error | nomad, consul, enterprise-only, job-validation |
| Reschedule Policy with Attempts = | validation | error | nomad, validation, reschedule-policy, conflicting-options |
| unknown PEM block type for signing key | validation | error | tls, pem, certificate, key-format |
| upserting evals failed | exception | error | nomad, state-store, evals |
| checksum value cannot be empty | validation | error | nomad, checksum, validation, artifact |
| error reading attribute | exception | warning | digitalocean, metadata-api, http |
| Failed to close | exception | info | linux, network-namespace, file-descriptor, resource-cleanup |
| Failed to initialize Consul client | console | critical | consul, startup, config, nomad |
| missing job ID for deregistering | validation | error | nomad, validation, deregister |
| on_update value is not compatible with check_restart | validation | error | |
| root key state is invalid | validation | error | nomad, keyring, root-key, enum-validation |
| Service with provider nomad cannot include Connect blocks | validation | error | nomad, consul, connect, service-mesh, job-validation |
| unable to lookup job summary for job id | exception | error | nomad, state-store, alloc, job-summary |
| Consul Ingress Service with a wildcard "*" service name can… | validation | error | nomad, consul, ingress-gateway, wildcard, hosts |
| failed to create staging directory for volume | exception | error | csi, nomad, filesystem, mkdir, staging |
| failed to get job deployment | exception | error | nomad, scheduler, deployment, state-store |
| failed to get pty | exception | error | pty, tty, process, nomad-executor |
| failed to set up TLS expiration metrics | exception | error | nomad, tls, config, startup |
| failed to upgrade connection | console | error | websocket, http-upgrade, proxy, network |
| filesystem function disabled | exception | error | hcl, jobspec, filesystem, functions |
| intro token file is a directory | validation | error | filesystem, nomad, config |
| Job task group has count . Count cannot exceed 1 with… | validation | error | nomad, job-validation, system-job, count |
| missing scaling policy type | validation | error | nomad, scaling-policy, validation |
| nonce reuse detected | exception | error | oidc, nonce, replay, cache |
| numa affinity must be one of none, prefer, or require | validation | error | nomad, numa, validation, enum |
| parse error | console | error | hcl, syntax, parsing, nomad |
| can not set node's scheduling eligibility to eligible while… | validation | error | nomad, state-store, node-drain, scheduling-eligibility, invalid-state |
| capacity_max ( ) cannot be less than existing provisioned… | validation | error | nomad, validation, host-volume, capacity |
| [✘] Could not retrieve JWT accessor | exception | error | vault, jwt, permissions, policy |
| creation_grace is less than minimum | validation | error | docker, duration, config, nomad |
| Deployment has terminal status | validation | error | nomad, state-store, deployment, invalid-state |
| error parsing rsa key | console | error | rsa, x509, keyring, key-parsing |
| failed to inspect exit code of exec object | exception | error | docker-driver, exec, exit-code |
| failed to read snapshot file | exception | error | snapshot, corruption, truncated, io |
| ipc_mode must be or , got | validation | error | nomad, exec-driver, task-config, validation |
| Job task group redefines ' ' from group | validation | error | nomad, job-validation, task-group, duplicate-name |
| missing datacenter for client registration | validation | critical | nomad, rpc, validation, config |
| raft apply failed | exception | error | nomad, variables, raft, leader-election |
| System jobs may not have an affinity block | validation | error | nomad, job-validation, system-job, affinity |
| transparent proxy block has invalid UID field | validation | error | validation, connect, transparent-proxy |
| upserting policy failed | exception | error | nomad, acl, state-store, memdb |
| could not stat file | exception | error | filesystem, stat, io |
| CSI.NodeDetachVolume: PluginID is required | validation | error | csi, validation, nomad, storage |
| distinct_hosts should be set to true or false; | console | error | hcl, nomad, constraint, boolean |
ErrConnectInvalidNetworkMode invalid network mode for Consul Connect | validation | error | nomad, consul-connect, network-mode, job-validation |
| error in job mutator | exception | error | nomad, job-mutation, admission-hook, validation |
| Error resolving bind address | validation | error | network, dns, consul, advertise-address |
| failed to parse 'period' duration | validation | error | docker, duration, config, nomad |
| failed to start stream | exception | error | rpc, yamux, stream |
| failed to update job | exception | warning | periodic-jobs, heap, race-condition, scheduling |
| missing ExternalID | validation | error | csi, validation, go, storage |
| namespace contains at least one non-terminal job . All jobs… | validation | error | nomad, state-store, namespace, job-lifecycle |
| root key in use, cannot delete | error_code | error | nomad, keyring, variables, conflict |
| Service[ ] validation failed | validation | error | nomad, service, validation |
| bootstrap check failed | exception | error | nomad, acl, bootstrap, state-store |
| can't evaluate periodic job | validation | error | nomad, periodic-job, unsupported-operation |
| Could not find Nomad executable | exception | error | discovery, missing-binary, testing, build |