ipfs/kubo
Documented errors, page 2 of 7. Back to ipfs/kubo
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| unexpected error while checking writeablility of repo root | exception | error | filesystem, init, io |
| cannot change CID format of the MFS root; use 'ipfs config… | exception | error | |
| cannot add named links to a non-UnixFS dag-pb node; pass… | validation | error | dag-pb, unixfs, validation, object-api |
| invalid hex in SHA-512 checksum | exception | error | checksum, validation, self-update |
| mountFuse: ConstructNode() failed | exception | error | go, daemon, fuse, mount, node-construction |
| : MFS destination is not a directory | validation | error | cli, mfs, to-files, path |
| %s : %w | exception | warning | gateway, offline, ipns, http-503 |
| block not found locally, cannot provide | exception | error | ipfs, routing, provider, blockstore |
| Unable to initialize libp2p due to conflicting resource… | exception | error | |
| internal error encoding node | exception | error | cli, ipld, panic, encoding |
| : MFS destination is a file: only one entry can be copied to | validation | error | cli, mfs, to-files, batch-add |
| serveHTTPGateway: GetConfig() failed | exception | critical | config, daemon, gateway, startup |
| Unable to initialize libp2p due to conflicting resource… | exception | error | |
| EC private key not in the valid range for secp256k1 | validation | error | |
| internal error listing | exception | error | |
| lifetime must be greater than zero, got | validation | error | |
| PEM block not found in input data | exception | error | cli, keystore, pem, validation, import |
| +unique/+entities must combine with pinned and/or mfs in | validation | error | config, provide, dht, validation |
| error while inspecting | exception | error | |
| failed to raise ulimit to minimum | validation | error | ulimit, file-descriptors, containers, go |
| invalid EC private key length | validation | error | |
| invalid encoding | validation | error | cli, ipld, multicodec, encoding |
| Unable to initialize libp2p due to conflicting resource… | exception | error | |
| cids didn't match - local | exception | error | dag, cid-mismatch, http-rpc, version-skew |
| invalid priority value | validation | error | config, json, go, marshaling |
| dagStore: key was not a cid | exception | error | cid, blockstore, key-parsing, dagstore |
| fast-provide | exception | warning | network, dht, provide, pinning |
| ls returned more objects than expected | exception | error | go, ipfs, rpc, ls, invariant |
| Unable to initialize libp2p due to conflicting resource… | exception | error | |
| unexpected non-stream passed to PostRun: please file a… | exception | error | streaming, rpc, bugreport, type-mismatch |
| r.String() | exception | warning | go, ipfs, pins, blocks |
| some blocks not removed | exception | error | cli, blockstore, pinning |
| too many levels of symbolic links | exception | error | cli, keystore, filesystem, symlink |
| failed to raise ulimit to IPFS_FD_MAX | validation | warning | ulimit, file-descriptors, configuration, go |
| invalid flag value | validation | error | config, json, go, marshaling |
| only sha2-255-32 is allowed with CIDv0 | validation | error | block, cid, cidv0, multihash, sha2-256, validation |
| %T is not a valid IPLD node | exception | error | ipld, dag-get, type-mismatch, bugreport |
| finding binary path | exception | warning | diagnostics, os-executable, cross-platform, runtime |
| could not resolve name | exception | error | ipns, dnslink, resolution, coreapi, namesys |
| api flag specified but command cannot be run on the daemon | validation | error | cli, kubo, api-flag, conflicting-options |
| error creating output file | error_code | error | filesystem, permissions, io |
| serveHTTPGatewayOverLibp2p: ConstructNode() failed | exception | critical | node-construction, libp2p, gateway, experimental |
| telemetry endpoint returned HTTP | exception | warning | telemetry, http, network |
| this dag node is a directory | exception | error | unixfs, coreapi, sentinel-error, ipfs |
| missing private key for node ID | exception | error | libp2p, identity, peerstore |
| QUIC transport does not support private networks, please… | error_code | error | libp2p, quic, private-network, transport |
| unsupported EC private key version | validation | error | crypto, asn1, secp256k1, key-import |
| not found | exception | warning | config, golang, map-traversal |
| ( != ) | http | error | http, rpc, versioning, compatibility |
| writing | exception | error | cli, keystore, filesystem, rename |
| command disabled | validation | error | cli, kubo, command-configuration |
| converting libp2p private key to std Go key | exception | error | |
ErrNoVersion no version file found, please run 0-to-1 migration tool.
| error_code | critical | fsrepo, repo-version, migration, init |
| file is not regular | exception | error | cli, unixfs, compression, tar |
| running libp2p with Swarm.Transports.Multiplexers.Yamux… | error_code | error | libp2p, config, yamux, muxer |
| committing delete batch | error_code | warning | datastore, batch, commit, migration, dht |
| expected *mfs.File, didn't get it. This is likely a race… | exception | error | mfs, race-condition, type-assertion, go |
| failed to get config | exception | critical | config, startup, json, mfs |
| failed to get repo path | validation | error | config, autoconf, repo-path, startup |
| querying datastore for stale DHT value records | error_code | warning | datastore, migration, dht, purge |
| serveHTTPGateway | exception | error | gateway, listener, startup, race |
| creating temporary file for | exception | error | cli, keystore, filesystem, permissions |
| flushing | exception | error | cli, keystore, filesystem, fsync, io |
| ls returned more links than expected | exception | error | go, ipfs, rpc, ls, invariant |
| new root is not a valid dag-pb node | exception | error | |
| SHA-512 mismatch: expected | exception | error | checksum, integrity, download |
| external downgrade phase failed | exception | critical | go, migrations, downgrade, subprocess |
| failed to derive PeerID from PrivKey | exception | error | config, crypto, peerid |
| got unexpected output from util.RmBlocks | exception | error | blockstore, internal-error, rpc |
| invalid EC private key | exception | error | crypto, asn1, secp256k1, key-import |
| invalid bootstrap address | validation | error | cli, bootstrap, multiaddr, validation |
| invalid rlimits | validation | error | freebsd, ulimit, rlimit, go |
| dht client does not support GetClosestPeers | exception | error | routing, dht, cli, type-assertion |
| expected *mfs.Directory, didn't get it. This is likely a… | exception | error | mfs, race-condition, type-assertion, go |
| failed to load config | exception | error | config, json, repo |
| no embedded dependency information | exception | error | build-info, version, cli |
| unknown data field encoding | exception | error | cli, deprecated, dag-pb |
| unrecognized node type | exception | error | mfs, unixfs, cli |
| could not be parsed | exception | error | migrations, url-parsing, go |
| closing temp file | exception | error | io, file-close, temp-file, update |
| Import.HashFunction unrecognized | validation | error | config, hash, validation, multihash |
| non-resolvable API endpoint | validation | error | network, dns, kubo, api-address |
| Provide.DHT.Interval | validation | error | config, validation, dht, reprovide |
| inline-limit exceeds maximum allowed size of bytes | validation | error | cli, validation, cid, inline |
| can't combine --all with other matching options | validation | error | cli, ipfs, p2p, flag-validation |
| cannot add default bootstrap peers: AutoConf is disabled… | validation | error | cli, bootstrap, autoconf, config |
| remote service failed to pin requestid= | exception | error | |
| is not writeable by the current user | exception | error | filesystem, permissions, init |
| creating libp2p resource manager | exception | error | |
| failure writing filesroot to dagstore | exception | critical | datastore, mfs, startup, disk |
| (currently offline, perhaps retry without the offline flag) | exception | error | offline, block-not-found, dag-export |
| path ' ' is not pinned | exception | error | ipfs, cli, pinning, not-found |
| provider: +unique requires pinned and/or mfs | validation | error | config, provider, strategy, unique, reprovide |
| removed, use 'ipfs dag' or 'ipfs files' instead | exception | error | cli, removed, migration |
| unrecognized routing option | exception | error | ipfs, kubo, routing, cli, invalid-argument |
| attempted to print nil peer | exception | error | |
| cp: cannot flush the destination file's parent folder | exception | error | |
| failed to start server, process closing | exception | error | http-server, lifecycle, shutdown, context-canceled |
| record exceeds maximum size of | validation | error | |
| ttl ( ) must not be greater than lifetime ( ) | validation | error | ipns, cli, validation |