ipfs/kubo
Documented errors, page 3 of 7. Back to ipfs/kubo
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| datastore configuration of | exception | error | |
| files rm always flushes for safety. The --flush flag cannot… | exception | error | |
| saving old key in keystore | exception | error | keystore, filesystem, cli |
| failed to enable Swarm.EnableHolePunching: it requires… | exception | error | |
| file type not supported | exception | error | go, ipfs, rpc, unixfs |
| is not a valid path | exception | error | |
| no sources specified | validation | error | migrations, configuration, network-download |
| not connected | exception | warning | swarm, libp2p, network, disconnect |
| key type %T is not allowed to be imported, only RSA… | exception | error | keystore, key-type, validation, key-import |
| serveHTTPGateway: socket activation failed | exception | error | socket-activation, systemd, gateway, daemon |
| CIDv0 only supports sha2-256 | validation | error | go, ipfs, cid, unixfs, options |
| could not find a non dev version | error_code | warning | versioning, network, migrations |
| no delegated publishers configured: add… | validation | error | ipns, config, delegated-publishing |
| not a directory | exception | error | mfs, cli, path-validation |
| path ( ) does not exist | exception | error | go, daemon, fuse, mount, filesystem |
| serveHTTPApi | exception | error | daemon, network, port-in-use, rpc-api |
| mountFuse: GetConfig() failed | exception | error | go, daemon, config, fuse, mount |
| produced block is over 2MiB: big blocks can't be exchanged… | validation | error | blocksize, bitswap, dag, unixfs |
| unrecognized Swarm.ConnMgr.Type | exception | error | config, libp2p, connection-manager |
| cannot add named links to a UnixFS | validation | error | unixfs, dag-pb, node-type, deprecated-api |
| daemon is shutting down | exception | warning | daemon, shutdown, healthcheck, cli |
| decoding old private key | exception | critical | crypto, identity, config, data-loss |
| opening repo ( ) | exception | error | repo, lock, fsrepo, cli |
| %w: %v | exception | error | mfs, cli, unixfs, dag-pb |
| cannot remove individual bootstrap peers when using 'auto'… | validation | error | cli, bootstrap, autoconf, config |
| provider: error flushing MFS | error_code | error | mfs, provider, datastore, flush, reprovide |
| cannot specify negative resolve cache size | validation | error | config, ipns, offline |
| e (stream error trailer header value) | exception | error | http-rpc, stream-error, trailer, io |
| unknowm mhType | exception | error | rpc-client, multihash, validation |
| unrecognized hash function | exception | error | |
| deprecated configuration detected. Manually migrate… | validation | error | config, deprecation, reprovider, migration |
| depth limit exceeded | exception | error | unixfs, import, depth-limit |
| failure to encode config | validation | error | |
| probe resolve | exception | error | diag, healthcheck, dag, resolve |
| error loading plugins | exception | error | plugins, daemon, startup |
| error reading log message | exception | warning | logging, http, streaming, io |
| identity was not set in config (was 'ipfs init' run?) | exception | critical | config, identity, initialization |
| no peer ID in config! (was 'ipfs init' run?) | exception | critical | config, identity, initialization |
| Provide.DHT.OfflineDelay must be non-negative, got | validation | error | config, go, validation, duration |
| invalid cid version | validation | error | cli, cid, validation, bad-input |
| invalid type ' ', must be one of | validation | error | go, ipfs, pin, validation |
| batch deleting stale key | error_code | warning | datastore, batch, delete, migration, dht |
| can't publish while offline: pass `--allow-offline` to… | exception | error | |
| key with name ' ' doesn't exist | exception | error | |
| method name is missing from Routing.Methods config param | validation | error | config, routing, go, validation |
| private networking (swarm.key / LIBP2P_FORCE_PNET) does not… | exception | error | ipfs, kubo, autotls, private-network, swarm-key, config |
| ambiguous multiaddr could refer to or | exception | error | network, dns, multiaddr |
| failed to find specified key | exception | error | config, cli, unset, key-not-found |
| saving new key to config | exception | error | config, filesystem, cli |
| copying binary to stash | exception | error | io, filesystem, disk, update |
| service endpoint must be a valid HTTP URL | validation | error | validation, url, remote-pinning, config |
| service endpoint should be provided without the /pins suffix | validation | error | validation, url, remote-pinning, endpoint-format |
| The Swarm.ResourceMgr.Limits configuration has been removed… | validation | error | config, migration, resource-manager |
| unable to use (deprecated) and a custom at the same time | validation | error | cli, block-put, deprecated-flag, conflicting-options |
| expected a file argument | exception | error | cli, files, arguments |
| ipfs api address could not be found | exception | error | go, ipfs, rpc, daemon, discovery |
| reading current MFS root | exception | error | |
| command must be run on the daemon | validation | error | cli, kubo, daemon-not-running |
| (currently offline, perhaps retry after attaching to the… | exception | error | offline, network, block-not-found, dag-export |
| decoding GitHub release | exception | error | |
| failed to get config value | exception | error | config, cli, key-not-found, repo |
| unknown CID version | validation | error | cid, unixfs, validation, options |
| BUG: unhandled autonat service mode | panic | error | autonat, bug, panic, libp2p |
| cp: cannot get node from path | exception | error | mfs, cli, path-resolution |
| reading new root block | exception | error | blockstore, dag-pb, datastore, cli |
| path cannot be empty | validation | error | go, daemon, fuse, mount, config |
| unexpected message from DAG import | exception | error | |
| cannot import key with name 'self' | exception | error | cli, keystore, ipns, validation |
| deprecated configuration detected. Manually migrate… | validation | error | config, deprecation, provider, migration |
| invalid key | exception | error | ipfs, ipns, routing, input-validation |
| please specify a key type with --type | exception | error | |
| import failed at block | exception | error | car, dag-import, corrupt-data |
| keystore name for back up cannot be named 'self' | validation | error | cli, keystore, reserved-name |
| release not found on GitHub | exception | error | |
| this dag node is not a regular file | exception | error | unixfs, coreapi, sentinel-error, ipfs |
| error: can't ping self | exception | error | cli, ping, self-reference, validation |
| expected PRIVATE KEY type in PEM block but got | exception | error | keystore, pem, pkcs8, key-import |
| serveHTTPApi: SetAPIAddr() failed | exception | error | daemon, filesystem, repo, permissions |
| unknown layout | validation | error | ipfs, add, unixfs, input-validation |
| protocol name must be within '/p2p/' namespace | validation | error | p2p, cli, validation |
| unsupported API address | validation | error | cli, kubo, multiaddr, api-address |
| creating identity ( ) | exception | error | crypto, identity, key-generation, cli |
| creating keystore base directory | error_code | error | |
| file Rename error: , file remove error | exception | error | |
| pinning service not available | exception | error | ipfs, cli, pinning, configuration |
| cannot add or remove remote pinning services with 'config… | exception | error | |
| opening binary | exception | warning | io, permissions, diagnostics, filesystem |
| reading stash directory | exception | error | filesystem, permissions, update, rollback |
| failed to unmarshal into a flag: must be null/undefined… | validation | error | config, json, go, unmarshaling |
| failure to decode config | validation | error | |
| msg (server-provided error message) | exception | error | http-rpc, server-error, not-found |
| copying binary | exception | warning | io, diagnostics, filesystem, concurrency |
| dagStore: key was not a cid: had | exception | error | cid, blockstore, key-parsing, dagstore |
| error initializing plugins | exception | error | plugins, daemon, startup |
| expected type %T, got %T | validation | error | |
| no usable bootstrap peers: AutoConf is disabled… | validation | error | autoconf, bootstrap, config-validation, startup |
| cannot specify negative offset | validation | error | |
| CheckCIDSize: getting node size | exception | error | dag, blocksize, cid |
| conn not found | exception | warning | swarm, libp2p, network, multiaddr |
| could not read config | exception | error | config, repo, gateway, startup |