ipfs/kubo
Documented errors, page 5 of 7. Back to ipfs/kubo
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| priority must be positive | validation | error | config, json-parsing, validation |
| %s | exception | error | cli, cid, error-passthrough |
| 'child' field is missing or not a map | validation | error | datastore, config, log, nested-spec, go |
| new root is not a valid UnixFS node | exception | error | |
| WebRTC Direct transport does not support private networks… | error_code | error | libp2p, webrtc, private-network, transport |
| cannot delete root | exception | error | |
| cp: cannot flush the source's file's parent folder | exception | error | |
| expected a regular file | exception | error | cli, dag-put, input-validation |
| probe fetch | exception | error | diag, healthcheck, dag, fetch |
| %s: %w | exception | error | |
| syncing temp file | exception | error | io, fsync, temp-file, update |
| unmount failed after 10 seconds of trying | error_code | error | fuse, unmount, timeout |
| cannot open archive file | exception | error | |
| failed to determine peer ID for private key | exception | error | ipns, identity, keystore, corruption |
| unrecognized multihash function | validation | error | cli, multihash, block-put, bad-flag-value |
| either the filestore or the urlstore must be enabled to use… | validation | error | ipfs, add, filestore, experimental-feature, config |
| GitHub API returned HTTP | exception | error | github, http, network, api-error, cli |
| Import.UnixFSFileMaxLinks must be positive, got | validation | error | config, unixfs, validation, import |
| parameter 'fraction' must be set | http | warning | http, bad-request, missing-parameter, profiling |
| failed to open repo | exception | error | repo, datastore, lock, cli |
| invalid probe CID | exception | error | diag, cid, internal |
| path is a directory, use -r to remove directories | exception | error | |
| unable to parse duration, expected a duration string or a… | validation | error | config, json-parsing, duration |
| cannot create new key | exception | error | keystore, ipns, peer-id |
| DHT timeout value must be >= 0 | validation | error | cli, ipns, validation |
| empty or malformed .sha512 file | exception | error | checksum, sha512, validation, github |
| Mount isn't compatible with Windows yet | exception | error | |
| format was set by multiple options. Only one format option… | validation | error | |
| invalid configuration: Provide.DHT.MaxWorkers cannot be 0… | validation | error | config, validation, provide, resource-limits |
| Routing.Type=delegated does not support content providing… | validation | error | config, routing, provide, validation |
| address does not contain tcp or udp protocol | validation | error | p2p, multiaddr, validation |
| file does not support seeking | exception | error | cli, cat, unixfs, seek |
| record is empty | validation | error | |
| Import.BatchMaxSize must be positive, got | validation | error | config, import, validation |
| Import.UnixFSDAGLayout must be | validation | error | config, unixfs, dag-layout, validation |
| internal error | exception | error | |
| not a file | exception | error | mfs, cli, cp |
| service endpoint should be provided without any query… | validation | error | validation, url, remote-pinning, query-params |
| invalid peer id | exception | error | cli, libp2p, peer-id, validation |
| 'mounts' field is missing or not an array | validation | error | datastore, config, mount, validation, go |
| no key by the given name or PeerID was found | exception | error | ipns, publish, keystore, not-found |
| not found in zip | exception | error | |
| unrecognized import format | exception | error | keystore, cli-usage, bad-argument, key-import |
| expected a file handle | exception | error | cli, dag-import, input-validation |
| incorrectly formatted address filter in config | exception | error | libp2p, config, multiaddr |
| Support for Experimental.GraphsyncEnabled has been removed… | validation | error | config, migration, graphsync |
| cannot create key with name 'self' | exception | error | |
| cannot remove links from a HAMTShard at the dag-pb level… | validation | error | unixfs, hamt, dag-pb, deprecated-api |
| converting std Go key to libp2p key | exception | error | keystore, libp2p, key-conversion, key-import |
| failed to access file | exception | error | |
| Provide.DHT.MaxProvideConnsPerWorker must be positive, got | validation | error | config, validation, dht, workers |
| expecting one argument: name | validation | error | cli, argument-validation, remote-pinning, usage-error |
| failed to unmarshal json. | validation | error | config, json, cli, parsing |
| registering HTTP delegated routing views | error_code | error | |
| serveHTTPGateway: manet.Listen | exception | error | network, bind, port-in-use, gateway |
| unsupported path namespace | exception | error | path, namespace, ipns, resolution |
| Your programs version | exception | error | |
| cannot change remote pinning services api info with `config… | exception | error | |
| cannot export key with name 'self' | exception | error | |
| key not found | exception | warning | datastore, cli, key-not-found |
| method name is not a supported method on Routing.Methods… | validation | error | config, routing, go, validation |
| query error | exception | error | |
| unrecognized archive type | exception | error | |
| unrecognized reachability option | exception | error | libp2p, config, nat |
| invalid IPNS record | validation | error | |
| Routing.AcceleratedDHTClient option is set even tho… | exception | error | ipfs, kubo, routing, dht, config |
| Provide.DHT.DedicatedPeriodicWorkers must be non-negative… | validation | error | config, validation, dht, workers |
| unrecognized type | exception | error | |
| cannot show or change pinning services credentials | exception | error | |
| failed to start subcommand | exception | error | |
| is not a file | exception | error | go, migrations, ipfs, unixfs |
| downloading checksum file | exception | error | network, github, checksum, download |
| expected map for mountpoint | validation | error | datastore, config, mount, validation, go |
| Experimental.StrategicProviding was removed. Remove it from… | validation | error | config, deprecation, experimental-features |
| Import.CidVersion must be 0 or 1, got | validation | error | config, cid, validation, import |
| ipfs configuration file already exists! Reinitializing… | exception | error | |
| config setting IPNS.RecordLifetime | exception | error | ipns, config, validation |
| download exceeds maximum size of | exception | error | network, download, size-limit, proxy |
| fs-repo requires migration | exception | error | daemon, migrations, repo-version |
| umount timeout | error_code | error | fuse, unmount, timeout |
| unknown datastore type | exception | error | datastore, config, unknown-type, go |
| WebTransport transport does not support private networks… | error_code | error | libp2p, webtransport, private-network, transport |
| cannot read archive | exception | error | |
| cp: cannot put node in path | exception | error | mfs, cli, cp |
| Import.UnixFSDirectoryMaxLinks must be non-negative, got | validation | error | config, unixfs, validation, import |
| supernode routing was never fully implemented and has been… | exception | error | ipfs, kubo, routing, cli, removed-feature |
| failed to decode PrivKey | exception | error | config, crypto, identity |
| failure to parse config setting IPNS.RecordLifetime | exception | error | ipns, config, duration-parse |
| invalid IPNS name | validation | error | ipns, validation, peer-id |
| not a file node | exception | error | migrations, unixfs, type-assertion |
| waiting for pin interrupted, requestid= | exception | error | |
| is not a profile | validation | error | config, cli, profile |
| syncing deletes | error_code | error | datastore, fsync, migration |
| syncing orphaned keystore cleanup | error_code | error | |
| cannot access config, repo not open | exception | error | go, lifecycle, repo, config |
| pin | exception | error | pin, path-resolution, error-wrapping |
| no binary found in archive | error_code | error | |
| Provide.Strategy='flat' is no longer supported. Use 'all'… | validation | error | config, deprecation, provide-strategy, validation |
| unexpected PEM block for format= | exception | error | keystore, format-mismatch, pem, key-import |
| unknown config value, Migrations.Keep must be 'cache'… | validation | error | migrations, config-validation, go |