kubernetes/kops
Documented errors, page 29 of 33. Back to kubernetes/kops
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| error creating keypair | exception | error | openstack, keypairs, ssh, api |
| error creating LB | exception | error | openstack, loadbalancer, octavia, api-error |
| error deleting port | exception | error | |
| error detatching LoadBalancers | error_code | error | aws, autoscaling, load-balancer, cloud-api |
| error fetching instance from compute API | error_code | error | gcp, compute-api, permissions, network |
| error from ec2 DescribeInstances request | exception | error | |
| error getting clientset | console | error | clientset, api-client, kops |
| error waiting for instance | exception | error | |
| failed to find kind in object | validation | error | kind, manifest, validation, kubernetes |
| FindVPCInfo is not implemented yet for Scaleway | exception | error | |
| found multiple NatGateways with id | exception | error | aws, ec2, api-response, natgateway |
| hostname was empty | exception | error | ssh, validation, hostname |
| missing keypairID for signer | exception | error | nodeup, pki, keypair |
| provider ID cannot be empty | error_code | error | aws, autoscaling, tags, iam |
| setting ForwardingRule labels | exception | error | gce, forwarding-rule, labels, api-error |
| SizeGB must be at least 10 GB | validation | error | linode, volume, validation, minimum-size |
| unhandled sha length for | exception | error | go, sha, validation, asset-copy |
| updating dockerconfig secret | console | error | |
| error building DiscoveryStore for cluster | exception | error | discovery-store, vfs, oidc |
| error listing EventBridge targets | exception | error | aws, eventbridge, targets, iam |
| error parsing NonMasqueradeCIDR | exception | error | |
| failed to delete firewall | exception | error | hetzner, firewall, deletion, cloud-api |
| failed to list members | exception | error | openstack, octavia, loadbalancer, api-error |
| FindVPCInfo not implemented on azureCloud, use FindVNetInfo… | error_code | error | azure, vpc, vnet, not-implemented |
| ServiceAccount-level IAM is not yet supported on cloud %T | validation | error | |
| zone flag is required for GCE clusters | console | error | |
| Akamai (Linode) support is currently alpha, and is… | validation | error | linode, akamai, feature-flag, alpha, configuration |
| controlPlaneRef.kind was | exception | error | |
| could not find one of launch template or mixed instances… | validation | error | aws, autoscaling, launch-template, missing-config |
| DNS provider does not support zones | console | error | dns, dns-controller, provider, configuration |
| error creating an identity | exception | error | |
| error deleting keypair | exception | error | |
| error finding launch template ID for autoscaling group | exception | error | |
| error listing Subnets | exception | error | |
| error parsing IAM statements | exception | error | |
| error revoking SecurityGroupRule | exception | error | |
| failed to list images | exception | error | |
| found multiple kOps NatGateways in route table | exception | error | aws, ec2, natgateway, routetable, duplicate-resources |
| gcpProjectID is required | validation | error | gcp, tpm, validation, missing-field |
| instance-group is required | validation | error | cli, validation, missing-argument, instance-groups |
| instance group already exists | console | error | |
| instance is required | validation | error | gcp, tpm, validation, missing-field |
| invalid bucket path | validation | error | scaleway, vfs, url-parsing, configuration |
| invalid s3 path | validation | error | s3, url-parsing, vfs, go |
| invalid target | validation | error | cli, flags, validation, kops |
| missing instance id | exception | error | |
| the path does not support public ACL | exception | error | vfs, acl, s3 |
| unable to create server | exception | error | |
| unable to determine vfs type for | exception | error | |
| could not find utility subnet in zone | exception | error | |
| distrusting keypair for | exception | error | |
| error creating router interface | exception | error | |
| error writing SSL certificate | exception | error | |
| failed to extract L3 floating ip | exception | error | |
| Found multiple server groups with name | exception | error | |
| found no matching assets for expr | exception | error | |
| InstanceGroup not set on etcd | validation | error | |
| invalid kops server url | exception | error | |
| NatGateway has multiple addresses | exception | error | |
| parsing taints for instance group | exception | error | hetzner, taints, config-validation |
| spotinst: unable to load credentials | exception | error | |
| attested document createdOn | validation | error | |
| error building IAM policy | exception | error | |
| error creating IAMInstanceProfile | exception | error | aws, iam, instance-profile, create |
| error deleting IAM role policy | exception | error | aws, iam, delete, race, api-error |
| error registering coordinationv1 | exception | critical | kubernetes, scheme, leader-election, dependencies |
| expected slice at , got %T | exception | error | |
| failed to extract flavors | exception | error | openstack, gophercloud, flavors, response-parsing |
| found forwardingRule | exception | error | |
| found multiple subnets with name | exception | error | |
| invalid topology | validation | error | topology, cli-flags, cluster-creation |
| parsing Azure Blob location | exception | error | azure, url-parsing, nodeup |
| private key not found | exception | error | go, nodeup, private-key, keystore |
| reading Docker config from stdin | console | error | |
| reading keyset for | exception | error | nodeup, keystore, vfs |
| verifying PKCS7 certificate chain | exception | error | |
| waiting for application security group create/update… | exception | error | |
| building instance profile for | exception | error | karpenter, iam, instance-profile, kops |
| CIDR must specified for networks where mode=legacy | validation | error | |
| creating interfaces client | exception | error | azure, sdk, network-client |
| error creating group | exception | error | nodeup, groupadd, os-groups |
| error deleting IAM role | exception | error | |
| error deleting instance group | exception | error | |
| error deleting tag | exception | error | openstack, neutron, tags, deletion |
| error from DescribeNatGateways | exception | error | aws, ec2, nat-gateway, api-error |
| error listing resource record sets | exception | error | aws, route53, api-error |
| error listing RouteTables for subnet | exception | error | aws, ec2, api-error, route-table |
| error reading local-ipv4 from AWS metadata | exception | error | aws, imds, metadata, network |
| error reconfiguring group | exception | error | nodeup, groupmod, os-groups |
| InstanceGroups::Create not supported for server-side client | exception | error | go, unsupported-operation, kops, read-only |
| unknown DNSType | validation | error | dns, cli-flags, topology, cluster-creation |
| error appending tag | exception | error | openstack, neutron, tags |
| error listing IAM roles | exception | error | |
| error listing InternetGateway | exception | error | aws, ec2, internet-gateway, api-error |
| error modifying VPC attribute | exception | error | aws, vpc, dns, iam, api-error |
| error reading | exception | error | |
| error retrieving subnet with id | exception | error | openstack, neutron, subnet, lookup |
| found multiple AutoscalingGroups with name | validation | error | aws, autoscaling, duplicate-resource |
| Multiple pools found for name | exception | error | openstack, octavia, loadbalancer-pool, ambiguous-state |
| resourceID not provided to getTags | exception | error |