| too many arguments | validation | error | cli, secrets, argument-validation |
| decoding pem public key | exception | error | go, pem, tls, certificates, bootstrap |
| error attaching volume | exception | error | |
| error creating droplet with name | error_code | error | |
| error deleting V2 LoadBalancer | exception | error | aws, alb, nlb, elbv2, deletion |
| error listing keypairs | exception | error | |
| error listing networks | exception | error | gce, network, vpc, listing |
| error querying DigitalOcean droplet ID | exception | error | nodeup, digitalocean, metadata, kubelet |
| error retrieving network with id | exception | error | openstack, neutron, network, lookup |
| error updating AutoscalingGroup tags | exception | error | aws, autoscaling, tags, cloud-api |
| failed to fetch floating ips for instance | exception | error | |
| failed to fetch port for instance | exception | error | |
| get droplets Instance group for tags | error_code | error | |
| GetApiIngressStatus: Failed to list floating IP's | exception | error | openstack, neutron, floating-ip, ingress |
| parsing attested document creation | exception | error | |
| SourceRanges and SourceTags should not both be specified | validation | error | gcp, gce, firewall, validation |
| unable to tag subnet | exception | error | aws, nat-gateway, tagging, permissions |
| arn contains unexpected number of colons | validation | error | |
| attested document vmId is required | validation | error | |
| bastion supports --topology='private' only | validation | error | topology, bastion, cli-flags, cluster-creation |
| error deleting ServiceAccount | exception | error | gce, iam, service-account, deletion |
| error parsing object in manifest | exception | error | |
| failed to attach target groups | error_code | error | aws, autoscaling, target-group, cloud-api |
| failed to extract listeners | exception | error | openstack, octavia, json, unmarshal |
| failed to initialize the pod controller, error | console | error | dns-controller, kubernetes, initialization |
| listing DNS records named | exception | error | scaleway, dns, domain, api |
| SSHKey.Name is required | validation | error | ssh, linode, validation |
| unhandled aws metadata path | validation | error | aws, imds, unsupported-path |
| waiting for route table deletion completion | exception | error | azure, network, route-table, long-running-operation |
| ca certificate for was not found; cannot issue certificates | exception | critical | pki, ca, keystore, missing-certificate |
| error deleting ec2 LaunchTemplate | exception | error | aws, ec2, launch-template, deletion, api-error |
| error parsing Akamai (Linode) instance ID | exception | error | linode, akamai, instance-id, strconv |
| failed to get IP for server | exception | error | scaleway, ipam, network, api |
| Failed to get port with id | exception | error | openstack, neutron, port, state-drift |
| getting Loadbalancer for API Ingress Status | exception | error | |
| InstanceGroup not found | validation | error | |
| must set output flag; yaml or json | console | error | |
| spotinst: failed to create launch spec | exception | error | spotinst, launch-spec, api-error, create |
| spotinst: unsupported instance group type | exception | error | |
| Subnet ID is required for subnet name= | validation | error | |
| unable to determine hash from HTTP HEAD | exception | error | |
| unable to parse env var KOPS_BASE_URL | exception | error | |
| unknown role | console | error | |
| use 'kops get keypairs' instead | validation | error | cli, kops, deprecated-command, keypairs |
| zone is required | validation | error | gcp, tpm, validation, missing-field |
| couldn't find recordset with name | exception | error | |
| empty PKCS7 signature | validation | error | |
| error creating TargetPool | exception | error | gcp, gce, targetpool, load-balancing |
| error detaching IAM role policy | exception | error | |
| etcd nodes requires the ExperimentalRoles feature flag to… | exception | error | feature-flag, etcd, instance-group, kops |
| found multiple Akamai (Linode) VPC Subnets named | exception | error | linode, akamai, subnet, duplicate-resource, vpc |
| getting keystore | exception | error | cli, keystore, cluster-spec |
| multiple ipv6 addresses found on interface | exception | error | |
| NatGateway has nil addresses | exception | error | |
| creating/updating load balancer | exception | error | |
| error deleting cluster files in | exception | error | |
| error deleting router | exception | error | |
| error getting file status of | exception | error | |
| error querying VM ScaleSet VMs | exception | error | |
| requesting agent forwarding | exception | error | |
| error marshaling policy to JSON | exception | error | |
| expecting VPC CIDR to not be | exception | error | |
| failed to find image | exception | error | |
| failed to update floating ip | exception | error | |
| fetched certificate subject key identifier does not match… | validation | error | |
| spotinst: unexpected instance group role | validation | error | |
| waiting for network security group create/update completion | exception | error | |
| waiting for network security group deletion completion | exception | error | |
| azure support is currently alpha, and is feature-gated… | validation | error | |
| could not find private subnet in zone | exception | error | |
| found multiple SQS queues matching queue name | exception | error | |
| spotinst: error building ocean | exception | error | |
| intermediate certificate pool is required | validation | error | |
| invalid Linode object storage path | validation | error | linode, object-storage, url-parsing, vfs |
| invalid spaces path | validation | error | digitalocean, spaces, url-parsing, vfs |
| spotinst: error building elastigroup | exception | error | |
| error deleting autoscaling launch template | exception | error | |
| error updating subnet | exception | error | |
| waiting for subnet create/update completion | exception | error | |
| could not find ciliumpassword secret | exception | error | |
| error appending tag to subnet | exception | error | |
| error creating volume | exception | error | |
| error deleting router interface | exception | error | |
| error listing security groups | exception | error | |
| error loading kubeconfig | exception | error | |
| error parsing expected Policy for SQS | exception | error | |
| expected object at , got %T | exception | error | |
| no known addresses for node | exception | error | |
| scheduler nodes requires the ExperimentalNodes feature flag… | validation | error | |
| SSH agent has no keys | exception | error | ssh, ssh-agent, authentication |
| error associating subnet cidr block | exception | error | |
| error getting PublicIPAddress for API Ingress Status | exception | error | |
| error searching for detached instances for autoscaling group | exception | error | |
| listing load balancers | exception | error | |
| listing network security groups | exception | error | |
| parsing attested document expiration | exception | error | |
| service account name cannot contain a wildcard | exception | error | |
| timeout waiting for instance | exception | error | |
| cannot find CA certificate | exception | error | |
| error attaching LoadBalancers | error_code | error | aws, autoscaling, load-balancer, cloud-api |