kubernetes/kops
Documented errors, page 3 of 33. Back to kubernetes/kops
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| error getting GCE DNS zones | exception | error | gce, dns, gcp, cloud-provider |
| instance group neither control-plane nor api-server | validation | error | kops, gcp, instance-group, roles |
| %s | exception | error | |
| cannot decode GCE label | error_code | error | gce, labels, url-decoding, encoding |
| storage profile is required for VMScaleSet | validation | error | azure, vmss, terraform, storage-profile |
| Additional SecurityGroup not found for name | exception | error | openstack, neutron, security-groups |
| converting cluster object | exception | error | kubernetes, kops, conversion, api-versioning, controller |
| error creating kops config template | exception | error | kops, cluster-api, gcp, object-generation |
| error deleting SecurityGroup | exception | error | aws, ec2, security-group, delete, dependency-violation |
| FindPrimaryKeypair not supported by configserverKeyStore | exception | error | keystore, configserver, unsupported-operation |
| found multiple instance groups matching servergrp | error_code | error | |
| unsupported distro | exception | error | os-detection, linux-distributions, compatibility |
| creating client for Scaleway Cloud | exception | critical | scaleway, client-init, configuration, kops |
| error deleting security group rule | exception | error | openstack, neutron, security-group, deletion-failed |
| error fetching cluster | exception | error | kubernetes, cluster-api, not-found, reconcile |
| invalid Azure Blob location; expected azureblob:// | validation | error | azure, validation, nodeup |
| is required | validation | critical | env, config, linode, authentication |
| unable to parse CNI plugin binaries asset URL | exception | error | kops, cni, url-parsing, environment-variable, configuration |
| unknown distro | exception | error | linux-distributions, ssh, os-detection |
| cannot mix publicIP values in private or IPv6-capable… | validation | error | aws, networking, elastic-ip, cluster-spec |
| cannot specify cluster via --name and positional argument | validation | error | cli-flags, argument-parsing, cluster-name |
| error listing (all) InternetGateways | exception | error | aws, ec2, internet-gateway, api-error |
| error writing cluster json to stdout | console | error | cli, json, output |
| etcd version is not supported with etcd-manager, please… | validation | error | etcd-manager, etcd-version, cluster-spec |
| failed to load package | exception | error | go, kops, addons, clusterpackage, model-builder |
| id was not set on CloudInstance | exception | error | aws, ec2, instance-termination, invalid-input |
| missing and in section of | validation | error | |
| user not found | exception | error | filesystem, permissions, user-lookup |
| cluster passed validation | exception | warning | kubernetes, validation, timeout |
| did not find owner for node | exception | error | kubernetes, kops, bootstrap, instancegroup, capi |
| backupStore must be set for use with etcd-manager | validation | error | kops, etcd-manager, cluster-spec, config-validation |
| error creating directories | exception | error | filesystem, assets, io |
| error hashing manifest | exception | error | addons, hashing, bootstrap-channel |
| error marshaling pod to yaml | exception | error | go, kubernetes, nodeup, yaml-marshaling |
| getting http client | error_code | error | kops, rolling-update, http-client, tls, kubeconfig |
| namespace was not provided for namespace-scoped object | exception | error | kubernetes, namespace, validation |
| Region is not a recognized EC2 region | validation | error | aws, region, validation, config |
| subnet task not found for InstanceGroup | exception | error | linode, subnet, model-builder, task-dependency |
| updating back-end server IPs for load-balancer | exception | error | scaleway, load-balancer, api-error, networking |
| creating VMSSs client | exception | critical | azure, client-construction, configuration, vmss |
| error creating Cluster controller | exception | critical | controller-runtime, startup, kubernetes, controller-registration |
| error parsing certificate | exception | error | pki, certificate, json-parsing |
| Error too many '=' ( ) in | validation | error | cli, configuration, parsing, label-validation |
| failed to parse network CIDR | exception | critical | network, cidr, cluster-spec, configuration, ipv6 |
| reading encryption config | console | error | cli, filesystem, secret, kops |
| unhandled state for json value | exception | error | json, state-machine, streaming |
| cannot specify --key with "all" | validation | error | cli, flag-validation, keypair, kops |
| error building InstanceGroup from CAPI Machine | exception | error | kubernetes, kops, capi, bootstrap, instancegroup |
| flag not found | exception | warning | feature-flag, kops, config, lookup |
| unable to expand the template | exception | error | kops, templates, filesystem, cli |
| cannot build kube client for | console | error | kubernetes, kubeconfig, client-go, client-construction |
| cannot find subnet (declared in instance group , not found… | exception | error | kops, subnet, instance-group, configuration |
| cannot mix --name for cluster with positional arguments | validation | error | cli, argument-validation, kops-get |
| error building launch spec | exception | error | kops, aws, spotinst, launch-spec, instance-group |
| error visiting container | exception | error | yaml-manifest, visitor-pattern, go |
| failed to load AWS config | exception | error | aws, configuration, ec2-imds, credentials |
| invalid authorization token | validation | error | authentication, token, linode, bootstrap |
| AWS partition was empty | exception | error | aws, arn, validation, config |
| cannot find owner for instance | exception | error | gce, kubernetes, node-identity, metadata, mig |
| creating listener for NLB on port | exception | error | aws, nlb, elbv2, infrastructure |
| error building service account role tasks | exception | error | aws, iam, service-account, irsa |
| error reading /var/log | exception | warning | ssh, node-dump, filesystem, go |
| node name not set | exception | error | kubernetes, drain, rolling-update, node-registration |
| CloudProvider not supported with etcd-manager | validation | error | etcd-manager, cloud-provider, cluster-spec |
| creating directory | exception | error | filesystem, permissions, kops, dump |
| error disabling swap | exception | error | nodeup, linode, swap, kubelet |
| error reading Keyset | exception | error | kubernetes, rbac, kops, secrets, delete |
| failed to generate AWS IAM S3 access statements | exception | error | aws, iam, s3, kops |
| found virtual network without address space | exception | error | |
| getting AWS credentials | exception | critical | aws, credentials, authentication, bootstrap |
| intermediate certificate fetch recently failed for signer… | exception | error | azure, tls, cache, negative-cache, aia-fetch |
| reading /etc/os-release | exception | error | os-release, os-detection, filesystem, linux |
| unable to find any containerd binaries in assets | exception | critical | nodeup, containerd, assets |
| api-version must be specified | validation | error | cli, api-version, authentication |
| cannot determine challenge endpoint for instance id | exception | error | aws, ec2, networking, bootstrap |
| error building DNS provider | exception | error | dns, scaleway, provider-registry, kops |
| error deleting InstanceTemplate | exception | error | gce, compute-api, instance-template, deletion, resource-in-use |
| error listing Eventbridge rules | exception | error | aws, eventbridge, list-rules, cluster-deletion |
| failed to load aws config | exception | error | go, aws, aws-sdk-go-v2, credentials, bootstrap |
| missing target for route | validation | error | aws, route, validation, missing-target |
| url not valid for STS request | exception | error | aws, sts, security, url-validation |
| acceleratorCount must be positive or 0 | validation | error | gce, validation, gpu, config |
| error Clusters cannot span multiple regions | validation | error | aws, region, zone, cluster-spec |
| error getting instance group for MIG | exception | error | gce, gcp, instance-group, mismatch, kops |
| failed to extract loadbalancer pages | exception | error | openstack, octavia, api-response, pagination |
| malformed format of NetworkSecurityGroup ID | validation | error | azure, resource-id, parsing, nsg |
| no clusters found | console | error | cli, state-store, kops-get |
| error adding needs-update label | exception | error | kubernetes, rbac, node-labels, rolling-update |
| error loading AWS config | exception | error | aws, config, credentials, sdk |
| error marshaling manifest to yaml | exception | error | kube-apiserver, yaml, manifest |
| expected azureblob:// URL, got | exception | error | kops, azure, vfs, url-validation |
| failed to get machine type | exception | critical | aws, metadata, imds, machine-type, nodeup |
| unsupported cloud provider for authenticator | validation | error | go, nodeup, bootstrap, cloud-provider, configuration |
| error finding contained version | exception | error | nodeup, containerd, config |
| error loading Cluster | console | error | state-store, cluster-spec, kops-get-full |
| error parsing ConfigStore.Base | exception | error | vfs, state-store, config, url-parsing |
| failed to copy index | exception | error | container-image, registry, push, multi-arch |
| malformed format of subnet ID | validation | error | azure, resource-id, parsing, validation |
| unexpected error during validation | exception | error | kubernetes, validation, api-error |
| describing instance type | exception | error | aws, ec2, api-error, instance-type |