kubernetes/kops

Documented errors, page 4 of 33. Back to kubernetes/kops

Code / MessageTypeSeverityTags
error deleting Volume
exception error aws, ec2, ebs, volume-deletion
error listing
exception warning ssh, filesystem, node-dump, go
listing back-ends for load-balancer
exception error scaleway, load-balancer, api, auth
building cloud
exception error kubernetes, kops, cloud-provider, bootstrap-data, controller
creating discovery client
exception error kubernetes, client-go, config
error creating file
exception warning filesystem, permissions, node-dump, go
error launching editor
exception error cli, editor, environment
hetzner cloud provider currently supports only one zone…
validation error hetzner, zones, cluster-creation, validation
incorrect RequestHash
exception error go, authentication, pki, request-body, integrity
instance has no private IPv4 address
exception error aws, ec2, ipv4, node-naming
os disk is required for VMScaleSet
validation error azure, terraform, vmss, validation
error building containerd flags
exception error nodeup, containerd, flagbuilder
error building loader
exception error nodeup, loader, task-generation
Error parsing version
panic error
error reading full cluster spec for
console error state-store, vfs, kops-get-full
failed to check if device
exception error volumes, mount, device, nodeup
failed to get GCE RSA attestation key from TPM
error_code critical gcp, tpm, gce, node-authentication
subnet must specify a zone or the ID of an existing subnet
validation error aws, subnet, cluster-spec, validation
could not determine cluster region: no subnet specifies a…
validation error aws, region, subnet, cluster-spec
error creating ServerGroup
exception error openstack, nova, server-group, cloud-api
error parsing container runtime version
validation error nodeup, containerd, semver
failed to get info for Akamai (Linode) instance
exception error linode, api, authentication, network
addon manifest hash was not populated
exception error addons, bootstrap-channel, hashing, validation
cannot interpret value as unsigned integer
validation error reflection, value-parsing, go
error listing
exception error
error parsing cluster spec.kubernetesVersion
panic error
error reading SSH public key files
exception error cli, ssh, file-io
error starting challenge listener
exception error network, nodeup, bootstrap
host not found for
exception error kubernetes, bootstrap, pki, not-found
listing server preferred resources
exception error kubernetes, client-go, discovery, network
unexpected path
exception error go, vfs, path-prefix, invariant, enrollment
creating accessor for
exception error kubernetes, meta-accessor, dynamic-client, kops
error converting to yaml
exception error yaml, serialization, kops
error describing volumes
exception error openstack, cinder, storage, etcd
malformed format of loadbalancer ID
validation error azure, resource-id, parsing, load-balancer
nodeup config hash mismatch
validation critical nodeup, hash-mismatch, integrity-check, bootstrap
error creating Akamai (Linode) volume
exception error linode, storage, create, api-error, kops
error revoking SecurityGroup
exception error openstack, security-group, neutron, delete
finding primary network interface
exception error nodeup, aws, eni, imds, networkd
getting GVR namespaces
exception error kubernetes, discovery, schema
InstanceGroup not found
exception error
no instance group defined in nodeup config
validation critical nodeup, bootconfig, missing-config, bootstrap
Unable to execute tasks (circular dependency)
exception error
Invalid value for
exception error openstack, validation, boot-from-volume, metadata, kops
parsing path for kops-channels manifest
exception error go, nodeup, vfs, configuration, channels
cluster not found
exception error kops, cluster-registry, state-store, not-found
control plane nodes can't get certs from kops-controller
panic error
error creating certificate
exception error pki, keystore, certificate-issuance
found multiple machines with providerID
exception error clusterapi, duplicate-resources, provider-id, kubernetes, kops
instance type not found in region
exception error aws, ec2, instance-type, validation
invalid feature gate value
validation error kubelet, feature-gates, config-validation
on Akamai (Linode), subnets must include Regions
validation error linode, akamai, cluster-config, subnet
resource ID resource group
exception error
error listing IP Addresses
exception error gce, api, networking, static-ip
error listing tree
exception error
error waiting for Subnet patch to complete
exception error gcp, gce, subnet, infrastructure
failed to convert network ID
exception error hetzner, loadbalancer, network, config, parse-error
marshaling Karpenter resource for
exception error yaml, serialization, karpenter, kops
too many reservations returned for the single instance-id
exception error aws, ec2, bootstrap, instance-lookup
unknown hash algorithm
exception error hashing, validation, assets, configuration
converting kubeconfig to yaml
exception error yaml, kubeconfig, serialization
error getting TargetPool
exception error gce, gcp, target-pool, api-error
error loading channel
exception error kops, channel, network, cli
error parsing
console error dns, zone-rules, configuration, flag-parsing
error reading SSH key file
exception error cli, ssh, file-io, deprecated
error rendering RolePolicyDocument
exception error aws, sqs, iam-policy, render
listing namespaces
exception error kubernetes, client-go, network, rbac
malformed format of PublicIPAddress ID
validation error azure, resource-id, parsing, public-ip
no images found in instance groups in cluster
exception error cli, instance-groups, machine-deployment, cluster-api
spotinst: error building cloud instance group
exception error spotinst, instance-group, mapping, delete
error finding openstack region
exception error openstack, configuration, region, env-var
error listing /etc/containerd
exception warning ssh, containerd, node-dump, go
expected exactly one object in manifest
exception error kube-apiserver, healthcheck, manifest-parsing
failed to build cloud group for instance group
exception error
function panic
exception error
parsing additional containerd config entry
exception error containerd, config, parsing, csv
unhandled type in manifest: %T
exception error go, kubemanifest, visitor, type-mismatch
unknown or unsupported distro
console error nodeup, systemd, os-detection, distro-support
error deleting group
exception error scaleway, instance-group, delete, rolling-update
error on getting VM ScaleSet
exception error azure, api-error, vm, authentication, kops
failed to apply objects
exception error kubernetes, apply, server-side-apply, rbac
failed to complete lifecylce action
exception error aws, autoscaling, lifecycle-hook, nodeup
failed to start SSH session
exception error ssh, network
no decernable storage availability zone could be mapped to…
exception error openstack, availability-zone, nova, cinder, mapping
unable to resolve IP for instance
exception error gce, instance, ip-address, resolution
cannot revoke ingress for ID
exception error aws, ec2, security-group, ingress, revoke
error building neutron client
exception error openstack, neutron, endpoint, service-catalog, gophercloud
error describing VPC
exception error aws, vpc, ec2-api, iam, cluster-creation
keyset not found
exception error cli, keypairs, keystore
unable to issue certificate
exception error pki, certificate, keystore
unable to load secret immediately after creation
exception error vfs, secrets, verification, replace
error parsing etcd cluster tag
exception error openstack, etcd, metadata, parsing
error updating InstanceTemplate for InstanceGroupManager
exception error gce, instance-template, instance-group-manager, google-compute-api
getting load-balancer
exception error scaleway, load-balancer, api-error, find
Specified both IP Address and rule-managed IP address
validation error gce, forwarding-rule, config-validation, ip-address
cannot apply changes to ServiceAccount
exception error gce, gcp, iam, service-account, immutable-field
error rendering DO file
exception error terraform, digitalocean, rendering, spaces
failed to ensure the directory
exception error volumes, mount, filesystem, nodeup
unexpected target type for deletion: %T
exception error aws, ec2, launch-template, type-assertion, internal
unknown CA
exception error pki, ca, keystore, kops-controller