vitessio/vitess
Documented errors, page 5 of 13. Back to vitessio/vitess
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
ErrUnpreparedQuery : call PlanQuery on a query planner first | error_code | error | vexec, query-plan, api-misuse, sentinel-error |
| healthcheck timed out | exception | error | healthcheck, timeout, network |
| non-constant regexp | error_code | warning | sql, regexp, evalengine, query-planning |
| unsupported query | exception | error | vtexplain, unsupported-statement |
| : "progressFile" needs to be empty as vitess always starts… | error_code | error | mysql-shell, backup-restore, configuration |
| a conflicting table named | exception | error | vitess, vschema, vindex, conflict |
| GetConnection failed | exception | error | mysql, connection, vtcombo |
| lost topology lock, aborting | exception | error | vtctld, topology, shard-lock, concurrency |
| BuildKeyspace( ) failed | exception | error | vschema, vindex, configuration |
| cannot complete workflow because you have not yet switched… | error_code | error | vitess, movetables, traffic-switch, cutover |
| cannot update progress with a nil diff report | exception | error | vdiff, nil-pointer, progress |
| could not set state | exception | error | vreplication, state-update, mysql, secondary-failure |
ErrUnsupportedQuery %w: %s | error_code | error | go, vreplication, sql, unsupported-query |
| failed query COMMIT, err | exception | error | mysql, commit, transaction, binlog-player |
| listener must take exactly one input argument | panic | error | reflection, panics, api-misuse |
| removing from wrong List | panic | error | data-structure, panics, api-misuse |
| : cannot create schema migration in | validation | error | rbac, authorization, vtadmin, schema-migration |
| BeforeSchema differs | exception | error | schema, ddl, validation, vttablet |
| error in connecting to mysql db with connection | exception | error | mysql, connection, binlog |
| error updating time throttled | exception | warning | vreplication, throttler, mysql |
| VStreamer is not open | exception | warning | vitess, vstreamer, vreplication, lifecycle |
| writing serving data failed | exception | error | topo, serving-graph, rebuild-keyspace, network |
| can't convert to decimal | validation | error | mysql, decimal, parsing, wrapped-error |
| creating this tablet would override old primary | exception | error | topo, tablet, primary, failover |
| failed to Execute() template | panic | error | go, panic, template, string-rendering |
| invalid NewMaxReplicationLagModuleConfig | validation | error | go, throttler, config-validation |
| malformed logfile name | exception | warning | go, logging, file-parsing, purge |
| Query must match one of these templates | error_code | error | vexec, sql, validation |
| the argument is required for the RefreshState command | validation | error | vtctl, cli, missing-argument, refresh-state |
| unexpected result from | exception | error | vreplication, mysql, query-result |
| unsupported format specifier: %%%c | validation | error | mysql, datetime, format-string, parsing |
| %s | validation | error | vttablet, config, vreplication |
| source and target table names must match for copying schema | validation | error | vitess, wrangler, schema-copy, validation |
| the given number of shards | validation | error | go, sharding, capacity-limit, input-validation |
| unsupported from source (%T) | validation | error | sqlparser, vreplication, unsupported-sql, from-clause |
| value is not a valid int | validation | error | validation, tenant, movetables, input |
| ExecNoPrepare unexpected error: %+v | exception | error | panic, sql, recovered-panic |
| failed to execute logHeader template | panic | warning | go, panic, http-handler, debug-page |
| GetSchema(cluster = , keyspace = , tablet = ) failed to… | exception | warning | vtadmin, semaphore, schema, concurrency |
| invalid health-check path | http | warning | vtgate, http-api, validation |
| marshal primary health state | exception | error | vtorc, serialization, prototext, database |
| RebuildSrvVSchema( ) = | exception | error | vitess, topology, vschema, rebuild |
| %w: %w | exception | error | backup, restore, fatal-error |
| cannot determine table columns for | exception | error | schema, sidecar-table, columns, vstreamer |
| cannot get (or create) shard | exception | error | topo, tablet, shard, initialization |
| could not get the original sql_mode on target | exception | error | vreplication, mysql, sql-mode |
| could not set the permissive sql_mode on target using | exception | error | vreplication, mysql, sql-mode, ddl |
| table not found in vschema for keyspace | console | error | vitess, workflow, vschema, sharded-keyspace, missing-table |
| both the dry-run mode and actual buffering is enabled. To… | validation | error | vtgate, buffering, flags, startup |
| BUG: limiter was unable to reserve an event… | panic | error | go, panic, rate-limiting, throttler, config |
| found no possible unique key on | exception | error | online-schema-change, schemadiff, unique-key, ddl |
| GetTabletMap() failed | exception | error | topo, topology, shard-deletion, wrangler |
| must specify at least one keyspace_shard to delete (got %+v) | http | error | http, bad-request, validation, vtadmin |
| cannot find tablet: %+v | error_code | error | vtcombo, topology, tablet, healthcheck |
| could not find primary tablet | exception | error | vtorc, replication, topology-recovery |
| missing source | exception | error | vreplication, source, workflow |
| running MySQL version | exception | error | mysql, backup, restore, version-compatibility, downgrade |
| unexpected bit operation | panic | error | go, panic, bitwise, evalengine, invariant |
| can't parse RAND_EVENT | exception | error | binlog, streaming, event-parsing |
| could not restart source streams | console | error | vreplication, cancel, tablet, update |
| CountersWithMultiLabels: wrong number of values in Add | panic | error | go, panic, stats, metrics |
| GetKeyspace( ) failed to acquire topoReadPool | exception | warning | vtadmin, semaphore, concurrency, timeout |
| Invalid hint: , expected 3 characters | validation | error | schema, naming, validation |
| malformed spec: doesn't define a range | validation | error | validation, sharding, configuration |
| source shard must have a primary for copying schema | validation | error | vitess, wrangler, topology, schema-copy |
| stream needs a position or a table to copy | validation | error | vreplication, vstreamer, configuration |
| table not supported by vexec | error_code | error | vexec, vreplication, unsupported-table |
| throttler not open | exception | error | vitess, throttler, lifecycle, not-open |
VT09003 VT09003: INSERT query does not have primary vindex column | error_code | error | insert-select, vindex, sharding |
| AddFile cannot be called on read-only backup | validation | error | s3, backup, api-misuse, read-only |
| CreateTablet( ) | error_code | error | topo, tablet-copy, error-wrapping |
| DiscoverVTGates(cluster = ) | exception | error | vtadmin, discovery, topology, network |
| failed to load static auth plugin. Plugin configured but… | validation | error | go, servenv, grpc, authentication, configuration |
| Numeric.ReverseMap: length of keyspaceId is not 8 | exception | error | vindex, numeric, reverse-map, keyspace-id |
| UnicodeLooseXXHash.Verify | exception | error | vtgate, vindex, utf-8, xxhash |
| unsupported aggregation function | validation | error | vreplication, sql, aggregation, vttablet |
| : request cannot be nil | validation | error | vtadmin, validation, invalid-request, keyspace |
| no read locks acquired yet | exception | error | go, mysqlctl, locking, global-read-lock, api-misuse |
| cannot delete tablet | exception | error | tablet-management, topology, safety-guard |
| compressed transaction payload events are not supported… | exception | error | binlog, compression, flavor, mariadb, vstreamer |
| '%n' directive requires a slice | panic | error | go, codegen, tooling, panic, astfmtgen, format-directive |
| streams are mismatched across source shards | validation | error | vreplication, reshard, consistency, missing-stream |
| target keyspace not defined, or it does not have… | validation | error | vreplication, vschema, multi-tenant |
| unable to select @@foreign_key_checks | exception | error | vreplication, foreign-keys, system-variable, dbclient |
| can't strip checksum from binlog event | exception | error | binlog, checksum, corruption |
| cell mode should be handled by the gateway, not the… | validation | error | vtgate, balancer, config |
| failed to execute logEntry template | panic | warning | go, panic, http-handler, template, debug-page |
| failed to successfully refresh all tablets in the | console | error | vitess, traffic-switch, tablet-refresh, target-shard |
| invalid int value for | validation | warning | tabletserver, http, validation, go |
| : unsupported URL host | exception | error | grpc, resolver, discovery, configuration |
| unsupported from expression (%T) | validation | error | sqlparser, vreplication, unsupported-sql, from-clause |
| unsupported multi-table usage | validation | error | vreplication, unsupported-query, sql-plan |
| Create ReshardWorkflow failed | error_code | error | vreplication, reshard, vschema, validation |
| failed to lock / ; if you really want to delete this shard… | exception | error | topo, lock, shard, concurrency |
| RENAME clause found | exception | error | ddl, online-ddl, rename, mysql |
| unimplemented connection protocol | error_code | error | vtbench, protocol, benchmark |
| BUG: invalid state | panic | error | go, panic, throttler, state-machine |
| [BUG] tried to replace 'Name' on 'TableName' | panic | error | sqlparser, ast-rewrite, codegen, panic, identifiers |
| can't parse binlog event, invalid data: %#v | exception | error | binlog, corruption, parsing |
| cannot map vindex to unique keyspace id | exception | error | vtgate, vindex, dml, sharding |