apache/hadoop

Documented errors, page 28 of 39. Back to apache/hadoop

Code / MessageTypeSeverityTags
Not supported yet.
exception error jmx, metrics2, hadoop, unsupported-operation
Simulated job's configuration parameter
exception error
suite " + suiteClassName + " suiteName is empty
validation error hadoop-compat-bench, suite-registration, plugin-validation
callqueue.capacity.weights only takes positive weights.
exception critical hadoop, ipc, configuration, callqueue, validation, server-startup
dest is root directory
exception warning s3a, rename, root, invalid-argument
File not found: , likely due to delayed block removal
exception error hdfs, namenode, file-not-found, race-condition, delayed-block-removal
SHOULD_REPLICATE flag and ecPolicyName are exclusive…
validation error hdfs, erasure-coding, create-flags, mutually-exclusive-parameters
Version Mismatch (Expected: , Received: )
exception error hdfs, datatransfer, version-mismatch, datanode, protocol, block-io
already exists!
exception error metrics2, hadoop, jmx, duplicate-registration, lifecycle
BytesPerChecksum option is set multiple times
validation error hadoop, file-create, options, checksum, varargs
Cannot import image from a checkpoint…
exception error hdfs, namenode, checkpoint, import, configuration
Limit is negative.
exception error hdfs, caching, validation, configuration
AADToken: HTTP connection to
http error
Block (= ) not found
exception error hdfs, namenode, block-not-found, pipeline-recovery, retry
DiskBalancer is not initialized
exception error hadoop, hdfs, datanode, diskbalancer, configuration
Failed to for on because another recovery is in progress by…
exception warning hdfs, lease-recovery, under-recovery, transient, concurrency
FileSystem is not a DFS.
exception error hdfs, ha, filesystem, type-mismatch, uri
Port number ' ' invalid
exception error hadoop, configuration, fencing, ssh, invalid-port
The SSL encryption is enabled for the component's ZooKeeper…
exception error hadoop, zookeeper, ssl, tls, keystore, secrets, configuration, java
The value of the aclSpec parameter is invalid.
validation error azure-abfs, acl, illegal-argument, modifyaclentries
Unexpected empty line
exception error hadoop, disk, df, parsing, locale, system-command
Unset property fs.s3a.assumed.role.arn
exception error s3a, hadoop-aws, credentials, assumed-role, iam, configuration
hdfsOpenFile( ) failed: error ( )\n
console error hdfs, libhdfs, c, errno, file-open, vecsum
Invalid argument
validation error hdfs, rbf, federation, quota, cli, argument-validation
No valid @Metric annotation found.
exception error metrics2, hadoop, annotation, builder
Parallel access to the create path detected. Failing…
exception error
Path is a directory.
exception error ftp, is-a-directory, open, file-not-found
The aclSpec argument is invalid.
validation error azure-abfs, acl, illegal-argument, removeaclentries
The target path ' ' starts with /.reserved/raw but the…
exception error distcp, reserved-raw, encryption-zone, input-validation, hdfs
"Failed to append to non-existent file " + path + " for…
exception error hdfs, append, file-not-found
Fetch fail on include for
exception error
instance is not set
exception error rpc, server, builder, dependency-injection
mode cannot be NULL
validation error ssl, tls, null-check, constructor, hadoop
No argument passed to 'shell' fencing method
exception error hadoop, configuration, fencing, shell, argument-missing
No schema options are provided
exception error erasure-coding, schema, validation, hadoop-common
Option '-moveToLocal' is not implemented yet.
exception error movetolocal, not-implemented, hadoop-shell, unsupported-operation
S01
Dir [ ] does not exist
error_code critical httpfs, server-startup, missing-directory, configuration
Timed out waiting for discardSegments() response
exception error qjm, rollback, discard-segments, timeout, journalnode
Configuration problem with provider path.
exception error
Expected to find in section.
exception error hdfs, oiv, fsimage, reversexml, snapshot-diff, missing-field
Lease mismatch: is accessed by a non lease holder
exception error hdfs, namenode, lease, single-writer, pipeline-recovery
parent is not a dir
exception error hadoop, filesystem, mkdir, parent-not-directory
Unable to parse user and SSH port
exception error hadoop, configuration, fencing, ssh, parse-error
Unknown TaskAttempt
exception error mapreduce, am-client, task-attempt, rpc
Update but the new block does not have a larger generation…
exception error hdfs, namenode, generation-stamp, pipeline-recovery, monotonicity
addDirective: you cannot specify an ID for this operation.
exception error hadoop, hdfs, namenode, cache-directive, api-misuse
compress called on closed compressor
exception error
finishedTimeEnd must be greater than finishedTimeBegin
validation warning hadoop, mapreduce, jobhistory, rest, http-400, query-param, time-range
Invalid hostname verifier
validation error ssl, tls, hostname-verification, configuration, hadoop
Missing either or
exception error cli, setfacl, acl, missing-argument, hadoop
Parent path is not a directory
exception error hdfs, mkdir, parent-not-directory, path-conflict
Unexpected HAServiceStateProto:
exception error hadoop, hdfs, ha, namenode, protobuf, enum
URL is malformed
validation error azure, abfs, url, configuration, malformed-url
Expected entry to have a field
exception error hdfs, oiv, fsimage, reversexml, snapshot-diff, missing-field
Har: setowner not allowed
exception error hadoop, har-filesystem, read-only, setowner, permissions
Limit exceeds buffer size
exception error hadoop, io, buffer, validation, capacity
Reach the limit of the buffer
exception error hadoop, io, buffer, buffer-overflow, eof
Receive reply from slowNode
exception error
Directory is not writable
exception error disk, permissions, filesystem, diskchecker, writable
getClassPath: failed calloc
console error hdfs, libhdfs, classpath, out-of-memory, calloc
Missing both 'ipAddr' and 'name' in server response.
exception error java, hadoop, webhdfs, json, datanode, schema
no authentication method for " + authMethod
exception error hadoop, ugi, authentication-method, version-mismatch, rpc
Attribute with name is not found.
exception error xattr, missing-attribute, object-tags, tos
File already exists
exception error ftp, file-already-exists, create
found without
exception error hdfs, reversexml, fsimage, required-field, inode
MR AM not authorized to cancel delegation token
exception error mapreduce, delegation-token, cancellation, security
is NULL, empty or contains a '&
exception error
Path is not a directory
exception error hdfs, mkdir, file-already-exists, filesystem
Seek not supported
exception error ftp, hadoop, input-stream, seek, unsupported-operation
"Unknown command: " + cmd
validation error hdfs, rbf, federation, nameservice, cli, argument-validation
Block size must be greater than 0
exception error create-options, block-size, illegal-argument, validation
Can't recover key for
exception error keystore, kms, crypto, password, metadata
not found in datanode.
exception error
S02
[ ] is not a directory
error_code critical httpfs, server-startup, path-validation, filesystem, configuration
Source ' ' and destination ' ' are the same
exception error hdfs, file-copy, path-validation, symlink
StopWatch is already stopped
exception error hadoop, stopwatch, timing, illegalstate, api-misuse
does not support positioned reads with byte buffers.
exception error crypto, hdfs, stream, bytebuffer, positioned-read, hadoop
detachCurrentThreadFromJvm: Unable to detach thread
console warning libhdfs, windows, jni, detachcurrentthread, dll
Illegal argument
validation warning hdfs, namenode, bootstrap-standby, cli, invalid-argument, usage
Missing arguments
exception error cli, setfacl, acl, missing-argument, hadoop
Path contains a symlink and symlink resolution is disabled…
exception error
is not available
exception error registry, dns, configuration, unsupported-operation
Cannot remove directory
exception error hadoop, hdfs, datanode, storage, rollback, permissions, filesystem
e.toString()
exception error
getKey() + ": Stream is closed!"
exception error hadoop-aws, s3-select, stream-lifecycle, use-after-close
Incorrect data format. Rename operation.
exception error hdfs, edit-log, corruption, rename, legacy-format
Metric name already exists!
exception error metrics2, hadoop, metric-name-collision, naming
protocol is not set
exception error rpc, server, builder, protocol
Storage directory for location
exception error hdfs, datanode, storage, block-pool, missing-directory
Unmatched ')'
exception error hadoop, mapreduce, join, parser, parentheses
Illegal partition for
exception error hadoop, mapreduce, partitioner, index-out-of-bounds, custom-partitioner
Invalid attribute value for…
validation error hadoop, configuration, kerberos, relogin, ugi
keyProvider cannot renew token [ ]
exception error
Metric name ' ' contains illegal whitespace character
exception error metrics2, hadoop, naming, argument-validation
Reaching the limit of the buffer.
exception error hadoop, io, buffer, buffer-overflow, eof
Attempt to create an encryption zone for a non-empty…
exception error
Error instantiating ReservedSpaceCalculator
exception error
Interrupted waiting for discardSegments() response
exception error qjm, rollback, discard-segments, interrupt, edit-log
Interval should be positive. Value passed is
exception error metrics2, hadoop, quantiles, argument-validation
No parent of
exception error registry, zookeeper, path, tree-traversal