apache/hadoop
Documented errors, page 29 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| sleepTime = < 0 | exception | error | retry-policy, configuration, illegal-argument, hadoop-common |
| Unsupported version | exception | error | |
| user is null. | validation | error | authorization, proxy-user, impersonation, null-check, hadoop |
| File is empty | exception | error | json, file, hadoop-common, empty-file |
| Provided Subject must contain a KerberosPrincipal | exception | error | hadoop, kerberos, ugi, jaas-subject |
| Redundant -protocol command | validation | error | hadoop, logging, cli, loglevel, duplicate-flag, protocol |
| StopWatch is already running | exception | error | hadoop, stopwatch, timing, illegalstate, api-misuse |
| The server is stopped. | exception | error | |
| vecsum_zcr_loop pass | console | error | hdfs, vecsum, zero-copy, wrapper |
| wrong value class: is not | exception | error | hadoop, sequence-file, type-mismatch, append |
| Failed to delete snapshot | exception | error | |
| File does not exist: | exception | error | hdfs, getfilestatus, file-not-found, distributed-filesystem |
| Handler is already specified for | exception | error | |
| Mount table has already been configured with a merge slash… | validation | error | |
| No such file | exception | error | json, file, hadoop-common, configuration |
| Permission denied | exception | error | |
| rename destination parent | exception | error | hdfs, rename, file-not-found, destination |
| suite " + suiteClassName + " is empty for both API and SHELL | validation | error | hadoop-compat-bench, suite-registration, plugin-validation |
| Unsupported split version | exception | error | mapreduce, job-submission, splits, version-mismatch, upgrade |
| Failed to validate decoding | exception | error | |
| Invalid numDataUnits and numParityUnits | exception | error | |
| Max relative expiry is too big. | exception | error | hdfs, caching, validation, expiration, overflow |
| mkdir failed for | exception | error | distcp, hadoop, mkdir, permissions, quota |
| Path is not a file | exception | error | checksum, directory-mismatch, hdfs-parity, tos |
| URI: is an invalid Har URI since '-' not found. Expecting… | exception | error | |
| Bad argument | exception | error | hadoop, high-availability, zkfc, cli, usage |
| Both source file listing and source paths present | exception | error | distcp, cli, conflicting-options, source-paths |
| Expected one of -b, -k, -m, -x or --set options | exception | error | cli, setfacl, acl, missing-flag, hadoop |
| Object comparison not supported | exception | error | |
| Thread Interrupted | exception | error | |
| vecsum failed with error | console | error | hdfs, vecsum, wrapper, exit-code |
| Can't store key in | exception | error | java, hadoop, keystore, key-provider, jceks |
| Failed to sufficiently replicate: min= | exception | error | |
| folder | exception | error | |
| Invalid header length | exception | critical | hdfs, data-transfer, corruption, wire-protocol, packet-header |
| Unknown op in data stream | exception | error | hdfs, datatransfer, op-code, datanode, protocol, corruption |
| Cannot start secure DataNode due to incorrect config. See… | exception | error | |
| Could not read signature secret file | exception | critical | hadoop-auth, secret-provider, configuration, file-permissions |
| Source ' ' does not exist | exception | error | hdfs, file-copy, file-not-found, filesystem |
| Too many arguments | exception | error | cli, getfacl, acl, too-many-arguments, hadoop |
| XAttr: does not exist. The CREATE flag must be specified. | exception | error | xattr, flag-validation, create-flag, object-tags, tos |
| No space available in any of the local directories | exception | error | |
| Progress option is set multiple times | validation | error | hadoop, file-create, options, progress, varargs |
| suite " + suiteClassName + " suiteName conflicts with… | validation | error | hadoop-compat-bench, suite-registration, name-conflict |
| Waiting for writer thread is interrupted. | exception | error | |
| not configured | exception | error | |
| Credential " + name + " does not exist in " + this | exception | warning | hadoop, credential-provider, keystore, alias-not-found, jceks |
| Either LDAP base DN or LDAP domain value needs to be… | exception | error | |
| failed to fill reservoir | exception | error | |
| Failed to gcDeletedSnapshot | exception | error | |
| GCS bucket name cannot be empty. | exception | error | uri, gcs, bucket, validation |
| Invalid start or len parameter | validation | error | hadoop, filesystem, argument-validation, block-location |
| rename destination parent | exception | error | hdfs, rename, parent-not-directory, destination |
| Timed out waiting for doPreUpgrade() response | exception | error | hdfs, qjm, journal-node, upgrade, timeout, ha |
| Too many source paths | validation | error | hdfs, namenode, batched-listing, limit, input-validation |
| Inconsistent size of finalized replicas. Replica | exception | error | |
| : not a file in | exception | error | hadoop, har-filesystem, is-a-directory, file-not-found |
| Principals do not exist in the keytab | exception | error | |
| Public key for signature validation must be provisioned. | exception | error | |
| Token cancel is not supported for | exception | error | |
| Cannot import image from a checkpoint… | exception | error | hdfs, namenode, checkpoint, import, configuration |
| Could not resolve Kerberos principal name: | exception | error | |
| getShuffleFinishTime() not supported for MapTask | exception | error | hadoop, mapreduce, taskstatus, unsupported-operation, api-misuse |
| inProgressOk = false, but selectInputStreams returned an… | exception | error | |
| missing task ID | http | error | mapreduce, web-ui, http-400, applicationmaster, task-id, query-parameter |
| No such group:" + group | exception | error | unix, group-mapping, nfs, id-mapping |
| still not started | exception | error | |
| The file belonged to does not exist or it is not under… | exception | error | hdfs, namenode, lease, block-state, file-closed |
| The SSL encryption is enabled for the component's ZooKeeper… | exception | error | hadoop, zookeeper, ssl, tls, truststore, secrets, configuration, java |
| Unknown version of delegation token | exception | error | |
| Unsupported counter type | exception | error | metrics2, hadoop, annotation, type-mismatch, reflection |
| does not support positioned readFully. | exception | error | crypto, hdfs, stream, positioned-read, hadoop |
| Could not start Curator Framework | exception | error | |
| Incorrect data format. delete operation. | exception | error | hdfs, edit-log, corruption, delete, legacy-format |
| Network Location is null | exception | error | hadoop-common, network-topology, null-pointer, configuration |
| Outstanding satisfier queue limit | exception | error | |
| Configured mapreduce.local.reduce.tasks.maximum must be >= 1 | validation | error | mapreduce, local-job-runner, configuration, thread-pool |
| Container name must not be null or empty | validation | error | azure, abfs, container, validation, argument-error |
| Har: rename not allowed | exception | error | hadoop, har-filesystem, read-only, rename, atomic-commit |
| Har: setReplication not allowed | exception | error | hadoop, har-filesystem, read-only, replication |
| Property not found | validation | error | |
| ProvidedReplica does not support renaming data | exception | error | hdfs, datanode, provided-storage, read-only, rename |
| Required param for op: is null or empty | validation | error | |
| The truststore location parameter is empty for the… | validation | error | ssl, tls, zookeeper, configuration, truststore |
| Unable to create file | exception | error | ftp, stor, permission-denied, transfer |
| Bad header found in token storage. | exception | error | |
| Can't continue with getBlockLocalPathInfo() authorization… | exception | error | |
| Channel should be a SelectableChannel | exception | error | hadoop-common, network, nio, sockets, java |
| is not an instance of Seekable or PositionedReadable | exception | error | |
EBADF The handle is invalid. | exception | error | native-io, windows, fstat, file-descriptor, ebadf |
| Failed to initialize RestCsrfPreventionFilter. | exception | error | |
| Har: append not allowed. | exception | error | hadoop, har-filesystem, read-only, append |
| Network Locationpath doesn't start with / | exception | error | hadoop-common, network-topology, path-validation, java |
| '" + ownerStr + "' does not match expected pattern for… | validation | error | |
| ProvidedVolume does not yet support writes | exception | error | |
| rename destination cannot be the root | exception | error | hdfs, rename, root-path, path-validation |
| renaming to FAILED | exception | error | |
| Too many failed volumes - current valid volumes | exception | error | |
| Cannot rename the root directory | exception | error | rename, root-directory, path-validation, tos |
| CreateParent option is set multiple times | validation | error | hadoop, file-create, options, varargs, validation |