apache/seatunnel
Documented errors, page 10 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| get job state error | exception | error | zeta-engine, job-state, job-history |
| Hive metastore client factory | exception | error | hive-metastore, reflection, type-mismatch |
| Interrupted while writing python.script.config | exception | error | interruption, process, startup |
| Login failed on server | exception | error | ftp, authentication, login, network |
| MySQL-CDC diagnostic: requested starting offset sourceInfo= | console | info | mysql, binlog, diagnostics, offset |
| No checkpoint found for jobId= | validation | error | zeta-engine, rest-api, savepoint, restore |
| Unable to parse OffsetDateTime from CDC TIMESTAMP_TZ value… | exception | error | cdc, datetime, parse, timestamp |
| Unsupported metric class | exception | error | metrics, connector, unsupported-type |
| Unsupported operand type, the minuend type | exception | error | cdc, type-mismatch, numeric |
| Vitess CDC requires resolved catalog tables for… | validation | error | vitess, cdc, config, catalog-tables, empty-list |
| Could not register for streaming with metadata in messages… | console | info | cdc, postgresql, wal2json, fallback |
DESERIALIZE_FAILED Failed to deserialize Amazon SQS message | error_code | error | java, sqs, deserialization |
| Failed to check JDBC savepoint support; fallback to full… | console | warning | jdbc, savepoint, fallback |
| Failed to delete Point-in-Time with ID | console | warning | elasticsearch, point-in-time, cleanup |
| Failed to open catalog | exception | error | milvus, catalog, grpc, connection |
| reconvert not support | exception | error | java, data-conversion, unsupported-operation |
| Suppressing further Python source stderr lines for this… | console | info | python, stderr, log-flood, throttling |
| reset state failed, only end state can be reset, current is | exception | error | zeta-engine, task-state, reset, state-machine |
| The job with id ' ' save point failed | exception | error | zeta-engine, savepoint, checkpoint |
| Conflict key field ' ' value is null or not found in row | exception | error | databend, conflict-key, upsert, null-value |
| Continuous discovery scan failed, will retry in next… | console | warning | file-connector, filesystem, retry, scheduler |
| Could not load keystore | exception | error | mysql, cdc, ssl, tls, keystore |
| DECIMAL precision exceeds maximum , truncating to | console | warning | jdbc, duckdb, decimal, precision |
| Error closing MQTT client | exception | warning | mqtt, connection, shutdown, cleanup |
| Error reading MySQL variables: | exception | error | mysql, jdbc, sql-exception, cdc |
| Failed to execute HTTP request to Firebase endpoint | exception | error | firebase, network, http, io |
MISSING_NECESSARY_FIELD 'schema' is required. | error_code | error | sensorsdata, seatunnel, config, schema |
| Neither confirmed_flush_lsn nor restart_lsn could be found | exception | error | cdc, postgres, replication-slot, lsn |
| Received empty row data, skipping | console | warning | data-quality, null-row, skip, databend |
| RetryingMetaStoreClient found but no compatible getProxy… | console | warning | hive, reflection, version-mismatch, metastore |
| short overflow | exception | error | arithmetic, overflow, jdbc |
| Skip deleting table directory because target path has no… | console | warning | hive, hdfs, path, committer |
| Unable to create file | exception | error | ftp, file-create, io, permissions |
| Unsupported alter table event | exception | error | schema-evolution, paimon, unsupported-event, cdc |
| Cannot get maximum archive log SCN as no archive logs are… | exception | critical | oracle, cdc, logminer, archived-log, scn |
| Column type is empty. | exception | error | starrocks, type-converter, schema |
COMMON_ERROR_CODE-17 SeaTunnel array type not supported this genericType | exception | error | orc, unsupported-type, array, data-type |
| Conflict between 'body' and dedicated Airtable options for… | validation | error | config, airtable, conflict, validation |
| Couldn't obtain encoding for database | exception | error | cdc, postgres, encoding, jdbc |
| Failed to close Google Pub/Sub publisher | exception | error | google-pubsub, shutdown, io, java |
| Failed to read table metadata from information_schema for | console | warning | jdbc, mysql, metadata, information-schema, sql |
GET_SIGN_FAILED Get signature from DinkTalk server failed | error_code | error | dingtalk, hmac, signature |
| Hive metastore_uri is required for regex table discovery… | validation | error | hive, config, metastore, missing-option |
| Incremental snapshot for tables requires primary key, but… | validation | error | mysql, cdc, primary-key, incremental-snapshot, config |
| Table field name cannot be empty | validation | error | schema, validation, catalog-table, field-name |
| Unknown row kind: | exception | error | iceberg, cdc, row-kind, unsupported-operation, sink |
| Unsupported type in LocalTimeArrayType | exception | error | serialization, array, unsupported-type |
| Unsupported type for numeric minus. | exception | error | cdc, unsupported-type, numeric |
CONSUME_DATA_FAILED No config found for topic: + record.getTopic() | error_code | critical | rocketmq, runtime, subscription |
| EOF from edge socket ingress | exception | error | network, eof, socket, connection-closed |
| Failed to close Pulsar sink writer. | exception | error | pulsar, sink, resource-cleanup |
| Hive `table_name` must use `databasePattern.tablePattern`… | validation | error | hive, config, regex, format |
| Invalid AmazonDocumentDB connection URI in option 'uri' | validation | error | amazondocumentdb, mongodb-uri, url-parsing, config-error |
| must not be blank | validation | error | deeplake, config, validation |
| Option not be null. | exception | error | excel, configuration, rows, poi |
| Skip failed sink table in Spark starter | console | warning | spark, sink, multi-table |
| splitId must not be null | exception | error | cdc, null-check, api-misuse, argument-validation |
| tableName cannot be empty | validation | error | table-identifier, validation, empty-string |
| Unsupported convert to LocalTime, typeDefine | exception | error | java, type-conversion, time, seatunnel-api |
| Unsupported resolve schemaChangeEvent | console | warning | cdc, schema-evolution, debezium, ddl |
| Unsupported row type: | console | warning | cdc, tidb, tikv, cdc-event |
| Does not support split requests: subtask | exception | error | unsupported-operation, split-assignment, fluss, enumerator |
| enable_file_split=true but compress_codec= | console | warning | configuration, file, compression, split, conflicting-options, log-warning |
| error handler must be between 0 and , but was | validation | error | config, range-check, error-handler |
| Failed to connect to host: " + host + " by user: " + user +… | exception | critical | ssh, network, connection, scp, clickhouse |
| Failed to derive qualified default table location, fallback… | console | warning | hive, fallback, warehouse, hadoop |
| Failed to flush data in prepareCommit | exception | error | airtable, checkpoint, flush |
| Failed to send Airtable API request | exception | error | network, http, airtable |
KAFKA_VERSION_INCOMPATIBLE Incompatible KafkaProducer version | error_code | error | kafka, reflection, version-incompatibility, transactions |
| Option 'ignored_fields' is deprecated. Use 'properties'… | console | warning | deprecation, config, hugegraph |
POLL_FAILED Failed to poll SNMP agent | error_code | error | snmp, polling, source, streaming |
| Row-level error ratio in stage | exception | error | row-level-error, ratio-threshold, data-quality |
RULE_VALIDATION_FAILED row : fail rule | error_code | error | assert-connector, data-quality, row-validation |
| SeaTunnel config file was not found in working directory | console | warning | spark, config, file-resolution |
TABLE_NOT_FOUND BigQuery target table does not exist | error_code | error | bigquery, table-not-found, configuration |
| Table does not have a full replica identity, please… | exception | error | postgres, cdc, replica-identity, config |
| The S3A credentials provider class | validation | error | config, aws-s3, validation |
| TopicPartition ' ' matched by multiple table configs… | console | warning | config, pulsar, overlap |
| Unsupported deploy mode | validation | error | deploy-mode, cli, internal |
| WALDisruptor close timeout error | exception | error | timeout, wal, shutdown, hdfs |
DELETE_PIT_FAILED DELETE /_pit response null | error_code | warning | elasticsearch, point-in-time, null-response, cleanup |
| Error reading oracle variables | exception | error | oracle-cdc, jdbc, connection, sql-exception |
| Log file path is empty, get logRef | exception | error | logging, configuration, zeta-engine |
RABBITMQ-04 Cannot send RMQ message to queue | error_code | error | rabbitmq, network, publish, io |
| Scheduler timed out during close; up to | console | warning | shutdown, scheduler, timeout, observability |
| Skipping deletion: Log directory | console | warning | logs, configuration, path-validation, cleanup |
| Vitess CDC captures one keyspace per source. Table | exception | error | cdc, vitess, config-validation |
WRITE_DATA_FAIL upsert data failed, size down to 10, break | error_code | error | milvus, sink, upsert, batch, write |
| Bedrock Mantle stream ended abnormally | exception | error | llm, bedrock, streaming, network |
| Execute splitVector command failed | console | warning | mongodb, cdc, command-error, splitvector |
| Failed to close Pulsar admin. | exception | warning | pulsar, cleanup, admin-client, shutdown |
| Failed to parse job config: | exception | error | sql-config, config-parsing, java |
| Failed to read AzureCosmosDB data from database | exception | error | azure-cosmosdb, query, throttling, network |
| Ingress queue physically full, returning RETRY | console | warning | backpressure, queue-full, retry, socket-source |
| No agent.yaml found. Use --config /path/to/agent.yaml, set… | exception | error | startup, configuration, file-not-found |
| PostHog option 'base_url' must not be blank | validation | error | seatunnel, posthog, config, validation |
| Request failed with code | console | warning | http, starrocks, status-code |
| Required option ' ' should have no default value. | validation | error | |
| Rocketmq consumer can not pull data, split | console | warning | rocketmq, kafka-like-source, empty-result, offset |
| SNMP agent returned error status | exception | error | snmp, agent-error, write, sink |