apache/seatunnel
Documented errors, page 11 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| SNMP source retries must not be negative | validation | error | config, snmp, validation |
| Unknown ftp connection mode | exception | error | config, enum, ftp, validation |
| Unknown restore mode code: | exception | error | java, enum, serialization, version-compatibility |
WRITE_PROPS_BUCKET_KEY_ERROR ${cause.getMessage()} | error_code | error | paimon, bucket-key, configuration, create-table |
| AzureCosmosDB requires uri, endpoint, or connection string… | validation | error | config, azure-cosmosdb, validation, missing-option |
| Collection does not appear to be sharded, fallback to… | console | warning | mongodb, cdc, sharding, fallback |
| Could not find existing binlog information while attempting… | exception | error | snapshot, offsets, state, cdc |
| Error during file discovery | console | warning | file, io, filesystem, skip-on-error |
| Failed to discover captured tables for enumerator | exception | critical | cdc, enumerator, table-discovery, jdbc |
| Failed to write checkpoint data, file | exception | critical | hdfs, checkpoint-storage, file-write |
| Field name not found in row type | exception | error | assert, schema, field-name |
| Invalid SNMP source OID | validation | error | config, snmp, oid, parsing |
| Option 'authentication_type' is required | validation | error | azure-queue-storage, missing-config, authentication |
| Refusing write without --yes | validation | error | cli, safety-guard, write-operations, confirmation |
| StringUtils.stringifyException(e) | exception | error | sftp, ssh, jsch |
| The auto increment start value is too large, please check… | exception | error | fake-connector, auto-increment, integer-overflow, config |
| The physical plan didn't have any can execute pipeline | exception | error | zeta-engine, physical-plan, job-config, empty-plan, validation |
| The single-split reader don't support reading multiple… | exception | error | source, split, unsupported-operation, parallelism |
| Too many row-level errors in stage | exception | error | row-level-error, threshold, config |
| Unsupported convert to | exception | error | type-conversion, unsupported-operation, sql-type |
| Cannot deserialize TiDB DELETE CDC row because both value… | exception | error | cdc, tidb, delete-event, old-value, pk-handle |
| Cannot determine source type for BYTES field, defaulting to… | console | warning | jdbc, sqlserver, bytes, null-binding |
| Creation of replication slot failed | exception | critical | postgresql, cdc, replication-slot, debezium, privilege |
| Dry-run mode must not be empty. | validation | error | cli, dry-run, validation |
| Failed executeSql error | exception | error | jdbc, doris, catalog, sql |
| failed to stream load data with label: | console | error | doris, stream-load, http, network |
GET_PRIMARY_KEY_FAILED Cannot get primary key from clickhouse | error_code | error | clickhouse, primary-key, metadata |
| Interrupted while draining Python source stdout after… | exception | error | interruption, process, shutdown |
| Invalid endpoint: , expected format host:port | validation | error | config, validation, endpoint, format |
INVALID_STARTING_RECORD_OFFSET Invalid starting record offset | error_code | error | iceberg, offset, restore |
| Please configure unique `table_path`, not allow… | validation | error | jdbc, config-validation, duplicate-key |
RECEIVE_FAILED Interrupted while buffering MQTT source message | error_code | error | mqtt, interrupted, thread, queue-full |
REQUEST_FAILED Deep Lake request failed with HTTP | error_code | error | http, deeplake, rest, api |
| SftpException wrapped (pwd failed while resolving file… | exception | error | sftp, pwd, sftpexception, connection |
TABLE_QUERY_EXCEPTION HBase table [ ] does not exist | error_code | error | hbase, table-not-found, source-split-enumeration, config |
| The file format is incorrect. Please check the format in… | console | warning | file, compression, file-format, logging |
| Unsupported convert to byte[] | exception | error | type-mismatch, bytes-conversion, seatunnel-api |
UNSUPPORTED_PRIMARY_DATATYPE ${cause.getMessage()} | error_code | error | paimon, primary-key, unsupported-type, schema |
| AmazonDocumentDB TLS CA bundle is not a readable file: | validation | error | tls, file-not-found, configuration |
CONVERT_TO_CONNECTOR_TYPE_ERROR_SIMPLE Failed to deserialize JSON | error_code | error | json, kafka, maxwell, deserialization |
| Failed to read AmazonDocumentDB data from database | exception | error | java, documentdb, cursor, network |
| Hive table not available yet or metastore not reachable | console | warning | hive, metastore, lazy-creation |
HugeGraphConnectorErrorCode.ILLEGAL_CONFIG_ARGUMENT Mapping[ / ]: 'nullableKeys' and 'notNullableKeys' are mutually exclusive — set… | error_code | error | hugegraph, config-validation, nullable-keys, mutually-exclusive |
| Interrupted while enqueuing error row for error sink | exception | warning | error-sink, interrupted-exception, cancellation, zeta-engine |
IotdbConnectorErrorCode.INITIALIZE_CLIENT_FAILED Initialize IoTDB client failed. | error_code | critical | iotdb, connection, sink, init |
| MySQL-CDC diagnostic: master status file= | console | info | mysql, cdc, diagnostics, binlog, gtid |
| No user specified for sftp connection. Expand URI or… | exception | error | sftp, config, missing-credentials |
| Null data value ' ' Cannot send downstream | exception | error | json, canal, cdc, null-value, malformed-event |
| Option validation failed | validation | error | |
| SftpException wrapped (ls failed while listing status) | exception | error | sftp, io, directory |
| The jdbc url format is incorrect | validation | error | jdbc, url-parsing, illegal-argument |
| The ' ' option configured is incorrect, this table( )… | validation | error | java, job-config, dag, unconnected-node |
| Unsupported auth type | validation | error | config, enum, connector-edge-socket |
| versions prior to starrocks 3.3.2 do not support rename… | console | warning | starrocks, schema-change, version-compatibility, rename |
| Close JDBC writer failed. | console | warning | jdbc, cleanup, resource-leak, warning |
CommonErrorCode.ILLEGAL_ARGUMENT Topic must be configured for single-table Pulsar sink. | error_code | error | pulsar, sink, config-validation |
| Connector ' ' has unknown option keys: . Please check for… | validation | error | |
| end_timestamp can't be negative | validation | error | hbase, validation, timestamp, config |
| Get Error URL failed. | console | warning | network, http, starrocks, stream-load |
| Invalid secret_key: not Base64 encoded | validation | error | config, validation, base64, encryption |
| Json parsing exception. | validation | error | excel, file-format, poi, connector-file |
| is required | validation | error | configuration, validation, missing-key |
| Unsupport ARRAY | exception | error | jdbc, yashandb, type-conversion, array |
| Unsupported convert to Float | exception | error | java, type-conversion, unsupported-operation |
| Unsupported convert to Integer, typeDefine | exception | error | java, type-conversion, unsupported-operation |
| All candidate sink tables were skipped in Spark starter. | exception | error | spark, sink, multi-table |
| Already an MDCSupplier | exception | error | tracing, mdc, argument-validation |
| AmazonDocumentDB TLS CA bundle contains no certificates: | validation | error | tls, certificates, file-content |
CREATE_HIVE_TABLE_FAILED Unsupported schema save mode: | error_code | error | hive, sink, schema-save-mode, enum, config |
DATABASE_NO_COLLECTIONS DATABASE_NO_COLLECTIONS | error_code | error | milvus, source, catalog, empty-database |
| Error closing potentially broken REST client | console | warning | hugegraph, connection, http-client, resource-cleanup |
| Error while closing pulsar consumer | console | warning | pulsar, shutdown, cleanup |
| Failed to close Pulsar consumer. | exception | warning | pulsar, consumer, resource-cleanup, shutdown |
| Failed to create empty dataset at | exception | error | lance, catalog, file-write-failed |
| Invalid indexType ' ' for column ' '. Valid values are | exception | error | vector-index, enum, validation |
| Invalid LSN returned from database | exception | error | cdc, postgres, lsn, replication-slot |
| Resolved trace path escapes baseDir | validation | error | zeta-engine, event-tracing, path-traversal, security |
| \t skipping database | console | warning | cdc, sqlserver, table-discovery, sql, swallowed-exception |
| The ' ' option configured in [ ] is incorrect, and the… | validation | error | java, job-config, dag, reference-not-found |
| Unexpected error creating database | exception | error | hive, metastore, database, unexpected |
| Unsupported convert to BigDecimal, typeDefine | exception | error | java, type-conversion, decimal, bigdecimal |
| Unsupported Databend type | console | warning | databend, type-mapping, fallback, catalog |
| A decoding format must override this method to apply… | exception | error | unsupported-operation, format, metadata |
CLUSTER_LIST_GET_FAILED Cannot get cluster shard list from clickhouse | error_code | error | clickhouse, cluster, metadata |
| oracle_insert_mode=APPEND_VALUES only supports generated… | exception | error | oracle, jdbc, config, sql |
QUERY_COLLECTION_NUM_ERROR QUERY_COLLECTION_NUM_ERROR.getDescription() | error_code | error | typesense, http, search-query |
| restart_lsn could be found | exception | error | cdc, postgres, replication-slot, lsn |
SEARCH_WITH_PIT_FAILED POST /_search response null | error_code | error | elasticsearch, http, point-in-time, null-response |
| tables_configs[ ]: 'start_mode.timestamp' and… | validation | error | kafka, config-validation, seatunnel |
| Unauthorized to execute splitVector command | console | warning | mongodb, cdc, authorization, splitvector |
| Unsupported convert to LocalDateTime | exception | error | type-mismatch, datetime-conversion, seatunnel-api |
| Unsupported rowKind: " + rowKind | exception | error | clickhouse, cdc, rowkind, unsupported-operation |
| Value in the pg_replication_slots table for slot = ' '… | exception | error | cdc, postgres, lsn, corrupt-data |
| Vitess CDC requires database-qualified table paths, but… | exception | error | vitess, cdc, table-path, config, naming |
| A slot marked as temporary or with an exported snapshot was… | console | warning | cdc, postgresql, version-compatibility, replication-slot |
DRIVER_NOT_FOUND Cannot find Databend JDBC driver | error_code | critical | databend, jdbc, driver, classpath, startup |
| Interrupted closing target_point_lookup workers | exception | warning | interruption, threading, cleanup |
| load flink starter error. | exception | critical | flink, classpath, starter-jar, startup |
| NebulaGraph rejected the write with code | exception | error | nebulagraph, write-failed, server-error, ngql |
| Observability is explicitly disabled… | console | warning | config, observability, zeta |